• | Table of Contents
• | Index
Absolute Beginner's Guide to Networking, Fourth Edition
By Joe Habraken
Publisher | : Que
Pub Date | : September 19, 2003
ISBN | : 0-7897-2911-3
Pages | : 416

Absolute Beginner's Guide to Networking, Fourth Edition gives readers the ability and understanding necessary to create and administer a network. The book shows the reader how to physically connect computers and other devices to a network and access peripherals such as printers over the network. Readers will also be able to configure computers to access the network and the network to share an Internet connection. This book will provide easy-to-understand details on new technologies and background information (such as basic networking, including protocols and physical infrastructure) necessary for the user to network computer devices.

Absolute Beginner's Guide to Networking takes the frustration out of planning and creating a network, and helps readers understand what they are getting into when planning a network and strategies for making the network a success.


• | Table of Contents
• | Index
Absolute Beginner's Guide to Networking, Fourth Edition
By Joe Habraken
Publisher | : Que
Pub Date | : September 19, 2003
ISBN | : 0-7897-2911-3
Pages | : 416

Copyright
About the Author
Acknowledgments
We Want to Hear from You!
Reader Services
Introduction
 | Conventions Used in This Book
 | How This Book Is Organized
Part I: Networking Basics
 | Chapter 1. Computer Networking Overview
 |  | What Is a Network?
 |  | Why Network Your Computers?
 |  | PC Networking: How It All Began
 |  | Clients and Servers: What Does It All Mean?
 |  | Network Players: Users and Administrators
 |  | Understanding LAN Data Transmission
 |  | Networking Does Not Require the "All Knowing"
 | Chapter 2. Different Needs, Different Networks
 |  | Understanding Peer-to-Peer Networking
 |  | Server-Based Networks
 |  | Understanding Network Topologies
 |  | Assessing Your Network Needs
 |  | Planning the Network
 | Chapter 3. Networking Hardware
 |  | Working with Network Interface Cards
 |  | Working with Network Connectivity Devices
 |  | Some Thoughts on PC Hardware
 | Chapter 4. Building the Network Infrastructure
 |  | Understanding Network Architectures
 |  | Understanding Ethernet
 |  | Understanding IBM Token-Ring
 |  | Understanding FDDI
 |  | Choosing a Network Connectivity Strategy
 | Chapter 5. Network Protocols: Real and Imagined
 |  | Understanding the OSI Model
 |  | How the OSI Model Works
 |  | Thoughts on Using a Conceptual Model
 |  | TCP/IP
 |  | IPX/SPX
 |  | Other Network Protocols of Note
Part II: Getting the Network Up and Running
 | Chapter 6. Configuring Peer-to-Peer Networks
 |  | Selecting and Configuring Network Protocols
 |  | Setting Up the Peer-to-Peer Network
 |  | Combining Linux and Windows
 |  | Accessing Windows Workgroup Shares
 |  | A Final Word on Peer-to-Peer Networking
 | Chapter 7. Network Operating System Overview
 |  | What Is an NOS?
 |  | Client and NOS Interaction
 |  | Configuring a Server with an NOS
 |  | Sharing Folders and Directories
 |  | How Network Printing Works
 | Chapter 8. Networking with Novell NetWare 6.5
 |  | NetWare and Networking
 |  | The Netware Network Structure
 |  | Installing NetWare
 |  | Administering a Novell Network
 |  | Working with Volumes and Folders
 |  | Working with Users and Groups
 |  | Configuring Network Clients
 |  | NetWare DNS and DHCP
 | Chapter 9. Networking with Microsoft Windows Server 2003
 |  | Understanding the Microsoft Networking Model
 |  | Installing Microsoft Windows Server 2003
 |  | Choosing a Server's Role
 |  | Understanding Windows Active Directory
 |  | Creating User Accounts
 |  | Sharing Windows Folders
 |  | Understanding Share Permissions
 |  | Windows and NTFS Permissions
 |  | Sharing Printers
 |  | Security and Windows Server 2003
 | Chapter 10. Networking with Linux
 |  | Installing Red Hat Linux
 |  | Network Configuration
 |  | Root Configuration
 |  | Selecting Installation Packages
 |  | Booting Your Linux System
 |  | Upgrading Your Linux System Software
 |  | Linux Administrative Tools
 |  | Working with Users
 |  | Working with Red Hat Network Services
 |  | Sharing Network Resources
 |  | Monitoring the System and Network
 | Chapter 11. Working with Applications on the Network
 |  | Selecting Application Software
 |  | Using Application Software on the Network
 |  | Understanding Microsoft .NET
 |  | Understanding Client/Server Databases
Part III: Expanding Your Network
 | Chapter 12. TCP/IP Network Administration
 |  | Working with IP Addresses
 |  | Configuring IP Addresses
 |  | Working with DHCP
 |  | Understanding DNS
 |  | Routing and Subnetting IP Networks
 |  | Introducing IPv6
 | Chapter 13. Expanding a LAN with WAN Technology
 |  | Working with the Plain Old Telephone System
 |  | Working with Dial-up and Dedicated Connections
 |  | The T-Carrier System
 |  | Understanding Switched Networks
 |  | Circuit Switching
 |  | Packet-Switching Networks
 |  | A Word Regarding Remote Access
 | Chapter 14. How the Internet Works
 |  | Where Did the Internet Come From?
 |  | Working with the File Transfer Protocol
 |  | Understanding Electronic Mail
 |  | Working with the Web
 |  | Other Internet Onramps
 | Chapter 15. Connecting a Network to the Internet
 |  | Connecting to the Internet
 |  | Getting Your Own Domain Name
 |  | Getting Your IP Addresses
 |  | Sharing an Internet Connection
 |  | Sharing an Internet Connection with Windows Server 2003
 |  | Working with Proxy Servers
 |  | Understanding Network Address Translation
 | Chapter 16. Hosting a Web Site
 |  | The Internet and Your Corporate Presence
 |  | Who Will Host Your Web Site?
 |  | Creating a Web Site
 |  | Taking Advantage of an Intranet
 | Chapter 17. Networking on the Run
 |  | The Evolution of Mobile Computing Devices
 |  | Working with Laptops
 |  | Understanding Remote Access
 |  | Understanding Access Protocols
 |  | Managing Remote Connections
 |  | Working with Virtual Private Networks
 |  | PDAs and the Network
Part IV: Keeping the Network Running Smoothly
 | Chapter 18. Protecting Network Data
 |  | Understanding Hard Drives
 |  | Working with RAID
 |  | Understanding the RAID Flavors
 |  | Backing Up Data
 |  | Working with Uninterruptible Power Supplies
 | Chapter 19. Network Troubleshooting
 |  | It's Not Always User Error
 |  | Identifying Network Operating System Problems
 |  | Diagnosing Hardware Problems
 |  | Monitoring the Network
 |  | Dealing with Connectivity Issues
 |  | Your Approach to Troubleshooting
 | Chapter 20. A Network Security Primer
 |  | Administrators and Users
 |  | Working with User Accounts
 |  | Understanding Share Permissions
 |  | Using Groups to Provide Access Levels
 |  | Fighting Against Viruses
 |  | Protecting a Network from Outside Attack
 |  | Understanding Firewalls
 |  | Types of Firewalls
 |  | A Final Word on Network Security
 | Glossary
Index


Copyright

Copyright © 2004 by Que Publishing

All rights reserved. No part of this book shall be reproduced, stored in a retrieval system, or transmitted by any means, electronic, mechanical, photocopying, recording, or otherwise, without written permission from the publisher. No patent liability is assumed with respect to the use of the information contained herein. Although every precaution has been taken in the preparation of this book, the publisher and author assume no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained herein.

Library of Congress Catalog Card Number: 2003103338

Printed in the United States of America

First Printing: September 2003

07 06 05 04 4 3 2 1

Trademarks

All terms mentioned in this book that are known to be trademarks or service marks have been appropriately capitalized. Que Publishing cannot attest to the accuracy of this information. Use of a term in this book should not be regarded as affecting the validity of any trademark or service mark.

Warning and Disclaimer

Every effort has been made to make this book as complete and as accurate as possible, but no warranty or fitness is implied. The information provided is on an "as is" basis. The author and the publisher shall have neither liability nor responsibility to any person or entity with respect to any loss or damages arising from the information contained in this book.

Bulk Sales

Que Publishing offers excellent discounts on this book when ordered in quantity for bulk purchases or special sales. For more information, please contact

U.S. Corporate and Government Sales
1-800-382-3419
corpsales@pearsontechgroup.com

For sales outside of the U.S., please contact

International Sales
1-317-428-3341
international@pearsontechgroup.com

Credits

Acquisitions Editor

Jenny Watson

Development Editor

Mark Cierzniak

Managing Editor

Charlotte Clapp

Project Editor

Sheila Schroeder

Production Editor

Benjamin Berg

Indexer

Erika Millen

Proofreader

Linda Seifert

Technical Editor

Mark Hall

Team Coordinator

Vanessa Evans

Interior Designer

Anne Jones

Cover Designer

Dan Armstrong

Page Layout

Michelle Mitchell

Dedication

To my students at the University of New England: Enjoy life; it is the greatest "free" gift you will ever receive. Oh, and try to be on time for class once in awhile.


About the Author

Joe Habraken is a best-selling author, information technology professional, and educator. He is currently an assistant professor at the University of New England, where he teaches a variety of information technology classes introducing undergraduate students to computer basics, software applications, Web design, and the use of personal computers in business settings. His books include Microsoft Office XP 8 in 1, Practical Cisco Routers, and Sams Teach Yourself Microsoft Server 2003 in 24 Hours. With more than 15 years as a trainer and consultant, Joe enjoys taking difficult computer concepts and making them accessible to readers and students.


Acknowledgments

As you will find with computer networking, networks (like Rome) are not built in a day. And the same goes for a book like this. It really does take a team (sometimes it seems like a village) to create a book that covers a subject matter that seems to change on a daily basis.

First of all, I would like to thank Kim Rich, who took time out from her busy schedule to shoot many of the photos that appear in this book. I would also like to thank the very hard-working Jenny Watson, my acquisitions editor, who assembled the team that worked on this project. Jenny made sure the project stayed on track and is a truly great person to work with.

I would also like to thank Mark Cierzniak, the development editor, who burned the midnight oil to make sure this was the best book possible. He also made many useful suggestions related to the subject matter included in the book. Another big thanks goes out to our technical editor, Mark Hall, who verified the technical aspects of the text and provided expert advice on the material we covered.

I would also like to thank Ben Berg, our copy editor, for diligently cleaning up the text and making a number of great suggestions; finally, a big thanks to the project editor, Sheila Schroeder, who ran the last leg of the race and made sure this book got into print (and into your local bookstore). Thank you all very much!


We Want to Hear from You!

As the reader of this book, you are our most important critic and commentator. We value your opinion and want to know what we're doing right, what we could do better, what areas you'd like to see us publish in, and any other words of wisdom you're willing to pass our way.

You can email or write me directly to let me know what you did or didn't like about this book—as well as what we can do to make our books stronger.

Please note that I cannot help you with technical problems related to the topic of this book, and that due to the high volume of mail I receive, I might not be able to reply to every message.

When you write, please be sure to include this book's title and author as well as your name and phone or email address. I will carefully review your comments and share them with the author and editors who worked on the book.

Email: | feedback@quepublishing.com
Mail: | Mark Taber Associate Publisher Que Publishing 800 East 96th Street Indianapolis, IN 46240 USA


Reader Services

For more information about this book or others from Que Publishing, visit our Web site at www.quepublishing.com. Type the ISBN (excluding hyphens) or the title of the book in the Search box to find the book you're looking for.


Introduction

Network administrators and other computer technology professionals are well aware of the continued rapid evolution of computer and networking technology. The last 20 years have certainly seen a whirlwind of changes, both for network administrators and network users. Network technology provides faster and faster networking media, and computer hardware prices are such that even the smallest of companies see the cost-effective aspects of deploying sophisticated network implementations.

It has also become imperative for even the smallest company to have a connection to the Internet. This includes a corporate presence on the World Wide Web.

So, a big issue for companies both big and small is getting network resources and Internet information to the desktop of each and every employee. This means having an understanding of how networks work, and knowing what kind of technologies are available for moving data between two computers in the same room or two computers separated by a thousand miles.

Since this book is considered a resource for "beginners," I have attempted to put together a body of information that would be useful for someone new to networking, but also provide enough depth to be an excellent starting point for someone who plans on learning more and maybe eventually working in the computer networking field. You are now holding the result.

The Absolute Beginner's Guide to Networking, Fourth Edition will help you bridge the information gap related to information technology and computer networking. Although this book covers a wide breadth of information, it also provides you with enough detail that you won't be lost as you further explore the subjects covered.

Although this book takes its subject matter very seriously, the material itself is approached in a straightforward, conversational manner that should help you digest the information without dozing off or developing a horrible migraine headache. Technology can be very intimidating, but this book will show you that the right information can go a long way as you explore networking technology, network operating systems, and the hardware devices that make networking possible.


Conventions Used in This Book

Certain conventions have been followed in this book to help you digest all the material. For example, new terms appear in italics. These terms can also be found in the Glossary, which supplies a short definition for each term.

At the beginning of each chapter, you'll find a quick-view list of the major topics that will be expounded upon as you read through the material that follows. The end of each chapter provides a list of summary points, reiterating some of the important information covered in the chapter.

You will also find several icons used throughout this book. These icons are accompanied by additional information on a subject, supply asides that provide useful insight, or give warnings that can help you steer clear of problem areas related to a certain subject or technology. These icons are as follows:

Note

These sidebars include additional information related to the current topic, but they do not have to be read in order for you to have complete understanding of the information provided in the regular text.

Tip

These sidebars contain higher-level information and additional insight into a topic that expands on the material provided in the chapter.

Caution

These boxes attempt to reach out and grab your hand before you press that red destruct button. Cautions point out major problems or issues related to technologies or network practices.


How This Book Is Organized

This book has been completely updated for its fourth edition. Chapters relating to network operating systems such as Novell NetWare 6.5, Red Hat Linux, and Windows Server 2003 have been added to get you up to date on the latest network operating systems. Since TCP/IP is the standard network protocol, a new chapter on TCP/IP administration (Chapter 13) has been added to help you get up and running with the aspects of using and administering TCP/IP on a network.

The book is divided into four parts; each part provides you a body of information that covers a particular area related to computer networking. Part I, "Networking Basics," provides an overview of computer networking and information on network hardware. It also covers the basics of peer-to-peer and server-based networks. It includes information on networking hardware and also provides you with information on the different protocol stacks that are used on networked computers. The different media for building the network infrastructure, such as Ethernet and IBM Token-Ring, are also discussed.

Part II, "Getting the Network Up and Running," covers the configuration aspect of peer-to-peer networks and also provides an overview of working with network operating systems. Chapters providing an overview of the network operating systems Novell NetWare, Red Hat Linux, and Microsoft Windows Server 2003 are also included.

Part III, "Expanding Your Network," discusses how to administer a TCP/IP network, which includes information on using DNS, DHCP, and subnetting an IP network. Information on how to use WAN technology to expand and connect LANs at different locations is also included. This part of the book also discusses how to connect a network to the Internet and develop a company Web site.

Part IV, "Keeping the Network Running Smoothly," discusses how to protect network data using strategies such as RAID arrays and backups and also discusses how to troubleshoot network problems. This part of the book provides a primer on network security, which includes information on protecting the network from viruses and outside attacks. New chapters related to disaster planning and serving as a network administrator have also been added.

To help you keep track of all the new terminology that is introduced in the book, Appendix A provides a glossary. This will allow you to review the new terms that are introduced in the various chapters of the book.

Exploring computer networking and the various hardware and software components required is certainly an exciting endeavor. I hope that you enjoy this book as much as I enjoyed writing it.


Part I: Networking Basics

Computer Networking Overview

Different Needs, Different Networks

Networking Hardware

Building the Network Infrastructure

Network Protocols: Real and Imagined


Chapter 1. Computer Networking Overview

In this chapter

  • Defining the computer network

  • Reasons for networking personal computers

  • How PC networks got their start

  • Transferring data from the computer to the network

  • Understanding the role of the network administrator

It is certainly safe to say that computers have become as integral to modern life as fast food, cell phones, and sport utility vehicles. And although these trends may seem a little alarming, even scary (especially to anyone who has had a near miss with a massive SUV piloted by a driver who is preoccupied with his cell phone and a greasy box of French fries), the personal computer has evolved from a standalone device reserved for business applications into a device that can provide everything from real-time communications between users, to streaming audio and video, to the sharing of facts and figures across the length and breadth of our planet.

Computers are no longer just number-crunching business tools; they have become integral to communication, entertainment, and education. All the incredible possibilities offered by personal computers are in most part based on the simple notion that we can connect computers together into networks.


What Is a Network?

Before we plunge headlong into a discussion of how networks actually operate and what it takes to get them up and running (a discussion that will lead you through the other chapters of this book), we should probably first define what a network is and then discuss why you would want to connect computers into a network. A network can be anything from a simple collection of computers (two connected computers qualify as a network) at one location that have been tied together using a particular connectivity medium (such as network cabling or wireless technology) to a giant global network, such as the Internet, that uses a number of different connectivity media, including microwave and satellite technology. The network can then be used to transmit data, voice, and even video between users on the network.

Networks consist of the computers, the connectivity medium (such as copper wire or fiber optic cables), and other devices, such as hubs, switches, and routers (which are all discussed later in the book), that make up the network infrastructure. Some devices, such as network interface cards, serve as the computer's connection to the network. Devices such as switches and routers provide traffic-control strategies for the network. All sorts of different technologies can actually be employed to move data from one place to another, including network cabling (copper or fiber optics), radio waves, and even microwave technology.

Note

Networks are not networks just because they contain highly complex connectivity strategies. Two computers running the Windows Me operating system can be joined together by their COM ports (also known as serial ports) by a single serial cable. Is this a network? Sure, it allows you to share resources between the two computers and therefore meets the basic definition of what a network is.

In our discussion of computer networks, we will be looking at two distinct entities: LANs and WANs. A local area network (LAN) is a collection of personal computers and other peripheral devices connected at one location. A wide area network (WAN) is a collection of LANs at different locations connected together using various WAN technologies (discussed in Chapter 13, "Expanding a LAN with WAN Technology").


Why Network Your Computers?

There are actually some very compelling reasons why someone (someone being a person, small business, or mega-institution) with more than a couple computers would want to connect those computers into a network. What the network will actually be used for will, of course, vary depending on the needs of the person or organization creating the network. Networks can be used for simple tasks, such as sharing a printer, or they can be used for more advanced applications, such as a complex point-of-sale system and worldwide video conferencing.

All networks, whether big or small, are typically created so that users on the network can share resources and communicate. The list that follows breaks down some of the reasons for networking computers:

  • File sharing. Networking computers makes it very easy for the users on the network to share data files. Files on a particular user's computer can be shared on the network or files can be placed on a file server, which provides a central location for all files needed by the users on the network.

  • Hardware sharing. Users can share devices such as printers, CD-ROM drives, and hard drives (users can be assigned space on network server drives). Once networked, computers can share their own local devices, such as CD-ROM and hard drives, or take advantage of high-speed printers or other devices that are provided by a particular server on the network.

  • Program sharing. Applications such as spreadsheets and word processors can be run over the network. You keep most of the files that make up the application on a special application server on the network. This makes installing the software on a computer easier (because it can be done over the network). It also makes upgrading an application easier because the upgrade only has to be performed on the server itself.

  • User communication. Networks allow users to take advantage of communication media such as electronic mail, newsgroups, and video conferencing. Because voice, pictures, and video can be moved across the network as data, network communication is certainly not limited to just text messages. A number of communication platforms exist for PC networks such as Lotus Notes and Microsoft Exchange.

  • Multiplayer gaming. While this certainly isn't a reason for networking computers in a business environment, individuals who set up home-based peer-to-peer networks can take advantage of a large number of computer games that provide support for multiple players on a network.

Not only does a network provide the ability to share resources found locally on the network (such as a printer shared by several users in a small office), but the fact that the network exists means that the local network can be connected to other networks. Most networks, big and small, are also now connected to the Internet, meaning that the potential for sharing resources and communication is almost endless. One of the most compelling reasons for a company to decide to network its computers is to have all its users "plugged in to" the global network that is the Internet.

Tip

In networks that consist of more than just a few computers, you will have two different types of computers operating on the network: clients and servers. Client computers supply users with a connection to the network. Servers actually serve up the resources that are available on the network—everything from files to electronic mail post offices. A more detailed discussion of clients and servers is offered later in this chapter.


PC Networking: How It All Began

Computing and the advances that led to the modern personal computer go as far back as the human race itself, way back to devices such as the abacus (500 B.C.) and the Jacquard loom (a nineteenth-century mechanized loom that used a series of punch cards to create a particular weave). While our focus in this book is the networking of the personal computer, a little background information on the evolution of modern computing makes sense. To start, we can jump ahead to the 1950s.

Mainframes and Miniframes

Although there were a number of super computers created prior to 1950, the early mainframe market (which was not all that huge because of the size and cost of these computers) was dominated by International Business Machines (IBM). The IBM Model 701, which used vacuum tubes, was created in 1952. IBM also led the field in mainframe innovations and introduced the first computer disk storage system, as well as developed the FORTRAN programming language.

Advances in technology lead to the development of a smaller version of the mainframe, the miniframe. In the 1970s, the miniframe gained dominance in the computing world, making computer technology accessible to a larger number of companies and organizations (even though these companies paid a premium for their ability to compute).

One point that should be made in relation to mainframes and miniframes is that, by design, all storage and computing power was centralized. This meant users (on dumb terminals) accessed centralized, shared information and used centralized applications provided by the miniframe. In many cases, some type of messaging system was also available to users on a mainframe or miniframe so that they could communicate.

Note

Vacuum tubes were used in early computers to convert alternating current to direct current, a function that is handled in computers today using circuit boards.

Note

When a company or organization plans a LAN or WAN implementation, the core purpose of creating the computing network should always be kept foremost in mind. LAN and WAN technology offers many possibilities for networking computers, with some of the possibilities sporting more "bells and whistles" than the alternative (meaning, there are a number of ways to network computers: Some are glitzy but expensive; some are boring, yet fiscally sound and technically effective). In a perfect world, LANs and WANs should be built using the appropriate technology to meet the networking needs of the company or organization.

The Advent of the PC

Many techno-historians would debate which of the personal computers that appeared in the late 1970s and early 1980s really captured the imagination of early PC computer users and led to the personal computer revolution.

In August 1981, the IBM PC was released. Although not the only heavy-hitting PC available in the 1980s (the Apple Macintosh was released in 1984), the IBM PC (see Figure 1.1) quickly became the standard for businesses. Because the operating system for the IBM PC, DOS, was not wholly owned by IBM (Microsoft made MS-DOS available to other PC manufacturers), clones of the IBM PC quickly appeared in the marketplace. This made the PC a tool that even individuals and the smallest of businesses could afford.

Figure 1.1. The IBM PC became the standard desktop computer for businesses.

The development of software applications for DOS-based machines exploded in the 1980s, cementing the PC's role as the business-computing workhorse. However, the fact that PCs were standalone devices meant that users could not readily collaborate and share resources. The PC basically isolated its user.

Connecting PCs

Given that IBM brought a standalone, decentralized computing device—the PC—to the business marketplace in 1981, one would think that the theory, hardware, and software used to network PCs together had yet to be developed. In fact, though, the issues related to networking PCs had been worked out prior to 1980 by the ingenious researchers at the Xerox Corporation's Palo Alto Research Center (PARC). Not only did they create the Alto, a computer with a graphical user interface (GUI) and a mouse, but they also developed the hardware and software necessary to connect computers and printers together into a LAN.

In 1976, PARC researchers Robert Metcalfe and David Boggs (Metcalfe's assistant) published a paper titled "Ethernet: Distributed Packet-Switching for Local Computer Networks." Ethernet (discussed in detail in Chapter 4, "Building the Network Infrastructure") was further developed by Xerox, Intel, and DEC and is still the most popular PC networking architecture in the world.

As the PC gained dominance in the computing world, other network architectures were developed (such as IBM's Token Ring, which is discussed in Chapter 4). Many new companies, such as 3Com and Cisco Systems, surfaced in the 1980s and 1990s and grew rapidly as the need for networking interface cards and other network connectivity devices expanded in parallel with the evolution and sales of the personal computer.

Note

Dumb terminals consist of a monitor that is directly connected to the mainframe or miniframe and a keyboard, which also has a direct connection to the centralized computer.

Note

Oddly enough, Xerox never capitalized on many of the discoveries made at PARC. Apple was actually the first company to introduce a computer with a GUI interface and a mouse when it unveiled the Macintosh in 1984.


Clients and Servers: What Does It All Mean?

Although a number of the PC operating systems now available (such as Windows and the Apple OS) provide for peer-to-peer networking (discussed in the next chapter), in most cases one thinks of a network as being made up of clients and servers. A client is a computer that allows a user or users to log on to the network and take advantage of the resources available on the network. A client computer will run a client operating system (such as Windows XP Professional). The purpose of the client is to get a user onto the network; therefore, client computers don't usually have the processing power, the storage space, or the memory found on a server because the client does not have to serve up resources to other computers on the network (although dropping PC prices and advances in technology allow you to buy client computers that have the power and storage equal to a server that was purchased a year or two earlier).

A server, on the other hand, is typically a much more powerful computer that runs a network operating system (NOS) such as Microsoft Windows Server 2003 or Novell NetWare. The server provides centralized administration of the network and serves up the resources that are available on the network, such as printers and files (the NOS provides the server with these capabilities). The administrator of the server decides who can and cannot log on to the network and which resources the various users can access.

Most LANs consist of many clients and a few servers. While one server always controls user logons, other servers can specialize in providing certain types of resources (such as print servers and file servers, which are discussed in the next chapter). Figure 1.2 provides a diagram of a "typical" PC network.

Figure 1.2. PC networks consist of clients and servers.

Obviously the scale of a network will depend on whether the network is used by a huge corporation or has been set up for a home business. For example, a home network and a business network will probably both make use of hubs as a way to physically connect the computers. But a home network won't necessarily have network servers and print servers that are required to provide services to the large number of users found on a corporate network.

Tip

Because client and server computers both have processing capabilities, the workload on a PC network can be distributed between the client and the server. This differs from the centralized computing provided by mainframes and minicomputers, where the central computer provides all the processing power for the users logged on via dumb terminals.

Tip

You may hear the term workstation used interchangeably with client in reference to the computers used by network users to access the network. In reality, workstation more commonly refers to higher-end client machines that require more memory and processing power to run more complex software, such as the design software used by engineers.


Network Players: Users and Administrators

The fact that two different types of computers—clients and servers—exist on the network means that the people on the network will also play different roles. Users make up most of the folks you find on a PC network. They are there to access network resources. A user requires a user logon and password to gain access to the network.

The person who serves as the caretaker of the network is the network administrator. The administrator controls the network servers. This means that network access and the level of access is controlled by the administrator using the tools provided by the NOS.

Most network operating systems supply the network administrator with the ability to monitor network use, including user logons. Tools for monitoring hardware parameters such as memory and processor usage on a server are also typically available. The administrator is also responsible for disaster planning and securing the network resources from outside attack and virus infestation.

One of the most difficult aspects of being a network administrator is convincing users that the access levels and security policies used on the network are there for a purpose—and that purpose is to protect the valuable corporate resources found on the network. Although network administrators are typically thought of as dime-store dictators or control freaks by the users, administrators are typically faced with long hours and a great deal of hard work to keep their networks up and running. They certainly don't wear beepers as a fashion accessory.

Note

There is certainly more to a network administrator's job than just dealing with user and hardware problems. Network administrators also may supervise technical employees and be responsible for the budgeting and procurement related to the computer network.


Understanding LAN Data Transmission

Before we delve more deeply into the nuts and bolts of PC networking, we need to discuss how data is transmitted on the network. The way data travels on the network media (such as copper wire and glass fiber-optic cable) differs from how data flows between the different components in a computer.

First, let's define the bit. A bit is the smallest unit of data found on a computer; bits are represented by either a one (1) or a zero (0). When you type a letter or create a spreadsheet, you see your data as words in paragraphs or numbers in a column. Your computer sees this information as binary data—ones and zeros.

On a computer, data in the form of a bit stream travels in parallel across wires arranged on the motherboard. These parallel wires on the motherboard are referred to as the data bus. When data is required by the computer's processor from the computer's hard drive, the data moves along the bus, which is very much like a multilane superhighway, allowing several bit streams to move simultaneously.

To actually move data from one computer to another on the network, there obviously needs to be some kind of network medium; copper wire is actually the most often used network medium (the topic of network media is discussed in Chapter 4, in the section "Choosing a Network Connectivity Strategy"). Unfortunately, no matter what type of network medium you choose, the data can only travel along it as a single bit stream, which is referred to as a serial transmission.

A device is needed to take the parallel data from the computer, which is like a multilane super highway, and condense it into a serial transmission, which is the equivalent of a one-lane road. This device also provides the connection between the PC and the network media.

The device I'm talking about here is a network interface card, or NIC. The NIC contains a transceiver (a transmitter and receiver) that is able to convert data from parallel to serial, and vice versa. A NIC can come in the form of a separate card that you install in the computer (there are a large number of different NIC manufacturers). The NIC must be compatible with the bus slot that you wish to install it in. Some personal computers, such as the Apple iMac, come with a built-in NIC that's ready to go. Figure 1.3 shows two different kinds of NICs.

Figure 1.3. Network interface cards provide the physical connection between a computer and the network.

So it's the NIC that supplies the physical connection between a computer (client or server) and the network media, and it's the network card that supplies the translation of data from parallel to serial. As you can see, the NIC is a very important component of networking PCs. The network interface card is discussed in Chapter 3, "Networking Hardware," in the section "Working with Network Interface Cards."


Networking Does Not Require the "All Knowing"

Now that we have defined some of the general aspects of computer networking, such as clients and servers, I'd like to take a moment to give you a pep talk. Although some incredible minds have worked long and hard on developing the software and hardware that is used to create a computer network, it is not required that you have the collective intelligence of all the network pioneers to be a network administrator.

Being a network administrator is the same as being a bricklayer or a concert pianist. They both understand the basics of their medium—the brick and the piano—but neither of them could necessarily create a brick or a piano from scratch. However, they both understand the tools of their trade. Even being the administrator for a small network used in a home office will require a knowledge base related to PCs beyond that of the average user.

You will need to understand how computers work and be able to add devices to PCs, such as network interface cards and new hard drives, but you are not necessarily required to build computers from scratch. You are also not required to know all the intricacies of every piece of software running on the network.

Anyone willing to develop a good understanding of computer hardware, networking devices (such as hubs and the various choices for networking media), and network operating systems (especially the network operating system you will use on your network) can build a solid and usable LAN. Although this book is not going to make you a network expert, it is certainly a good first step as you accumulate the knowledge base that will allow you to create and manage your own networks. Just remember, it's not rocket science, just computer networking. So, fear not and read on.

The Absolute Minimum

In this chapter we had the opportunity to sort out some of the important technology milestones that led to the introduction of the personal computer. We also had an opportunity to define networking and take a look at why you would want to network PCs.

  • Strictly speaking, a network is two or more connected computers. The larger the network, the greater the variety of network devices (such as hubs or routers) that will be required to connect the networked computers together.

  • Computers can be networked to share resources such as printers and files. Networked computers can also provide a communication medium for network users.

  • Mainframes and minicomputers provided a centralized computing model in which all resources are supplied by the mainframe or minicomputer and accessed by users accessing the computer using dumb terminals.

  • The IBM PC, launched in August of 1981, began the PC revolution. It became the standard for the desktop business computer.

  • Networks are made up of client and server computers. Client computers are used by network users to gain access to the network. Server computers are used to supply the resources that are accessed by the users on the network.

  • Network user access to the network and its resources is controlled by the network administrator. The network administrator controls both the access level of the users and the resources that they can access. This ability to control access is provided by the network operating system running on the server.

  • Computers process data in parallel, whereas data is moved across the network in serial. The network interface card (NIC) is used to translate data from parallel to serial, and vice versa, and it provides the computer with a connection to the network media.


Chapter 2. Different Needs, Different Networks

In this chapter

  • Understanding peer-to-peer networks

  • Working with peer-to-peer network limitations

  • Understanding server-based networks

  • Deploying specialized network servers

  • Understanding network topologies

  • Assessing your networking needs

In the previous chapter we took a look at the evolution of Microsoft Windows and also introduced other desktop operating systems such as Linux and the Macintosh OS. Now, we can concentrate on two main approaches to networking: peer-to-peer networking and server-based networking. Each of these networking approaches offers advantages and disadvantages.

You will find that deciding on a particular approach to networking will be directly related to the number of users you have and the types of services your network needs to offer to these users. For example, if just a few users need to share a printer, a peer-to-peer network will probably get the job done.

Peer-to-peer networks work particularly well in homes or small office situations where only a few files and possibly a printer need to be shared. Setting up a peer-to-peer network in a home also makes it easy to share a single connection to the Internet (connecting a network to the Internet is discussed in Chapter 15, "Connecting a Network to the Internet").

In cases where you have a lot of users and want to make the sharing of files or other network resources more secure and centrally controlled, a server-based network would better meet your needs. After discussing the two different approaches to networking and the basics of networking topologies, we will take some time to sort out how you can assess your own networking needs and then plan your own network.


Understanding Peer-to-Peer Networking

Peer-to-peer networking provides a simple, low-cost method for connecting personal computers in situations where you want to share files and other resources such as a printer. Peer-to-peer networking does not require a server, meaning the added expense of a powerful computer to act as a server and a network operating system for the server is avoided in this approach to creating small networks.

In a peer-to-peer network, the computers on the network function as peers. A peer computer basically acts as both a client and a server computer. Peer computers can access resources on the network, and they can supply resources to other peer computers (the same as a server does on a server-based network).

A peer-to-peer network is also commonly referred to as a workgroup. This is because the term workgroup connotes collaboration without central control, differentiating the peer-to-peer network from the larger-scale server-based network.

The only real requirements for building a peer-to-peer network include installing an operating system on the PCs that supports peer-to-peer networking and then physically connecting the PCs (this means outfitting the computer with a network interface card and then cabling the PCs together; in the case of Macintosh computers, you don't even need the network interface card). Before taking a look at where we are today with peer-to-peer networking and the pros and cons of peer-to-peer networking, let's take a quick look at how peer-to-peer networking has changed over the last decade.

Peer Products Come and Go

Peer-to-peer networking has been around almost as long as the PC. On the IBM PC/clone side of personal computing, the DOS operating system did not provide for peer-to-peer networking. Add-on products were required to provide the functionality for sharing files or printers over a small network. Products such as Artisoft's LANtastic and Novell's NetWare Lite (Novell no longer markets NetWare Lite or a follow-up peer-to-peer product named Personal NetWare) provided workgroup networking in the late '80s and very early '90s.

The fact that you had to actually purchase the peer-to-peer networking software obviously increased the cost of creating a small workgroup. In many offices, where only a few users shared a printer or files, sneakernet (meaning no network at all) was still the low-cost choice.

As mentioned in Chapter 2, Microsoft introduced its own peer product in 1992 in the form of Windows for Workgroups 3.11. Subsequent versions of Windows, including the latest version Windows XP, are all workgroup-ready. As Microsoft Windows became the dominant operating system for PCs, this really signaled the end of the need for additional software to add workgroup functionality to a personal computer.

Note

Artisoft quickly became a huge player in the peer-to-peer networking market and built a multimillion-dollar business. LANtastic is still sold today by SpartaCom, Inc., an Artisoft spin-off. Artisoft itself is still around but now concentrates on software-based telephone systems for small- to medium-size businesses and corporate branch offices.

Peer-to-Peer Networking Today

With Microsoft Windows dominating today's personal computing market (because of availability, usability, and acceptance as standards in the business world), peer-to-peer networking is certainly an easy-to-configure, low-cost avenue for sharing files and printers at home or a small business. Once the computers and printers in the peer-to-peer network have been physically connected, actually setting up the sharing of files and printers is a very straightforward matter (which we discuss in Chapter 6, "Configuring Peer-to-Peer Networks".)

Linux distributions also provide workgroup capabilities with other Linux clients or with Microsoft Windows clients (through the use of SAMBA, which is discussed in Chapter 6). Figure 2.1 shows the Explorer window of a Linux workstation (running Lycoris Desktop) that has been configured to be part of a Windows workgroup.

Figure 2.1. Linux workstations can also be configured to participate in a Windows workgroup.

Note

While Microsoft Windows and the Apple Macintosh OS dominate the number of installations worldwide, Linux distributions are starting to make significant inroads. Some PC manufacturers are also beginning to provide Linux as a preinstalled OS on some systems.

Pros of Peer-to-Peer Networking

The pros related to peer-to-peer networking revolve around cost and ease of installation. Depending on the operating system you are running on your computers, peer-to-peer networking does not require the purchase of additional software or a computer to act as a dedicated network server. Most operating systems that support peer-to-peer networking also make it very easy for you to configure your computers so that they will communicate in a workgroup.

In a nutshell, here are the overall advantages of peer-to-peer networks:

  • They are relatively cheap as far as hardware outlay goes. You don't have to buy any additional computers, such as a server.

  • They are pretty easy to set up.

  • All the software that you need is typically included in your operating system.

  • Centralized administration is not required and individual users can configure the sharing of resources.

  • The peer computers don't depend on a central server machine for their resources or to log in to the network; therefore, they can operate even when other peer computers are not available.

Even though peer-to-peer networking is cheap and fairly simple to set up and configure, it is not scalable, meaning that around 10 computers at the most can live together in a peer-to-peer situation. What's more, you will still have to outfit the computers with network interface cards and connect them. If you use twisted-pair cabling, you will need a hub. If you go with coaxial cable, you will need T-connectors and terminators. Other connection strategies, such as wireless communication, will require the appropriate hardware.

Tip

Connecting computers in a peer-to-peer network is really no different from creating a small server-based network. All the computers must be connected by some connectivity scheme. Chapter 4, "Building the Network Infrastructure" discusses the different connectivity media in the section "Choosing a Network Connectivity Strategy."

Cons of Peer-to-Peer Networking

Although peer-to-peer networking appears to be the perfect networking solution in situations where you don't want to go to the trouble to install and configure a network server (or can't afford a server and the network operating system software), it does have a number of limitations. First of all, it is extremely limited as far as the number of computers you can connect together. This type of networking is really reserved for very small installations of 10 computers or less. Many experts recommend that a peer-to-peer network not include more than five peer computers; this limit is recommended because the greater the number of peers accessing information, the greater the performance hit on the peers that are providing that information. Since peer networking distributes resources across the network, having many peer shares (which each potentially require a different password) can make accessing files confusing.

Peer-to-peer networking also does not provide any centralized security on the network. Users don't have to be authenticated by a network server to actually view and potentially use the resources on the network. This is related to how resources are shared in a workgroup.

Each resource that is shared (such as a drive, folder, or printer) can potentially require a different password for access. If a lot of resources are shared across the network, you will have to remember the password for each resource. This type of security is referred to as share-level security; each drive, folder, or printer that is shared is referred to as a share.

A summary list of peer-to-peer network shortcomings follows:

  • There's an increased performance hit on computers because of resource sharing. If users access your printer, your computer's processing resources are used as they print.

  • No centralized location of shared files makes it difficult to back up data.

  • Security must be handled on a resource-by-resource basis.

  • Decentralization of resources makes it difficult for users to locate particular resources.

  • Users might have to keep track of numerous passwords.

Peer-to-peer networking definitely needs to operate in an environment of cooperation. If your users can't play well together, you will have problems because the users themselves control the various resources. Peer-to-peer networking is, however, a good way to share resources on home networks and small, single-office business networks. If you simply want to share a printer between a few computers or build a gaming network, peer-to-peer is the way to go.


Server-Based Networks

Server-based networking provides you with the ability to build large networks that offer a greater range of resources to users (when compared to peer-to-peer networks). This is because a number of different, specialized server types (such as mail and database servers) can be included on the network.

Server-based networks also provide you with greater centralized control of resources and make it easier to add additional computers, users, and resources (again, when compared to peer-to-peer networks). Server-based networks are scalable networks, meaning they are easily expandable.

One requirement for a server-based network is a computer running a network operating system; this computer is known as the server. As already mentioned in Chapter 1, "Computer Networking Overview," a server computer is basically a special-purpose machine that logs in users and "serves" up resources, such as files and printers, to the users. Because the server verifies users and determines the level of access the users will have to the various network resources, server-based networks provide a more secure environment than peer-to-peer networks.

Actually accessing resources on a server-based network is also easier than in the peer-to-peer environment because one username and one password gets a user onto the network and provides that user access to any resource he or she has the appropriate permissions for. This is in sharp contrast to a peer-to-peer network, which may have a different password for every resource on the network.

Tip

Server-based networks typically employ a more powerful computer (in terms of processor speed, RAM, and hard drive capacity) to act as the server. Network operating systems such as Microsoft Windows Server 2003 and Novell NetWare both have baseline hardware needs for the computer that will run the operating system. We will discuss computer hardware issues related to networking in Chapter 3, "Networking Hardware".

Pros and Cons of Server-Based Networking

As is the case with peer-to-peer networking, server-based networking has its pros and cons. The upside of server-based networking revolves around the fact that this type of network provides central control of resources and makes it easier for users to actually find resources. For example, the network operating system (NOS) Microsoft Windows Server 2003 manages resources such as shared folders and drives, printers, and even users in a tool called the Active Directory, shown in Figure 2.2 (this is how the Active Directory tool would appear to a network administrator).

Figure 2.2. Network operating systems such as Windows Server 2003 provide for the central management of users and resources.

Active Directory is used to add and remove users from the network and can even be used to place users who access the same resources into groups. Management tools such as Active Directory provide the administrator with the ability to control network access and the different levels of access that are given to users or groups of users. Information on configuring user accounts for network access is discussed in more detail in Chapter 20, "A Network Security Primer," in the section "Administrators and Users."

This ability to manage network users and resources centrally comes with a high price tag, however, and one of the major cons of server-based networking is the cost of the dedicated server computer and the NOS that you must run on it. Server-based networks also require a network administrator—someone who is well versed in the NOS being used. This usually means an additional employee on the company's payroll, which is another cost associated with server-based networks.

However, the overall cost of network operating system software and computer hardware is lower today than it ever has been, and the server-based network has become the standard for networking in even relatively small companies. Security features built in to the NOS allow the network administrator to protect the company's data from outside the network, and they also provide a great deal of control over sensitive data and its access from inside the network.

Let's break the pros and cons of server-based networks into two lists, with the pros first:

  • Users log on using one username and password to access network resources.

  • The network security is centrally controlled, as are the network resources.

  • Resources such as folders and files can easily be backed up because they are centrally located.

  • Dedicated, high-powered servers allow users faster access to resources.

  • Server-based networks can be easily expanded.

Now let's look at the cons:

  • For small companies, the cost of the server equipment, the network operating system, and the appropriate client licenses can be a con.

  • Although not a con if you are the network administrator, someone must be charge in setting up and controlling the resources on the network. This typically means a dedicated network administrator's position.

  • If the main server goes down, so goes the access to network resources.

The local area network (LAN)—another name for a server-based network in one location—is really the rule rather than the exception in today's business world. Even small LANs can use different types of servers to provide users with the resources they need. Let's take a look at the possibilities.

Types of Network Servers

We've already discussed the fact that a LAN uses a server to validate users as they log on to the network. If a user's login name and password don't match up, the server doesn't let him or her on the network. In large networks, this "central computer" (for lack of a better name) can be kept quite busy logging users on to the network as they fire up their client PCs. Rather than overburden this server with additional duties, it's not uncommon to distribute the workload among other specialized servers.

File Servers

A file server's job is to serve as a home for the files that are needed by users on the network. This can include files that a number of users share. These files are typically held in what is called a public folder, which can include private folders that are specific for a particular user. The great thing about using a file server is that important files reside in one place, making it very easy to back up the data periodically. The downside is that if the file server goes down, users can't get at their files.

Print Servers

A print server is used to host a network printer. It is basically the control conduit for the printer. Because print jobs need to be spooled (placed on the computer before they are sent to the printer) before they are printed, the print server supplies the hard drive space needed. The print server also queues up all the print jobs being directed to the printer. The network administrator can also delete print jobs and change the queue order of print jobs by accessing the print server.

Communication Servers

A communication server runs specialized software that allows users on the network to communicate. It provides services such as electronic mail and discussion groups to allow users to share information. Two of the most popular communication packages for a LAN (and each need to be set up on a server on a LAN) are Microsoft Exchange and Lotus Notes (both of these communication packages are discussed in Chapter 11, "Working with Applications on the Network").

Tip

Even though various network services can be spread out over several special servers, the access to these servers is still controlled by the user's logon name and password. The central server not only lets the user onto the network but also determines the resources that the user can actually access.

Application Servers

Application servers host various applications such as specialized databases. Even typical desktop applications such as word processors and spreadsheet software can also be stored on an application server. This makes updating software applications much easier because the software doesn't actually reside on every client workstation; users start these applications from their local computers, but the application software is actually stored on the server.

Web Servers

Web servers provide you with the ability to create a Web site that can be accessed internally by your employees (this is called an intranet) or by folks surfing the Internet. Web servers aren't for everyone, and many companies still use Web-hosting companies to get their Web sites up and running on the Internet. A number of different software packages can be used to set up a Web server, and they vary in ease of use and stability. Microsoft Windows Server 2003 ships with Internet Information Server 6.0 (IIS6), a Web server software package. Figure 2.3 shows the IIS6 management console that is used to configure a Web server on a Microsoft network.

Figure 2.3. Web servers are used to host corporate or personal Web sites.

Caution

With security on the Internet becoming more of a concern every day (or so it seems), setting up your own Web server can open up your company to a direct attack from the outside. The security issues related to protecting a company's Web site are certainly beyond the scope of this book, but some general security issues related to Web servers and the Internet are discussed in Chapter 16, "Hosting a Web Site".

Other Specialized Servers

There are also other types of servers that can reside on the network that don't actually provide any resources to the LAN users, but they are needed to make the network run properly or more efficiently. For example, on larger networks that use the TCP/IP network protocol, each computer must be configured with a unique Internet Protocol (IP) address (which is much like a person's Social Security number) to communicate on the network (IP addressing is discussed in detail in Chapter 5 in the section "TCP/IP"). This means that the network administrator might have to configure hundreds of computers, one at a time. However, a server running the Dynamic Host Configuration Protocol (DHCP) can actually automatically assign IP addresses to computers as they are started up on the network.

DHCP can be run on your main network server or other server on the network. Windows Server 2003, various Linux distributions, and Novell NetWare can provide services such as DHCP on the network. Server has a built-in version of DHCP. This means a server, such as one running Windows Server 2003, can be configured to provide IP addresses (this range of addresses is called a scope) to the computers on the network dynamically. This saves you a lot of time having to statically configure the IP address for each and every computer on the network. Figure 2.4 shows the DHCP snap-in that is used on a Windows Server to manage IP address leases.

Figure 2.4. DHCP can be used to provide IP addresses to network clients.

Other specialized servers you might need on a LAN relate to the fact that operating systems all assign some kind of friendly name to a computer. For example, think about the World Wide Web; when you want to go to a Web site, you type the Web site's name (also known as a Uniform Resource Locator or URL) into your Web browser. You don't typically enter the actual numerical address of the site (which is an IP address). Special servers on the Internet, called DNS servers (they run the Domain Name Service), are used to resolve that friendly name you entered into an actual address. It is not uncommon to also set up DNS servers on LANs to provide this same type of service.

You've probably noticed that the needs of your users and the size of your network dictate how many of these specialized servers you have to set up on your LAN. The larger your LAN is, the greater the need to distribute the day-to-day workload among different servers on the network. In contrast, a small network might use just one server that logs on users and supplies printer and file services.

Tip

Understanding DNS and how DNS servers work wasn't always an issue that network administrators had to deal with. Only recently, when everyone decided that his or her LAN also needed to be connected to the Internet, did issues related to name resolution and the TCP/IP protocol arise. We will try to make some sense out of TCP/IP and how IP addresses are used on a network in Chapter 12, "TCP/IP Network Administration"


Understanding Network Topologies

Now that we've completed a general overview of the two types of networks you can build (peer-to-peer and server-based), we can discuss some of the basics related to the actual physical layout of LANs. Different topologies have been defined to characterize a LAN's layout (a topology is just how the network's cabling maps out).

Although these topologies do in some respects reflect the type of cabling (coaxial cable versus twisted-pair cable, both discussed in Chapter 4) that is used and the network architecture that is deployed (network architectures are also discussed in Chapter 4), they are just models and in many cases a LAN might use a hybrid of a couple different topologies.

Bus Topology

A bus topology is characterized by a main trunk or backbone line with the networked computers attached at intervals along the trunk line, as shown in Figure 2.5. This topology type is considered a passive topology because the computers on a bus just sit and listen. When they "hear" data on the wire that belongs to them, they accept that data (they actually listen using their network interface cards). When they are ready to transmit, they make sure no one else on the bus is transmitting and then send their packets of information.

Figure 2.5. A bus topology provides one of the simplest ways to connect a group of computers.

Bus networks typically use coaxial networking cable (it looks like the same coaxial cable used for cable television, but it is actually slightly different) hooked to each computer using a T-connector. Each end of the network is terminated using a terminator specific to the cable type (if you use 50-Ohm cable, you use 50-Ohm terminators). Because the bus network is really just a collection of cable, connectors, and terminators, there is no amplification of the signal as it travels on the wire. This means that the size of the network will be limited by the maximum distance the cable type can actually move the signal that holds the data.

Bus networks are easy to assemble and are easy to extend. They require a fairly limited amount of cabling when compared to other topologies. Bus networks are prone to cable breaks, loose connectors, and cable shorts that can be very difficult to troubleshoot. One physical problem on the network, such as a detached connector, can actually bring down the entire bus network. Although at one time a bus network would have been the cheapest and easiest way to connect a small group of computers for peer-to-peer networking, the drop in the price of hubs (discussed in the next section on star networks) and the ease of using twisted-pair wire have really pushed the coaxial cable bus network to the edge of extinction.

The main reason for knowing about bus networks is that there are still bus installations found in small and medium-size companies. Remember that troubleshooting this type of network will typically require an inspection of all the cabling and their connections. As far as building a new network using a bus technology, you are far better off going with a star configuration using a hub (the star topology is discussed in the next section).

Tip

Although a number of different cable types can be used for LANs, copper-based twisted-pair wire has really become the standard. In fact, most network interface cards now only come with a port for a twisted-pair connector and not the T-connector used with bus networks. It is fairly inexpensive and easy to work with because it is flexible (it bends around corners). The different wiring possibilities for your network and wireless connectivity are discussed in Chapter 4.

Star Topology

In a star topology, the computers on the network connect to a centralized connectivity device called a hub. Each computer is connected with its own cable (typically twisted-pair cable) to a port on the hub, as shown in Figure 2.6. Star LANs also use the same type of wait-and-listen strategy to access data or send data as characterized by the bus topology.

Figure 2.6. The star topology uses a hub as the central connection point for the computers on the LAN.

Because the star topology uses a separate cable connection for each computer on the network, star networks are easily expandable, with the main limiting factor being the number of ports available on the hub (although hubs can easily be daisy-chained together to increase the number of ports available). Expanding a star topology network is also very unobtrusive: Adding a computer to the network is just a matter of running a wire between the computer and the hub. Users on the network will be pretty much unaware that the expansion is taking place.

Disadvantages of the star topology revolve around cabling needs and the hub itself. Because each computer on the network requires a separate cable, cable costs will be higher than a bus topology network (although twisted-pair, the cable type used for star networks, is the least expensive cable type). Having to purchase a hub or hubs for your network does add additional costs when you are building a network based on the star topology, but considering the benefits of this type of topology in terms of managing the physical aspects of your network, it is probably well worth it.

The greatest benefit of using the star topology is that you can easily add new computers to the network without disrupting service to the computers already on the network. Also, if one computer goes down on the network, it does not negate the ability of the other computers on the star to communicate with each other. Obviously, the most crucial failure point on a star network would be the central hub.

Ring Topology

A ring topology connects the LAN computers one after the other on the wire in a physical circle, as shown in Figure 2.7. The ring topology moves information on the wire in one direction and is considered an active topology. Computers on the network actually retransmit the packets (packet is a generic term for the chunks of data that are being moved along the network) they receive and then send them on to the next computer in the ring.

Figure 2.7. The ring topology connects the computers in a circle, where a token is used to permit the transmission of data.

The ring topology is considered an active topology because the computers in the ring actually pass a token around the circle. The token is a special packet of data, sort of like your ATM card, that gives the computer with the token special abilities. If a computer wants to send data onto the network, it has to wait until it has possession of the token. This is how the IBM-Token Ring network architecture operates (which is discussed in Chapter 4).

True ring topologies can be difficult to troubleshoot, and the failure of one computer on the ring can disrupt the data flow (because data circulates around the ring in one direction). Also, adding or removing computers from this type of topology can disrupt the operation of the network. On most small LANs, you won't run into the ring topology because IBM Token Ring and some other high-speed network technologies that use a ring are more typical of larger networks.

Since Token Ring hardware is expensive and Token Ring networks require a substantial knowledge base to administer, ring topologies are only used on larger corporate networks. You would not use this type of topology for a home or small office network. The star topology is the cheapest and easiest to deploy in a small office situation.


Assessing Your Network Needs

Now that we've gotten some of the prerequisite basic theory out of the way, we need to take a moment to discuss assessing your own network needs. The type of resources that your users need to share and the number of users, as well as their physical locations, will really dictate how you use the rest of the information in this book to choose the type of network you build, the network operating system you use, and the type of servers (if any) you place on your network.

Let's break the process into a list:

  • How many users do you currently have and do they each have their own PC? A very small user base with only a couple of computers could really get along just fine on a peer-to-peer network. More users and more client machines may dictate that you go with a server-based network.

  • What type of resources do your users need to share? If you are looking at a situation where only a printer and a few files need to be shared, you are again probably in the realm of the peer-to-peer network. In cases where specialized resources such as databases and multiple printers or file servers are required, you will definitely be working in a server-based networking environment.

  • Where are your users? If all the users work in close proximity, you can typically select an easy-to-deploy network media type, such as wire (or you might be able to use existing electrical or phone wire, as discussed in Chapter 4). If your users are on different floors of a building or in different buildings, this will complicate issues related to getting all the users connected. In cases where you have users that telecommute, you can use special servers, such as remote access servers (called RAS servers), to allow users to dial into the network. We cover remote access in Chapter 17, "Networking on the Run".

  • How will your network grow over time? If you expect growth in your user base and the type of resources that they need to access, a server-based network is really the only way to go. A star topology also provides the easiest type of network topology for expanding the number of computers on the network.

  • What does your budget look like? Even if you determine that you need a number of specialized servers on your network, you have to be able to afford the physical aspects of the network (such as the cabling and the topology). How many specialized servers you can set up is also going to be limited by your budget. Although it might seem to be very exciting to plan to implement the latest and greatest technologies, budgeting constraints might require that you build a simpler network that provides you with the ability to expand in the future.

Although these are just some general guidelines, you should probably do a serious needs analysis before jumping into the network arena. There is nothing worse than miscalculating your needs and ending up with a network that just isn't usable or ending up with a network that is under-utilized.


Planning the Network

You should hold off on creating your network plan until you have truthfully assessed your networking needs. Once you have that information available, you can start the task of determining what kind of client machines you need to purchase and what kind of servers you will have to set up on your network.

Keep in mind that business networks must meet the business requirements of your company or institution. While it is very difficult to assess the actual monetary value added aspects of business computer networks, the network must fit into the overall business plan. This relates to budgetary issues, the infrastructure of the company (do you have to connect remote offices to the central office?), and the level of security required for the network. A company handling credit card information on its network will certainly need a higher level of network security than other networks.

A good way to expand your understanding of network planning is to read through this book. It provides nuts-and-bolts information on network infrastructures and some of the choices for network clients and network operating systems. Because this book does not profess to be anything more than an introduction to the world of networking, you will need to do some additional research. The World Wide Web is an incredible resource for the novice network builder. It provides information on products, networking theory, and even allows you to purchase the hardware and software that you need to get your network up and running.

In situations where you will be involved in the building of large networks, you might want to go outside your company and hire a consultant to help you plan the network infrastructure. In the case of smaller networks, a little research and some careful consideration should help you put together a network that will meet your needs.

The Absolute Minimum

In this chapter we looked at the differences between peer-to-peer and server-based networks. We also had the opportunity to look at the different topologies that are used for the physical layout of networks.

  • Peer-to-peer networks are best used in situations where a few users need to share a few resources.

  • Peer-to-peer networks use share-level security, which means that each resource could have a different password.

  • Server-based networks provide for centralized management of the network.

  • Server-based networks log on a user with one password. The user can access any resources that he or she has been given the appropriate permissions for.

  • Server-based networks can distribute the workload among specialized network servers, such as file and print servers.

  • Special servers, such as Web servers, can expand the ability of the network to communicate outside its physical location.

  • The bus topology is the simplest topology and uses a passive methodology for computers accessing the network.

  • The star topology is the most common network topology and also the easiest to expand. The star topology is also considered a passive topology (like the bus topology).

  • The ring topology is an active topology because computers on the ring pass a token. To send data onto the network, possession of the token is required.

  • It is extremely important that you assess your networking needs before actually planning your network. Take future growth into account when assessing your LAN needs. Also plan your network so that it becomes an integral tool in the company's overall goals and ambitions.


Chapter 3. Networking Hardware

In this chapter

  • Working with network interface cards

  • Selecting and installing a NIC

  • Using hubs and internetworking devices

  • Working with PC motherboards

  • Understanding processors and PC RAM

  • Working with hard drives

  • Differentiating server and client hardware

Now that we've discussed the different kinds of networks and looked at network topologies, we should spend some time discussing the hardware involved in networking. This chapter will concentrate on the connectivity devices that define the network topology—the most important being the network interface card. We will also take a look at hubs, routers, and switches.

Another important aspect of building your network is selecting the hardware for your client PCs and your network servers. There are many good primers on computer hardware—for example, the Absolute Beginner's Guide to PC Upgrades, published by Que. Also, numerous advanced books, such as Upgrading and Repairing PCs (by Scott Mueller, also from Que), are available, so we won't cover PC hardware in depth in this chapter. We will take a look at motherboards, RAM, and hard drives because of the impact these components have on server performance.

Let's start our discussion with the network interface card. We can then look at network connectivity devices and finish up with some information on PC hardware.


Working with Network Interface Cards

As far as networking is concerned, the network interface card (NIC) is one of the most important PC devices. Each computer on the network (including servers and clients) requires one, and it is the NIC that provides the connection between the PC and the network's physical medium (such as copper or fiber-optic cable, both of which are discussed in the next chapter).

Many of the new motherboards available for PCs and servers have the network interface integrated with the motherboard. Older computers or new computers that do not provide onboard network interfaces will require that a NIC be added to it (unless you buy your network clients and servers with a NIC as their standard hardware configuration, which can be integrated on the motherboard or a separate card in an expansion slot). Figure 3.1 shows a PCI NIC from 3Com, which provides the RJ-45 female port for the CAT 5 twisted-pair cable that connects the computer to a hub or switch (more about these connectivity devices later in the chapter).

Figure 3.1. Network interface cards provide the connection between the PC and the network cabling.

Not only does the NIC provide the computer with a connection to the network, but it also handles an important data-conversion function. Data travels in parallel on the PC's bus system; the network medium demands a serial transmission. The transceiver (a transmitter and receiver) on the NIC is able to move data from parallel to serial, and vice versa. This is not unlike automobiles moving on a multi-lane superhighway that must all merge into one lane of traffic.

Network interface cards also supply the basic addressing system used to get data from one computer to another on the network. This hardware or MAC address is burned into a ROM chip on the NIC. It is referred to as the MAC address because the Media Access Control (MAC) layer is actually a sublayer of the OSI model's Data Link layer (the OSI model is discussed in detail in Chapter 5, "Network Protocols: Real and Imagined," in the section "Understanding the OSI Model").

Tip

The hardware address on the NIC actually provides the definitive address for a computer on the network. Different protocol stacks, such as TCP/IP, use a logical addressing system (in the case of TCP/IP, it is IP addresses). In this case, the logical address must be resolved to the NIC's hardware address before the data can actually be received.

Selecting a NIC

NICs come in different types, depending on the network architecture being used on the network (such as Ethernet or token ring, which are both discussed in the next chapter). NICs also differ in the type of motherboard slot they fit into. PCI NICs fit into a PCI slot on a motherboard. ISA NICs fit into an ISA slot. Figure 3.1 shows a PCI card (PCI cards are shorter than ISA cards, as are their respective slots on the motherboard).

When you select a NIC, it needs to be compatible with the architecture of the network. The Ethernet network is, by far, the most common network architecture type and is used for both peer-to-peer networks and large-scale corporate networks. Ethernet connectivity devices, such as hubs, are also much cheaper than the connectivity devices deployed on a token-ring network.

The NIC specification must also comply with the throughput on your network. For example, if you are running a Fast Ethernet network at 100Mbps, an Ethernet card designed for 10Mbps isn't going to be appropriate. You will actually find that most new NICs are autoswitchable between 10Mbps and 100Mbps speeds (accommodating both Ethernet and Fast Ethernet).

The NIC that you select must also fit in an empty expansion slot on your computer's motherboard. On an IBM or compatible PC, you may have a number of choices, such as an ISA, PCI, or EISA slot. The slots available will depend on the motherboard (motherboards are discussed later in the chapter). Figure 3.2 shows a motherboard that provides both ISA and PCI expansion slots.

Figure 3.2. Your motherboard will typically provide ISA and PCI expansion slots.

The Industry Standard Architecture (ISA) bus (a bus is the internal wiring system on the motherboard) was the standard used on the IBM PC and the IBM XT class of personal computers. This slot type supported 8-bit throughput for expansion devices. The ISA bus speed was increased to 16 bits in 1984. A large number of devices, such as modems, sound cards, and NICs, are available for this bus type. Even some newer motherboards provide ISA slots. However, a number of high-speed motherboards are now available that have PCI slots only and do not support ISA expansion cards (PCI cards are faster than ISA cards).

The PCI bus, on the other hand, was introduced by Intel in 1993 and has really become the industry standard. PCI provides a 32-bit bus, and PCI version 2.1 supports 64-bit and faster bus specifications. As with ISA, PCI cards support a large number of peripheral devices.

Although ISA NICs are generally going to be cheaper than PCI NICs, PCI NICs are obviously going to provide better overall performance because of their potential for faster throughput. You can get some other enhancements with a NIC that improve the transfer of data from the NIC to the computer's processor:

  • Buffering. Memory chips are actually placed on the NIC. This RAM is used as a buffer. It can hold data that is awaiting services provided by the computer's processor. It can also hold data waiting to be broadcast out onto the LAN medium.

  • Direct Memory Access (DMA). Computers that support DMA allow devices such as network interface cards to transfer and accept data directly from the computer's RAM. This means that the processor does not have to become involved in the process of moving data to or from the NIC and RAM.

  • Bus mastering. NICs can be designed to directly access computer RAM without using the computer's processor as an intermediary. Bus mastering (which is similar to DMA) allows the NIC to control the bus and send and receive data to and from the computer's RAM.

NICs that provide buffering and support DMA or bus mastering are going to be more expensive than NICs that do not. However, when selecting a NIC for a mission-critical server, you will probably want to buy one with all the performance bells and whistles.

Note

Token-ring networks are typically found in larger corporations. The token-ring architecture does offer some advantages over Ethernet (particularly on high-traffic networks, where bandwidth is at a premium), which we discuss in the next chapter.

Note

There is a slight chance you might run into three other computer bus architectures: EISA, VESA, and MCA. Extended Industry Standard Architecture (EISA) was developed by Compaq and other PC clone manufacturers as a suggested PC slot standard (it never became the industry standard) when IBM rolled out PCs embracing Micro Channel Architecture (which is now nothing more than a footnote in bus architecture literature). EISA provided 32-bit bus throughput as well as ISA compatibility. The Video Electronics Standards Association (VESA) bus provided support for 486 processors. This 32-bit bus system has been abandoned by motherboard manufacturers in favor of the PCI bus. Micro Channel Architecture (MCA) was a new bus system launched by IBM for its PS/2 family of computers. MCA was not compatible with ISA, and the availability of MCA peripherals was limited when the PS/2 family was first introduced. MCA expansion cards were also extremely expensive. The MCA bus was eventually abandoned by IBM in favor of the PCI bus.

Installing a NIC

You certainly don't need an engineering degree to install a network card in a PC. However, before you tackle the job, you need to be aware of one thing: You need to have a handle on a subject area that an old colleague of mine referred to as "static awareness." Static electricity can actually produce enough voltage to ruin a motherboard or expansion card, such as a NIC. This means that you should use some sort of antistatic wristband that attaches to the PC case or do your work while standing on an antistatic mat. The bottom line is that you should avoid working on the computer in a room that is carpeted.

You will also want to be sure you have a couple of decent screwdrivers. These screwdrivers should not have magnetized tips. Now, here are the steps to follow:

  1. Open up the case on the computer and install the NIC in an open expansion slot.

  2. Close up the case and attach the network medium (typically twisted-pair cabling).

  3. Boot up the computer. If you purchased a plug-and-play network card and are using an OS that supports plug-and-play technology, the most you will have to do is provide a disk or CD-ROM that contains the driver for the NIC.

  4. If you are using an operating system that does not detect new hardware devices, you will have to manually install the NIC. If the card came with installation software, use that software to install the necessary drivers.

Because most new computers and the operating systems that they run embrace plug-and-play technology, installing a NIC in a computer is really just a matter of placing the NIC in an empty motherboard slot and then restarting the computer. Plug-and-play NICs will be recognized by the operating system and the appropriate software driver will be loaded on the system. Figure 3.3 shows the Windows XP Professional OS identifying a plug-and-play NIC.

Figure 3.3. Operating systems like Windows XP embrace plug-and-play technology, making it easy to add a new NIC to the system.

While there are very few operating systems (client and NOS included) that do not embrace some sort of plug-and-play technology that identifies installed components such as a NIC, you should still have a basic knowledge of IRQs if you are going to work with PCs. So, what is an IRQ (or Interrupt Request)? Well, each device in your computer, including the mouse, keyboard, and NIC, is assigned an Interrupt Request line that the device uses to alert the microprocessor (CPU) that it needs data processed. Each device must be assigned a unique IRQ; otherwise, you will have an IRQ conflict. Although PCI motherboards do allow devices to share an IRQ, common practice is to have a unique IRQ for every device on the system.

In most cases, you probably won't have to assign IRQs from scratch to a device such as a NIC, but you may run into an IRQ conflict (particularly if you are running older versions of Windows). Viewing the IRQ assignments and the free IRQs on a system isn't that difficult. Each operating system has some sort of utility that you can use to vie the IRQs on the system. For example, Figure 3.4 shows the Windows XP Device Manager, which displays the IRQ assignments on the system.

Figure 3.4. Windows XP and most other operating systems allow you to examine the IRQ configuration of a computer.

Standard IRQ settings do exist for PCs. Table 3.1 lists IRQs 0–15. As you can see, a number of the IRQs are reserved for particular system devices.

Table 3.1. IRQ Settings

IRQ

Use

0

System timer

1

Keyboard

2

Cascade to secondary IRQ controller

3

COM port 2 and 4 (serial port)

4

COM port 1 and 3 (serial port)

5

LPT2 (printer port)

6

Floppy disk controller

7

LPT1 (printer port)

8

Real-time clock

9

Free

10

Primary SCSI adapter (or free)

11

Secondary SCSI adapter (or free)

12

PS/2 mouse

13

Floating-point math coprocessor

14

Primary hard disk controller

15

Secondary hard disk controller (or free)

Obviously, in cases where the computer does not have a second COM port or an LTP2 port, these IRQs will be available. Each computer's hardware configuration will vary (look back at the IRQ assignments in Figure 3.4 and compare them to Table 4.1), and so will the IRQ assignments and available IRQs on the system.


Working with Network Connectivity Devices

Depending on the type of topology your network uses and the type of cabling you use (cabling is discussed in Chapter 4, "Building the Network Infrastructure"), your LAN might require some sort of connectivity device to connect the various network computers, printers, and other devices together. In cases where you need to extend your LAN (say, to the second floor of an office building) or add a large number of new users to the LAN, other connectivity devices might be required. Some of these connectivity devices merely serve to connect devices; others are used to boost the data signal traveling on the network medium, and still others actually participate in determining how data traffic should flow on the network.

Let's start our discussion of network connectivity devices with the hub, which is a device you would use on a small network, or even in a peer-to-peer networking situation, to connect computers. The other devices that we will look at, such as repeaters, switches, and routers, are often lumped under the blanket term internetworking devices. An internetwork is a network of LANs, meaning that some sort of connectivity technology is used to extend a LAN beyond its typical size or to connect different LANs together into one large network.

Hubs

Hubs are commonly used LAN connectivity devices (although inexpensive switches are rapidly replacing hubs on networks). They serve as the central connection points for LANs (hubs are used on LANs that embrace the star topology discussed in Chapter 2, "Different Needs, Different Networks"). A basic hub contains no active electronics and therefore cannot be used to extend a LAN (that is, extend it past the cabling distance specifications discussed in the next chapter). It basically organizes your cables and relays data signals to all the computers on the LAN.

Hubs are used on networks that use twisted-pair cabling. Ports available on the hub provide the connection points for the devices on the network. Computers and other devices are attached to the hub by individual network cables. Hubs come in many sizes and shapes and supply different numbers of ports.

In cases where the LAN outgrows the size of the hub, a new hub can be attached (the hubs are "daisy chained" together using a short connection cable often referred to as a rat tail) to the current hub, thus providing greater port density. Figure 3.5 shows a 24-port Ethernet hub.

Figure 3.5. Hubs provide a connecting point for LAN nodes.

Hubs come in all sizes and shapes and are available in a wide range of prices. Typically, the more ports on the hub, the more expensive the hub. Hubs that support faster varieties of Ethernet, such as Fast Ethernet (which we discuss in the next chapter), will also cost more.

Repeaters

As you will find out in the next chapter, the different types of network cabling all have a maximum distance that they can move a data signal. In cases where a LAN must be extended beyond the maximum run for a particular cabling type, repeaters are used. A repeater takes the signal that it receives from computers and other devices on the LAN and regenerates the signal so that the signal maintains its integrity along a longer media run than is normally possible.

Repeaters don't have any capabilities for directing network traffic or deciding the particular route certain data should take; they are simple devices that just sit on the network, boosting the data signals they receive. The problem with repeaters is that they amplify the entire signal that they receive, including any line noise. So, in worst-case scenarios, they pass on data traffic that is barely discernable from the background noise on the line.

Bridges

A bridge is an internetworking device used to help conserve the bandwidth available on the network. When LANs really start to grow, network data traffic can begin to overwhelm the available bandwidth on network media.

One strategy for conserving network bandwidth is to chop the network up into smaller segments. These segments are connected to a bridge. Bridges are smarter than hubs and repeaters and actually use some software to help get the job done. A bridge is able to read the MAC address (also known as the hardware address—remember it's burned onto the NIC in each computer on the network) of each data packet circulating on the network segments connected to the bridge. By learning which MAC addresses live on each of the network segments, the bridge can help keep data traffic that is local to a particular segment from spreading to the other network segments that are serviced by the bridge.

Switches

A switch is another internetworking device used to manage the bandwidth on a large network. Switches are rapidly becoming one of the most used internetworking devices for connecting even smaller networks because they allow you some control over the use of the bandwidth on the network. A switch, which is often referred to as a "bridge on steroids," controls the flow of data by using the MAC address that is placed on each data packet (which coincides with the MAC address of a particular computer's network card). Switches divide networks into what are called Virtual LANs or VLANs. The great thing about a VLAN, which is a logical grouping of computers on the network into a sort of communication group, is that the computers don't have to be in close proximity or even on the same floor. This allows you to group computers that serve similar types of users into a VLAN. For example, even if your engineers are spread all over your company's office building, their computers can still be made part of the same VLAN, which would share bandwidth.

Switches use a combination of software and hardware to switch packets between computers and other devices on the network. Switches have their own operating system. Figure 3.6 shows the status of a VLAN (VLAN1) on a Cisco 2900 switch. Understanding what is being shown in this figure requires an understanding of the switch's OS. Basically, this particular screen shows the hardware/MAC address of the switch and the IP address of the switch. Other statistics relate to the number of packets sent and received by the switch (which are all at 0 because the switch has just been placed on the network).

Figure 3.6. A proprietary switch operating system is used to configure and monitor a switch.

Because switches can offer a high density of connection ports, they can replace hubs on a network. This means that each computer on the network can be connected to its own port on the switch. When PCs are directly connected to a switch, the switch can supply each PC with a dedicated amount of bandwidth. For example, users on a 100Mbps Ethernet (fast Ethernet) network can realize bandwidth of 100Mbps. The computers don't compete for the bandwidth the way computers do on a network that is connected via a hub. This is why switches are rapidly replacing hubs. Inexpensive switches are even available for the small network and home network markets.

Some switch hardware can also take advantage of full-duplex access to the network media, which allows for the sending and receiving of data simultaneously on the network. This provides network access on an Ethernet network that would essentially be collision free (Ethernet networks experience data collisions pretty much as a rule; Ethernet is discussed in the next chapter). A computer on a Fast Ethernet network, which runs at 100Mbps, would actually realize a net total of 200Mbps throughput because sending and receiving can take place simultaneously on the full-duplex media.

Switches (because of the aforementioned reasons) are becoming very popular on both small and large networks. They have all but replaced bridges as the internetworking devices for conserving network bandwidth and expanding LANs into larger corporate internetworks. And they are also making the hub a thing of the past on smaller networks.

Routers

Routers are even smarter than bridges and switches (routers operate at the Network layer—a higher level in the OSI conceptual model than bridges and switches, which operate at the Data Link layer; we discuss all the layers of OSI in Chapter 5). A router uses a combination of hardware and software to actually "route" data from its source to its destination. (By software, I mean an operating system.) Routers actually have a very sophisticated OS that allows you to configure their various connection ports. You can set up a router to route data packets from a number of different network protocol stacks, including TCP/IP, IPX/SPX, and AppleTalk (protocols are discussed in Chapter 4).

Routers are used to segment LANs that have become very large and congested with data traffic. Routers are also used to connect remote LANs together using different WAN technologies.

Figure 3.7 shows a Cisco 2516 router. This router has a built-in hub and three different WAN connection points. Notice the BRI port marked in the figure. BRI stands for ISDN Basic Rate Interface, which allows this router to connect to a remote network using an ISDN connection (ISDN and other WAN technologies are discussed in Chapter 13, "Expanding a LAN with WAN Technology").

Figure 3.7. Routers are used to segment networks into logical subsets.

Routers divide large networks into logical segments called subnets. This division of the network is based on the addressing scheme the network uses, such as IP addresses. Data traffic related to a particular subnet is kept local. The router only forwards data that is meant for other subnets on the extended network. This routing of network data helps conserve network bandwidth.

Routers decide how to forward data packets to their destinations based on a routing table. Routers use protocols built in to their operating system to identify neighboring routers and their network addresses (such as IP addresses). This allows routers to build a routing table. Figure 3.8 shows the command-line interface used on a Cisco router. This figure also shows the IP routing table for a small network that consists of two connected Cisco routers. Each of the subnets shown at the bottom of the table (notice the list of IP addresses) represents a different router interface. 10.2.0.0 and 10.3.0.0 are on the router that supplied this screen. The subnets 10.1.0.0 and 132.1.0.0 were discovered by the router (using the RIP protocol) on a connected router.

Figure 3.8. Routers build and use a routing table to determine where data packets should be forwarded.

    [ Team LiB ]


Some Thoughts on PC Hardware

Now that we've discussed NICs and some of the connectivity devices you will run into when you network computers, we will finish out the chapter by looking at some other critical pieces of PC hardware—specifically, motherboards, processors, hard drives, and RAM. We need to discuss these hardware components because they inherently affect a PC's overall performance. Understanding how these hardware components fit into the overall PC hardware puzzle will help you when it is time for you to select hardware for network clients or network servers. Since this book serves as a primer to networking and network hardware, you should consult a heavy-duty reference such as Upgrading and Repairing PCs by Scott Mueller, published by Que.

First, let's take a look at some issues related to motherboards. Then we can take a look at processors, hard drives, and memory.

Motherboards

The motherboard is the main system board for a PC, and it provides the data highway (or bus system) that moves data between components on the motherboard and the PC's processor. The speed of data moving along the bus is measured in megahertz (MHz). Although 66MHz was once considered fast for the bus speed of a motherboard, motherboard manufacturers quickly provided motherboards with bus speeds of a 100 to 133MHz. Motherboard bus speed has continued to increase with each new motherboard and chip set. There are motherboards now available that provide bus speeds in excess of 500MHz.

At one time the motherboard would never have been considered the limiting factor in a PC configuration but with advances in PC memory and processors, a computer with an older motherboard may only provide few options as far as upgrading; meaning newer memory modules and processors may not be compatible with a legacy motherboard.

Although how fast a computer can work with data is really ultimately decided by the computer's processor, deciding on a particular motherboard should probably be determined, in part, by the features the motherboard's chipset provides. The chipset determines the ceiling for the bus speed. Chipsets provide DMA support (discussed earlier in this chapter in the section "Selecting a NIC") and other features, such as an Accelerated Graphics Port (AGP provides faster video response). These features will also boost the overall performance of the computer.

Note

No matter what operating system you use, computers use pretty much the same strategy to identify themselves on the network. This strategy involves broadcast messages, meaning that a message will go out to every other computer on the network, proclaiming a computer's identity or requesting information related to the identity of another computer on the network. Broadcast messages create what is called broadcast traffic, and broadcast traffic can suck up valuable network bandwidth that otherwise could be used to move LAN data. Routers keep broadcast traffic from spreading beyond a particular segment, thus conserving a lot of potential network bandwidth.

Processors

The processor is really the brain of the computer. It processes binary information input by the user or received from other devices on the computer, such as the network interface card. Processor speed is measured in megahertz (MHz). The Intel processor used on the original IBM PC ran at 8MHz. Processors are now available that run in excess of 2,000MHz (that is, 2GHz or gigahertz).

Processors are manufactured by a number of different companies, including Intel, Motorola, Cyrix, and AMD. The selection of the processor type and speed, as far as networking is concerned, will depend on whether you are configuring a client machine or a network server. Faster (and even multiple) processors are a must on a server that needs to process a large number of calls for data from users on the network.

Basically, you should choose the processor you want to use for a computer and allow that choice to determine the motherboard you use for the computer. This helps narrow the choice of motherboards down to those that support the processor.

Memory

There seems to be as many memory types for personal computers as there are types of apples. Computer memory or RAM (Random Access Memory) is the working storage area. It is used by the processor and other devices to temporarily store information, and it's also accessed by software as we work on our computers.

You can't just install any type of RAM on your motherboard; it is actually dictated by the chipset the manufacturer places on the motherboard. This means you need to know the type of RAM that is compatible with a particular motherboard.

RAM comes in two basic formats: SIMMS and DIMMS. A SIMM (Single Inline Memory Module) is a epoxy-coated silicon wafer that contains a number of memory chips. The SIMM fits into a slot on the motherboard. SIMMs must be placed on the motherboard in identical pairs (there are typically four SIMM slots on a motherboard). This means that to have 64MB of memory on the motherboard, two 32MB SIMMs would be installed. You will only run into SIMMs if you are working with an older computer that has a legacy motherboard. Newer motherboards support the DIMM.

A (DIMM) Dual Inline Memory Module contains memory chips like a SIMM but actually provides a greater density of memory chips and therefore more RAM. DIMMs do not have to be installed in pairs, and there are typically three DIMM slots on a motherboard. This means that a computer with 256MB of memory would only require the installation of one 256MB DIMM.

RAM speed has been historically measured in nanoseconds (ns). The lower the nanosecond rating for the RAM, the faster the RAM. For example, 10ns RAM would be faster than 30ns RAM. The speed of newer RAM memory is now measured in MHz (as is the motherboard bus speed and processor speed).

As mentioned earlier, a number of different RAM types are available, and the type used is dictated by the motherboard used on the computer. Although memory has changed dramatically since the advent of the PC, the RAM types listed here are all types you might find on a motherboard designed for a Pentium processor (clone processor motherboard):

  • Fast Page Mode (FPM) memory. This type of RAM is mounted in SIMM modules of 2, 4, 8, 16, or 32MB and is the traditional RAM type. FPM RAM is typically found in 60ns and 70ns versions. You cannot mix different speeds on the same motherboard.

  • Extended Data Output (EDO) RAM. This RAM type is an improvement of FPM RAM that provides for the faster reading of data. EDO RAM is usually sold in 60 and 50ns versions. The 50ns version is available at a higher cost. EDO RAM is mounted in SIMM modules.

  • Synchronous Dynamic RAM (SDRAM). This RAM type is still considered the standard for desktop computers but is rapidly being replaced in new computer systems with DDR-SDRAM (discussed in a moment). SDRAM is typically referred to as PC100 or PC133 RAM, depending on its speed. SDRAM comes in DIMMs and has an access time of only 12 to 8ns (PC100 and PC133 RAM, respectively). This type of RAM is called synchronous because it's actually able to synchronize itself with the speed of the motherboard.

  • Double Data Rate-Synchronous DRAM (DDR-SDRAM). This type of RAM is actually able to transfer data twice during the motherboard's clock cycle (which is measured in MHz). This means that this type of RAM can be twice as fast as other RAM types. DDR-SDRAM comes in DIMMs and can provide speeds of 400MHz. This is the most commonly used RAM type on new computer systems.

  • Rambus DRAM (RDRAM). RDRAM was developed by Rambus, Inc. RDRAM is a very fast type of DRAM that uses a two-byte wide data channel to move data at high speeds. Rambus memory sticks are referred to as RIMMs because they look similar to SIMMS. Rambus memory is becoming the standard for Pentium 4 motherboards and is available on both desktop and server computers.

While the type of memory you use can enhance PC performance, the true bottom line is that the more RAM you have on a system the better the system's performance. Adding RAM to any computer will increase system throughput. The addition of RAM, in many cases, will even provide more of a performance jump than switching to a faster processor.

Hard Drives

The first hard drive available for the original IBM PC boasted a capacity of 10MB (10 million bytes). Now it is common for hard drives or fixed disks to have capacities in excess of 40GB (that's 40 billion bytes). In fact, a 40GB hard drive is now considered quite small in comparison to the large capacity drives that are available.

Hard drives come in two flavors: IDE drives and SCSI drives. An Integrated Drive Electronics (IDE) drive is a hard drive (or other device such as a CD-ROM) where the controller for the drive is built in to the drive itself. An IDE drive is connected to the motherboard using a ribbon cable. Each motherboard IDE connection supports up to two IDE drives. Motherboards typically have two IDE connections, meaning a maximum of four IDE drives (this includes hard drives and CD-ROM drives) could be installed on the computer.

Small Computer System Interface (SCSI) hard drives are attached to a SCSI controller card (placed in one of the motherboard's expansion slots or built right onto the motherboard, in the case of servers). SCSI controllers allow for the attachment of more drives (up to seven); therefore, SCSI drives are pretty much the standard for server computers.

In terms of server hardware, SCSI hard drives are preferred over IDE drives because SCSI drives boast a 12% performance boost over their IDE counterparts. Also, only two IDE drives can be connected to the motherboard via the same ribbon cable (limiting a computer to a maximum of four IDE drives connected to the motherboard). On the other hand, one SCSI controller will support up to seven drives, which makes it easier to deploy multiple-drive configurations, such as a RAID array (RAID is discussed in the section titled "Working with RAID," in Chapter 18, "Protecting Network Data").

Note

The newest drive standard available is Enhanced IDE (EIDE). It provides faster data rates and can support larger storage devices than the IDE standard.

Network Server Considerations

Network servers require large storage capacity, fast processors, and ample memory. Server tower cases also are larger than client computers and provide much more space for additional hard drives and other peripherals.

Server computers often have motherboards that provide space for more than one processor. Most network operating systems are built to take advantage of multiple processors. In fact, some network operating systems support up to 32 processors.

Servers also typically contain many more hard drives than you would find on a client machine and usually contain SCSI hard drives rather than IDE drives (which you would typically find on a client computer). This is not only to provide adequate storage space but also to build in some redundancy for storing files. We will talk about how drive redundancy can be used to help keep important data safe in Chapter 18. The SCSI controllers are also typically part of the server's motherboard rather than an add-on card.

The hardware configuration for a server will, to a certain degree, be dictated by the network operating system running on that server. Each network operating system provides a baseline configuration for a server that will run that NOS. We look at network operating systems in Chapters 8, 9, and 10; where we discuss Novell NetWare, Microsoft Windows Server 2003, and Red Hat Linux, respectively. You will see that each of these network operating systems have recommended baseline hardware server configurations (detailed in each of the chapters).

Network operating systems are also generally less forgiving when you attempt to run them on computers with odd configurations or atypical hardware. NOS software companies often provide a hardware compatibility list that allows you to view what types of server hardware have been tested with the particular operating system.

Before you actually finalize your server configurations, you need to do some research on the NOS you will be running. Novell, Microsoft, Red Hat, Sun Microsystems, and other NOS providers typically provide white papers and other material that allow you to look at case studies and performance data related to a particular NOS and various hardware configurations.

Note

Network storage capacity is no longer limited to the hard drives you have on your network servers. The recent introduction of network attached storage (NAS) provides a way to add storage capacity to a network without adding an actual server computer. An NAS device is really just a box of hard drives that is directly connected to the network. NAS devices, such as the Quantum SnapServer, run their own proprietary OS and can be configured for file sharing using remote management software that can be run from a network client or server. NAS devices don't need a monitor or keyboard because you remotely configure them over the network. NAS devices provide an easy way to add hard drive storage capacity to a large network or even a peer-to-peer network without the expense of a network operating system and dedicated server hardware.

Note

Servers often will contain drive bays that contain "hot-swappable" drives. This means a drive can be added or swapped while the server is running. These drive bays allow you to access the drive by sliding the drive out of the case; it's not unlike opening a drawer. This means that you can deal with drive issues without powering down the network server or opening the server case.

Network Client Considerations

Network clients don't typically need the processing power and storage capacity required by a server computer. Network clients do need, however, to be able to properly run the client operating system they have been configured with. Be sure that a client machine has at least the minimum hardware configuration to run the client operating system.

As with network operating systems, client operating systems will also often have hardware compatibility lists that provide you with a listing of the type of computer hardware that has been tested with the OS. As with servers, the more robust the hardware configuration of the computer, the faster (and better) the OS will run on the system.

Tip

Microsoft, Red Hat, Novell, and Sun all provide the hardware requirements to run their network operating systems. Check out these sites:

  • www.microsoft.com

  • www.redhat.com

  • www.novell.com

  • www.sun.com

A Final Word on Computer Hardware

To buy or to build? That is the question. Although the very low price of computer components may seem like a fairly seductive reason to build computers for a network, prebuilt PCs are configured with components that the computer manufacturer knows (or should know) work well together. Computer manufacturers also provide warranties and service plans. And in most cases they also provide excellent support. So, why build PCs? Adding RAM or hard drives to a PC is one thing, but building a bunch of computers from components may be nothing more than a major headache.

With computer hardware prices continuing to drop, you can purchase PCs from any number of computer manufacturers that will provide you with excellent desktop and server systems. Do your research before buying and make sure that you configure your servers and desktop computers to take care of the job for which they were intended.

The Absolute Minimum

In this chapter we took a look at networking hardware devices such as the network interface card. We also took a look at networking connectivity devices such as hubs, switches, and routers. Computer hardware considerations were also discussed.

  • Network interface cards (NICs) supply the connection between the computer and the network's physical medium. The NIC supplies the MAC or hardware address that is used to identify a computer on the network.

  • Internetworking devices are used to connect network computers and other devices. Hubs, bridges, switches, and routers are devices that provide different strategies for connecting PCs and managing (or in the case of a hub, not managing) the network bandwidth.

  • A motherboard is the main circuit board for a PC, and it provides the connection point for the processor and peripheral cards. The motherboard also supplies the data bus used to move data from various devices to the computer's memory and processor, and vice versa.

  • Network servers require more processing power, RAM, and storage space than network client computers.


Chapter 4. Building the Network Infrastructure

In this chapter

  • Understanding network architectures

  • Working with Ethernet

  • Understanding the IEEE standards for networking

  • Becoming familiar with IBM Token-Ring

  • Choosing a network connectivity strategy

Now that we've sorted out the differences between peer-to-peer networks and server-based networks and looked at some of the hardware considerations for network clients and servers, we can concentrate on issues related to actually setting up a network's infrastructure. The word infrastructure is probably one of those words that is both overused and misused by network administrators. For example, when something goes wrong on the network, it is very convenient to tell management that there is "an infrastructure anomaly," which actually means "I have no idea what the problem is."

However, if you think about an infrastructure like our U.S. highway system, two things stand out: An infrastructure is both a physical construct (such as miles and miles of roads) and a place where certain rules have been devised for users of the infrastructure (such as speed limits, stop signs, all those things that drivers west of Ohio completely ignore).

Networks are no different; their infrastructure will consist of some kind of network medium such as copper cabling or radio waves. Rules for how computers and other devices actually access the network infrastructure will also be set in place. The first thing that we will look at in this chapter is network architectures. The network architecture you use for your network defines how network devices access your network medium.


Understanding Network Architectures

In Chapter 2, "Different Needs, Different Networks," we took a look at the different physical topologies used to describe how devices are physically laid out on a LAN. Topology is a fairly broad way to discuss how a particular LAN is organized. A network architecture, on the other hand, provides more specific information on not only physical layout but also the cabling specifications that can be used and the actual method that the computers and other devices use to access the network media. Network architectures are defined by strict specifications provided by the Institute of Electrical and Electronics Engineers (IEEE), an international organization whose mandate is to develop and share electrical and information technology specifications worldwide.

In Chapter 5, "Network Protocols: Real and Imagined," we will take a look at the OSI model, which provides a theoretical look at how network communication takes place between a sending and a receiving device. Although the IEEE standards relate to real-world network functionality, these specifications have actually been grouped at the Data Link layer of the OSI theoretical model. Now, having said this, we will save the theory until we discuss OSI and LAN protocol stacks in Chapter 6. Just be aware that for the purpose of discussion and development, the IEEE folks have placed their actual network architecture specifications into a model that explains network interaction in a purely theoretical manner.

As with any technology, network architectures have come and gone. For example, ARCnet (Attached Resource Computer Network), the oldest network topology (old is a relative term because this architecture was created in 1977), used a ring topology in which an electronic token was passed from computer to computer. The computer with the token could access the network and send data.

You would have to look far and wide to find an ARCnet network (although, I'm sure they are out there); other network architectures such as Ethernet (the most popular in the world) and IBM Token-Ring have replaced this early network architecture. What's more, new architectures, such as Fiber Distributed Data Interface (FDDI), and Asynchronous Transfer Mode (ATM) have been developed to provide faster throughput on network backbones (ATM is discussed in Chapter 13, "Expanding a LAN with WAN Technology").

Before we take a look at the commonly used network architectures (as of today) and how even these architectures are continuing to evolve, we need to discuss the terms data transmission speed and bandwidth. Data transmission speed is measured in bits per second and noted as bps. A bit is one binary digit, either a 1 or a 0 (it is the smallest unit of data; 8 bits actually make up a byte). All the architectures that we will look at provide data transmission speeds in excess of a million bits per second, which is noted as Mbps.

In terms of networking, bandwidth is considered the number of bits that can be sent across the network medium at a given time. So, the terms data transmission speed and bandwidth are often used interchangeably when discussing an architecture's data throughput.

Another issue related to these different architectures is the actual distance that data can be transmitted along a particular medium type. For example, Ethernet has a limitation of 100 meters over copper twisted-pair wire (without using any type of amplification device such as a repeater, which is discussed later in the chapter). If fiber-optic cable is used, an Ethernet run can be up to 2,000 meters (that's 2 kilometers—a meter is slightly longer than a yard, so 2,000 meters would be more than 20 football fields long).

We will be discussing bandwidth and maximum cable lengths as they relate to each of the network architectures we discuss. Now, let's take a look at the LAN architectures themselves.


Understanding Ethernet

As with many of the PC and network technologies that we use today, Ethernet got its start in 1972 at the Xerox Palo Alto Research Center (PARC). Xerox actually released a commercial version of Ethernet in 1975 that provided a transmission speed of 3Mbps.

Ethernet was a big hit, and Xerox, Intel, and the Digital Equipment Corporation (DEC) worked together to modify the Ethernet specifications and produced a version that provided a data transmission speed of 10Mbps. It is this 10Mbps flavor of Ethernet that was standardized by the IEEE in its 802.3 specifications (which we look at later in the chapter).

Ethernet is the most commonly used network architecture in the world. Let's look at how Ethernet controls the access of computers and other devices to the network.

Ethernet Network Access Strategy

Ethernet is a passive, wait-and-listen network architecture. Computers must contend for transmission time on the network medium. In fact, Ethernet is commonly described as a contention-based architecture.

Ethernet provides access to the network using Carrier Sense Multiple Access with Collision Detection (CSMA/CD). This strategy of network access basically means that the devices (such as computers) on the network listen to the network and wait until the line is clear; they "sense" when the line is clear and they can transmit data. The computer then sends its packets out onto the line. If there is more than one computer transmitting, collisions result. Sensing the collisions, the computers stop transmitting and wait until the line is free. One of the computers will then transmit, gaining control of the line and completing the transmission of the data.

To receive data, computers just sit and wait, listening to the line. When they sense that a particular transmission is meant for them, they receive it on their network card.

Believe it or not, collisions are very common on Ethernet networks. Devices such as hubs (which we discussed in Chapter 3, "Networking Hardware") have a collision light on their front panel, and you will see it blink fairly often, letting you know that collisions have taken place on the LAN. Collisions are only a problem if they become excessive.

The main advantage of Ethernet is that it is one of the cheapest network architectures to implement. Network interface cards, cabling, and hubs are fairly inexpensive when compared to the hardware required for other architectures such as Token Ring (which we discuss shortly). A major disadvantage of Ethernet relates to collisions on the network. The more collisions, the slower the network will run, and excessive collisions can even bring down the network.

As far as network topologies go, Ethernet networks typically will be found in a bus or star configuration, depending on the type of cabling used. With twisted-pair cabling becoming more and more popular and hubs becoming very affordable, most Ethernet networks will be configured in a star topology, as shown in Figure 4.1.

Figure 4.1. Ethernet LANs are typically arranged in a star topology, with a hub at the center of the star.

Tip

As I've already said, collisions are a common occurrence on an Ethernet network. Collisions are only an issue if they become excessive. Excessive collisions could be caused by a malfunctioning network card or other device on the network. Cable runs that exceed the maximum length requirement can also lead to excess collisions because computers are not able to sense the activity of computers at the far end of the network. Also, the more devices there are on an Ethernet network, the more collisions will increase. There are strategies for cutting down on the number of collisions on an Ethernet LAN, such as the use of routers and switches.

Fast Ethernet

Faster versions of Ethernet—faster than the original 10Mbps flavor of Ethernet—have been developed. Fast Ethernet is so named because of its "faster" throughput speed (when compared to the 10Mbps version). Fast Ethernet provides a bandwidth of 100Mbps. This faster throughput is due to the fact that the time it takes to transmit a bit of information over the Ethernet media has been reduced by a factor of 10. So, Fast Ethernet is able to run 10 times faster than 10Mbps Ethernet, thus providing 100Mbps throughput.

Fast Ethernet cannot run over network cards and hubs designed for a 10Mbps Ethernet network. However many hubs, switches, and Ethernet network cards are now 10/100 switchable and so can accommodate 10Mbps or Fast Ethernet.

Gigabit Ethernet

An even faster version of Ethernet is Gigabit Ethernet, which uses the same IEEE Ethernet specifications and the same data format as the other versions of Ethernet. Gigabit Ethernet provides a data transmission speed of 1,000Mbps.

While Fast Ethernet has been implemented on LANs using both twisted-pair and fiber-optic cabling, Gigabit Ethernet was originally restricted to fiber-optic-based networks and required high-speed switches and specialized servers. Gigabit Ethernet was thought of as a high-speed backbone medium for large LANs.

However, Gigabit Ethernet is now available within the LAN and Gigabit network cards can be deployed in network clients and servers. Category 5 cable can also be used as the Gigabit Ethernet connectivity medium (more about cabling later in the chapter). A faster version of Gigabit Ethernet, 10Gigabit Ethernet is currently in the works. It also has potential over both fiber optic and copper-based cabling media.

Ethernet IEEE and Cable Specifications

The IEEE provides specifications for a number of the technologies related to networking computers, including Ethernet. The list that follows shows some of these specifications:

  • 802.3 Ethernet (CSMA/CD) LAN

  • 802.5 Token-Ring LAN

  • 802.7 Broadband Technical Advisory Group

  • 802.8 Fiber-Optic Technical Advisory Group

  • 802.9 Integrated Voice and Data Networks

  • 802.10 Network Security

  • 802.11 Wireless Networks

As you can see from the list, Ethernet is defined by the IEEE 802.3 specifications. Ethernet operates at the Data Link layer of the OSI conceptual model (discussed in Chapter 5). A number of different IEEE types of Ethernet exist depending on the variety of cabling used on the network (we will discuss different cable types in more detail later in the chapter, in the section "Cabling Options").

These types of Ethernet, Fast Ethernet and Gigabit Ethernet, are designated by three-part names, such as 10BASE-T. The first part of the name (such as 10 or 100) designates the transmission speed. For example, 10 indicates 10Mbps Ethernet.

The second part of the name, which will be "base" for all the types of Ethernet, specifies that the Ethernet signal is a baseband signal. This means that the data flows in a stream in a single signal. This type of transmission cannot carry multiple channels of information as can the alternative, broadband (we discuss broadband technologies such as the T-Carrier system in Chapter 13, "Expanding a LAN with WAN Technology," and we look at broadband Internet connections in Chapter 15, "Connecting a Network to the Internet").

The final part of the Ethernet type name designates the kind of cable used. For example, in the type name 10BASE-T, the T specifies twisted-pair cable wire, and it is assumed that this is unshielded twisted-pair cable (it's also assumed that you would use Category 5 unshielded twisted-pair wire for networking—more about cabling later in the chapter). Now that we've sorted out the naming conventions, we can take a look at the Ethernet and Fast Ethernet standards available. These different varieties of Ethernet are summarized in the list that follows:

  • 10BASE-T. This type of Ethernet uses twisted-pair cable (it's unshielded twisted pair, or UTP). The maximum cable run (without any signal amplification) is 100 meters (328 feet). 10BASE-T uses a star topology.

  • 10BASE-2. This type of Ethernet uses a fairly flexible coaxial cable (RG-58A/U is its designation, and it is often referred to as thinnet), with a maximum cable run of 185 meters (185 is actually rounded to 200, thus the 2 in 10BASE-2). Using T-connectors (and no hubs) to connect the cabling to the computers' network cards, 10BASE-2 takes on a bus topology. Although 10BASE-2 has always been the cheapest implementation of Ethernet, 10BASE-T setups are now the norm.

  • 10BASE-5. This type of Ethernet uses a large-gauge coaxial cable (called thicknet), and the computers on the network are connected to a main trunk line. The cables from the computers are connected to the main trunk cable with the use of vampire tabs, which actually pierce the main trunk cable (pretty cool, huh). You won't find too many 10BASE-5 networks out there, although this type of Ethernet was popular in manufacturing environments at one time.

  • 10BASE-FL. This type of "slow" (meaning it only runs at 10Mbps) Ethernet runs over fiber-optic cable. The maximum cable run is 2,000 meters (2 kilometers).

  • 100BASE-TX. This type of Fast Ethernet uses the same Category 5 UTP cabling found on 10BASE-T Ethernet. This implementation can also use 100-Ohm shielded twisted pair. The maximum cable distance without a repeater is 100 meters.

  • 100BASE-T4. This type of Fast Ethernet can actually run over Category 5 cabling, as can 100BASE-TX, but it can also run over lower-grade twisted-pair cabling such as Categories 3 and 4. The maximum cable length is the standard twisted pair reach of 100 meters.

  • 100BASE-FX. This type of Fast Ethernet runs over fiber-optic cable. The maximum cable distance with no signal enhancement is 412 meters.

  • 1000Base-T. This type of Gigabit Ethernet supplies 1000Mbps over Category 5 twisted pair cabling.

  • 10Gigabit Ethernet. This type of Ethernet supplies 10 billion bits per second over fiber optic cable.

As already mentioned, you will find that many of the network cards and hubs you buy now support both 10Mbps and Fast Ethernet (the devices are switchable). Also, just about anyone putting together a new Ethernet network would use Category 5 (CAT 5) twisted-pair wiring (or CAT 6 if they wish to spend more and have the option of taking advantage of faster Ethernet specifications in the future). Most new network cards only support RJ-45 connectors—the male connector type used on twisted-pair wiring. Larger companies may use some fiber-optic cabling as a high-speed backbone between floors, but copper-base cable is still the norm.


Understanding IBM Token-Ring

IBM Token-Ring was developed by IBM in the middle 1980s with an interest in supplying a fast and reliable alternative to Ethernet. Although IBM Token-Ring (or Token-Ring as we will refer to it in this chapter) networks are wired in a star configuration, Token-Ring actually operates in a logical ring, meaning the central device that connects the computers (a Multistation Access Unit, or MAU) hosts an internal ring (more about these devices in a moment), where access to the network media is handled by possession of a token that is passed from computer to computer on the ring.

Token-Ring specifications are found under the IEEE 802.5 specifications. Token-Ring operates at the Data Link layer of the OSI model (specifically the MAC sublayer of the Data Link layer). Token-Ring implementations often use Type 1 shielded cabling (limiting ring membership to 250 devices) or Category 5 twisted pair cabling (limited ring membership to 72 devices).

Token-Ring hardware (network cards and MAUs) is generally more expensive than Ethernet hardware, but Token-Ring networks are considered more reliable in high-traffic situations because the way that computers gain access to the network medium does not produce the collisions that can take place in the Ethernet environment. Let's take a close look at the Token-Ring media-access strategy.

Tip

The MAU is the equivalent of the hub used in Ethernet networks. It provides the central connecting point for the computers on the LAN. MAUs, however, are more sophisticated (and expensive) than Ethernet hubs. The MAU provides the logical ring that supplies the ring topology used by the computers on the LAN as they pass the token.

Token-Ring Network Access Strategy

As already mentioned, Token-Ring networks are wired in a star configuration, with a Multistation Access Unit (MAU) providing the central connection for the devices on the LAN. A MAU on a Token-Ring network is the equivalent of a hub on an Ethernet network, but the MAU is a much more sophisticated (and expensive) device. Token-Ring uses a ring topology, where data travels in only one direction. However, the actual ring on which the token is circulated is a logical ring inside of the MAU. Figure 4.2 provides a diagram of a Token-Ring network and the logical ring provided by the MAU.

Figure 4.2. Token-Ring LANs are wired in a star topology but operate as a ring.

Access to the network media is handled using a token. The token is passed around the ring until a computer wishing to send information out onto the network takes possession of the token.

A computer that passes the token to the next computer on the logical ring would be called the nearest active upstream neighbor (NAUN). The computer receiving the token is the nearest active downstream neighbor (NADN). Once a computer takes possession of the token and transmits data, it then creates a new token and passes it to its NADN. The token makes its way around the ring until a node on the network takes possession of it to transmit.

Tip

As far as receiving data on the network, data sent from a computer on the network moves around the logical ring. When the computer slated to receive the data sees the data on the ring, it accepts the data using its network interface card.

Token-Ring IEEE and Cabling Standards

The specifications for running IBM Token-Ring architecture have been defined by the IEEE and are designated as IEEE 802.5. Token-Ring, like Ethernet and the other network architectures (such as FDDI, which we discuss in the next section), operates at the OSI model's Data Link layer (covered in detail in the next chapter, "Network Protocols: Real and Imagined").

Because using a token-passing strategy means that computers can only broadcast data when they possess the token, Token-Ring is characterized by no collisions. Another plus of the Token-Ring strategy is that more-equal access to the network media is provided when compared to the strategy used by Ethernet (a device on an Ethernet network can actually dominate the network by flooding it with data). The fact that Token-Ring networks provide equal access for sending data has typically made them popular in certain industries, such as banking, because they provide a more guaranteed real-time delivery of important information (such as bank deposits and withdrawals).

Typical Token-Ring networks are slower than Ethernet (particularly Fast Ethernet). Token-Ring comes in two different flavors: a 4Mbps type and a 16Mbps type.

However, faster Token-Ring implementations are becoming a reality. IBM and other Token-Ring hardware vendors, such as Olicom Inc., are now making 100Mbps Token-Ring NICs. This new 100Mbps flavor of Token-Ring is referred to as High Speed Token-Ring or HSTR. Olicom also has developed a high-speed switch to complement the use of HSTR NICs on a Token-Ring network. The high-speed NICs and switches can be used on existing Token-Ring infrastructures without a change of LAN cabling.

Gigabit Token-Ring is now also available and is being used for high-speed backbones to connect Token-Ring LANs. The 1000Mbps (1000Mbps is a gigabit) throughput on the network is possible because of Gigabit Token-Ring switches that have been developed by companies such as Madge. These switches basically allow an uplink to be created between two Token-Ring LANs using fiber-optic cabling as the link backbone.

As far as cabling specifications go, Token-Ring uses an entirely different system for numbering and categorizing the types of cables used for Token-Ring networks. The two most common cabling types used are referred to as Type 1 and Type 3. Type 1 is a twisted-pair cable that is encased in a braided shielding (this type of cable is known as shielded twisted pair, or STP). Type 3 cable is an unshielded twisted-pair cable and is less expensive than the Type 1 shielded cable. It is limited for use on 4Mbps networks, however.

Fiber-optic cable can also be used to link Token-Ring MAUs together. Because fiber-optic cable provides for greater cable run lengths (which we will discuss shortly), connecting MAUs allows the possibility to extend the LAN over a greater physical distance. This type of cable is referred to as Type 5.

Note

Token-Ring does provide a very neat feature that allows the computers on the Token-Ring network to help diagnose problems with the logical ring. This process is called beaconing. When the computers on the network are first brought online, the first computer powered on is designated as the Active Monitor. The Active Monitor sends out a data packet every seven seconds that travels around the ring to help determine whether any of the nodes on the network are done. For example, if a particular computer does not receive the packet from its NAUN, it creates a packet containing its address and the NAUN's address and sends the packet onto the network. This packet provides information that the Token-Ring can actually use to automatically reconfigure the ring and maintain network traffic.

Tip

Although there are many more Ethernet networks worldwide than Token-Ring networks, Token-Ring is not necessarily a dying technology. New switching technologies and faster versions of Token-Ring are in the works to speed network throughput (see the information on High Speed Token-Ring earlier in this section). It is estimated that there are more than 12 million computers on Token-Ring networks worldwide.


Understanding FDDI

Although we have been primarily looking at network architectures that you may see on small and intermediate-sized networks (as well as some large networks), we should discuss an architecture that you would typically only see on networks of greater size. The Fiber Distributed Data Interface (FDDI) is an architecture that provides high-speed network backbones that can be used to connect and extend the range of LANs. FDDI uses fiber-optic cable and is wired in a ring topology. FDDI uses token passing as its media-access method and can operate at high speeds (most implementations are 100Mbps, but faster data-transfer rates are possible).

FDDI does not have an IEEE specification but rather has a designation of ANSI X3T9.5, which has been formulated by the American National Standards Institute (ANSI). Because FDDI uses a token-passing media-access strategy, it is considered reliable and provides equal access to all the computers on a network. With FDDI, however, you can set priority levels, which means you can designate that servers be allowed to send data more often over the network than client computers.

FDDI is expensive to set up because the computers require a special network card and fiber-optic cabling is also much more expensive than copper twisted-pair wire. Because most FDDI installations use a redundant second ring, twice as much cabling is required.

Note

Because FDDI uses a true ring topology, there is always the potential problem of a break in the ring. To combat this problem, FDDI installations consist of two rings. Each ring passes the token in a different direction, and certain key computers are connected to both rings. Then, if there is a break in one of the rings, the data can be rerouted in the opposite direction on the other ring. Since FDDI networks are typically used as high-speed backbones connecting a wide variety of LAN types, it is extremely important that they supply a consistent connection between the LANs. This is why the redundant rings are used.


Choosing a Network Connectivity Strategy

Now that we have taken a look at the commonly used LAN network architectures, let's concentrate on the different connectivity strategies that can be used to link your computers and other devices together. As you can see from our discussion of the various network architectures, the standard connectivity medium is some sort of cabling. The most popular cabling type is still copper wire. However, other technologies that make use of wireless technologies and wiring systems that are already in place (such as the telephone or electrical wiring system in a building) are also available and are becoming increasingly popular.

Let's take a look at some of the standards for network cables. Then we can look at some of the other connectivity strategies and how they are being used in different LAN settings.

Cabling Options

Network cabling consisting of copper wire has been the predominant network connectivity medium since the very beginning of the local area network. Copper-based cable transmits the data stream along the wire as an electrical signal. The discrete changes in the electrical signal on the cable distinguish the 1s and 0s in the bit stream. You already know that the network interface card (which we discussed in detail in the last chapter) has the job of taking the PC's information and getting it out onto the network medium in a format that is compatible with that particular medium (for example, electrical information is placed on copper wire, and light information is placed on fiber-optic cable).

Copper-based network cabling takes two major forms: coaxial cable and twisted-pair cable. Although the prices for fiber-optic cable (which does not experience interference because it uses light energy rather than electrical energy) are dropping and more fiber-optic LANs (particularly LAN backbones) are popping up all the time, copper wire is still the predominant wire type. Figure 4.3 provides a look at thinnet coaxial, thicknet coaxial, Category 5 twisted-pair cable, and fiber-optic cable, respectively.

Figure 4.3. Copper-based and fiber-optic cables are used as the physical media for LANs.

Let's take a closer look at copper-based possibilities. We can then take a look at fiber-optic cable.

Tip

When dealing with a physical medium such as copper wire (or fiber-optic cable for that matter), properties of the medium itself affect the distance that a signal can be sent and the integrity of that signal. Some physical phenomena you should know about include:

  • Attenuation. The degradation of the data signal over the run of the cable or medium (this is why different cable types have different maximum lengths).

  • Impedance. The resistance of a wire to data transmission. All cable types have impedance that is measured in Ohms. The greater the impedance, the more energy that is required to move the signal over the wire.

  • Interference. Signals from other nearby devices and noise from the wire itself (some of the energy on the wire is absorbed by the wire itself) can interfere with the actual transmission signal. In cases where two wires run closely together, they can interfere with each other's signal. This is called crosstalk.

Coaxial Cable

Two types of coaxial cable are used for networking computers: thicknet and thinnet. Thicknet is a heavy-gauge coaxial cable that is fairly inflexible and requires special equipment (over and above a simple network card) to connect the computer to the network backbone.

Installations of thicknet (RG-8 and RG-11 coaxial cable) are practically nonexistent, but some can still be found in certain settings, such as in manufacturing companies. This is because this thicker version of coaxial cable is well shielded (encased in a coating of material that looks somewhat like aluminum foil) and therefore doesn't suffer as much from interference as thinnet cable (a manufacturing environment with a lot of machinery in use can certainly produce potential interference problems when the cabling runs close to large electrical devices).

Thicknet networks are characterized by a cable backbone that is tied to servers and workstations on the network by vampire taps (the taps actually pierce the cable). The transceiver is actually attached to the tap (rather than a network interface card), and then the computer is connected to the transceiver/tap by a drop cable (which connects to the NIC on the computer).

Thinnet (RG-58 coaxial cable) was the cable of choice at one time because of its relative ease of installation and its low cost. Thinnet LANs employ a bus topology, where a T-connector is attached to each computer's network card. The computers are then chained together using appropriate lengths of cable. Thinnet installations require that each end of the network be terminated, and terminators are placed on the downside T-connector of the computers that reside on either end of the network.

Although it is valid for us to discuss coaxial cabling, in reality you are going to find that twisted-pair cable is the network medium of choice for most LANs. Let's take a look at twisted-pair wiring and how it works.

Twisted-Pair Wire

Twisted-pair wire comes in a number of different grades. Everyone is familiar with the twisted-pair wire used for the connection between your telephone and the phone wall outlet. Twisted pair is so named because the cable is actually made up of a number of single copper wires that are twisted together.

Why are the pairs of wire twisted? You already know that copper wire is susceptible to interference (as discussed in an earlier Tip sidebar). Two copper wires running parallel to each other would actually interfere with each other quite a bit. Believe it or not, by twisting the wires together, the interference (or crosstalk) between the wires is minimized.

Twisted-pair wire comes in two major flavors: unshielded twisted pair (UTP) and shielded twisted pair (STP). The big difference between UTP and STP is that the STP wires are encased in a foil wrap that protects them from interference.

UTP is the most commonly used network wiring. It is inexpensive, flexible, and light, thus making it very easy to work with. UTP cable is terminated with an RJ-45 connector, which is kind of the big brother to the RJ-11 male connector that you find on a telephone cord.

UTP cable has been placed in different categories based on data-transmission capabilities. You will often hear UTP referred to as CAT 3 or CAT 5. Table 4.1 provides a listing of these various UTP categories.

Table 4.1. Twisted Pair Categories

Category

Maximum Bandwidth Provided

Additional Information

1

None

Used in old telephone systems; this is not a data-grade cabling.

2

4Mbps

Not really considered a data-grade cable.

3

10Mbps

Considered the minimum cable requirement for data networks running Ethernet.

4

16Mbps

Equivalent to the Type 1 Token-Ring cabling without the shielding.

5

100Mbps

Has become the standard for new LAN installations and has completely overshadowed all the previous categories.

6

1,000Mbps

CAT 6 provides possibilities for broadband transmission. This may also end up being the copper cable of choice for Gigabit Ethernet networks.

Fiber-Optic Cable

Fiber-optic cable is a high-speed alternative to copper wire and is often employed as the backbone of larger corporate networks. However, the drop in the price of fiber-optic cable has started to make it a possibility for other LAN uses. Fiber-optic cable uses glass or plastic filaments to move data and provides greater bandwidth as well as longer cable runs (up to 2 kilometers, depending on the network architecture). With the need for network speed seemingly on the rise, fiber-optic installations are becoming commonplace.

Fiber-optic cable uses pulses of light as its data-transfer method. This means a light source is required, and lasers or light-emitting diodes are used. Fiber-optic cable is more expensive and more difficult to install than copper cable, but fiber-optic's ability to move data faster and farther makes it an excellent alternative to copper.

A very interesting aspect of fiber-optic cable is that because it uses light to transfer network data, it is not susceptible to tapping (that is, the stealing of data off the line itself). Copper cabling, on the other hand, can be tapped because it uses an electrical signal to send data. On networks where security is an issue, fiber-optic cable provides a more secure environment.

Note

Copper wire can be looped, bent, and put through all kinds of gyrations and still carry an electrical signal. Just think about how tangled your vacuum cleaner cord gets when you are vacuuming; however, the vacuum cleaner keeps running. Fiber-optic cable, on the other hand, has to remain relatively straight to carry data as a light pulse. You can't bend fiber-optic cable in a 45-degree angle and you can't have kinks in it. Fiber-optic network installations require cabling professionals who understand the fragility and maximum bend of fiber-optic cabling. This is why copper cable still reigns as king (or queen, for that matter); it is easy to install and fairly forgiving when it is installed poorly.

Phone and Electrical Wire Networks

One option for connecting PCs in a small network environment, such as a home peer-to-peer network or a small business network with a limited number of computers, is to use existing phone lines. Because the data communications on the network operate at a different frequency than the phone, phone communication is not disrupted by using the phone lines for a dual purpose (phone calls and the movement of data).

There is actually an organization called the Home Phoneline Networking Alliance (check out www.homepna.org for more information), which is attempting to create a standard for home networking products that use existing phone lines. Although many of the products available provide limited bandwidth, some supply 10Mbps throughput, which is as fast as the vanilla flavor of Ethernet. Phone line connectivity cards are available from a number of vendors. There is the Diamond PCI Phoneline card (it looks a lot like an Ethernet PCI NIC), called the Diamond Homefree. It can be used to connect PCs at 10Mbps by attaching them to any phone jack using a cable with RJ-11 ends (the same ends you find on any phone cord). Linksys also makes a phone line networking card. You will find that most of the phone-line products are compatible with the various flavors of Windows such as Windows 9x, 2000, and XP. Again, simple peer-to-peer networking is the aim of these products, as well as sharing a single Internet connection.

Other phone-line products take advantage of USB technology and use a small device that looks like a hub. The computers are attached to the device by a cable that runs from each computer's USB port. Your existing electrical lines also provide a source of wiring for connecting computers into a network. Again, a number of different companies make electrical or power-line networking products. This technology is considered to be another possibility for the home networking arena (as is phone-line technology) but could be used in some small business networking situations.

As with phone-line networking, using electrical lines as a connectivity medium allows computers to share files and printers and also share a single Internet connection. Power-line networks currently only offer bandwidth of around 350Kbps. This means that network communication is slower than some of the other alternatives (it is certainly not as fast as the phone-line alternatives).

Wireless Options

The options for creating wireless networks have seemingly exploded over the last couple years. Wireless network connections take advantage of radio signals, infrared light, or lasers. For longer distances, wireless communications can also take place through cellular telephone technology (as seen with any number of cellular devices, such as Web-ready cellular phones), through microwave transmission, or via satellite. Because the microwave and satellite technologies fall more into the realm of wide area networking, let's take a closer look at radio LAN technology and infrared technology. We will discuss cellular technology in Chapter 17, "Networking on the Run."

Radio Connectivity

Radio connectivity is used to extend the range of a LAN or make it easy for users with laptops to connect to the LAN without the use of cabling. Wireless radio LANs require that an access point be placed on the network for the computers that wish to connect to the LAN. For example, 3COM makes a wireless access point that attaches to an existing Ethernet network (Cisco also makes similar devices). It looks like a hub with an antenna on it. Computers outfitted with a wireless Ethernet card (these cards typically have a small antenna on them and otherwise operate like any other NIC using a transceiver) can connect to the access point. Figure 4.4 provides a diagram of a LAN that uses wireless technology for network access.

Figure 4.4. PCs outfitted with wireless network adapters connect to the LAN using a wireless access point.

The distance that a computer can be from the access point and still connect to the LAN varies from wireless product to wireless product. The 3COM specs for its wireless access point device claim a throughput of up to 11Mbps and a maximum range of 300 feet.

Wireless radio LANs are becoming increasingly popular in hospital settings (where nurses and doctors need to be mobile) and in business environments where a conference room must be quickly converted into a training room hosting multiple PCs connected to a LAN.

One issue related to wireless radio LANs is that it is fairly easy to intercept data. Although most radio LANs use one particular frequency, there are strategies for minimizing the possibility of data being intercepted (known as eavesdropping).

Some wireless communications will actually break up the data and broadcast portions on different frequencies, thus making it harder to eavesdrop. Another method of diminishing the possibility of eavesdropping is known as frequency hopping. This is where the transmitter and the receiver switch (or hop) frequencies periodically.

An important new set of specifications for wireless communication via radio signals is Bluetooth. A number of companies, including Microsoft, IBM, 3COM, and Nokia are creating Bluetooth devices such as keyboards, mice, personal digital assistants (PDAs), and cellular phones. Bluetooth is also being used to create networking devices.

Intel has certainly not been idle in relation to mobile computing and wireless communication. Intel has introduced the Centrino mobile computing technology, which integrates a wireless network connection into laptop computers that use the Intel Centrino processor.

Tip

Radio frequencies are regulated by the FCC in the United States. Therefore, to use most of the frequencies available in the radio wave spectrum, a license is required (for example, AM and FM radio stations must be licensed). Some frequencies, however, fall into an unregulated range. The FCC has reserved several frequency ranges for unregulated use (all measured in hertz): 902–928MHz, 2.4GHz, and 5.72–5.83GHz. Cordless phones and remote control toys have sucked up most of the 900MHz range, so wireless LAN technologies typically operate at 2.4GHz and above.

Infrared Connectivity

Another possibility for wireless networking is infrared. Infrared systems use very high frequencies, just below visible light in the electromagnetic spectrum, to carry data. Like visible light, infrared signals can be blocked by opaque objects. Therefore, this technology is not suitable in all situations.

Because infrared technology is fairly limited in respect to the distance that two communicating devices can be apart, it is primarily used as a way for a laptop user to connect to a printer (both devices are outfitted with an infrared eye). Infrared is also becoming a popular method of syncing up personal data assistants, such as two Palm Pilots (we discuss handheld computing devices in Chapter 17, "Networking on the Run").

The Absolute Minimum

In this chapter we looked at the different network architectures that are used for local area networks. We also looked at the different connectivity mediums that can be used to connect networked devices such as copper cable, fiber optic cable, and wireless connection strategies.

  • Network architectures determine the physical layout of the network and the strategy used by computers to access the network medium.

  • Ethernet is a passive architecture and uses Carrier Sense Multiple Access with Collision Detection (CSMA/CD) as its network medium access strategy. It is defined by the IEEE 802.3 specifications. Faster versions of Ethernet, such as Fast Ethernet and Gigabit Ethernet, are also available.

  • IBM Token-Ring, which is defined by IEEE 802.5, uses possession of a token (which is passed around the logical network ring) as the network medium access method.

  • The two types of cable options for network media are copper cable and fiber-optic cable. Unshielded twisted-pair (UTP) cable is the cheapest and most often used cable type for new LANs.

  • Radio signals can be used to transfer data on wireless networks when an access point device is connected to the LAN and computers are outfitted with radio network cards.

  • Infrared is a wireless technology that is used to beam a signal between a laptop and a printer or to synchronize handheld personal data assistants.


Chapter 5. Network Protocols: Real and Imagined

In this chapter

  • Network protocols and data communication

  • Understanding the OSI Conceptual Model

  • The roles of the OSI layers

  • Understanding real-world protocol stacks

  • Exploring the TCP/IP stack

  • Understanding Novell's IPX/SPX network protocol stack

  • Using NetBEUI on small networks

  • Understanding the AppleTalk protocol stack

So far, we've taken a look at the types of networking, the hardware considerations for building a network, and the different aspects of network architectures and network connectivity media. In this chapter we will concentrate on issues related to how computers actually communicate on the network. We'll cover the theoretical side of network communication and then take a look at the different protocols that are actually being used to transfer data on a network.

"What is a protocol," you ask? Well, think about the word protocol itself. A protocol is really a set of rules or guidelines dictating behavior. One communication protocol that is often followed in the business world is the handshake. It typically means that a nonthreatening exchange of information can take place.

Also, everyone has heard of diplomatic protocol, which defines the rules of communication used when two diplomats meet to discuss various issues. In the computer world, a protocol provides the rules for how computers communicate. Network protocols are actually hard-wired into the programming used by the networking software you find on client and server computers.

Because data is created and saved on a computer in a particular format, that data will actually undergo some translation and modification before it can be sent out over the network to another computer. Again, think about diplomatic protocol; if two diplomats don't speak the same language, they use interpreters. Well, you will find that sometimes data must be translated before it can be sent over the network so that the original data arrives at the receiving computer in a format that is understandable.

So, just as communication between diplomats might have to move through several layers (in this case, translators) before a message is received, computer data must move through several intermediary layers before the data can actually be placed on the network media and then travel out over the network. This means that a number of small protocols actually are used as the data moves through these layers. A group of small protocols that work together to prepare data for the communication process is called a protocol stack.

A number of different protocol stacks, such as TCP/IP and IPX/SPX, can be used to communicate over the network. To understand how the protocols in the stack work together, we will look at a theoretical model that has been created to explain network communication and data transfer. The OSI model is used by network administrators, software programmers, and other Information Technology professionals to discuss the way network protocols manage the communication between computers on the network. Programmers also use this layered model to develop new protocols and tools for network communication.

Note

Although everyone seems comfortable with the handshake as a greeting (except for perhaps Donald Trump, who has a phobia related to shaking hands), you will also find that the term handshake pops up a lot in the networking world. It is often used as a term associated with different data communications strategies and refers to an agreement made between two computers to exchange data. For example, we'll talk about the three-way handshake when we discuss the Transmission Control Protocol (TCP) later in this chapter.


Understanding the OSI Model

In the late 1970s the International Standards Organization (ISO) began to develop a conceptual model for network communications called the Open Systems Interconnection Reference Model. It is commonly known as the OSI model.

In 1984 the model became the international standard for network communications, providing a conceptual framework that describes network communication as a series of seven layers. In the model, each layer is responsible for a different part of the process that takes place when two computers on a network establish a connection and move data between them. Figure 5.1 shows the layers of the OSI model. Table 5.1 provides a brief description of the role of each layer.

Figure 5.1. The OSI model is used to describe how a protocol stack initiates and controls network communication.

The OSI model is numbered from the bottom up. You will find, depending on what book or resource you are consulting, that the model layers are not always referred to by name. For example, the Network layer, which is the third from the bottom, is often referred to as layer 3.

Table 5.1. The OSI Layers

Layer Number

Layer

Function

7

Application

Provides the interface and services that support user applications and provides general access to the network

6

Presentation

Serves as the translator layer of the OSI model and is responsible for data conversion and encryption

5

Session

Establishes and maintains the communication link between the sending and receiving nodes

4

Transport

Responsible for end-to-end data transmission, flow control, error checking, and recovery

3

Network

Provides the logical addressing system used to route data on the network

2

Data Link

Responsible for the framing of data packets and the movement of the data across the physical link

1

Physical

Manages the process of sending and receiving bits over the physical network media (the wire and other physical devices)


How the OSI Model Works

The model actually is used to describe how data that's generated by a user, such as an email message, moves through a number of intermediary forms until it is converted into a stream of data that can actually be placed on the network media and sent out over the network. The model also describes how a communication session is established between two devices, such as two computers, on the network. Because other types of devices, such as printers and routers, can be involved in network communication, devices (including computers) on the network are actually referred to as nodes. Therefore, a client computer on the network or a server on the network would each be referred to as a node.

When data is sent by a network node (for example, a computer sending an email message, as already mentioned), that data moves down through the OSI stack and then is transmitted over the network media. When the data is received by a node, such as another computer on the network, it moves up through the OSI stack until it is again in a form that can be accessed by a user on that computer.

As you already saw in Table 5.1, each of the layers in the OSI model is responsible for certain aspects of getting user data into a format that can be transmitted on the network. Some layers are also for establishing and maintaining the connection between the communicating nodes, and other layers are responsible for the addressing of the data so that it can be determined where the data originated (on which node) and where the data's destination is.

An important aspect of the OSI model is that each layer in the stack provides services to the layer directly above it. Only the Application layer, which is at the top of the stack, would not provide services to a higher-level layer.

The process of moving user data down the OSI stack on a sending node (again, such as a computer) is called encapsulation. The process of moving raw data received by a node up the OSI stack is referred to as de-encapsulation.

To encapsulate means to enclose or surround, and this is what happens to data that is created at the Application layer and then moves down through the other layers of the OSI model. A header, which is a segment of information affixed to the beginning of the data, is generated at each layer of the OSI model, except for the Physical layer. This means that the data is encapsulated in a succession of headers—first the Application layer header, then the Presentation layer header, and so on. When the data reaches the Physical layer, it is like a candy bar that has been enclosed in several different wrappers.

When the data is transmitted to a receiving node, such as a computer, the data travels up the OSI stack and each header is stripped off of the data. First, the Data Link layer header is removed, then the Network layer header, and so on. Also, the headers are not just removed by the receiving computer; the header information is read and used to determine what the receiving computer should do with the received data at each layer of the OSI model.

It is by using these headers that the sending computer is able to communicate with the receiving computer and provide the receiving computer with either information or actual instructions related to the disposition of the data at the various levels of the OSI model. Using the candy bar analogy again, the situation on the receiving computer would be like opening a candy bar enclosed in many layers of wrapping, with each individual wrapper providing important instructions on how to unwrap the candy further and eventually eat the candy bar.

Figure 5.2 provides a diagram of the encapsulation and de-encapsulation processes. The header information supplied at each layer of the OSI model by the sending computer will be used by the receiving computer as it massages the data into a format that can actually be accessed by a user on that computer.

Figure 5.2. Data is encapsulated on the sending computer and then de-encapsulated on the receiving computer.

One thing you should keep in mind as you review the different functions of the layers in the OSI model is that there are real protocols found in real network protocol stacks that actually perform the functions that we discuss in the sections that follow. Later in the chapter we will map a number of the LAN protocols in use today to the OSI model to show how the real protocol stack performs the functions that we have discussed in relation to each of the layers of the OSI model.

Now that we have some of the basic theory related to the OSI model out of the way, let's take a more detailed look at the various layers of the OSI model and how they relate to encapsulation and de-encapsulation.

Tip

If you are going to actually work in the computer-networking field, it is extremely important that you memorize the different layers in the OSI model and have a basic knowledge of what each layer does. A good way to remember the network layers from bottom to top is to use the following mnemonic: Please Do Not Throw Sausage Pizza Away.

Tip

This concept of the sending computer placing messages or information in the various OSI layer headers that is then read and stripped off by the receiving computer is known as peer communication. Information placed in a header at a particular layer by an actual protocol operating at that layer is then read by a protocol operating at the same layer on the receiving computer.

Application Layer

The Application layer provides the tools that the user actually sees (but handles processes that the user does not see). Because it is at the top of the OSI model, it does not provide services to layers above it (because there are no layers above it), but it does provide network services related to user applications such as message handling, file transfer, and database queries. It also synchronizes applications between the client and server and makes sure that the resources are available for error recovery and to provide data integrity.

When a user working in a particular application, such as a spreadsheet program like Excel, decides to save a worksheet file to his home directory on the network file server, the Application layer of the OSI model provides the appropriate service that allows the file to be moved from the client machine out onto the appropriate network volume. This transaction is actually transparent to the user.

Presentation Layer

The Presentation layer can be considered the translator of the OSI model. This layer takes the data from the Application layer and converts it to a format that can be read by the Application layer of the receiving computer. The Presentation layer is also responsible for data encryption (if required by the application used in the Application layer) and data compression, which will reduce the size of the data.

You are probably already familiar with a number of the different file formats that serve as Presentation layer standards. These include standards for text, sound, graphics, and even video. Table 5.2 provides a summary of some of these file formats by standard category.

Table 5.2. Presentation Layer Standards

Data Type

Presentation Layer Standard

Text

ASCII, EBCDIC, HTML

Sound

MIDI, MPEG, WAV

Graphics

JPEG, GIF, TIFF

Video

AVI, QuickTime

So, the Presentation layer provides Application layer applications with a choice of data types for transmission over the network media. For example, if an application sends data in binary (pretty much the coin of the realm—it's recognized by every computer), no further action is required by the Presentation layer because the binary data can be read by the receiving computer. However, if the data is sent in another format, the Presentation layer will have to convert it to a more generic standard.

Session Layer

The Session layer is responsible for setting up the communication link or session between the sending and receiving computers. The Session layer also manages the communication session that is set up between these nodes.

The Session layer actually offers three different modes for the communication sessions set up between the network nodes: simplex, half-duplex, and full-duplex. Simplex transmits data in only one direction (such as your thermostat connecting to your furnace). Half-duplex allows for communication in two directions but only allows for the transmission of data in one direction at a time (such as a one-lane bridge). Full-duplex allows communication in both directions at the same time.

Another function of the Session layer is to place special checkpoints in the data stream as it moves from the sending computer to the receiving computer. These checkpoints can then be used in situations where the connection between the computers is lost. Only the data in the data stream that is found after the most recently received checkpoint will have to be re-sent by the sending computer.

Note

This idea of building features into software and hardware that aid in system or network communication recovery (such as the checkpoints in the Session layer) is lumped under the umbrella term fault tolerance. Fault tolerance simply means that some strategy is being used for quick recovery or to protect resources. For example, in terms of data fault tolerance on a network, one of the best methods is a regular backup of data (see "Backing Up Data," in Chapter 18, "Protecting Network Data").

Transport Layer

The Transport layer is in charge of flow control as the data moves from the sending to receiving node. Up to this point, we have referred to the information created by a user on a networked computer as data. When this data reaches the Transport layer, it is actually segmented into small data packages; each of these packages is referred to as a packet. A number of packets will make up the original data that was generated by the user (such as the email message discussed earlier in the chapter).

As far as flow control is concerned at the Transport layer, the communicating computers will use acknowledgements to verify the receipt of data. These acknowledgements are sent from the destination computer to the sending computer when an agreed-upon number of data packets have been sent by the sending node. For example, the sending node might send three bursts of packets to the receiving node and then receive an acknowledgement from the receiver. The sender can then send another three bursts of data.

The Transport layer also provides two different types of data delivery methods: connection-oriented and connectionless. Connection-oriented transport uses a system of acknowledgements to ensure data delivery and defines a static route on the network so that the packets are delivered along the same route during the session. This is considered a reliable connection.

Connection-oriented protocols operate in much the same way that you establish communications over the telephone. You establish a session with the person you are calling. A direct connection is maintained between you and the party on the other end of the line. When the discussion concludes, both parties typically agree to end the session.

Connectionless transport at the Transport layer does not use acknowledgements or a static path for data delivery. Therefore, this is considered an unreliable method of data delivery. Connectionless transport does not require the network resources that connection-oriented communication requires, however.

Connectionless protocols operate more like the regular mail system. They provide appropriate addressing for the packets that must be sent, and then the packets are sent off much like a letter dropped in the mailbox. It is assumed that the addressing on the letter will get it to its final destination, but no acknowledgment is required from the computer that is the intended destination.

Tip

When packets are segmented at the Transport layer, they are sized according to the requirements of the protocols that will operate at the lower levels in the OSI model, such as the Network and Data Link layers.

Note

Both connection-oriented and connectionless methods of data transport are used on networks. For example, in the TCP/IP stack, the protocol TCP (Transmission Control Protocol) is used for connection-oriented transport. Another protocol in the TCP/IP stack, UDP (User Datagram Protocol), also operates at the Transport layer of the OSI model and is used for connectionless transport of data on the network. UDP requires fewer computer and network resources than TCP to move data.

Network Layer

The Network layer is charged with the duty of addressing the packets for delivery using a particular logical addressing strategy. For example, networks that use TCP/IP as their network protocol use IP addresses to address packets (every computer on the Internet has a different IP address). Networks that use IPX/SPX (Novell's network protocol stack) use IPX addresses.

The Network layer is also responsible for determining the path that packets will take as they are routed on a network from source to destination. The Network layer is where routers operate, using the logical addressing assigned to a packet to determine the route for that packet on the network. We discuss routing and IP addresses in Chapter 12, "TCP/IP Network Administration."

Routers determine the route for packets with the help of a special kind of protocol, called a routing protocol. These routing protocols, such as the Routing Information Protocol (which is a protocol found at the Network layer in both the TCP/IP and IPX/SPX protocol stacks), build routing tables that are then used by the router for path determination (routing is discussed in Chapter 12).

Tip

How computers and other devices are identified on a network will depend on the network protocol that is being used. Each network protocol (as you will see later in this chapter) uses some sort of method for assigning logical (in many respects "made up") names or addresses to the various devices on the network.

Data Link Layer

We've already discussed the fact that as data on the sending computer moves down through the OSI layers, encapsulation takes place (the data is encapsulated with a header from each of the layers). At the Data Link layer, the data packet is actually placed inside a data frame. The frame type is defined by the type of network architecture that is being used on the network. For example, an Ethernet frame will be used on Ethernet networks, and a token ring frame will be used on token ring networks.

The Data Link layer also is responsible for data movement across the actual physical link to the receiving node and therefore uniquely identifies each computer on the network based on its hardware address that is encoded into the network interface card. So that there is some mechanism for checking the validity of a frame sent over the network media, protocols that operate at the Data Link layer also will add a cyclical redundancy check (CRC) as a trailer on each frame (the trailer is placed at the end of the frame, whereas the header would be on the other end of the frame). The CRC is basically a mathematical calculation that takes place on the sending computer and then on the receiving computer. If the two CRCs match up, the frame was received in total and its integrity was maintained during the transfer.

Physical Layer

The duties of the Physical layer seem quite mundane, when you compare them to the rest of the OSI model. But they are certainly no less important. As the frames from the Data Link layer are passed to the Physical layer, they are converted into a single bit stream. This means that all the bits (a stream of 1s and 0s) are queued up one after another as they move out onto the network media.

The Physical layer is also responsible for the actual generation of a signal across the network media (this could be electrical, light impulses, or radio waves, depending on the type of network media the network uses). This means that the Physical layer defines the actual physical aspects of how the cabling (if actual physical cable is used) is hooked to the computer's network interface card.


Thoughts on Using a Conceptual Model

Now, having read about each of the OSI layers, you still might wonder why this conceptual model is even necessary. You will find that when we start discussing actual network protocols, many of them do not map perfectly to the various layers of the OSI model. First of all, a conceptual model for network communications is useful in that it provides a context for discussing how data is generated by a user and then moved from one computer to another on a network. Breaking the different events involved in network communication into subsets also makes it generally easier to discuss and understand the entire process.

Another good reason for using a layered model is that programmers can actually work on modular protocols that "hook" into the overall conceptual model without really having to worry about the protocols that exist above or below the layer that they are working at. They know that protocols exist at these layers that will get the job done.

For example, even though TCP/IP does not have an individual protocol in its stack that maps to each and every layer in the OSI model, programmers have used this modular concept of different layers as new TCP/IP protocols have been developed. The Hypertext Transport Protocol (HTTP) was developed by programmers who knew that protocols already existed in the TCP/IP stack that took care of the Transport, Network, and Data Link layer functionalities.

HTTP is the protocol that provides us with the ability to use Web browsers to access Web sites on the World Wide Web. Programmers designed it to plug into the protocols already available in the TCP/IP stack.

Now that we've spent some time discussing the theory and concepts of network communication, we can take a look at the protocol stacks that are actually used. We will start with TCP/IP, which, due to the Internet, has become the worldwide standard protocol stack for computer networking.

Note

The different frame types are actually defined by specifications devised by the IEEE (Institute of Electrical and Electronic Engineers). The IEEE also divided the Data Link layer of the OSI model into two sublayers: the Logical Link Control (LLC) layer and the Media Access Control (MAC) layer. The MAC sublayer is related to the hardware-addressing scheme that was devised by the IEEE. The LLC sublayer establishes and maintains the link between the sending and receiving computers as data moves across the network's physical media. The LLC sublayer also provides service access points (SAPs), which are reference points that other computers sending information can refer to and use to communicate with the upper layers of the OSI stack on a particular receiving node.


TCP/IP

The Transmission Control Protocol/Internet Protocol (TCP/IP) has become the common language for the networking world. It is the protocol suite (or stack) that serves as the foundation for the mega-network known as the Internet. Most network operating systems, such as Windows 2000 Server, Novell NetWare 5.x, and the many different flavors of Unix and Linux, now embrace TCP/IP as their default networking protocol.

TCP/IP was developed by the Defense Advanced Research Projects Agency (DARPA). It was originally developed as a wide area networking protocol suite that could be used to maintain communication links between sites even if certain sites became inoperable during a worldwide nuclear war; however, another underlying reason for the creation of the TCP/IP protocol stack was that the Department of Defense needed a protocol stack that could communicate across dissimilar networks. These different types of networks existed because the government uses a bidding system and suddenly found itself with different computer systems at various branches of the Defense Department: the army, navy, and so on. Therefore, TCP/IP is jokingly called the "protocol of low bid."

TCP/IP contains a number of "member" protocols that make up the actual TCP/IP suite. Because the TCP/IP protocol stack was developed before the completion of the OSI reference model, these protocols do not map perfectly to the various layers of the model.

The Department of Defense Model

The TCP/IP suite was actually developed using a different conceptual model, called the Department of Defense (DoD) model. The DoD model has four layers:

  • Application layer. This layer in the DoD stack is equivalent to the OSI Application, Presentation, and Session layers. This layer provides the user interface for the various protocols and applications that access the network, and it handles file transfer, remote logon to other nodes, email functionality, and network monitoring.

  • The Host-to-Host layer. Equivalent to the OSI Transport layer, this layer provides flow control and connection reliability as data moves from a sending to a receiving computer. This layer takes the data from the Application layer protocols and begins the process of readying the data for movement out over the network.

  • The Internet layer. This layer corresponds to the OSI Network layer. It is responsible for the routing of data across logical network paths and provides an addressing system to the upper layers of the DOD stack. This layer also defines the packet format used for the data as it moves onto the network.

  • The Network Access layer. This layer is equivalent to the Data Link layer of the OSI model and consists of the protocols that take the packets from the Internet layer and package them in an appropriate frame type. The various frame types are described by the IEEE specifications we discussed in Chapter 4, "Building the Network Infrastructure."

We have been concentrating on the OSI model in our discussion of network protocol stacks, which is the accepted conceptual model for networking today. Figure 5.3 shows some selected protocols from the TCP/IP stack mapped to the OSI layers.

Figure 5.3. The TCP/IP stack mapped to the OSI model.

TCP/IP Protocols

A number of different protocols make up the TCP/IP stack. There are protocols that handle network access, data transport, and the logical addressing of data packets as they are routed over a network. Table 5.3 provides a brief explanation of some of the key TCP/IP protocols in the stack (including those shown in Figure 5.3).

Table 5.3. TCP/IP Protocol Stack Members

Protocol

Job

HTTP

The Hypertext Transport Protocol defines the message format and transmission used by Web servers and Web browsers.

Telnet

The Telnet protocol is the terminal emulation protocol that allows you to connect a local computer with a remote computer or other remote device.

FTP

The File Transfer Protocol provides an interface and services for file transfer on a network.

SMTP

The Simple Mail Transport Protocol provides email services on the Internet and IP networks.

TCP

The Transmission Control Protocol is a connection-oriented transport protocol.

UDP

The User Datagram Protocol is a connectionless transport protocol.

IP

The Internet Protocol is the basis for all addressing on TCP/IP networks and provides a connection-oriented Network layer protocol.

ARP

The Address Resolution Protocol maps IP addresses to MAC hardware addresses.

RIP

The Routing Information Protocol is a routing protocol used by routers to determine the best path for packets traveling on an internetwork.

As you can see from Table 5.3, the TCP/IP stack contains protocols that fulfill all the needs for data movement on the network as related to the OSI conceptual model. Protocols such as HTTP and FTP actually provide functions that operate at three layers of the OSI model (Application, Presentation, and Session). Although we refer to FTP as a protocol, it is actually a large protocol that provides a user interface and functions like a mini-application. FTP client software was used a great deal to transfer files on the Internet before HTTP became available.

IP Addressing

Another important aspect of TCP/IP is the logical addressing scheme that TCP/IP uses at the Network layer of the OSI model. This logical addressing is provided by the IP protocol. Everyone with access to the Internet has probably run across an IP address. It takes the form of four decimal numbers separated by periods. This format is referred to as dotted decimal.

This dotted decimal notation actually shows us the address in a format we understand (a series of decimal numbers). Computers and other devices on the network actually see this address as a decimal stream of 32 bits. Each of the four parts of the address are referred to as an octet. That is because each octet contains eight bits of information (a bit being either a 1 or 0).

For example, the IP address 130.1.16.1 would be seen by devices on the network as this:

10000010 00000001 00010000 00000001

Note

TCP/IP is the protocol of choice for routing data between networks. These large networks are best described as "networks of networks" (many LANs connected together) and are referred to as internetworks. Another term that is often used to refer to internetworks is enterprise networks. This describes the entire network infrastructure for a large company or institution that may be made up of multiple sites across a geographical area, a country, or even the world.

IP Address Classes

Because IP-based networks can be of varying sizes (very large, large, medium, and small), the architects of the IP addressing system set up different classes of IP addresses to accommodate different sizes of networks. Three classes of addresses for use on networks exist: Class A, B, and C. Here's more information on each class type:

  • Class A. Used for very large networks and supplies more than 16 million node addresses for the network. Due to the way IP addresses are structured, a Class A network can serve a huge number of host computers (nodes); however, there can only be 127 Class A networks. ARPAnet (built in the early days of the Internet) is an example of a Class A network.

  • Class B. Used for networks that still need a lot of node addresses, such as for large companies and institutions. There are 16,384 Class B network addresses available, with each Class B network supplying more than 65,000 host addresses.

  • Class C. Used for small networks. There are more than 2 million Class C network addresses available. Class C networks only provide 254 node addresses, however.

Two other classes of IP addresses should also be mentioned: Class D and Class E. Class D network addresses are used by multicast groups receiving data from a particular application or server service. An example of a multicast use of Class D addresses is Microsoft NetShow, which can broadcast the same content to a group of users at one time. Class E addresses belong to an experimental class, which is not available for use by folks like you and me.

Finding your Class

You can quickly identify the class to which an IP address belongs by looking at the decimal value of the first octet; each class (A, B, or C) has a specific first octet range:

  • Class A (1–126)

  • Class B (128–191)

  • Class C (192–223)

Notice that 127 is missing from the range of numbers. It is used for special testing of the IP configuration of a computer.

Tip

You can easily convert dotted decimal IP addresses to their binary equivalents using any scientific calculator, such as the Windows Calculator, that can be viewed in scientific mode. Be sure that the Dec (decimal) option button is selected and then enter the first octet's decimal number. Then select the Bin (binary) option button. Each binary number should consist of eight digits. You might have to add a leading zero or two to make up the eight positions. Repeat this procedure for each octet.

The Subnet Mask

In the Old West, a cowboy was nothing without his horse. Likewise, IP addresses really don't mean anything without an accompanying subnet mask. Devices on a network need to be able to tell what part of the IP address is providing information related to which network the computer with a particular address is on, as opposed to what part of the address actually refers to just the computer or node itself. This is determined by the subnet mask. Devices on the network use the subnet mask to "mask" out the portion of the IP address that refers to the network that the node sits on. If you look back at Figure 5.4, you'll notice that a computer must be configured with both an IP address and the appropriate subnet mask.

Figure 5.4. The IPX/SPX stack mapped to the OSI model.

Each class has a default subnet mask:

  • Class A: 255.0.0.0

  • Class B: 255.255.0.0

  • Class C: 255.255.255.0

Without going into a lengthy and complex explanation of how computers and other devices use a subnet mask to determine certain information from an IP address, the default subnet masks provide some obvious visual clues. If you remember, a Class A network provides more than 16 million node addresses. Also, there are only 126 Class A network addresses available.

If you look at the Class A subnet mask, you will notice that 255 only appears in the first octet. In binary, 255 would be 11111111, meaning that all eight bits are turned on. These "turned on" bits in the subnet mask actually mask out the first octet of any Class A IP address. This tells a computer that the first octet holds the network information.

Notice that all the other octets in the Class A subnet mask are 0—this would be 00000000 in binary—and would not mask out the information in the second, third, and fourth octets. This allows these octets to be used for node addresses. Each octet contains eight bits, so in a Class A network, eight bits are used to determine network information, and the other 24 bits are used for node addresses. This is why so many different possibilities are available for node addresses (again, more than 16 million).

In the case of Class B networks, only the third and fourth octets are used for node addresses; this is because the first and second octets are masked out by the subnet mask and provide the network information. With only 16 bits available for node addresses, this means that Class B networks supply fewer node addresses (around 65,000).

Using this logic, you can see why Class C networks supply so few IP addresses (254). This is because only the fourth octet is reserved for node addressing, and the rest of the octets are used for network information. The subnet mask 255.255.255.0 masks out all the octets in a Class C address except for the last octet.

Tip

IP networks can be divided into segments called subnets. We take a look at some of the basics of subnetting in Chapter 12, "TCP/IP Network Administration." We also look at configuring IP addresses and subnet masks on network computers in Chapter 12.


IPX/SPX

IPX/SPX (which stands for Internetwork Packet Exchange/Sequenced Packet Exchange) is a network protocol stack developed by Novell for use on networks running the Novell NetWare network operating system. Novell NetWare is a popular network operating system (NOS) that has provided file and print server functionality to LANs since the early 1980s (we will discuss Novell NetWare in Chapter 6, "Configuring Peer-to-Peer Networks").

IPX/SPX, like TCP/IP, is actually a stack of protocols that perform different functions in the overall network communication process. Also like TCP/IP, IPX/SPX does not map directly on a layer-per-layer basis to the OSI conceptual model. IPX/SPX actually requires fewer resources (both from a computer and a network) than TCP/IP and therefore gained a strong foothold (as did Novell NetWare) in the early decades of the PC revolution, because computers with limited capabilities (limited in terms of the amount of memory and hard drive space, if any, on the computers) running the DOS operating system could be networked. IPX/SPX is suitable for small and large networks and is a routable network protocol suite (like TCP/IP).

Note

Novell NetWare was based on the XNS (Xerox Network Systems) network operating system that was created at the Xerox Palo Alto Research Center in the 1970s.

IPX/SPX Protocols

The IPX/SPX protocol stack is made up of a number of protocols that handle the various duties required for network communication on both a sending and a receiving node. Figure 5.4 shows a mapping of IPX/SPX stack protocols to the OSI conceptual model. Table 5.4 provides definitions of some of the more important protocols in the IPX/SPX stack.

As you can see from Figure 5.4, IPX/SPX has protocols that handle the functionality of the Application, Presentation, Session, Transport, and Network layers. These protocols basically plug into the standards that operate at the Data Link layer of the OSI model and are defined by the IEEE standard discussed in Chapter 3, "Networking Hardware." Novell NetWare can be used as the NOS on both Ethernet and Token Ring networks.

Table 5.4. IPX/SPX Protocol Stack Members

Protocol

Job

NCP

The NetWare Core Protocol handles network functions at the Application, Presentation, and Session layers. It is responsible for providing the connection between clients and servers. It also handles packet creation when the sending of data is initiated by a computer on the network.

SAP

The Service Advertising Protocol is used by NetWare servers to announce the addresses of file and print servers on the network. This is how NetWare clients know how to find network resources.

SPX

The Sequenced Packet Exchange protocol is a connection-oriented protocol that operates at the Transport layer of the OSI model.

IPX

The Internetwork Packet Exchange protocol is a connectionless transport protocol that handles the addressing of nodes on an IPX/SPX network.

RIP

The Routing Information Protocol (the Novell flavor) is responsible for the routing of IPX/SPX packets on the network.

Tip

As we discuss network protocols and networking in general, two terms that keep popping up are resources and bandwidth. A resource can be memory or hard drive space on a computer. The processor on a computer is also a resource in that it can only process so much information at any one time. On the network itself, bandwidth is probably the most important resource. I'm speaking of bandwidth in terms of the amount of data that can be pushed along the network media (the term bandwidth means something else entirely when you are discussing analog signals and their different amplitudes). Network administrators do everything they can to preserve the bandwidth on their networks. TCP/IP is generally considered more of a bandwidth hog when compared to IPX/SPX and therefore is one of the reasons why IPX/SPX was embraced early on for PC networking.

IPX/SPX Addressing

IPX/SPX also uses a logical addressing system to identify the nodes on the network. The IPX protocol is in charge of this addressing system. The IPX address is similar in theory to an IP address in that it provides both the network location and the actual node address of a computer.

Here's how it works: When you install the first NetWare server on the network, the server generates a network number. This hexadecimal number becomes the network number for the LAN, no matter how many additional NetWare servers (additional file and print servers) are added to the LAN. Therefore, all client machines (and additional servers) on the LAN will be assigned the same network number.

The clever part of IPX addressing is how the node address portion of the IPX address is determined. As you already know from Chapter 3, each computer has a MAC address, which is burned into a ROM chip on the NIC. The node portion of the IPX address is the MAC address of the computer (or other device).

Figure 5.5 shows an IPX address that was taken from a node on a NetWare network. The first portion of the address, as shown in the figure, is the network address, and the remainder of the address is the MAC hardware address for the device.

Figure 5.5. An IPX address is made up of a network address and a node address.

Configuring IPX/SPX

Novell NetWare is a good example of a client/server network operating system; a computer on the network either functions as a client or a server. Therefore, this means servers (such as the logon server and file and print servers) have to be configured and then clients configured so that they can access the resources provided by the various NetWare servers.

We will discuss some of the issues related to setting up and configuring NetWare servers in Chapter 8, "Networking with Novell NetWare 6.5." For now, I will say that actually installing the NetWare software on a server is very straightforward (as almost all network operating systems are now). However, even Novell now uses TCP/IP as the default network protocol, so during the installation, the IPX/SPX protocol stack must be enabled.

Configuring clients for NetWare is very straightforward because client software is included with the Novell network operating system that helps a network administrator in configuring the NetWare clients. NetWare can support DOS, Windows, Macintosh, and Unix clients. This add-on software for the client operating system sets up the computer with a NetWare logon so that users with user accounts on the NetWare server can log on to the network using their usernames and passwords.

Windows 9x, Windows 2000, and Windows XP computers can all be configured as NetWare clients. You can use the WIN32 client setup software included with the Novell NetWare NOS, or you can configure Windows clients for a NetWare network using your Windows software. You'll learn more about configuring Windows clients for NetWare in Chapter 8.

Tip

Windows NetWare clients actually use a Microsoft clone of the IPX/SPX network protocol called NWLink, which stands for NetWare link—clever, huh?


Other Network Protocols of Note

With TCP/IP serving as the de facto network protocol and many legacy networks (another way of saying "old networks") running IPX/SPX, some very fast and clever network protocols have kind of fallen by the wayside. Let's take a look at some other network protocols that you can still use and that will certainly be found on networks running in some environments.

NetBEUI

NetBIOS Extended User Interface (or NetBEUI) is a simple and fast network protocol that was designed to be used with Microsoft's and IBM's NetBIOS (Network Basic Input Output System) protocol on small networks. NetBIOS is a protocol that allows computers to be identified on the network by a friendly name. Anyone who has ever set up a version of Microsoft Windows has experienced setting up a computer name during the installation of the Windows software.

Although it's an excellent transport protocol that doesn't require a whole lot of resources from a computer or the network to move data, NetBEUI is not a routable protocol; therefore, it cannot be used on large networks where routers are used to move data between the various segments or subnets. As far as protocol concepts go, NetBEUI operates at the Transport and Network layers of the OSI model.

With the release of Windows XP, Microsoft no longer supports NetBEUI as a default network protocol. It is not listed when you attempt to add a protocol to the connection Properties dialog box of a computer running Windows XP (or Windows Server 2003). For information on adding NetBEUI to a Windows XP computer see the link http://support.microsoft.com/default.aspx?scid=kb;en-us;Q301041&sd=tech. It provides all the steps for installing NetBEUI as a network protocol.

AppleTalk

In the first decade or so of the PC revolution, the Macintosh computer definitely had a leg up on the DOS/Windows environment as far as networking was concerned because of the AppleTalk protocol stack. AppleTalk was (and still is) extremely easy to configure, and the hardware required for network connectivity (called LocalTalk) was built into each and every Macintosh (Mac computers, including the new iMac, still come with all the networking hardware required; however, their configuration is now slanted toward Ethernet and TCP/IP).

AppleTalk is a routable protocol that allows large networks to be broken into logical subgroups called zones. A zone is a collection of certain users (which do not have to be located at the same physical location) and is similar to the concept of workgroups in Microsoft peer-to-peer networking (we will explore Microsoft workgroups in Chapter 6). Users in a zone typically share the same network resources, such as files and printers.

AppleTalk Addressing

AppleTalk also uses a two-part network addressing system (as do TCP/IP and IPX/SPX). This address is divided into a network portion and a node (or computer) portion.

The network number is actually specified by the network administrator. Because it is a logical addressing system, decimal numbers can be used to identify the different AppleTalk logical networks that reside on the actual physical network. For example, a logical network that takes up an entire physical network could be assigned the network number 10 by the administrator. If several different AppleTalk networks were to be assigned to one physical network, the administrator could designate them as a numerical range, such as 10–20.

Node addresses are extremely easy to configure because you don't actually configure them at all. When a Macintosh client is brought up on the AppleTalk network, it generates a random node number and broadcasts it out onto the network to let the other computers know that it is going to use that number. This serves as the node address for the computer. The logical network number created by the administrator (such as 10, as in the preceding example) and the random node address that is generated by the computer make up the complete network address for the computer.

Tip

If the node address generated by a computer on an AppleTalk network is already taken, the computer will generate a new node address and broadcast this to the other computers on the network.

AppleTalk and the OSI Model

The AppleTalk protocol stack is made up of a number of protocols that supply all the features required for network communication. Table 5.5 provides a list and brief definition of some of the AppleTalk protocol stack members.

Table 5.5. AppleTalk Protocol Stack Members

Protocol

Role

AppleShare

AppleShare provides services at the Application layer.

AFP

The AppleTalk Filing Protocol provides and manages file sharing on the network.

ATP

The AppleTalk Transaction Protocol works at the Transport layer and manages the connection between computers.

NBP

The Name Binding Protocol maps computer hostnames to Network layer addresses.

ZIP

The Zone Information Protocol controls AppleTalk zones and maps zone names to network addresses.

AARP

The AppleTalk Address Resolution Protocol maps logical Network layer addresses to Data Link hardware addresses.

DDP

The Datagram Delivery Protocol provides the logical addressing system for the AppleTalk network.

DLC

Before we completely end this discussion of network protocols, I should mention the Data Link Control protocol (or DLC). DLC was actually developed for communication between mainframes and Hewlett-Packard (HP) printers. You might run into DLC in situations where you have printers directly connected to a network (rather than connected to a computer on the network) using an HP Jet Direct box or HP Jet Direct card. Typically, printers connected using these devices will be assigned an IP address like any other node on the network.

However, if you are using HP Jet Direct-enabled printers on a network that is not using TCP/IP, you must use DLC for the printer or printers to communicate with the computers on the network. DLC can be configured on Windows-based computers. DLC is also configured on the printers using installation software that is provided with the HP Jet Direct box or card.

Note

Mac computers are now geared up to use TCP/IP as their network protocol. You can still use AppleTalk on networks that do not need to be connected to the Internet.

The Absolute Minimum

This chapter has provided a discussion of conceptual network models, particularly the OSI model. We also had the opportunity to sort out the differences between different LAN protocols and how they relate to the OSI conceptual model.

  • Network protocol stacks are used by computers to communicate on the network.

  • The OSI model provides a conceptual model for network communication and data transfer.

  • The OSI model is divided into seven layers; each layer takes care of specific duties related to network communication.

  • The TCP/IP protocol stack has become the standard for computer networking because of the Internet.

  • TCP/IP is actually a stack of protocols, and each protocol takes care of certain processes involved in network communication.

  • The IP protocol provides the logical addressing system used on TCP/IP networks.

  • An IP address is a 32-bit, four-octet address.

  • Three classes of address, A, B, and C, are available for assigning addresses to TCP/IP networks. Class A is used for very large networks, Class B for medium-size networks, and Class C for small networks.

  • IPX/SPX is another routable protocol stack; it is typically used on networks running the Novell NetWare NOS.

  • IPX is the protocol in the IPX/SPX protocol stack that handles the logical addressing system for the network.

  • IPX addresses provide both network and node information. The network portion of the address is generated by the NetWare server, and the node address is the MAC hardware address of the computer.

  • AppleTalk is a protocol stack created by Apple and used on Apple Macintosh networks. AppleTalk node addresses are created by a Macintosh computer the first time it connects to the network.

  • DLC is a protocol that can be used to communicate with Hewlett-Packard printers directly connected to the network. It is used in situations where TCP/IP is not in use on the network.


Part II: Getting the Network Up and Running

Configuring Peer-to-Peer Networks

Network Operating System Overview

Netowrking with Novell NetWare 6.5

Netowrking with Microsoft Windows Server 2003

Networking with Linux

Working with Applications on the Network


Chapter 6. Configuring Peer-to-Peer Networks

In this chapter

  • Choosing a LAN protocol for peer-to-peer networking

  • Configuring LAN protocols on peer computers

  • Sharing resources in a Windows workgroup

  • Linux and Windows Workgroups

  • Configuring Samba

  • Accessing shared resources

We've taken a look at networking hardware, different network architectures, network protocols, and also discussed the differences between peer-to-peer networking and server-based networking. Now we can concentrate on configuring a peer-to-peer network. Although peer-to-peer networks are the simplest type of LAN you can create, you still need to know how to configure network protocols and share resources such as printers and files.

Be advised that you should only deploy a peer-to-peer network in situations where you are dealing with a limited number of computers that need to share resources and the number of computers is going to remain relatively static (if you are dealing with a rapidly expanding user-base and a number of resources that need to be shared, a server-based network might make more sense since it is more easily scaled).

Even a simple peer-to-peer network will require that some sort of network medium be used for communication between the peer computers. You can use traditional network wiring (such as CAT 5 or 6 twisted pair) and a hub to connect the computers or you can connect your computers using a wireless networking strategy. Let's begin our discussion of peer networking with a look at LAN protocol configuration. We can then look at the specifics of sharing folders and printers in a Microsoft Windows-based peer network and then look at some of the possibilities provided by Linux-based systems.


Selecting and Configuring Network Protocols

No matter what operating system you run on your peer computers, the computers participating in the peer-to-peer network need to be configured with at least one common LAN protocol. TCP/IP is the default protocol on pretty much every current client operating system including Windows XP, Mac OS X, and the various distributions of Linux (such as Lycoris Desktop and Red Hat).

Since most PCs in a peer-to-peer network also need to access the Internet, the configuration of the TCP/IP protocol on the computer is essential. We look at configuring TCP/IP on a Windows XP computer later in the chapter (more about TCP/IP is discussed in Chapter 12, "TCP/IP Network Administration").

At one time in the Windows environment, the most-often used and simplest LAN protocol for use on a small network was NetBEUI. With the release of Windows XP, NetBEUI is no longer a supported protocol on a Microsoft Windows-based computer. NetBEUI is available on the Windows XP CD and can be installed if you wish to set up a small network that does not use TCP/IP or NWlink (IPX/SPX). NetBEUI is fine for a small, isolated network that does not require Internet connectivity.

In situations where you don't want to configure peer computers with IP addresses (in a situation where Internet isn't an issue), you can actually use the NWlink protocol, which is Microsoft's implementation of Novell's IPX/SPX protocol stack. It's not necessary to have a NetWare server on the network; the computers "talk" via NWlink. This protocol can be added to a Windows computer as discussed in the next section. For more information on the IPX/SPX protocol stack see Chapter 5, "Network Protocols: Real and Imagined."

Note

NetBEUI is still required on some networks that run legacy applications that require the network protocol. Since NetBEUI is not a routable protocol (nor is it scalable) it is rapidly becoming a footnote in protocol history. If you need to install NetBEUI on a Windows XP computer check out the Windows XP FAQ at http://www.microsoft.com/windowsxp/expertzone/newsgroups/faq/default.asp. The FAQ provides the steps for adding NetBEUI to a computer's configuration.

Windows and LAN Protocols

All the recent flavors of Microsoft Windows (9x, 2000, and XP) all handle protocol configuration in pretty much the same way. In the Windows 9x and Windows NT environments, the process is begun by right-clicking the Network Neighborhood icon on the Windows desktop. In the shortcut menu that appears, you select Properties. This opens the Network dialog box. In the Windows 9x environment, protocols are managed on the Configuration tab of the Network dialog box. In the Windows NT environment, the Protocols tab of the Network dialog is used to add, remove, and configure protocols. Figure 6.1 shows the Protocols tab of the NT Network dialog box.

Figure 6.1. Windows 9x and Windows NT provide the tools for configuring protocols in the Network dialog box.

Adding a protocol to either Windows 9x or Windows NT clients is just a matter of clicking the Add button and then selecting the protocol from the list provided. Windows 2000 and Windows XP provide a similar set of steps for adding protocols. Let's take a look at adding a protocol to a Windows XP computer.

In Windows XP you get to the Local Area Connection via the Control Panel (select Start, then Control Panel). In the Control Panel, select Network and Internet Connection. In the Network and Internet Connection window, select Network Connections.

In the Network Connection window, right-click on the Local Area Connection and select Properties from the shortcut menu. The connection's Properties dialog box will appear as shown in Figure 6.2.

Figure 6.2. Windows XP provides the Local Area Connection Properties dialog box for configuring protocols.

Make sure that the General tab is selected on the Properties dialog box. To add a new protocol, click the Install button. The Select Network Component Type dialog box will appear, as shown in Figure 6.3.

Figure 6.3. Use the Select Network Component Type dialog box to add protocols and other components to the computer's network settings.

The Select Network Component Type dialog box provides you with three choices: Client, Service, and Protocol. Although this particular section covers adding and configuring protocols, let's take a moment to break down each of these components individually and then we can return to our discussion of protocols:

  • Client. This choice allows you to select the type of client your computer will act as. In the case of peer-to-peer networking, you still have to have the Client for Microsoft Networks installed, even though you don't log on to a central server.

  • Service. A service is an additional network feature such as File and Printer Sharing for Microsoft Networks. Because file and printer sharing is very important in peer-to-peer networking, this service will need to be installed if you wish to share files and printers in a workgroup.

  • Protocol. In a nutshell, protocols are the languages used for network communication between computers and other devices. As already mentioned, there must be a common protocol for the computers in a peer-to-peer network to communicate. Now, let's get back to the installation of a protocol in the Windows environment.

To add a protocol to the computer's configuration, click Protocol in the Select Network Component Type dialog box and then click Add. The Select Network Protocol dialog box will open, as shown in Figure 6.4.

Figure 6.4. Select a protocol to add to the computer's configuration.

Select the protocol you wish to add and then click the OK button. The protocol will be added to the protocol list in the Local Area Connections dialog box.

Note

Windows XP comes in two flavors: Windows XP Home and Windows XP Professional. Windows XP Home is suitable for the home and the small office. It can be configured for peer networking. For server-based networks, Windows XP Professional is required. The two flavors of the operating system are maintained and used in much the same way as far as the end-user is concerned.

TCP/IP Issues

TCP/IP is added to the network configuration of Windows 9x and the more recent version of Windows by default. The TCP/IP settings are also configured on these Windows operating systems so that the IP address, subnet mask, and other TCP/IP settings, such as the default gateway and primary DNS server, are received automatically from a network DHCP server.

If you are putting together a peer-to-peer network where the computers are also connected to the Internet (through a DSL or cable modem connection), you can leave TCP/IP settings so that all the IP settings are configured by your Internet service provider's DHCP server. If you have multiple computers connected to the Internet (for example, using a DSL router or a cable modem), your Internet service provider will provide IP addresses in a particular range to the computers in your peer network. So the computers should be able to use TCP/IP to communicate locally as well. (We will discuss connecting multiple computers to a single Internet connection in Chapter 15, "Connecting a Network to the Internet," in the section "Sharing an Internet Connection.")

In cases where you are connecting your peer-to-peer network to the Internet using a single connection, or if you are not going to connect the peer network to the Internet at all but still want to insist on using TCP/IP as your network protocol, you have two choices for coming up with the IP addresses for your computers:

  • You can allow Windows to configure itself automatically (this automatic IP addressing is available in the Windows versions made available after the 9x series).

  • You can configure the computers' TCP/IP settings manually.

Windows operating systems such as Windows XP provide a feature related to IP addressing called Automatic Private IP Addressing (APIPA). To explain: A Windows XP computer is by default configured to get its IP information (such as address and subnet mask) from a DHCP server, and so the computer will try to contact a local DHCP server. When it doesn't find a DHCP server on the network (because you wouldn't be running one on your peer-to-peer network), the APIPA kicks in and the computer assigns itself an IP address from the range 169.254.0.1 through 169.254.255.254 (Microsoft's private range of addresses, which are not used on the Internet) and a subnet mask of 255.255.0.0. Because the computers all end up with addresses in the same Class B range, they don't have any trouble communicating with each other using the TCP/IP protocol (more about TCP/IP is discussed in Chapter 12).

The alternative to APIPA is to statically configure the computers with IP addresses. Because a peer-to-peer network won't have any specialized servers such as a DNS server (it won't have any servers at all), you won't have to configure any of the IP settings other than the IP address and the subnet mask. The question is what should the range of IP addresses be and which subnet mask should you use for the computers in the peer-to-peer network?

The answer is pretty straightforward: Three ranges of IP addresses have been reserved to use for "private" addressing. These ranges of addresses have not been assigned to computers on the Internet, so if you use IP addresses in one of these ranges, your addresses will not potentially conflict with IP addresses already assigned to computers on the Net.

There is a range of addresses reserved in each of the three classes: Class A, Class B, and Class C. These ranges and the subnet mask you would use with each range are shown in Table 6.1.

Table 6.1. Private IP Address Ranges

Class

Address Range

Subnet Mask

A

10.0.0.1 to 10.255.255.254

255.0.0.0

B

172.16.0.1 to 172.31.255.254

255.255.0.0

C

192.168.0.1 to 192.168.255.254

255.255.255.0

Obviously, the Class A range gives you a very large number of available addresses (it's pretty much overkill for a peer-to-peer network), but you can set up your small peer-to-peer network as a Class A network if you like. You need to limit yourself to one class of private addresses, however, if you want the computers to talk to each other.

To manually configure the IP address and subnet mask, select Internet Protocol (TCP/IP) in the Local Area Connection Properties dialog box and then click the Properties button. Figure 6.5 shows the Internet Protocol (TCP/IP) Properties dialog box that opens.

Figure 6.5. Enter the IP address and subnet mask for the computer in the Internet Protocol (TCP/IP) Properties dialog box.

In the Internet Protocol (TCP/IP) Properties dialog box, click the Use the Following IP Address option button and then enter the IP address and the subnet mask for the computer. Then all you have to do is click OK and close the various open dialog boxes. Some Windows clients will require that you restart the system for the new networking configuration to take effect.


Setting Up the Peer-to-Peer Network

Once you have the peer computers configured with a LAN protocol, you are ready to actually set up the peer network itself. This means that you need to physically connect the computers with some sort of network medium. Windows (beginning with the second release of Windows 98) actually provides you with the capability to connect two computers using a serial cable attached to COM ports on the computers (we're talking a very small peer-to-peer network).

But for discussions sake, let's assume that your peer-to-peer network consists of several computers that have been connected using twisted-pair cabling and a hub. First you must enable file and printer sharing on the computers. While many Windows computers may already have this component installed by default, let's look at how you add this component. This is done in the Local Area Connection Properties dialog box (the same place where protocols were added to the computer's configuration). Follow these steps:

  1. Open the Control Panel (in Windows XP, select Start, then Control Panel).

  2. In the Control Panel, select Network and Internet Connection. The Network and Internet Connection window opens.

  3. In the Network and Internet Connection window, select Network Connections. The Network Connection window opens.

  4. In the Network Connection window, right-click on the Local Area Connection and select Properties from the shortcut menu.

  5. In the Local Area Connection Properties dialog box, click the Install button and then select Service in the Select Network Component Type dialog box.

  6. Then click the Add button.

  7. In the Select Network Service dialog box, select File and Printer Sharing for Microsoft Networks. Then click OK. The service will be added to the General tab of the Local Area Connection Properties dialog box. You can click OK to close the Properties dialog box.

Now, we can take a look at creating the workgroup and how resources such as drives, folders, and printers are actually shared on the peer network in the Windows environment.

Tip

You can also use a crossover cable to connect two Windows-based computers that are outfitted with Ethernet cards. The crossover cable negates the need for a hub. If you want to try and make your own crossover cable, check out the GCC Web site at www.gcctech.com/ts/doc/crossover.html.

Creating Windows Workgroups

You need to configure two items in the Windows environment for the peer-to-peer network to work: Windows File and Printer Sharing (as already discussed) and a workgroup (actually, you will also need to share folders and printers, which we will discuss later in the chapter). A workgroup is really just a logical grouping of computers that have been configured with the same workgroup name.

The easiest route for setting up a workgroup using Windows XP Home or Professional is the Network Setup Wizard. Follow these steps:

  1. Open the Windows Control Panel (select Start, then Control Panel).

  2. Select the Network and Internet Connection icon in the Control Panel. To start the Network Setup Wizard, select Set Up or Change Your Home or Small Office Network. The Network Setup Wizard will appear.

  3. Click Next to bypass the initial wizard screen. The next screen provides a checklist of things that you should do before proceeding with the wizard (such as install network cards and modems). Click Next to continue.

  4. On the next screen you are asked to choose how the computer connects to the Internet. You can either specify that the computer connects directly or through another computer (Windows XP offers Internet Connection Sharing, as does Windows 2003 Server; sharing an Internet connection is discussed in Chapter 16). Select the appropriate setting (see Figure 6.6).

    Figure 6.6. Specify how the local computer connects to the Internet.

  5. After making your selection, click Next. On the next wizard screen you must supply a description of the computer and a name for the computer. The description is optional but the name is important. You are actually assigning the NetBIOS name to the computer. The name must be unique and consist of 15 characters or less. This is the limit for NetBIOS names.

  6. After providing the description and name for the computer, click Next to continue. On the next screen (see Figure 6.7) you must supply the name for your workgroup.

    Figure 6.7. Supply the name for the workgroup.

  7. After supplying the workgroup name, click Next. On the next screen, the wizard lets you know that it is ready to apply the settings that you have configured using the wizard. Click Next.

  8. On the next screen you are given the option of creating a Network Setup Disk. This floppy disk is used to join Windows computers to the workgroup that are running pre-XP versions of Windows. You will need a blank formatted floppy disk to create the Network Setup Disk. After clicking Next, you will be prompted to insert the disk.

  9. After the disk is created you can continue to the final wizard screen. To complete the setup of the workgroup on the computer, click Finish.

You can run the Network Setup Wizard on all computers that you want to join to the domain, or use the Network Setup Disk when necessary. If a workgroup already exists, you can also specify the name of the workgroup on a computer without running the Network Setup Wizard. This is a little more advanced than using the Network Setup Wizard but it requires fewer steps. On a computer running Windows XP select Start, and then right-click on My Computer. Select Properties on the shortcut menu that appears. The System Properties dialog box will appear.

Click the Computer Name tab on the System Properties dialog box. The current name of the computer and the workgroup or domain that it belongs to are displayed (we discuss domains in Chapter 9, "Networking with Microsoft Windows Server 2003").

To change the computer's name or its workgroup, click the Change button. The Computer Name Changes dialog box appears (see Figure 6.8). Enter the workgroup name in the Workgroup box. If you wish to change the name of the computer, enter a new name in the Computer Name box.

Figure 6.8. You can change the computer name or workgroup affiliation.

After making your changes, click OK. It may take a moment but a message box will open welcoming you to the workgroup. Click OK to close the message.

Note

NetBIOS is a protocol that allows computers to be identified on the network by a friendly name. With the introduction of Windows 2000, Microsoft moved away from NetBIOS as the "friendly" naming system for computers on a network. Windows 2000 (and Windows XP) use the fully qualified domain name (FQDN) as the friendly name on networks. FQDNs are resolved to IP addresses by DNS servers. NetBIOS names are still required by computers running older versions of Windows and certain legacy network applications. Every computer you configure should have a unique computer name.

Windows Folder and Printer Sharing

Actually sharing folders and printers in the Windows environment is extremely straightforward. In both cases, it's just a matter of right-clicking the folder or printer that you want to share.

In the case of sharing folders, use Windows Explorer (in Windows XP, select Start, right-click on My Computer, and select Explore) to locate the folder that you want to share with the other computers in the workgroup. Then right-click the folder and select Sharing and Security (in earlier versions of Windows the selection is "Sharing").

The Properties dialog box for the folder will open. On the Sharing tab select the Share This Folder on the Network check box. You can then specify a name for the share, which is what you call the shared folder. Figure 6.9 shows the Sharing tab of the Properties dialog box on a Windows XP computer.

Figure 6.9. Use the Sharing tab on the Properties dialog box to share the folder.

In terms of printers, sharing is just as easy as sharing a folder. Open the Printers dialog box; in Windows XP, select Start, then Printers and Faxes (in most other versions of Windows, click Start, point at Settings, and then select Printers).

In the Printers and Faxes window, right-click any installed printer and select Sharing. The printer's Properties dialog box will open with the Sharing tab selected. Select the Share This Printer option and then provide the Share name for the printer. Figure 6.10 shows the Sharing tab of a printer's Properties dialog box. To close the Properties dialog box, click OK.

Figure 6.10. Printers are shared on the Sharing tab of the printer's Properties dialog box.

Tip

You can also use the Computer Name Changes dialog box to add a network client to a Windows Domain. You will need to have knowledge of an account name (and password) that has administrative rights on the Windows domain controller (the main server on the domain). All you have to do is select the Domain option button and then type the name of the domain. When you click OK, you will be prompted to provide the administrative account name and password. It may take a little time, but a message box should appear welcoming you to the domain.

Once the shares and printers are available for the workgroup, the various users can access these resources. Workgroup member computers and the shares that they offer can be accessed using Network Neighborhood or My Network Places (depending on the version of Windows). Shared printers will also appear along with the shared folders and can be quickly connected to. Figure 6.11 shows a printer and shared folders that are being provided by a workgroup peer.

Figure 6.11. Shares and printers can be accessed via the workgroup.

Tip

Windows XP actually provides you with an option that allows you to make print drivers for earlier versions of Windows available to computers on the network. This is very useful when a computer in a workgroup (or on a network domain) is running an earlier version of Windows and needs to be connected to the printer. Drivers are added for a shared printer using the Additional Drivers button on the printer's Sharing tab.


Combining Linux and Windows

Because peer-to-peer networks provide a way to connect a few computers together on "the cheap," we should also take a look at how Linux can fit into a Windows peer network. Linux is becoming an inexpensive alternative to other desktop operating systems (and also in the network operating system arena). This is particularly due to the fact that a number of Linux distributions can actually be downloaded from the Internet for free.

Linux-based computers can be made a part of a Windows workgroup by configuring an add-on program on the Linux computers called Samba. Samba derives its name from SMB or Server Message Block. SMB is an important part of the NetBIOS protocol and supplies the data blocks that make requests between client and server or between peers on a Microsoft network.

Samba is able to simulate the operation of SMB and also provide NetBIOS over IP (TCP/IP being the protocol stack for Linux), which means that a Linux computer can actually pretend to be a Windows client. This means the Linux machine can share folders and printers or access folders and printers in the workgroup.

Many distributions of Linux provide Samba on the installation CDs. In some cases you will have to make sure that Samba is installed as an option when you install the Linux OS. As already mentioned, Samba is installed by default and will actually be up and running on a computer using Lycoris Desktop. Samba can be further configured using a Samba client utility. Other Samba settings can be configured by editing Samba configuration text files. While the prospect of editing configuration files might be a little scary, there are other options for configuring Samba. For example, there is a tool called SWAT (Samba Web Administration Tool), which allows you to configure Samba from any Web browser. Let's take a quick look at how Samba is configured on a Linux computer, with the understanding that this is certainly not an exhaustive treatise on Linux or Samba.

Note

Samba is actually made up of a suite of programs. For example, smbd is the Samba daemon that handles the SMB services. Another program, nmbd, handles the NetBIOS name issues.

Note

Linux, an open source Unix-like operating system, is available in a number of different distributions such as Red Hat, Lycoris, SuSE, and Mandrake. While Linux has long been considered the operating system of geeks and hackers, a number of the distributions offer a very Windows-like environment that provides a pretty intuitive graphical user interface. Lycoris, which we discuss in this chapter, actually preconfigures a number of the features that allow you to connect to the Internet and Windows computers in a workgroup. If you want to experiment with Linux, check out www.linuxiso.org. It provides a place to download Linux distributions and burn your own installation CDs. To actually receive customer support and hard copy manuals, you may wish to actually purchase one of the Linux distributions. Most Linux distributions, including my favorites, Lycoris and Red Hat, are actually quite inexpensive when you compare them to other mainstream operating systems.

Configuring and Using Samba

Samba actually consists of two parts: a client and a server. Both of these parts must be configured so that the computer running Linux can both access and serve up shared resources in the Windows workgroup. Configuring the Samba client is very straightforward in most Linux distributions. Lycoris Desktop actually provides a very straightforward way of accessing the Samba client settings. Right-click on the Network Browser icon on the Lycoris desktop and select Configure Network Settings. The Windows Shares dialog box opens as shown in Figure 6.12.

Figure 6.12. The Samba client is most often configured using a desktop utility such as the Lycoris Windows Shares dialog box.

The server side of Samba must also be configured so that you can provide shared resources to other computers in the workgroup. The main Samba configuration file is named smb.conf. This file can be accessed using any file access or search tool provided by your Linux distribution. This file can also be located using the command line if you are familiar with the various commands required to operate at the Linux command line. Figure 6.13 shows the Konqueror window on the Lycoris desktop. It provides a search tool that was used to locate the smb.conf file.

Figure 6.13. You must locate and configure the smb.conf file.

The smb.conf file can be opened in a text editor. There are several sections to the smb.conf file, as shown in Figure 6.14. Most of the settings are straightforward and can be edited intuitively. You must provide a Workgroup name and the name of the server in the Global settings area of the smb.conf file. Other areas of the configuration include the homes area, where you set the home directory for users; the netlogon area of the configuration file, which determines whether or not you will allow guest logons; and a printers section where you specify print parameters related to shared printers.

Figure 6.14. The smb.conf file can be configured in a text editor.

Manually configuring the smb.conf file can be tricky, so if you are new to Linux, you will probably want to use a Samba configuration tool that makes the entire process a little more intuitive. We discuss SWAT in the next section.

Note

Some Linux distributions may not include Samba. You might also have to download and install the most recent version of Samba from the Internet. You can do this from your computer running Linux. Information related to Samba and links for downloading the recent release of Samba can be found at http://www.samba.org.

Using SWAT

An alternative to manually configuring the Samba configuration file is to use an add-on program to configure Samba. One of the easiest to use Samba configuration tools is SWAT. SWAT is included with some Linux distributions, or you can download it from one of the Linux software repositories on the Web (if you use Lycoris or Red Hat, the distributions have their own Web sites, lycoris.com and redhat.com respectively, that provide you with the ability to easily add software components to your Linux operating system. These services are typically reserved for those who have purchased a copy of the OS, however).

Note

You can see from Figure 6.12 that Lycoris has gone to great pains to provide a desktop environment that would be familiar to users of Microsoft Windows.

SWAT is also available from a number of Linux software repositories. Checkout www.linux.org and www.linux.com as starting places to locate LINUX add-on software such as SWAT.

Once SWAT is installed on the Linux computer (in some cases some configuration files on the Linux box may have to be customized for SWAT to work; again consult Web resources related to SWAT or consult Sams Teach Yourself Samba in 24 Hours), you can access the Samba configuration file by invoking SWAT in any Web browser.

In the Web browser address window type http://localhost:901/ and press Enter. The number 901 is actually a port number that allows a TCP connection between SWAT and your Web browser (the port number and the IP address provide the socket used as the communication avenue between TCP and HTTP on the Web browser). Figure 6.15 shows the Samba SWAT program running in the Mozilla Web browser.

Figure 6.15. The SWAT program allows you to configure Samba from a Web browser.

Once SWAT is up and running, you need to configure Samba so that it allows the Linux computer to communicate in the Windows workgroup. This is accomplished using the Samba Globals settings, which is reached by clicking Globals in the browser window.

The two most important settings in the Globals configuration are the name of the workgroup that the computer will belong to and how Windows peers trying to access shares on the Linux box will be validated. Figure 6.16 shows the Globals configuration settings that need to be addressed, such as the workgroup name and the NetBIOS name for the Linux computer.

Figure 6.16. Samba must be configured with the Windows workgroup name.

Linux actually has a lot more robust security than most of the flavors of Windows (except for perhaps Windows 2000 and Windows XP). This means that you need some sort of mechanism that will dilute the security so that Windows clients in the workgroup can easily access shares on the Linux computer without having to provide a username and a password each time they try to connect (the whole point of peer-to-peer networking is to try to keep things as simple as possible).

Samba weakens the Linux security by allowing you to set up a guest account. The guest account is automatically mapped to when one of the Windows peers in the workgroup attempts to access a shared folder on the Linux computer but doesn't provide an appropriate password (because there hasn't been a user account established for the Windows user on the Linux machine). Figure 6.17 shows the Samba screen where the security settings for connections and the guest account is specified (in this case nobody, meaning anyone trying to connect will be considered a guest).

Figure 6.17. Windows users accessing resources on the Linux box are automatically mapped to a guest account.

Shares are also created using SWAT. Directories on the Linux computer are mapped to a share name. This is done using the Shares screen (accessed by clicking Shares in the Web browser window). The Shares screen also allows you to set security options related to a particular share by specifying that the share is read or write. Access to specific hosts in the workgroup can also be allowed or denied using this screen.

Once Samba is completely configured using the SWAT interface (SWAT provides easy access to help files for configuring SAMBA) and the smbd and nmbd services are started using the Status screen of the SWAT utility, the Linux computer is ready to participate in the Windows workgroup. In the next section we look at accessing workgroup resources from Windows and Linux computers.

Note

All the aspects of using and configuring Samba would fill an entire book; in fact it has. For a detailed looking at configuring and using Samba check out Sams Teach Yourself Samba in 24 Hours by Gerald Carter.

Note

If you are logged on to the Linux computer as a "regular" user you will have to supply the "root" username and the root password to access SWAT. The root password is required when you configure the various services in Linux.


Accessing Windows Workgroup Shares

Accessing shares in a workgroup is very straightforward. In Windows you can browse for other computers in a workgroup using the Network Neighborhood or the My Network Places window (depending on the version of Windows you are using). Figure 6.18 shows the workgroup computers available to a workgroup member computer running Windows XP. Note that there are Windows peers in the workgroup and a Linux peer running Lycoris Desktop (and using Samba as a way to connect to the workgroup).

Figure 6.18. Windows peers can browse the workgroup for member computers.

To view the shared folders and printers that are provided by a workgroup peer computer, double-click on that computer. You can then access the files in the shared folders or connect to a printer provided by a workgroup member.

Linux computers also provide different methods for browsing the network. Lycoris Desktop uses the Konqueror Network Browser as shown in Figure 6.19. Note that the Lycoris computer (Icarus) is in a Windows workgroup that contains a Windows-based computer named Xena.

Figure 6.19. Linux desktop navigation tools such as the Konqueror Network Browser can be used to access the computers in the Windows workgroup.

Tip

The Linux distribution Lycoris Desktop makes file sharing easier than other Linux distributions. You can open a Properties dialog box for a folder using the Konqueror file browsing tool (from the Lycoris desktop). The Properties dialog box provides a Sharing tab that allows you to share the folder (it is similar to how a folder is shared on a Windows computer). Of all the Linux distributions currently available, Lycoris is one of the few that is ready to participate in a Windows workgroup right after it is installed on a computer.


A Final Word on Peer-to-Peer Networking

Peer-to-peer networking is a pretty cost-effective way to hook up a few computers and share resources such as printers and files. What's more, there are products that allow you to connect computers running different operating systems together into the same peer environment. For example, we've already discussed Samba as a possibility for including Linux computers in a Windows workgroup.

Remember, however, that peer networks are meant to be kept small before you start to develop grandiose plans for connecting a number of different operating systems into some giant peer-to-peer network. If you have more than 5 to 10 clients, network performance will suffer greatly, as will individual computer performance, as all those peers begin to access resources on the various computers.

Therefore, if you find you need to connect computers running various operating systems and think your network might grow in the future, you're better off buying a server and a network operating system that will support the different client types and provide you with the ability to centrally manage the network.

Tip

In Windows you can quickly map a drive to a network resource such as a shared folder. This allows you to reattach to the resource when your computer is rebooted. Right-click on any shared folder and select Map Network Drive from the shortcut menu. The Map Network Drive dialog box will open. Specify a drive letter for the shared folder (or go with the default) and then click Finish. The mapped drive will appear in Windows Explorer and the My Computer window when you open them.

The Absolute Minimum

In this chapter we sorted out the possibilities for peer-to-peer networking and looked at configuring LAN protocols for our peer network. Peer-to-peer networking works best in situations where there are less than 10 computers. Other things that you learned in this chapter include the following:

  • Protocols such as TCP/IP and NWlink can be used to connect Windows peer computers.

  • Windows workgroups identify the peer members by their computer names.

  • Windows drives and folders can be shared by right-clicking the resource in Windows Explorer and selecting Sharing and Security from the shortcut menu. Windows printers can also be shared in a similar fashion.

  • Linux computers can be configured with Samba so that they can be part of a Windows workgroup.


Chapter 7. Network Operating System Overview

In this chapter

  • Introducing network operating systems

  • Choosing a network operating system

  • Understanding how client computers communicate with the server

  • Matching client and server LAN protocols

  • Understanding client and server licensing

  • Sharing volumes and folders

  • Providing printing on the network

This chapter provides an overview of the network operating system or NOS. The NOS runs on a network server and as you know from Chapter 2 ("Different Needs, Different Networks"), server-based networking provides centralized control of networking resources, such as files and printers. User access to the network is also centrally controlled on server-based networks.

It is actually the network operating system running on the server that supplies the network administrator with the ability to centrally control network resources and network users. Let's take a closer look at what an NOS is, and then we can discuss some of the issues related to running a NOS such as licensing and server and client configuration.


What Is an NOS?

A network operating system is software that imparts special capabilities to a computer. These capabilities revolve around the fact that the configuration of the computer with an NOS makes that computer a server (a server being a computer that can "serve up" resources to computers requesting them). The NOS, in effect, makes the server the control center for all requests made by client computers as they attempt to access resources on the LAN.

Network operating systems have changed a great deal in the last 15 years. Early NOS platforms were basically designed to supply file and print services to users. This meant that deploying other server types, such as Web servers and application servers, meant you had to place a number of single-service servers on the network.

NOS software has become much more sophisticated and now supplies multiple services—one server might supply remote access and Web services and even serve as a router between two different IP subnets on a network. The NOS interface has also become somewhat more network administrator friendly.

For example, many of the NOS platforms now available, such as Microsoft Windows Server 2003 and Novell NetWare 6x, provide a number of additional services over and above file and print services. These services include remote access and Web site management, and also provide you with the ability to supply network services such as DHCP and DNS. The NOS utilities used to manage the servers also provide a graphical user interface (GUI) rather than a command-line format (although the command-line is still available for those who wish to use it), making it easier to configure and monitor the network.

Many NOS platforms also now provide utilities for monitoring server hardware resources and network traffic. In the past, having any decent monitoring capabilities meant you had to buy additional monitoring software. We discuss the use of these types of utilities in Chapter 19, "Network Troubleshooting".

Therefore, it is the NOS that ties computers and peripherals into a LAN by creating a server computer, which provides the communications center for the network. Let's take a closer look at how the operating system on a network client computer talks to the NOS on the network server.


Client and NOS Interaction

If the NOS makes a computer a server, what makes a computer a network client? For communication to take place between a network client and the network server, client computers must also be outfitted with software that "tunes" them to the network. This software is aptly called network client software.

When a standalone computer accesses a file on the local hard drive or prints to a directly connected local printer, this request for service goes to the computer's processor. The processor then makes this request a reality and either opens the specified file or sends a print job to the printer. All this activity is managed locally.

So, how do computers that are designed to access resources locally suddenly become able to access shares on a file server or print to a remote printer on a print server? The network client software that is installed on the client computer actually performs a little "bait and switch" operation that makes the computer think the network resource is still just a local resource.

This process is handled by a part of the network client software called the redirector. The redirector intercepts any requests made on the computer, such as a request to open a particular file or to print to a printer. If the redirector finds that the user wants to access a remote file on a server or print to a network printer, the request is forwarded to the network server. If the request is for the access of a local file (on the computer's hard drive), the redirector allows the request to proceed to the computer's processor so that the request can be processed locally.

The redirector can also forward requests from a client machine to servers that supply resources, such as network shares (or shared folders, which are discussed in the next chapter), or servers that supply print services (on small or medium-size networks, this might be handled by just one network server). Requests made on the client computer for remote resources are handled by the network operating system on the server.

Figure 7.1 supplies a diagram of how the redirector directs requests to either the local processor or the network server. The client computer is fooled by the redirector into thinking that all the resources it accesses (whether local or remote) are local.

Figure 7.1. The redirector on the client computer determines how requests for services should be routed.

Configuring Network Clients

For a computer to log on to a particular network type, it must be configured with the appropriate network client software. Microsoft Windows provides the necessary clients for both networking on a Microsoft network and a NetWare network. Figure 7.2 shows the Connection Properties dialog box for a computer running Windows XP Professional. Notice that both the Novell Client for Windows and the Client for Microsoft Networks have been installed on this computer.

Figure 7.2. Network client software allows a client to communicate with the network server.

It is not only necessary to have the correct client running on the computer, but it is also a good idea to keep the client up to date. For example, although Windows provides a Novell client (from Microsoft), a more recent client will probably be available on the Novell NetWare site. It can then be downloaded and installed on your network clients.

Client software provided by an NOS vendor such as Novell will also often include utilities that make it easier for the client to navigate the network and network resources. For example, the Novell client (at least the latest when this book was being written) provides the NetWare Connections utility, which allows a user on a client computer to check connections to various servers on the network. The Network Connections utility, shown in Figure 7.3, is launched by right-clicking the NetWare Services icon in the system tray. This icon is placed there when you install the NetWare client software on a Windows-based computer.

Figure 7.3. Network client software will often include utilities that make it easier for users to view and access network resources.

Note

Although this probably goes without saying, computers that serve as network clients must also be configured with network interface cards and the appropriate software drivers for the NICs. Such a computer must then be physically attached to the network using cabling or some other media access strategy.

Configuring Client Computers with LAN Protocols

The network client computers must also be configured with at least one of the network protocols supported by the network server. If you are running a TCP/IP network, both the server and the network clients must be configured for TCP/IP. If you are running clients in a mixed network environment, where resource servers may be running different network operating systems (such as Windows 2000 Server and NetWare, which is discussed in the next chapter), the clients must be configured with all the necessary protocols.

Configuring LAN protocols on a Windows-based client is very straightforward. For example, protocols are added on a Windows XP client from the network connection Properties dialog box. You click the Install button and the Select Network Component Type dialog box opens (see Figure 7.4). You then select Protocol to see a listing of available protocols that can be added to the computer's configuration.

Figure 7.4. You can add protocols to the client's configuration.

Once a client computer has been configured with the appropriate network client and with the needed LAN protocols, that client computer can be connected to the network. All a user will have to do is turn on the computer and then provide an appropriate username and password to log on to the network.


Configuring a Server with an NOS

Although we digressed for a moment to discuss network clients and how they communicate with the network server, we can now get back to our discussion of the NOS. Configuring a computer that will be a network server with a particular NOS is now easier than ever. Veteran network administrators love to recount the days when they were knee deep in NOS installation disks and had to wage a bare-knuckle battle at the command line to get a network server up and running.

As with all software now available, network operating systems ship on CD-ROMs (although the day when software ships on DVDs is not that far away, since a DVD can hold more than a CD). Nearly all of them provide straightforward installation programs, many of them GUIs, that walk you through the steps of configuring the NOS and the services that it will provide on the network.

Chapters 8, 9, and 10 look at NetWare 6x, Microsoft Windows Server 2003, and Red Hat Linux, respectively. You will see in these upcoming chapters, which each cover a different NOS, that installing the NOS is very straightforward and takes place mainly in a GUI environment.

Before you actually install the NOS on a computer system, however, you should determine two things: the server's hardware configuration and the client licensing method you will use on your network. These two issues should actually be figured out even before you buy the NOS software. So, let's back up a moment and take a look at these two important aspects of deploying a server on your network.

Note

Network clients can also be added to a computer's configuration using the Select Network Component Type dialog box. Select Client (rather than Protocol) to see a list of available clients.

Server Hardware Configuration

An important part of your "preinstallation research" involves compiling the specifications for your server's hardware configuration so that it will perform correctly when set up with a particular NOS. I'm sure you will agree when I say that the World Wide Web is a great resource. It provides you with a way to quickly research the hardware needs of a particular NOS without even leaving your chair.

All NOS vendors provide a hardware compatibility list. This list lets you know the different hardware devices—everything from NICs to hard drive controller cards—that have been tested and found to be compatible with the network operating system you are going to install. Hardware compatibly lists can be found on the NOS vendors' Web sites. Some NOS vendors also supply utilities that allow you to check a system's compatibly for a particular server platform. For example, the Microsoft Windows Server 2003 installation CD provides a utility that can not only determine the hardware devices that are compatible with the NOS but also the software. The Windows Server 2003 compatibility page is shown in Figure 7.5.

Figure 7.5. NOS vendors supply hardware compatibility lists and utilities that allow you to check the configuration of your server in relation to the needs of the NOS.

Not only do you need to configure your server with hardware that is compatible with the NOS, the server must have enough muscle to actually run the NOS in a production environment (meaning a LAN with users, resources, and running services). Each NOS vendor provides a listing of hardware requirements to run its NOS. For example, Windows Server 2003 requires a minimum of a 133MHz CPU, 128MB of RAM, and at least 1.5GB of free disk space. Be advised these are the minimums; Microsoft recommends that you use at least 256MB of RAM and a CPU of at least 500MHz.

The base hardware configuration for a particular NOS can be found on that particular company's Web site. We discuss hardware configuration for the NetWare, Windows Server 2003 and Red Hat Linux server platforms in Chapters 8, 9, and 10, respectively.

Keep in mind when working with a NOS that the basic hardware configurations provided by the vendor really only supply just enough muscle to run the NOS on the server. The amount of additional RAM or disk space (or even the number of processors) that you configure your server with will also be dictated by the type of services you provide your users and the number of users on the network. For example, if you are running both file and print services on the same server, you might need to boost the memory or processor speed to handle all the user request calls placed on the server's processor.

Note

Many NOS vendors will also supply white papers and case studies that can help you determine your server's hardware configuration for your particular network situation. Definitely do your research before finalizing the hardware configuration for your server or servers.

NOS Licensing

Once you have the server hardware issues figured out, you need to determine a licensing strategy for the network. Typically, a NOS will require that you have a server license for your server (a separate license for each server) and client licenses for your network clients. For example, you can buy a Novell NetWare 6x base package that licenses the server and five client connections. To license more clients, you buy what is called a connection additive license. These additive client licenses range from the addition of 5 users to 500 users. NetWare licensing is discussed in terms of installing licenses in Chapter 8,"Networking with Novell NetWare 6.5." Additional information related to licensing NetWare is available at Novell's Licensing site at http://www.novell.com/licensing/price.html.

Microsoft Windows Server 2003 licensing is similar to NetWare's licensing in that you need to license both your servers and your clients. Just because you buy a copy of Windows Server 2003 doesn't mean you can install the software on 50 different computers. Windows Server 2003 actually provides you with two different possibilities for licensing network clients: Per Seat and Per Server.

Per Seat means that you will purchase a license for each network user on the network. Each of these users can connect to any and all the servers on the network. Per Server means that you are licensed for a certain number of concurrent connections to the server. If you have 50 licenses, 50 clients can connect to the server.

All network operating systems supply you with some type of utility that you use to add server or client licenses to the network. Microsoft Windows Server 2003, for example, provides the Licensing snap-in, which allows you to add licenses to the network. Figure 7.6 shows the Windows Licensing snap-in. This snap-in is used to record client and server licenses that are in use on the network.

Figure 7.6. The Windows Licensing snap-in allows you to record client and server licenses for your network.

Licensing network server and client software is an extremely important part of a network administrator's job. It's important to have the appropriate licenses for all the software running on the corporate network. The legal ramifications of not having the appropriate licenses and getting caught are not pretty at all. Software licensing should be a key part of your overall network plan. Using pirated or unlicensed copies of software is greatly frowned upon in the computer technology world.

Tip

Microsoft's two different licensing options can be a little confusing. Per Seat is probably the best licensing strategy for large networks, especially if network resources are spread across a number of Windows servers. Per Server is the best choice when you have a small network consisting of only one server. It also works best for networks when only part of your client base is connected to the server at any one time.

Installing a NOS

Once you've have the server hardware ready to go and have sorted out how you will license your server and clients, you are ready to actually install the NOS on the server computer. As already mentioned, most network operating systems ship on CD-ROMs. Most NOS packages also include some sort of boot disk or provide a utility on the CD-ROM that makes it easy for you to create a set of installation disks.

You can use the boot disk or installation disks to configure partitions on the server's hard drive or hard drives and also load the appropriate drivers so that the NOS installation files can be accessed from the CD-ROM drive. You can also forgo using floppy disks at all and configure the computer's CMOS so that you can boot from the CD-ROM drive. The CD-ROM, then, supplies you with the appropriate setup mechanism for selecting and configuring the hard drive on which you will install the NOS.

Although installing each of the different network operating systems (and there are a bunch) will certainly be a unique experience (we look at NetWare, Windows Server 2003, and Linux installations in Chapters 8, 9, and 10, respectively), there are certain tasks you must perform to get an NOS up and running that are consistent across the different types of network operating systems. Installing an NOS and configuring a server typically require the following tasks:

  • Drive partitioning and formatting. A drive must be partitioned and formatted so that it can serve as the resting place for the NOS itself. Depending on the NOS, you might need to configure other drives on the server.

  • Server naming. The server must be given a unique name during the installation process. The ability to access a server by its friendly name is ingrained in just about every NOS. Each NOS will have its own set of conventions for naming the server.

  • Network naming. The network itself must be identified during the server installation. For example, in the case of a Windows server, the domain (which is basically the network) is given a name. On a NetWare network, you name the network tree, which again is basically the network.

  • LAN protocol installation and configuration. The LAN protocols that will be used for network communication must be installed on the server. Most network operating systems now use TCP/IP as their default network protocol. If you want to use other protocols, such as IPX/SPX and NetBEUI, you can designate that they be included in the server's configuration during the installation process. Configuring LAN protocols such as TCP/IP, where you must provide the IP address and subnet mask for the server, will also be part of the server installation process.

  • Network services selection. The different services that will be supplied by the server must be designated during the installation process. All network servers will offer file and print services by default, but if you also want the server to provide Web services or other services, such as Remote Access Service, you have to designate this during the NOS installation.

  • Licensing. The licensing for the server and clients must be configured on the server. Although licensing parameters can be configured once the server is up and running, each NOS will provide you with the option of configuring server and client licensing during the NOS installation. Clients will not be able to communicate with the server until you let the server know that these clients are licensed.

  • Setting the administrator's password. Regardless of whether the administrator's account is called Administrator, root, or Admin, you must set the password for this administrative account during the NOS installation. Because this account controls the server and the network, you need to select a password that will keep the server secure. Most folks who have done any reading about network operating systems know that the NetWare administrative account is called Admin. Therefore, don't pick a password that can be easily guessed.

  • Peripheral installation. Depending on the NOS, peripheral devices such as modems, printers, and other devices can be configured during the NOS installation.

Although the order of these different NOS installation duties will vary from NOS to NOS, you can see that information such as server and network names and even LAN addressing issues pop up during the installation of the NOS. This means that you hopefully had all this information available during the NOS installation because of the network plan that you put together. How servers will be named and the IP addresses assigned to these servers should have been all mapped out long before you sat down to actually install the NOS on the server computers.

Tip

The CMOS is actually the microchip memory that holds the Basic Input/Output System (BIOS) settings for your computer. These settings include the boot sequence for the drives on the computer as well as a number of other settings. The BIOS utility that allows you to control these settings is typically reached by pressing a key such as the Delete key or the F1 key during the first few seconds of the system's boot sequence. Each computer manufacturer supplies a slightly different BIOS utility. Most are menu driven and some even allow you to use the mouse to navigate the various settings. In most cases, some sort of documentation related to the BIOS will come with a new computer. Another source of information on the BIOS utility is typically the computer manufacturer's Web site.


Sharing Folders and Directories

The actual mechanics of sharing files on the LAN will differ depending on the NOS you are using on your network. But one common factor for server-based networks is that they require a user who has administrative rights to share a folder (or directory, as it is referred to on a NetWare network) on a network server. Depending on the size of the network, there may only be one user—you the administrator—who has the ability to create shared folders on network servers (which differs greatly from a peer-to-peer networking environment, where users can create shares on their computers as they see fit).

Shared volumes or folders on a network server as often referred to as shares. A network share is a volume or folder on a server that is made available to users on the network.

The level of access that a user on the network has to a network share will depend on the rights that are given to a user in relation to that share. User access rights can be assigned by user or more appropriately by group. A group is a logical administrative and security container. Security rights and access levels to objects on the network, such as shares, can be assigned to groups. This means that any user who is made a member of a particular group will also be supplied the same rights and access levels that have been assigned to the group. More about groups and security issues are discussed in Chapter 20, "A Network Security Primer".

As already mentioned, how shared directories and folders are actually created will depend on the NOS you are using. For more about the particulars of sharing resources in the NetWare, Windows Server 2003, and Linux environments see Chapters 8, 9, and 10, respectively.


How Network Printing Works

Printing has an interesting place in the seemingly long history of PC networking (although it has only been a little more than 20 years); the ability to share printers, along with file sharing, was one of the key reasons personal computers were networked in the first place. A shared printer on a network is a printer that accepts print jobs from more than one computer.

When you connect a printer to a server on the network and configure it to share print resources with users on the network, it is referred to as a print server. Different terms are also often used to designate where the printer is actually located on the network.

A local printer is a printer that is directly attached to a server. The printer is only local, however, in relation to the server that it is attached to. This server will, obviously, serve as the print server for the printer.

A remote printer is a printer attached to a computer other than your server, which can be pretty confusing because the computer that the printer is attached to would consider the printer local. Whether a printer is local or remote will depend on which computer on the network you are using as your reference point.

A third type of network printer also exists: the direct connect printer. A direct connect printer is a printer that contains its own network interface, processor, and memory for print serving. These printers are typically attached directly to a network hub or switch using twisted-pair cable, just like any computer on the network.

Printers without direct connection hardware can be attached to devices (made by a number of vendors), such as the Hewlett-Packard JetDirect external print server, and then connected directly to the network. The external print server provides at least one parallel port for connecting the printer and a CAT 5 Ethernet port for connection to the network hub.

Now that we know the different categories of printers that can be found on the network, we can discuss how network printing actually works. When a user prints a document from a network client using application software to a network printer, the redirector on the client machine sends the data out onto the network to the print server computer that controls the particular network printer.

The print server uses software called a print spooler to accept the print job and place this job in its print queue, which is just some of the computer's memory used to hold print jobs until they can be sent to the printer. When the printer is free to accept the print job, it is released from the print queue.

As with creating shares on the network, how printers and print servers are configured for network printing will vary depending on the NOS you are using. Check out Chapters 8, 9, and 10 for information on how to provide printing in the NetWare, Windows Server 2003, and the Linux environments, respectively.

Note

Several printers can be configured to be part of a printer pool, which is basically a group of printers (identical printers that use the same driver software) that is seen by the network as just one printer. Because multiple printers actually make up the one print resource, you have a lot more muscle when it comes to handling a huge influx of print jobs from network users. The various print jobs will be parsed out to the printers in the pool as the printers become available.

The Absolute Minimum

This chapter provided an overview of network operating systems. We discussed how servers and clients communicate related to shared folders and printers and we discussed some of the issues of running a NOS on the network.

  • A network operating system, or NOS, is software that allows a computer to "serve up" resources to network clients. The NOS also provides the central access point for a network and requires users to log on.

  • Calls for resources on the network are handled by the redirector, which is part of the client software. It actually fools the client into thinking that remote shares and printers are actually connected locally.

  • Each NOS product has been tested on a variety of hardware. Hardware that works with the NOS will be found on the network operating system's hardware compatibility list.

  • A network share is a drive or folder on a server that is made available to network users.

  • Printers can be shared on the network. This shared resource is managed by a print server. Print jobs sent to network printers are accepted by the print spooler software and placed in the print server's print queue.


Chapter 8. Networking with Novell NetWare 6.5

In this chapter

  • Installing NetWare

  • Understanding the NetWare network hierarchy

  • Using the NetWare management tools

  • Working with NetWare volumes and sharing files and printers

  • Creating user accounts and groups

  • Configuring network clients

  • NetWare DNS and DHCP

In Chapter 7 we took a look at some of the basics related to network operating systems. An overview was provided of what network operating systems do. In this chapter we look at the most recent version of NetWare, NetWare 6.5 (the most recent as of writing this book; I in fact had the pleasure of working with the NetWare 6.5 beta).

Like other network operating systems, Novell NetWare supplies you with the ability to set up file servers and print servers. Specialty servers providing services such as DNS, DHCP, and Web services can also be configured (NetWare 6.5 actually uses Apache2 as its Web server).

While one chapter cannot possibly do more than scratch the surface related to the body of information that is required to administer a network operating system such as NetWare, we can look at how NetWare arranges users and other objects in a logical hierarchy and look at some of the tools that are used to configure and administer a NetWare server.


NetWare and Networking

Novell has actually been a player in the computing industry since 1979. Originally Novell Data Systems, the company became known as Novell, Inc. in 1983. This was also the year that Novell released the first version of NetWare.

Although the first version of NetWare only ran on a Novell proprietary PC using a Motorola 68000 processor, Novell quickly saw the advantage of supplying a multiplatform NOS. In 1989, Novell marketed a version of its NetWare NOS that actually provided for the sharing of data and printers among IBM/compatibles, Apple Macintoshes, and Unix-based computers.

NetWare provides an excellent example of a client/server networking environment. Clients must be configured with NetWare client software to communicate with the NetWare server.

Novell NetWare has gone through a number of different versions. In version 3.0, released in 1989, support was added for 386 processors, allowing NetWare to run in 32-bit mode. One of the most important updates of NetWare was version 4.0, released in 1993, which provided the first version of the Novell Directory Services (NDS), a hierarchical database used to manage network objects, such as users and network resources (NDS preceded Microsoft's Active Directory by seven years).

NetWare has continued to evolve as a NOS platform. The NetWare 5 versions have given way to NetWare 6. NetWare 6 (and the upcoming 6.5) provides a number of enhancements. Features such as iFolder and iPrint have been added to NetWare's capabilities to make it easy for users to access NetWare services such as shared folders and printers via the Internet. NetWare 6 also has made some enhancements to the Novell Directory Services structure of NetWare networks. NDS is now called eDirectory. We will discuss the new NetWare eDirectory in more detail in the next section of this chapter.

NetWare provides a complete networking environment. It includes services such as DHCP and DNS and also provides you with Web server capabilities using the Apache2 Web server. Any service that you can deploy in Microsoft Windows Server 2003, Unix, or Linux, can also be deployed in the NetWare environment (such as FTP, remote access, and so on). We will discuss NetWare DHCP and DNS later in the chapter.

Note

The original version of NetWare was designated NetWare 4.0. In 1985, Novell released a new version of NetWare called Advanced NetWare and set the version number to 1.0. All subsequent versions, such as Novell NetWare 5 and 6, are the offspring of the 1985 1.0 release.


The Netware Network Structure

Versions of NetWare prior to the release of 4.0 used a flat database structure called the bindery to manage users, server volumes, and resources on the network. Each NetWare server had its own bindery (not unlike a Windows NT domain), making it more difficult for users to access resources on different network servers. As already mentioned, with the release of version 4.0, a hierarchical database called the Novell Directory Services (NDS) provided a tree structure that allowed for the integration of all network resources and objects into one branching structure.

Versions 4 and 5 of NetWare embraced NDS. With the release of NetWare 6, Novell has upgraded the directory service to the eDirectory; eDirectory is similar to NDS in that a branching hierarchy is used to hold objects that make up the network entities. Network trees, servers, users, groups, and other objects reside in this branching structure.

The eDirectory consists of a database, which identifies objects in the database through the use of a schema (which is really just a scheme for differentiating between objects such as servers and users; Figure 8.1 shows a lists of object definitions in the Schema Manager). The eDirectory is synchronized among the different branches in the eDirectory tree, making it easy to find resources anywhere on the network.

Figure 8.1. The schema is the defining element for the objects that can exist in the network hierarchy.

The eDirectory tree has a root, which is created when you configure the first NetWare server for the network. Additional servers, providing additional resources, can be added to the eDirectory tree as branches. Figure 8.2 shows the eDirectory tree for a NetWare network as seen in the ConsoleOne management tool.

Figure 8.2. The eDirectory tree holds the objects that make up the network.

When you create the root of the eDirectory tree, you must supply a name for the tree (in this example, the tree is called popeye). You must also create a context for the network tree when you create the root. The context describes the position of an object within the eDirectory tree. The context for the tree in Figure 8.1 is "habraken." The context of the tree might typically be specified by the name of your company. We will discuss the creation of the root in the next section of this chapter.

Note

Hierarchical network management structures such as eDirectory provide you with a highly scalable network (meaning it can easily be expanded in terms of new users, new services, and even additional locations). New containers or objects can easily be added to the eDirectory tree.


Installing NetWare

The current version of Novell's NOS (in beta testing as of this book's writing) is NetWare 6.5. Here is the base (minimum) hardware configuration for NetWare 6.5:

  • Processor: Pentium II or higher (a Pentium III running in excess of 700MHz recommended).

  • RAM: 512MB (running multiple services on a single server such as Apache and DNS will require more memory).

  • Video Adapter: A SVGA display adapter.

  • Hard drive: DOS partition of at least 200MB, with at least 200MB of available space. Also 2GB of available, unpartitioned disk space outside the DOS partition for sys volume.

  • CD-ROM drive: A bootable CD-ROM drive supporting the El Torito specification.

  • Network Interface Card: At least one NIC.

As with any NOS, you will want to configure your NetWare server or servers with the appropriate hardware to get the job done. It makes no sense to set up servers with marginal hardware configurations and then have them end up being performance bottlenecks once the network is up and running. For more about server hardware see "Network Server Considerations," in Chapter 3, "Networking Hardware".

For purposes of illustration, we will take a look at a clean install of NetWare 6.5 in this chapter. This means that no previous NOS was installed on the server. You can also update previous installations of NetWare with a newer version (such as 6 or 6.5). Upgrading a previous version of NetWare such as 5x to 6x requires that you upgrade client operating systems and the NDS database to eDirectory specifications (eDirectory is discussed in a moment). See www.novell.com for information on upgrading NetWare on an existing server. Tools such as the NetWare Deployment Manager can be used to back up existing servers, update network clients, and upgrade servers.

To do a clean install of NetWare you must configure and format a DOS partition on the boot drive of the computer. This DOS partition is used to boot the system and to load the NetWare files.

You can create and format the partition by booting to the NetWare Installation CD and following the prompts. Or you can configure the required partition yourself (before the NetWare installation) by using DOS 3.3 or later (if you still have a set of DOS disks lying around). DRDOS ships with NetWare and tools such as fdisk and the format command are available on the NetWare 6 installation CD. For more background information on DOS and fdisk see Chapter 18, "Protecting Network Data".

As already mentioned, you can create the Primary DOS partition on your server and make it the active partition using fdisk (from your own DOS disks or the DRDOS directory on the NetWare CD). You can then format the new partition using the DOS command format c:/s. The /s switch places the boot files on the new formatted partition.

Whether you create the boot partition by booting to the NetWare Installation CD or create it yourself, the rest of the NetWare installation is very straightforward. It is really no different than the step by step installation of other server products such as Windows Server 2003 or Red Hat Linux. You are basically walked through the entire installation process. The NetWare installation goes through two different phases: a DOS phase and then a GUI phase. Let's look at some of the high points of each of these installation phases with the understanding that the different selections that would actually be made during a NetWare installation would depend on the specifics of the network that you are creating.

Note

El Torito is a specification for bootable CD-ROM drives created by Phoenix Technologies and IBM. A CD drive that complies with the specifications allows you to boot from a CD-ROM. You can actually boot from the NetWare installation CD if you have the appropriate CD drive on the server.

Note

Do not use Windows 9x or Me Startup disks to create the partition and format it for a NetWare installation. These disks (which are made as emergency startup disks when you install Windows) do not have the correct version of DOS on them, even though they do contain the fdisk and format commands, and are not going to work properly with your NetWare installation.

NetWare Installation: DOS Phase

When you boot to the NetWare installation CD, DRDOS 7.02 is loaded. You are then provided with several choices related to the NetWare installation. To begin the installation press I as shown in Figure 8.3. You must then specify how the installation program searches for a CD-ROM driver. You can have the search conducted automatically by pressing A, or choose to conduct the search for only IDE (I) or SCSI (S) drivers.

Figure 8.3. The DOS portion of the installation begins with the loading of DRDOS and the search for CD drivers.

After the CD driver is found, you are provided with the opportunity to have the installation batch (installation.bat) file started automatically by pressing A. This begins the installation of the NetWare NOS in earnest. Different NetWare files will be loaded and then a Regional Settings screen will appear. On this screen you are to provide the country and keyboard settings if necessary (they are detected). Highlight Continue with the arrow keys and then press Enter to continue.

On the next screen you are asked to accept the licensing agreement by pressing the F10 key. You can then select either an Express or a Custom Install of the NetWare software. Once you have made your selections, highlight Continue with the arrow keys and then press Enter to continue. This concludes the DOS portion of the installation and the appropriate NetWare software files are copied to the hard drive of the server.

Note

The Netware 6.5 server installation requires two CDs: the NetWare 6.5 CD 1 (Operating System) and the NetWare 6.5 CD 2 (Products).

Note

Bat or batch files are a method of firing off a series of DOS settings and commands. A bat file is just a text file that lists the commands and settings that are to be run when the bat file is initiated.

NetWare Installation: GUI Phase

The next phase of the NetWare installation uses a GUI and a series of screens that require you to select the overall configuration of the server and the different services that will be added to the server installation (such as Web server and DNS server).

The first screen of the GUI installation phase provides you with the option of configuring a customized server, a basic file server, or a special preconfigured server such as a DNS/DHCP server or a backup server. If you choose to create a customized server you can add components such as the Apache2 Web server, the NetWare FTP Server, the Novell DNS/DHCP services, and other specialized server components.

After making your selections, a list of products to be installed will be listed. Clicking Install Files will begin the process of copying the various files to the server. After the files have been copied, you will be asked to provide a cryptography module that is stored on the Installation CD. After supplying the path to the module, you can continue the installation by clicking Next.

On the next screen you are asked to supply the IP address for the server and also have the option of enabling the IPX/SPX network protocol (for more about protocols see Chapter 6). The next screen also asks for information related to the IP network such as the hostname and domain of the server and also the IP address of name servers (DNS servers) on the network.

Other than providing the IP settings for the server, the other important aspects of the GUI phase of the NetWare server relate to the creation of the eDirectory root and the installation of licenses. When you create the new tree root for the eDirectory, you are asked to supply a tree name and the admin name and password for the administrator of the tree (admin is the default name). You are also asked to supply a server name and the tree context.

After configuring the root, you are asked to install licenses for the clients on your networks. NetWare 6x uses two different types of licensing: server connection license and user access license.

The server connection license (SCL) provides the user with access to network resources and services based on the server they log on to. This server-centric approach means that a user would need a license for every server that hosted a service. The user access license (UAL) provides each user with a license that allows them to access any service anywhere on the network. This user-centric licensing scheme makes much more sense on large networks.

The licenses for the installation will be on the installation CDs or a supplemental CD or disk provided by Novell. Once the licensing modules have been provided (it is a file with the NLF extension) the installation of the server software is complete and the system will reboot.

Note

With TCP/IP serving as the de facto protocol for LANs and WANs, understanding different IP settings is very important to configure a NOS. See Chapter 12, "TCP/IP Network Administration," for more information related to IP addressing, DNS, and DHCP.


Administering a Novell Network

Once the NetWare server software is installed on the server, you have more than one option for administering the server. When the server boots and then loads the NOS, a GUI interface starts on the server that can be used to access the ConsoleOne or the NetWare Remote Manager, which are both management utilities. You also have the option of managing the server from the command line; NetWare servers have historically been managed using a number of different menu-driven utilities that are run on the server. For example, to manage volumes and hard drives you would type nssmu at the Server Console command line, which would start the NSS Management Utility.

You also have the option of remotely administering the server and the network. You can access the NetWare Remote Manager from any client on the network using your Web browser. The NetWare Remote Manager allows you to manage your servers, users, and volumes. With the release of NetWare 6, another management tool, the iManager was also made available. It allows easy access to a greater number of server services and their settings, including DHCP and DNS.

The easiest way to access the NetWare Remote Manager and the iManager (and other Web-based NetWare utilities) is through the use of the NetWare Web Manager. To access the NetWare Web Manager, open your Web browser and type https://server-ip-address:2200 (where server-ip-address would be the actual IP address of your server; you are using a secure socket to access the server; that is why the https is required). When you press Enter, you will be asked to provide the admin password for the server; supply the password and click Login. The NetWare Web Manager will appear, as shown in Figure 8.4. You can access both the Remote Manager and the iManager from the main Web Manager screen.

Figure 8.4. The NetWare Web Manager can be accessed from any Web browser.

To open the Remote Manager, you click the Open Remote Manager link. The Remote Manager will open in its own Web browser window as shown in Figure 8.5.

Figure 8.5. The NetWare Remote Manager can be used to manage volumes and monitor server settings.

The Remote Manager allows you to quickly view the overall health status of your server. Click the Health Monitor link to view the status of the server's components. Figure 8.6 shows the Health Monitor screen. The Health Monitor includes information on processor use, failed logins, available memory, and other information related to server processes.

Figure 8.6. Health Monitor provides a snapshot of the general health of your NetWare server.

Notice in Figure 8.6 that there are Notify check boxes for each of the monitored processes in the Health Monitor. You can check these Notify check boxes for a particular parameter and configure an email address for the notification. Then when the status of that particular process changes (from green to yellow or red), an email notification is sent to the address that you specified.

As already mentioned, the Remote Manager also provides you with the ability to manage volumes, users, and other eDirectory objects. Let's take a look at volumes and folders (or directories as they are often referred to in the NetWare environment) and then we can take a look at users and groups and the Tree Walker utility that provides us access to the eDirectory.

Note

ConsoleOne, which was the successor to the NetWare Administrator program found in earlier versions of NetWare, has all but been replaced itself. The new Remote Manager and iManager are the tools of choice for managing your NetWare servers. In fact, you can no longer use ConsoleOne to manipulate drives and volumes in NetWare 6.5. You must use the mssu utility on the server or the Remote Manager (from the server or remotely from a client).

Tip

You can bypass the Web Manager and open the Remote Manager directly by typing http://server-ip-address:81. This opens the server on an unsecure socket. You will still have to supply the admin name and password to log on to the Remote Manager.


Working with Volumes and Folders

NetWare 6x embraces a new file storage system named Novell Storage Services (NSS). NSS allows an administrator to create and maintain larger volumes than provided by the traditional file system used by earlier versions of NetWare.

In the past an administrator would create a partition on a server drive and then create a volume or volumes on the partition. The volumes would then serve as a repository for data directories and files.

While NetWare 6 still provides you with the ability to create traditional partitions and volumes, the default system is NSS.

In NSS you still use partitions to identify the storage space available on hard drives; however, NSS also provides an additional logical grouping of storage space called the pool. A storage pool is a specific amount of storage space. The pool space can be on one or more drives. The pool can be on a single partition or more than one partition. Once you have created a pool, the pool can then be divided into volumes. In effect, the pool becomes really the same thing as a partition when a pool only resides on one drive.

Let's walk through the creation of a pool and a volume to shed some light on NSS and how it arranges storage space.

  1. In the Remote Manager, click the Partition Disks link under the Manage Server heading. The hard drives, partitions, and volumes will appear in the Remote Manager as shown in Figure 8.7.

    Figure 8.7. View the drives, partitions, and volumes on the server.

  2. To create a new pool, scroll down and locate a drive that contains free space. Then click Create.

  3. The File System Creation Operations screen will open. This screen provides a drop-down list for partition type (the default is Novell Storage Services, NSS) and two command choices: Create a New Pool, and Create a New Pool and Volume. Since we are creating just a pool at this point, click Create a New Pool.

  4. The NSS Pool Create screen appears. This screen (see Figure 8.8) provides the space available on the drive for the new pool. Enter the Pool Size and Pool Name and then click Create.

    Figure 8.8. Create a new pool from available disk space.

  5. You will be asked if you are sure you wish to create the pool; click OK.

You will be returned to the Partition Disks screen (which was shown in Figure 8.7). You can now create a new volume in the pool. Next to the pool name, click the Add a Volume link. The NSS Volume Create screen will appear. Provide a volume name and then the volume attributes as shown in Figure 8.9.

Figure 8.9. Create a volume in a NSS pool.

When you click Create you will be asked if you are sure you want to create the volume; click OK and the volume is added to the pool. You are also returned to the Partition Disks screen. After creating the new NSS volume, make sure to mount it on the Partitions Disks screen. Click the Mount Volume link next to the volume name and then click OK.

If you wish to view the capacity and free space on a volume, click the volume name on the Partition Disks screen. The Volume Information screen will open for that volume. Figure 8.10 shows the information for a new volume.

Figure 8.10. View the free space on a volume.

Creating and Sharing Directories

Volumes that you create (and mount) can then be accessed on the network by your users (and you, the administrator); mounting also allows the volumes to be populated with directories and files. You can add subdirectories (known in the Windows world as folders) directly from the Remote Manager. You can also upload files from the Remote Manager or browse the network as any other user would and add files to the subdirectory using Windows Explorer or the Network Neighborhood tool.

Let's look at adding directories to a volume from the Remote Manager:

  1. In Remote Manager, select Volumes. This will show all the volumes on the server. Click the volume name that you will add the directories to.

  2. The contents of the volume will be shown on the next screen (see Figure 8.11). Click the icon that represents the volume in the Info column of the File listing table (it is the icon that has the name of "." (dot) assigned to it).

    Figure 8.11. View the file listing for the volume.

  3. After you click the volume icon, the entry information for the volume will appear. This screen also shows the effective rights for the volume and provides you with the ability to add trustees for the volume (a trustee would have the same rights to the volume as the administrator, meaning write and modify rights). Scroll down to the bottom of this screen. A Create Subdirectory button and a New Name box (for the subdirectory) are available.

  4. Type a name for the new subdirectory (which will actually be a first level directory in the volume); then click the Create Subdirectory button.

  5. You will be returned to the volume's file listing screen and the new directory will appear in the list. To adjust rights related to the directory, click the directory's icon in the list. The Directory entry information for the directory will appear as shown in Figure 8.12.

    Figure 8.12. You can view the settings related to the new directory.

  6. Click the Inherited Rights Filter settings in the entry information. This opens the rights for the object (the directory) as shown in Figure 8.13. You can change any of the rights as needed by clearing a check box. When you have finished working with the rights, click OK. This returns you to the Directory Entry Information screen.

    Figure 8.13. Set the rights for the directory.

You can create additional subdirectories in any of the directories that you create by following this same set of steps. Files can be added to the directories by you or your users (depending on the purpose of the directory). Figure 8.14 shows the Network Neighborhood window on a NetWare client computer. The user has accessed the volume OHIO, which holds a shared directory named project1. If the user has write privileges to the directory, the user can add files to the directory.

Figure 8.14. Clients can view the network volumes.

Note

Issues related to rights and permissions and protecting network data are discussed in Chapter 20, "A Network Security Primer."

Sharing Printers

Printers can be added to the network using the iManager. NetWare 6x provides both network printing capability and the ability for users to connect to network printers via the Web. Novell's print services are called the Novell Distributed Print Services or NDPS; iPrint is an extension of NDPS, which can transform any NDPS printer into an iPrint enabled printer.

Novell iPrint is installed when you initially install the NetWare server software. Make sure that it is one of your selected products to be installed (without it you can't configure the printers through the iManager).

Adding a printer to the network isn't quite as easy as just clicking on a printer icon and sharing that resource. Since NetWare provides over-the-Web printing through iPrint there are a few hoops you must jump through before you can add a printer to the network.

First you must create a print broker. The broker is actually a transparent entity that provides support services related to printing on the network. You can't provide printing services without at least one broker on the network. For large networks you may want to have multiple brokers.

To create a broker, open the iManager (accessed via the NetWare Web Manager; click the Open Novell iManager 2.0 link). In the iManager window, expand the iPrint Management node. We will have to create a broker, a print service manager, and then a printer to provide printing on the network.

To create the broker, click the Create Broker link (see Figure 8.15). Provide a broker name for the broker (the name is up to you), the container, and an RMS (Resource Management Services) volume for the broker (a place for it to keep service database related files). The volume can be the sys volume on your server. You can browse for the container or the volume that will serve as the RMS volume using the appropriate Object Selector buttons (they look like magnifying glasses). After supplying the appropriate information, click the OK button to create the broker.

Figure 8.15. Create a print broker for the network.

Before we leave the broker, we need to start it. Click the Manage Broker link in the iManager. When the Manage Broker screen appears enter the name of the broker or browse for the broker. Then click OK. Select Startup to start the broker.

After you create and load the broker, you must create a print service manager. This manager controls the server's different printer agents. To create the print service manager, click the Create Print Service Manager in the iManager window. Provide a manager name, the container for the manager, and a volume that will serve as the database volume for the manager (see Figure 8.16).

Figure 8.16. Create a print service manager for the server.

After supplying the information for the print service manager, click OK. The print service manager will be created. You must load the print service manager on the server. Select the Manage Print Service Manager link in the iManager. On the screen that appears, provide the name of your print service manager and then click OK. To start the print service manager, click Startup.

Now, we can add a printer. Select Create Printer from the iPrint Management commands found in the iManager. Type a printer name, and provide the container for the printer and the manager name (which we just created a moment ago) for the printer (see Figure 8.17). After supplying the information, click Next.

Figure 8.17. Supply the name and the manager name for the printer.

On the next screen, supply the IP address of the printer or the DNS hostname for the printer (in the case of a printer connected to a server, supply the server's IP address). Then click Next to continue.

The next screen lists the print drivers that are available for the different Microsoft Windows clients such as XP, 2000, and 9x. Select the appropriate print driver for each of the client operating systems (you can also add print drivers to the print broker by opening the Manage Broker tool and selecting the Resource Management Service tab). After selecting the print drivers, click Next to continue. The new printer will be created. Click OK.

Note

It is impossible for an introductory book such as this to cover any NOS in detail, so we won't spend a lot of time configuring logical drives and working with volumes in more detail. Be advised that NetWare NSS can be used to configure software RAID levels. For more about RAID see Chapter 18, "Protecting Network Data."

Configuring an iPrint Client

Now the printer is installed on the network (and a broker and manager are available to take care of behind the scenes printing issues). But we still have one more step to go. We need to configure our network clients so that they can take advantage of iPrint printers. This means that we will actually set up our connection to the printer via a Web browser.

This procedure can actually be done by your users. All you have to do is to make the printers available on the network and make sure that the users have access control to the printers that they will use. They can connect to the iPrint server (your NetWare server) and install the iPrint client and select a printer.

To connect to the server through a browser, type http://server-IP-address://631/ipp in the browser address box, where server IP address is the IP address of the server. Then press Enter.

When the client connects to the server, you will be notified that you must install the iPrint client software on the computer. Click OK and download and install the software (select Run This Program from Its Current Location to quickly install the software). After installing the client, the computer will need to reboot.

After the system restarts type http://server-IP-address://631/ipp in the browser address box and press Enter. The client will connect to the server and provide a list of available printers (see Figure 8.18).

Figure 8.18. The printers available will be listed.

To connect to a printer, the user merely has to click the name of the printer in the Install list and then click OK when asked if they want to install the printer. The printer will be added to the printers on their Windows operating system and can be accessed via the Printers dialog box.

Note

Creating the different objects that are necessary for printing such as the broker, the print service manager, and the various printers requires a good understanding of the NetWare environment; consider the information provided in this chapter just a starting point as you work with this complex NOS. FYI: printers are managed using the Manage Printer tool provided by the iManager. It allows you to control the printer, set access control to the printer, and add drivers for the printer.


Working with Users and Groups

Managing a NetWare network also requires that you manage your users. User accounts must be created for users and they must be given the appropriate access rights to objects on the network such as directories and printers. A way to manage users who need the same rights and access to the same objects is to use groups, which are really a security container related to the group's interaction with the other objects on the network.

User accounts can be created using the Remote Manager. Let's walk through the creation of a user account:

  1. Scroll down in the Remote Manager window and select the Access Tree Walker link. Two objects will appear in the browser window: your tree's context and name and a security object for the tree.

  2. Since we are creating a user account, click the tree context and name object. This provides a list of objects in the tree object (see Figure 8.19).

    Figure 8.19. Objects in the tree are listed.

  3. To create a new user, click the Create User icon at the top of the objects list. The Create User screen appears (see Figure 8.20).

    Figure 8.20. Provide the information for the new user.

  4. Type a name for the user (also provide the surname) and a password. You must also confirm the password.

  5. After providing the information for the new account, click Create.

The new user account will be added to the object list. You can add additional user accounts as needed.

Groups can also be created from the Tree Walker. At the top of the NDS tree, click the Create Group Object icon. All you have to do is provide the group name and then click the Create Group Object button. The group will be created and added to the object list.

Once the group has been created, you can add users to the group. Find the group in the object list (in the Tree Walker) and click its information icon. The attributes of the group object will appear. At the bottom of the window, click the Add Group Member icon. The Add Group Member window will appear (see Figure 8.21).

Figure 8.21. Provide the name of the user to be added to the group.

Provide the name of the user that you want to add to the group, or browse the eDirectory to find the user. Once you have provided the user's name, click the Add Group Member button. The Group window will reappear showing the group's attributes, including the new member.


Configuring Network Clients

Another aspect of getting your users onto the NetWare network is configuring their client computers for network access. The easiest way to configure NetWare clients is to use the NetWare client software that ships with your server CDs. You can also download updated NetWare clients for the various flavors of Windows from www.novell.com.

Install the NetWare client software on the client computer. It is installed as is any software that is added to your computer's configuration. You will typically have to reboot the system.

When the system reboots, the Novell Clients for Windows logon window will appear as shown in Figure 8.22. On this screen the user must provide a valid user name, the appropriate password, and the tree, context, and server.

Figure 8.22. The NetWare Client window.

Once the user has logged on to the NetWare network, they can browse the network using Network Neighborhood or My Network Places. Different shared directories on the network can also be mapped to logical drives on the client computer. As with any NOS, most of the workings of the network such as file and printer access will be mostly transparent to the user.


NetWare DNS and DHCP

NetWare provides a number of special services such as Web server, FTP server, and application server. NetWare also provides support for both the DNS and DHCP services. This means that your NetWare server can act as a DNS name server. The NetWare server can also serve as a DHCP server providing IP addresses to network clients.

DNS and DHCP are installed as part of the server configuration when you initially setup the NetWare server. Both DNS and DHCP are installation options.

Although we will discuss how DNS and DHCP work in much more detail in Chapter 12, "TCP/IP Network Administration." I did want to mention NetWare's support for DNS and DHCP and the fact that these two services can both be administered using the Novell iManager. Figure 8.23 shows the iManager window with the DHCP Management and DNS Management nodes expanded. The iManager actually makes it very easy to add a DHCP scope (a range of IP addresses) or manage resource records on the DNS server.

Figure 8.23. The iManager provides easy access to DHCP and DNS settings.

We will discuss both DHCP and DNS in general terms in Chapter 12 and in terms more specific to network operating systems such as NetWare.

The Absolute Minimum

In this chapter we took a look at some of the basics related to installing Novell NetWare 6.5 on a network server. We looked at managing volumes and shares on the network and providing network printing. We also looked at creating users and groups.

  • Novell NetWare provides a highly scalable environment for computer networking. The NetWare installation takes the form of two phases: a DOS phase and a GUI phase.

  • NetWare management is accomplished using Web-based tools such as the Remote Manager and the iManager.

  • Volumes and Directories can be managed using the Remote Manager. User accounts and groups can be created using the Tree Walker, which is also accessed via the Remote Manager.

  • Printing is managed using the iManager. Before printers can be added to the network a print broker and a Print Service Manager must be created.

  • Services such as DNS and DHCP can also be configured on NetWare servers. These services are configured using the iManager.


Chapter 9. Networking with Microsoft Windows Server 2003

In this chapter

  • Understanding the Microsoft Networking Model

  • Installing Windows Server 2003

  • Understanding the Active Directory

  • Adding users to a Windows domain

  • Configuring a file server

  • Configuring a printer server

  • Understanding Group Policy

In Chapter 7, "Network Operating System Overview," we took a look at some of the basics related to network operating systems. In Chapter 8, "Networking with Novell NetWare 6.5," we discussed Novell NetWare 6 and the Novell approach to networking and logical LAN structure (the Novell Directory Service). In this chapter we cover Microsoft's latest (as of the writing of the fourth edition of this book) network operating system, Microsoft Windows Server 2003. We look at the installation requirements for Windows Server 2003.

Like Novell Netware, Microsoft Server 2003 offers you the ability to set up file servers and print servers. Specialty servers providing services such as DNS, DHCP, remote access, and Web services can also be configured (as they can in the NetWare environment).

Microsoft dramatically changed the way network administrators plan and configure the logical hierarchy for a network deploying servers running Microsoft network operating systems with the release of Microsoft Windows 2000 Server. The Active Directory provided a tree structure not available in the domain-centric networks provided by earlier versions of the Windows server operating system.

Before discussing the installation of Microsoft Windows Server 2003, we will look at Microsoft's logical network structure. We can then take a look at the hardware requirements for installing Windows Server 2003 and then look at some of the basic server functions, such as user management, sharing files, and supplying print services to clients on the network.


Understanding the Microsoft Networking Model

The Microsoft Networking model embraces the domain as the basic administrative container for the network. A domain is a grouping of computers and other devices that are managed by a Windows domain controller (a domain controller being a server that is the central authority for the domain). The domain maintains its own database directory of user accounts and controls its own resources such as printers and shared files.

While a domain could potentially serve thousand of users, there is often the need to go beyond the limitations provided by a single domain and expand the scale of the network. As already mentioned, the basic unit of the logical Microsoft network structure is the domain. The next largest unit is the tree. A tree is a collection of child domains. The tree itself is defined by a root domain, which serves as the parent domain for the child domains that branch from the domain root. The first domain you create serves as the root of the domain tree. Child domains branch off of root domain as shown in Figure 9.1.

Figure 9.1. A Windows network consists of a domain tree that holds a root and optional child domains.

The largest administrative structure provided by the domain hierarchy is the forest. A forest is a collection of domain trees.

To truly understand how domains interact within trees and forests, you need to understand trust relationships. A trust is an electronic agreement between domains and means that users can log on to their domain but still get at resources in another domain, if that domain "trusts" the user's domain.

When you create child domains within a domain tree, the child domains and the parent domain all are assigned transitive trusts. A transitive trust is a two-way street between the domains. The domains trust each other so that they share each other's resources. This means that all the domains in a tree trust the other domains in tree to use their resources (such as printers, DNS servers, and so on). So, the transitive trust relationships provide a reciprocating resource sharing environment that flows down through the tree.

You create a domain in the Windows server environment by bringing a domain controller online. Domain controllers are created by installing the Active Directory on a server running Windows Server 2003. So, one type of server that you will have to deploy on your network is at least one domain controller. We take a look at some other server roles often found in a Windows domain later in this chapter.


Installing Microsoft Windows Server 2003

Before you install Windows Server 2003 on a computer, particularly in cases where you are creating a new network infrastructure, you should create a map of what your network is going to look like. In particularly, you should outline the servers and other resource devices, such as printers, that will provide your network clients with services.

The role that a particular server will fill on the network should be determined long before you install the network operating system. The server's role, such as a domain controller (domain controllers are discussed later in this chapter) or a file server, will not only dictate the server's hardware configuration, but will also dictate the configuration of that server (and the services that it provides). We discuss server roles later in this chapter. Another important aspect of installing the network operating system is making sure that your server hardware is adequate to run the NOS and is also compatible with the Windows NOS.

Hardware Issues

Windows Server 2003 requires a minimum hardware configuration to run. As with all software—particularly network operating systems—the more you exceed the minimum requirements in areas such as RAM, processor speed, and hard drive space, the faster the server supplies services to network users and the greater the number of roles one server can fill on the network. (For example, a server could be a domain controller and could provide the DNS and DHCP services.)

Microsoft's suggested minimum hardware requirements (and some Microsoft recommendations) for Windows Server 2003 (Standard) are listed here:

  • CPU speed: 133MHz (550MHz recommended)

  • RAM: 128MB (256MB recommended; 4GB maximum on Standard Server)

  • Disk space for setup: 1.5GB

  • CD-ROM drive: 12X

  • Monitor: Super VGA capable of providing 800x600 resolution

Not only must you meet the minimum hardware requirements to successfully install and run Windows Server 2003, but you also must have a server that provides hardware that is proven to be compatible with the network operating system. If you are to use the server in a true production environment where you must supply mission-critical services to network users, your server hardware must come right off the Microsoft Windows Server 2003 Hardware Compatibility List. A copy of the list is available at www.microsoft.com/whdc/hcl/scnet.mspx.

If you plan to upgrade a server that is running Windows NT 4 or Windows 2000 Server, you should run the hardware and software compatibility test provided on the Windows Server 2003 installation CD. This test lets you know if the server is configured with hardware that is not on the Windows Server 2003 Hardware Compatibility List, and it provides a list of any software running on the server that is not compatible with Windows Server 2003.

All you have to do is insert the Installation CD and then select the Check System Compatibility button on the screen that appears. On the next screen you are provided with the ability to have the server's current software (any software additions you are running on a previous version of the Windows NOS) and the server's hardware checked for compatibility. Running this system check will supply you with a list of incompatible hardware and software (if there are any).

Note

In my humble opinion a "decent" hardware configuration for a computer running Windows Server 2003 is a processor in excess of 900MHz, with 512MB of RAM and a SCSI drive array with at least three 20GB drives (server hard drives are discussed in Chapter 3, "Networking Hardware"). Remember that any server hardware configuration must address the capacity that will be required by the services you run on the server.

Performing a Clean Install or an Upgrade

A major consideration related to a Windows Server 2003 installation is whether to upgrade in-place servers or do a clean install on a replacement server that will take over the role of a server or servers already on the network.

It actually requires fewer steps to perform a clean install on a computer that does not have a previous version (NT or 2000) of the Windows Server software installed. You can perform an installation of Windows Server 2003 on a new server (this also allows you to upgrade your server hardware at the same time) by simply booting to the Windows Server 2003 installation CD (the basics of the installation process are discussed in the next section). You can then configure this new server to take the role of domain controller.

Upgrading a Windows 2000 Server installation with Windows Server 2003 requires several other steps before you actually install the Windows Server 2003 software. Upgrading Windows NT servers also requires some preparation work. For example when you upgrade an existing Windows 2000 Server to Windows Server 2003, you are required to prepare the currently existing forest and the domain for the upgrade. The Windows Server 2003 provides a utility called adprep, which is a command-line utility found in the i386\ folder on the Windows Server 2003 CD-ROM.

Whether you are upgrading Windows NT or Windows 2000 Server, you should think through the entire process of upgrading. Preplanning will make sure that you get your network up and running as quickly as possible.

Note

All the ins and outs of creating Windows domains and configuring domain servers are beyond the scope of this book. For more information see Sams Teach Yourself Microsoft Windows Server 2003 in 24 Hours.

The Installation Process

Whether you upgrade or perform a clean installation, the actual process of installing the Windows Server 2003 software on a server is a fairly straightforward process. An installation wizard walks you through the steps of a basic installation. Configuring a server for a specific role is reserved for after the installation of the NOS (which we discuss in a moment).

In the case of a server software upgrade, you maintain many of the settings and services already running on the server. In the case of a new installation, there are two parts to installing Windows Server 2003 on a server: a Text phase and then a Windows phase. During the Text phase you will need to specify (and create if necessary) the partition that will be used as the target for the Windows Server 2003 installation.

Windows Server 2003 supports three different file systems for partitions that you create on the server:

  • FAT. FAT volumes use a file allocation table that provides the name of the file and the location of the actual clusters that make up the file on the hard drive. FAT is a hold over from the days of DOS. I can see no compelling reason to use FAT volumes on your servers.

  • FAT32. FAT32 is an extension of the FAT file system. It uses disk space on a drive more efficiently than FAT and was designed for Windows 95/98.

  • NTFS. NTFS 5 is the newest version of the NT file system (it was first introduced with Windows 2000 Server). It provides increased security for files on NTFS volumes and supports file system recovery. Microsoft recommends that you use NTFS as your file system on your server running Windows Server 2003. It is also required if you wish to install Active Directory on a server to make it a domain controller.

After the system partition has been created and formatted, the Text phase is complete. The system will reboot into a pre-Windows environment. The Windows phase of the installation will consist of a series of Windows-based screens that allow you to select configuration items such as the computer's name, the time zone and time for the computer, and the password for the computer's Administrator account. You are also asked to select your licensing mode during the installation of the server software (licensing issues related to network servers and clients is discussed in Chapter 7, "Network Operating System Overview").

The server installation will also require that you configure the network settings for the computer. You can go with the default of the client for Microsoft Networks, File and Print Sharing, and the TCP/IP protocol. If you wish to change this configuration, you can click the Custom settings option button on this screen. In most cases, it is probably easier to install additional network protocols such as NWlink (the Microsoft IPX/SPX compatible program) after the server is up and running.

Near the completion of the server software installation you are asked whether this server belongs to a workgroup or a domain. The default setting is that the computer is not on a network, or is on a network with a workgroup rather than a domain. The default workgroup name is WORKGROUP. Whether you are going to use the server in a workgroup (a small network) or a domain (a larger network), it is probably best to go with the default and complete the installation. It is very easy to change these settings once the server is actually up and running.

After all the software has been installed on the server, the system will reboot. To log in to your new server after it restarts, press Ctrl+Alt+Delete. At the password prompt supply the password you set for the Administrator account during the installation process. You will be logged on to the server.

Note

An upgrade of Windows 2000 Server to Windows Server 2003 requires that you upgrade the domain controller that serves as the Schema master. The schema defines the object types that can exist in the Windows Active Directory such as users, groups, and printers. The Schema master is typically the first domain controller that you brought online in your Windows 2000 Server domain. For more about upgrading to Windows Server 2003, see the Server 2003 Web site at http://www.microsoft.com/windowsserver2003/. The site provides a number of links with information on upgrading previous versions of Windows Server (such as NT and 2000) to Windows Server 2003.

Tip

One of the first things that you will want to do after installing Microsoft Windows Server 2003 is to activate the product. To combat software piracy, Microsoft has developed a product activation strategy for its network operating systems, client operating systems, and applications such as Microsoft Office. You can activate your Windows Server software either over the Internet or by telephone.


Choosing a Server's Role

Once the server software (Windows Server 2003) has been installed on a server (especially in situations where you have done a fresh install), you can configure the server for a specific role or roles. Some of the common server roles on a Microsoft network are

  • Domain Controller. As already mentioned, a Windows domain will require a domain controller. The domain controller authenticates users to the Active Directory as they attempt to log on to the network. The domain controller also provides the global catalog for the domain, which is a listing of all the objects in the domain such as users, groups, and printers.

  • File Server. A file server's job is to serve as a repository for the files that are needed by users on the network. These files are typically held in what is called a public folder, which can include private folders that are specific for a particular user.

  • Print Server. A print server is used to host a network printer. It is basically the control conduit for the printer. Because print jobs need to be spooled (placed on the computer before they are sent to the printer) before they are printed, the print server supplies the hard drive space needed.

  • Web Server. Web servers provide you with the ability to create a Web site that can be accessed by the general public via the World Wide Web. Web servers can also be used to create private Webs called intranets. Deploying a Web site is discussed in Chapter 16, "Hosting a Web Site".

  • Communications Server. A communication server runs specialized software that allows users on the network to communicate. It provides services such as electronic mail and discussion groups. Microsoft Exchange is an example of a communication server software package. It is installed on a server that is already running one of the Microsoft network operating systems. Communications servers are discussed in Chapter 11, "Working with Applications on the Network".

  • Remote Access Server. A remote access server (or RAS server) provides offsite users with the ability to dial-in or access the private company network using such strategies as virtual private networking. Remote access is discussed in Chapter 17, "Networking on the Run".

To configure a server for a specific role or roles in the Windows Server 2003 environment, you can use the Manage Your Server Tool. It actually opens automatically when you reboot the server after the NOS installation. Figure 9.2 shows the Manage Your Server window.

Figure 9.2. The Manage Your Server window can be used to add or remove roles from a Windows server.

Server roles can be added to a server directly from the Manage Your Server window (this window also shows any roles that have already been assigned to the server). Click Add or Remove a Role near the top of the window. The Configure Your Server Wizard will open.

After advancing past the initial screen of the Configure Your Server Wizard, you are provided with a list of different server roles. Select a role from the list (as shown in Figure 9.3) and then click Next. The wizard walks you through the process of adding the role to the server. After you have completed the steps provided by the Configure Your Server Wizard, the new server role will be listed in the Manage Your Server window.

Figure 9.3. The Configure Your Server Wizard makes it easy to add roles to your Windows server.

    [ Team LiB ]


Understanding Windows Active Directory

Active Directory is the directory service (a directory service is a database of information that is arranged in a top-down hierarchical manner) for your Windows network; it provides a hierarchical structure for domain management and implementation. The Active Directory provides the namespace for your domains and catalogs users, groups of users, computers, printers, and even security policies in a centralized database that is replicated among domain controllers on the network. Each item, such as a user or a group is referred to as an Active Directory object.

Since Active Directory provides a hierarchical, tree-like structure for your domains, sharing resources throughout the domain structure is made easier. And adding new domains to the tree is very straightforward, making the directory service provided by Active Directory highly scalable.

A Windows domain requires a domain controller. This role is added to a server by installing Active Directory on the server (this can be done using the Configure Your Server Wizard). During the installation of the Active Directory on the domain controller you are required to provide the full DNS name of your domain. The Domain Name Service hierarchy and naming conventions are discussed in Chapter 12, "TCP/IP Network Administration".

Once Active Directory is installed on a domain controller (along with DNS and DHCP if necessary), you are provided with a set of Active Directory Management tools. These tools allow you to add users and computers to the domain, manage the trusts between your various domains, and deal with wide area network sites on the network. The Active Directory tools are Active Directory Users and Computers, Active Directory Domains and Trusts, and Active Directory Sites and Services.

Active Directory Users and Computers

The Active Directory Users and Computers snap-in is used to manage user accounts, computers, and groups. It is the management tool for all the Active Directory objects residing in your Windows Server domain. It will also, no doubt, be the Active Directory snap-in that you use the most often as you manage your domain. Figure 9.4 shows the Active Directory Users and Computers snap-in.

Figure 9.4. The Active Directory Users and Computers snap-in is used to manage objects such as users and groups.

Note

In the Windows environment, a snap-in is one of any number of tools used to manage the server. Many of the Windows tools reside in the Microsoft Management Console as a snap-in. This provides a common interface when you are using these various tools.

Active Directory Domains and Trusts

The Active Directory Domains and Trusts snap-in is used to manage trusts between your domains. Since transitive trusts are assigned to domains in the same domain tree, Active Directory Domains and Trusts would typically be used to manage trust relationships between different domain forests.

The Active Directory Domains and Trusts snap-in is also important in another respect; it provides you with the ability to raise a domain's functional level. The domain functional level that you select will determine what type of domain controllers (based on the Microsoft network operating system they are running), are supported within your domain. By default the domain functional level is set to Windows 2000 mixed, which supports Windows NT 4, Windows 2000, and Windows Server 2003 domain controllers.

Active Directory Sites and Services

The Active Directory Sites and Services snap-in is used to manage the physical and logical structure of your Windows network. A site, which can be a subnet or a collection of subnets, is typically one physical location. Active Directory Sites and Services allows you to create multiple sites, which consist of different physical locations connected by WAN connections. Subnetting an IP network is discussed in Chapter 12.


Creating User Accounts

While an exhaustive study of the different Active Directory tools is certainly beyond the scope of this introductory book, we should take a look at how user accounts are added to a domain using the Active Directory Users and Computers snap-in. A domain account provides a user with the ability to log onto a domain and access the resources available on that domain.

Before adding domain users to the Active Directory, you should determine the set of parameters or rules that you will follow when you create the user names for your domain (or domains). For example, you may determine that you will use the first initial and then the last name of employees at your company to create each user name. Remember that user names must be unique on the network.

User accounts are added to the domain using the Active Directory Users and Computers snap-in. Open the Active Directory Users and Computers snap-in (Start, Administrative Tools, then Active Directory Users and Computers).

Expand the domain node in the snap-in tree. Then select the Users folder in the tree. A list of the default groups and users in your domain will appear in the details pane. To create a new user, click the Create a New User in the Current Container button on the Active Directory toolbar. The New Object - User dialog box opens as shown in Figure 9.5.

Figure 9.5. The New Object - User dialog box is used to create the new user account.

Enter a first name, initials, and last name for the user (this is actually the name that will appear in the Active Directory). In the User logon name box, type the user name that the user will use to log on to the domain. When you have entered the appropriate information, click Next to continue.

On the next screen you are asked to provide a password for the user (and confirm it) and set properties related to the user's password. The password possibilities are

  • User must change password at next logon. If you wish to let the users have control over the password that they assigned themselves, check this check box. You can then enter something generic such as "password" as the user's password. At the first logon, they will be required to change the default password.

  • User cannot change password. If you wish to assign passwords to your users, and not allow the user the option of changing his/her password, click this check box.

  • Password never expires. This makes the password selected by you or the user a lifelong password; it has no expiration time limit. When you do not use this option, passwords will be good for a month (31 days) by default.

  • Account is disabled. This check box allows you to disable the current account without actually deleting it.

After supplying the password and setting password options, click Next. A summary screen for the new user account will be provided. Click Finish. The new user account will appear in the Active Directory Users and Computers snap-in.


Sharing Windows Folders

Both drives and folders can be shared on a Windows network and the server that supplies these types of services is typically referred to as a file server. A file server provides a repository for files that must be accessed by the users on your network. Not only do file servers provide data access to users but they also often serve as a place where users can save files, either in a home directory or a directory that can also be accessed by other users.

A Windows file server can be created using the Configure Your Server Wizard. A share is simply a drive or folder that you share for access by your users. After specifying the server as a file server using the Configure Your Server Wizard, the Share a Folder Wizard starts automatically; click Next to bypass the initial wizard screen.

The next screen asks you to supply the path to the folder or drive that will serve as the new share. You can type the path in the Folder path box (see Figure 9.6). Or you can use the Browse button to locate the folder or drive on the computer. The Browse dialog box also provides you with the option of creating a new folder on a drive and then specifying it for the new share.

Figure 9.6. Specify the path of the folder for the share.

After specifying the path for the new share, click the Next button. On the next wizard screen you are asked to provide a share name for the new share. After supplying the name for the share, click Next to continue. The next wizard screen relates to the permissions of the folder. Different permissions levels can be assigned to your users in relation to the share and the items that it holds. We will discuss share permissions in the next section.

To complete the share creation process, click Finish. This will create the new share. Click Close to close the wizard's summary screen. The Configure Your Server Wizard will appear, letting you know that this server is now a file server.

Once the share has been created on the server, users on the network will have access to the files held in the share. The level of access that a particular user will have depends on the share permissions that have been provided for the user.

Tip

Shares can quickly be created using any folder on a Windows server. Right-click on the folder in Windows Explorer and select Properties. On the Sharing tab of the folder's Properties dialog box, share the folder. On this tab you can specify the name for the share on the network.


Understanding Share Permissions

As mentioned in the previous section, the level of access that a user has to a share on the network will depend on the level of share permission afforded that user (in reference to the share). When you share a volume or folder on the network, the default share permission assigned to the newly created share is Read-only for the Everyone group (all users on the network belong to the Everyone group).

A share permission is merely the access level that you give to a particular user or group of users in relation to a particular share on your file server (or other server on the network). Setting the share permission for a folder or volume also sets the share permission level for the files contained in the share.

Share permissions can be set at three different levels: Full Control, Change, and Read. A description of each share permission level follows:

  • Full Control. This permission level allows the user to modify file permissions and perform all the tasks that are permitted by the Change and Read permission levels. This access level gives a user the same access that an Administrator would have to the share.

  • Change. This permission level allows the user to create folders in the share and add new files. Users can change data in the files and add new data to the files contained in the shared folder.

  • Read. This permission level allows the user to display folders and files in the share, open the files in the share (in read-only mode), and run program files that are contained in the share.

Permission levels are set on the Share Permissions tab of the share's Properties dialog box. Right-click on a shared folder or drive in the Windows Explorer and then select Properties. Then click the Share Permissions tab on the Properties dialog box.

Figure 9.7 shows the Share Permissions tab for a network share. You can select the permission level for a particular user or group by clicking the appropriate permission level check box.

Figure 9.7. Set the share permission level for a user or a group.

You will probably have to add users or groups to the Group or User Names list provided on the Share Permissions tab. This is accomplished using the Add button. Once you have a user or group listed in the Group or User Names list, you can set the permission level for that group or user.

Note

Access levels and other properties related to user accounts are often assigned to users via their group memberships. A group is a number of network users. Assigning different access levels and other security-related features to groups is much easier than assigning these properties to individual users. For example, if all your accountants need access to the same files and need to have the same access levels, you can assign the access levels to the group "accountants" and then add users who are actually accountants to the group. These tasks are actually performed in the Active Directory Users and Computers snap-in.


Windows and NTFS Permissions

Windows servers also provide a second level of security related to shared files and folders on server drives that have been formatted with NTFS. Folders and files on NTFS volumes can also be assigned NTFS permissions. This differs from share permissions, which can only be applied to drives and folders. The NTFS permission levels for folders are listed in Table 9.1.

Table 9.1. NTFS Folder Permissions

Folder Permission

Access Level

Full Control

Allows the user or group to change permissions; delete the folder, subfolders and files; take ownership of the folder; and permits all other permission levels (read, write, list folders, and so on).

Modify

Allows modification of the folder, such as deletion of subfolders and files, and permissions related to all other lower-level permissions (read and execute, list contents, write and read).

Read and Execute

Navigate the folder contents (subfolders and files), execute contained executables and actions related to the list folder, and read and write permissions.

List Folder Contents

View the contents of the folder, such as subfolders and files in the folders.

Write

Create new contents in the folder, such as subfolders and files. Change the folder attributes and view the folder ownership and permissions information for the folder.

Read

View the files and subfolders in the folder and view other information related to the folder such as ownership, permissions, and file attributes.

NTFS permissions can also be applied at the file level. Table 9.2 lists the NTFS file permissions available.

Table 9.2. NTFS File Permissions

File Permission

Access Level

Full Control

Allows the user or group to change permissions, take ownership of the file, and exercise all other actions permitted by the other file permission levels.

Modify

Allows modification and deletion of the file and provides permissions related to all other lower-level permissions (read and execute, and write).

Read and Execute

Navigate the folder contents (subfolders and files), execute contained executables, and list folder and read and write permissions.

Write

Create new contents in the folder such as subfolders and files. Change the folder attributes and view the folder ownership and permissions information for the folder.

Read

View the files and subfolders in the folder and view other information related to the folder such as ownership, permissions, and file attributes.

Setting NTFS Permissions for a folder or a file requires two major steps. First you add groups or users that you wish to create permissions for; then you assign the user or group the permissions.

NTFS permissions are assigned using a folder's or file's Security tab on the objects Properties dialog box. Figure 9.8 shows the Security tab for a shared folder on the network.

Figure 9.8. Set the NTFS permission level for a user or a group.

Notice that in Figure 9.8, Administrators are provided Full Control over a network share. While on first inspection, NTFS permissions may seem to be as straightforward as share permissions, NTFS permissions are more complex due to the fact that NTFS permissions can be assigned to files; so a file can have different NTFS permissions than its parent folder.

NTFS permissions can also become confusing because they can be assigned to both groups and users, meaning a user may have NTFS permissions for a folder or a file that have been individually assigned as well as NTFS permissions that have been assigned to a group that the user belongs to. Some important points to keep in mind when working with NTFS permissions are

  • NTFS permissions are cumulative; a user's final NTFS permissions are a combination of the NTFS permissions assigned to groups that the user is a member of and NTFS permissions assigned directly to the user.

  • NTFS file permissions override NTFS folder permissions. Even if a user has the NTFS permission of Full Control for a folder, if the NTFS file permissions for a file in that folder have only been set to Read, the user will only be able to read the file, not write to or modify it.

  • Permissions are inherited from parent folders; this means subfolders and files contained in a parent folder will inherit the permissions that you set for the parent folder. However, you can choose to not allow permissions to be inherited from the parent, if you wish to set different permissions for the child subdirectory or file (we discuss turning off inheritance when we discuss setting NTFS permissions later in this chapter).

A very solid understanding of both share and NTFS permissions is required before you employ them on network shares. Check the Microsoft Windows 2003 Web site at http://www.microsoft.com/windowsserver2003/. You can also consult a book that provides a more in-depth look at how you secure files and folders on a network. One resource possibility is Sams Teach Yourself Microsoft Windows Server 2003 in 24 Hours.


Sharing Printers

Another essential service that a network provides to users is the ability to print. In Chapter 7, we looked at the different categories of printers that can be provided on the network. Setting up a local printer on a Windows server is really just a matter of physically connecting the printer to the server. The Plug and Play feature provided by Windows Server 2003 will configure the driver for the printer when you reboot the system.

As soon as you install a printer on a Windows server, you have, in effect, created a print server. Now all you have to do is share the printer. Since Windows Server 2003 has "Wizardized" many of the tasks that you must complete as a network administrator, probably the easiest way to share the printer and specify the Windows server as a print server is to use the Configure Your Server Wizard. This can be started from the Manage Your Server window by clicking the Add or Remove a Role link at the top right of the window.

On the Server Role screen, select Print Server, then click Next. On the next screen you are provided with the option of selecting the print drivers that will be installed for client operating systems when a network client computer connects to your print server's printer.

Figure 9.9. Specify the client operating system drivers to be installed for the printer.

The default selection is for Windows 2000 and Windows XP clients. If you will use other clients such as Windows 98, select the All Windows Clients option button. Then click Next to continue.

On the next screen, a summary of the print options that you have chosen will be listed. New printers will be added with the Add Printer Wizard. If you chose to install drivers for network client computers other than Windows 2000 and Windows XP, the Add Printer Driver Wizard will also be listed on the summary. It will allow you to install the print drivers for your legacy clients (such as Windows 98). Click Next to continue.

After you click Next, the Add Printer Wizard will appear. Click Next to bypass the initial screen. On the next screen you are asked to specify whether the new printer will be local or a network printer. As mentioned earlier in the chapter, Plug and Play printers are installed automatically and do not require the Add Printer Wizard. You can click Cancel to advance to the Add Printer Driver Wizard. This makes all the print drivers needed by your network clients available when a user connects to the printers. When the Add Printer Driver Wizard opens, click Next to bypass the introductory screen.

On the next screen, select the printer manufacturer and the printer that you wish to install the print drivers for. If you have a disk or CD with a newer driver for the printer, select the Have Disk button and provide the path for the driver.

Click Next to continue. On the next screen (see Figure 9.10) you can select the processor types and operating systems that will use the printer.

Figure 9.10. Select the operating systems needing printer drivers.

Selecting all the operating systems that will be used by network print clients will make the driver available to the client. Having printer drivers available for client computers on the print server allows clients connecting to a printer for the first time to download the appropriate printer driver. This saves you a lot of time running around and configuring client computers to work with a particular printer.

You must select at least one set of drivers other than the default installed Windows 2000 and Windows XP. After making your selection, click Next. The summary screen for the Add Printer Driver Wizard will appear. If you do not wish to install any additional drivers, clear the Restart to Add Another Printer Driver option, and then click Finish to close the wizard.

Make sure that your Server 2003 CD is in your CD-ROM drive. The Select Device window will open. Select the printer manufacturer and printer to add the drivers (yes, this is the second time this window has opened during the process: the first time was to install Windows 2000 and Windows XP drivers; this is to install additional client drivers). Then click Next. The drivers will be copied to the print server. Click Finish to complete the process.

Once you have used the Configure Your Server Wizard to specify that the server will play the role of Print server, the Print Server role will appear in the Manage Your Server window (see Figure 9.11). You can use this window to open the Printers and Faxes window, or add additional printers and print drivers.

Figure 9.11. The print server role is added to the Manage Your Server window.

    [ Team LiB ]


Security and Windows Server 2003

Microsoft Windows Server 2003 provides many security features to protect data on your network. We looked at share and NTFS permissions in this chapter. Using user groups to provide different access levels to network shares is discussed as part of the security overview that is provided in Chapter 20, "A Network Security Primer".

Windows Server 2003 provides a tool named the Group Policy snap-in that allows you to control a number of security features, including strong password protection and Kerberos Authentication. The Kerberos protocol (which supplies Kerberos Authentication) uses a system of tickets to authenticate users logging on and requesting services on the .NET network. Each domain controller in the Windows Server 2003 domain acts as a key distribution center. When the user logs on they are provided a ticket-granting ticket by the domain controller that authenticates their client account.

Note

The Kerberos protocol is named after the threeheaded dog (Kerberos) that guards the entrance to Hades.

When the client wishes to access a particular resource on the network, such as a file server, the client presents its ticket-granting ticket to a key distribution center (any of the domain controllers) and requests that it be provided a ticket-granting service ticket to access a particular resource.

Once the ticket-granting service ticket has been provided to the client by the key distribution center, the client supplies the ticket-granting service ticket to the resource server it wishes to access. The resource server then grants access to the resource. All of this ticket action, of course, is at the machine level and is not something that users or administrators will actually see taking place.

Group Policy is definitely an advanced feature of Windows Server 2003 and teaching you all the ins and outs of Group Policy is beyond the purpose of this book; however, I mention it to let you know that all the network operating systems that you work with (including Windows Server 2003) have been strengthened over the years to provide protection against network hackers and attacks.

The Group Policy feature secures a particular property using a policy. For example, if the strong password policy is enabled, passwords must meet the following minimum requirements:

  • Cannot contain the login name or a part of the login name.

  • Must be at least six characters.

  • Must contain characters from at least three character groups: English uppercase, English lowercase, numeric (0–9), and nonalphanumeric characters (such as %, $, and so on)

All the Group Policy settings for a domain can be viewed using Group Policy Management, which is shown in Figure 9.12. Individual policy objects such as the password policy have been discussed in this section.

Figure 9.12. Group Policy Management allows you to view the policies affecting domain security and other features.

To actually edit the policies for the domain (such as the strong password policy), you right-click on the Domain policy in Group Policy Management and then select edit.

Figure 9.13 shows the Group Policy Object Editor. It would be used to enable the password policy. This would affect all the computers in the domain since it is a domain policy.

Figure 9.13. The Group Policy Object Editor allows you to enable policies that affect network computers.

Administering a network operating system such as Windows Server 2003 requires an understanding of all the tools and features provided by the NOS. Being able to configure group policies is as important as being able to add users and configure file and print servers. A good way to learn a particular NOS is to set up a test network that allows you to configure servers so that the mistakes and changes that you make while learning don't actually affect a production network. Another good way to learn about a particular network operating system is to pursue a certification for that NOS.

The Absolute Minimum

In this chapter we took a look at some of the basics related to installing Windows Server 2003 on a network server. We also looked at sharing folders and printers on the network. Advanced security settings controlled by Group Policy were also discussed.

  • Microsoft Windows server embraces a hierarchy with the domain as the basic networking unit.

  • A collection of Windows domains is referred to as a tree. All the domains in the tree have transitive trusts with the other domains in the tree.

  • A group of domain trees is referred to as a forest.

  • To install Windows Server 2003 on a computer, the computer must have the basic hardware configuration suitable for the NOS and must also have hardware that is compatible with the NOS.

  • Windows Server 2003 can be installed on a computer that does not currently have an operating system and it can also be used to upgrade previous versions of the Windows server NOS.

  • A Windows server can be configured for a number of different roles, such as a domain controller, file server, and print server.

  • The Manage Your Server window provides easy access to the Configure Your Server Wizard, which can be used to configure different roles on a Windows server.

  • Active Directory is installed on a server to make it a domain controller. A number of Active Directory tools are used to manage Active Directory objects. The Active Directory Users and Computers snap-in is used to add users to the domain.

  • Windows servers can act as file servers. You create shares on the network and then can determine the share permissions related to that share and user access.

  • NTFS permissions can be used to secure shares and files on NTFS drives.

  • Print servers provide users on the network with access to printers on the network. A print server can be configured using the Configure Your Server Wizard.

  • Windows Server 2003 offers advanced security features through Group Policy. The Group Policy Management tool provides access to the Group Policy for a Windows domain.


Chapter 10. Networking with Linux

In this chapter

  • What is Red Hat Linux?

  • Installing Red Hat

  • Linux administrative tools

  • Managing users

  • Configuring Red Hat network services

  • Sharing network resources

This chapter provides an introduction to Linux, specifically the Red Hat distribution of Linux. Linux is both a desktop and server environment. Linux was created by Linus Torvalds when he was a student at the University of Helsinki. Linux is an open-system OS/NOS, and because the source code is freely available, a number of Linux distributions have popped up in the marketplace. Linux is similar to Unix in many respects and uses a similar command set.

Linux servers can offer file and print services as well as more complex services, such as Web hosting. The Apache Web Server software is a popular Web hosting add-on for Linux servers. Linux servers can also provide services to non-Linux clients. For example, a Linux computer running Samba can function as a Windows peer computer or as a Windows NT domain controller. Samba is discussed in Chapter 6, "Configuring Peer-to-Peer Networks."


Installing Red Hat Linux

Red Hat is just one of a number of Linux distributions. Since the Linux kernel software operates under a free software licensing called the GNU General Public License, companies like Red Hat are able to take the Linux kernel and add their own proprietary software code to create their own particular flavor of Linux.

Red Hat, Inc. provides both freeware versions and commercial versions (which you have to pay for) of their Linux distribution. The free version (which can be downloaded from Linux distribution sites such as www.linuxiso.org), provides a basic form of the operating system. Although we look at a free distribution of Red Hat in this chapter (Red Hat 8), network administrators intent on deploying Linux servers for hosting Web sites, network shares, and specialized client/server environments would definitely want to purchase commercial Red Hat Linux distributions that have been designed for enterprise networking.

Note

Samba is an open source version of the Server Message Block (SMB) file sharing program. It allows non-Microsoft operating systems such as Linux to communicate with the Microsoft Windows platform.

As with other network operating systems, you need to make sure that your server hardware is configured appropriately to run the NOS that you purchase. For example, a suggested hardware configuration for Red Hat (8) would be the following:

  • CPU speed: 200MHz or better

  • RAM: 128MB (192–256 MB recommended)

  • Disk space for setup: 1.5GB (at least 2GB or more for a server installation)

  • Monitor: Super VGA

Note

Linux has continued to capture market share as new and improved versions of the various Linux distributions have become available on the market (and commercial versions of these distributions have been developed). At the time of the writing of this book, statistics showed that Linux servers occupied the number 2 position as far as server implementations, with Microsoft in the number 1 position.

The amount of hard drive space required will depend on the number of services and packages that you install on your computer. If you intend to deploy commercial versions of Red Hat such as the Red Hat Advanced Server (which is intended for enterprise networking, meaning it is comparable to Windows Server 2003 and Novell NetWare 6x in capabilities), you will need a more robust hardware configuration on your server. The Red Hat Advanced Server actually provides support for multiple processors. The Red Hat Web site at www.redhat.com provides the hardware requirements for their various operating systems, and also supplies hardware compatibility lists for their products.

Installing Red Hat on an appropriate computer is quite straightforward. A GUI installation walks you through the steps of installing the software. We will hit some of the high points of the installation process, particularly those related to network settings. The installation will vary depending on the distribution of Linux that you use, as well as the version of that distribution. In any case, during the installation you will typically be asked about the type of mouse you are using, your keyboard configuration, and video card selection (as you would any operating system). But let's concentrate on installation issues that are peculiar to Linux.

Note

The partitioning of the computer's hard drive can be handled automatically by the Linux installation software. However, if you are going to install Red Hat on a computer that is already running another operating system such as Windows, you will have to create the partitions for Red Hat manually. You can manually create the partitions using a tool called Disk Druid or a Linux utility called fdisk (which is not the same as the DOS fdisk utility we discuss in Chapter 18, "Protecting Network Data"). You can obtain additional information on manual partitioning at the Red Hat Web site (www.redhat.com). There is also information related to partitioning on the documentation CD that you acquired with your release of Linux.

Two things that you must do during the initial steps of the installation are partition the computer's hard drive (so that space is available for the operating system) and select a boot loader for the Linux system. Each version of Linux will provide documentation that provides information on partitioning the system and selecting a boot loader for the OS.

To begin the installation, place the first CD-ROM in your CD drive and reboot the system (make sure that you configure your computer's CMOS settings so that the computer will boot to the CD drive. These settings are usually set in a menu-driven system that can be accessed during bootup by pressing a particular key such as F2 or Delete; watch your screen at bootup for the keystroke that allows you to enter the computer's configuration settings). When the system boots, a command-line screen will appear. You can install Red Hat in a text mode or GUI mode. Press Enter to begin the installation in graphical mode (which we look at later in this chapter). If you wish, you can start the text mode by typing text and then pressing Enter. The text mode actually follows through the same set of steps (more or less) that you experience when using the GUI installer.

After you press Enter, the GUI installation will begin. The first couple screens relate to choosing the language for the installation and the type of keyboard and mouse you are using.

An important step in the installation is selecting the installation type, which is performed on the Installation Type screen as shown in Figure 10.1. You can choose between options for a personal desktop, workstation, server, or custom installation.

Figure 10.1. Select the type of installation you wish to perform.

Since we are discussing Red Hat's basic abilities as a network server, I chose the Server option during my installation. Note that in Figure 10.1, after the options are selected, you click Next to continue with the installation.


Network Configuration

The network configuration of the Linux computer really entails making a simple choice between configuring the server (or workstation, if that is what you are configuring) with a static IP address and other IP related settings, such as DNS servers and default gateway, or allowing the computer to receive its IP configuration from a DHCP server (see Chapter 12, "TCP/IP Network Administration," for more about TCP/IP administration and settings).

For Red Hat, the default installation setting is to receive the TCP/IP configuration from a DHCP server, as shown in Figure 10.2. If you are going to configure the server with a static IP address and other settings, click the Configure Using DHCP check box to clear it and then provide the IP address, subnet mask, and other static settings for the computer (in the case of a server installation, you typically want to configure your server with static settings, especially if the server is going to provide services such as Web server).

Figure 10.2. Select how the computer will be configured for IP networking.

After completing the IP configuration settings for the server, the next installation step relates to configuring a firewall for the system. You can choose different security levels for the firewall (High, Medium, No firewall) and then specify the type of protocols that you will allow to pass through the firewall (such as WWW, FTP, and DHCP). For more about the basics related to firewalls, see Chapter 20, "A Network Security Primer."


Root Configuration

Another important part of the Red Hat installation is the configuration of the root password. The root account is the equivalent of the administrator account on a Windows server and the admin account on a NetWare server. The root account provides complete access to the Linux settings on the computer and allows you to configure and add services to the server.

Type a password for the root and confirm it. The password that you select should be complex enough that it cannot easily be guessed. After configuring the root password, the GUI installation also gives you the option of creating additional user accounts for use on the computer. Since you should only use the root account to configure the system, you should create at least one typical user account for yourself (and any other accounts that will be needed for users that use the system, which should be minimal in cases where you are configuring a Linux server). Figure 10.3 shows the GUI screen where you enter the root password and create additional user accounts for the system.

Figure 10.3. Enter a root password and create other user accounts as needed.

    [ Team LiB ]


Selecting Installation Packages

The next major portion of the installation process requires that you select the installation packages that will be installed on the server. You can select from a number of packages and these will depend on the purpose that the Red Hat server will fulfill on the network. These packages not only include services such as News server (NNTP) or Windows File Server (using Samba), but also allows you to select different GUI interfaces for your Linux installation.

GUIs such as GNOME and KDE provide you with a "Windows-like" environment, which makes it easier to access various Linux tools and configure the system (although some configuration will still take place at the command prompt, which is fairly standard for Linux). If you choose to use GNOME or KDE, this will require that you have a VGA graphics card that can handle at least 256 colors and a monitor that can display the card's output. Systems configured with a SVGA video card will provide you with the best possible output for displaying the Linux GUIs.

After selecting the packages you wish to install on the Linux server, you can proceed with the balance of the installation. The package installations may take some time, especially if you chose to provide a number of different services on the server.

After the files have been copied to your computer, you will be given the option of creating a boot disk for the system. The installation process will conclude with the configuration of your GUIs (such as GNOME or KDE), which will include the identification of your graphics card and your monitor.

Note

GNOME stands for GNU Network Object Model Environment. GNOME is a freeware GUI interface that was created as part of the GNU project (which has led to the creation of a lot of the software that runs on the Linux platform). KDE or K Desktop Environment is also an open source product.


Booting Your Linux System

After the Red Hat installation has completed, the computer will boot to the Red Hat login screen. You must provide a valid user name and password. You also have the option of selecting the type of session that you will run. You can select from the GUIs you have installed or boot the system in a failsafe mode by selecting the Session link at the bottom of the login screen.

Remember that Linux differs from the other network operating systems that we have discussed (Windows Server 2003 and Novell NetWare) in that the Linux platform provides both a desktop and server environment. To create a desktop environment, you choose the tools needed by network users prior to the system installation. To create a server environment, you select the services and server options that you wish to deploy on the network server.


Upgrading Your Linux System Software

Depending on the distribution of Linux that you are using, there will be various ways to upgrade your system software. You can buy or download a newer version of the software and then upgrade your system by installing from CDs (downloaded Linux distributions come in the form of CD ISOs, which must then be burned to a CD). Upgrading portions of your installation such as the KDE desktop or specific tools can be accomplished by going to the appropriate Web site and downloading the software.

Individual Linux software packages (such as utilities for managing the system and various network resources) can be found in different file formats. For Red Hat you can easily install new software using RPM (Red Hat Package Manager) files. These files have .rpm as their extension. These files have been specially prepared so that they can be installed quickly on your system using the Red Hat Package Manager utility. All you have to do is download the file (typically from www.redhat.com) and then locate it on your system using the Conqueror browser (a combination file and Web browser used on Linux systems where KDE has been installed; we discuss Conqueror later in the chapter). Selecting the file in Conqueror starts the Red Hat Package Manager and allows you to install the software.

You may also run into software packages that exist as compressed tarballs. A tarball is a file archive created with the Unix tar utility. It holds the source files for the software you wish to install. Tarballs will typically be compressed with the Linux utility Gzip to make them easier to download. A typical Gzip compressed tarball will have the extension .tar.gz. In most cases installing tarballs requires some annoying input at the command line in a terminal window. For example, let's say that we have a file named joe.tar.gz. To unzip the package you would open a console on your desktop (in KDE, select the KDE menu then select System Tools, and then Terminal).

In the terminal you would first switch to the directory that holds the file using the cd command (such as cd /directory name) and then type the following:

tar zxf joe.tar.gz /tmp

The zxf switches are used to unzip the archive (z), extract the file (x), and specify that this is the archive to work with (f). The /tmp at the end of the command will place the unzipped and extracted files into the tmp directory on your system (you can specify a directory other than tmp if you wish).

You can then go to the tmp directory (cd /tmp) or other directory that holds the extracted files. Now you have to type the following:

./configure
make
make install

This creates the installation file for the software and installs it. You should now be able to launch the application (typically from the terminal window or in some cases an icon will be created on the GUI menu system).

The absolute easiest way to upgrade Red Hat Linux (in cases where you purchased the software) is to use the Red Hat Network Alert Notification tool, which allows you to upgrade your Red Hat installation over the Web (other Linux distributions also have systems for upgrading over the Web). On the right side of the GUI toolbar (called the KDE Panel on a KDE desktop), the Red Hat Network Alert icon will let you know when your system is not up to date. The icon will appear as a red circle with an exclamation point in it (as shown in Figure 10.4).

Figure 10.4. The Red Hat Network Alert Notification tool makes it easy for you to upgrade your Red Hat system software.

When you click the icon a list of available updates will appear (also shown in Figure 10.4). Click the Launch up2date button in the Red Hat Network Alert Notification tool and you will be walked through the process of upgrading your Red Hat installation (you get to select what you want to upgrade and what you don't want to upgrade). The great thing about upgrading through the Red Hat Web site is that software dependencies are figured out for you, and if additional software is required to make your upgrade work, it will be identified and installed as well.

Caution

Before you install new software on a Linux system, you must make sure that you have taken care of any software dependencies that the new software requires. This means that you may have to install other software or system files before you can install the new software (and actually have it work). When you download software from Web sites such as www.kde.org or www.linux.org, there will typically be information about the software dependencies along with the download information.


Linux Administrative Tools

A number of Linux administrative tools can be accessed using the GUI that you have installed. For example, Figure 10.5 shows the Network Configuration utility. It allows you to set hardware, hosts, and DNS parameters for your network interface cards (and other network connections such as dial-in through a modem).

Figure 10.5. The Network Configuration utility allows you to set parameters related to network connectivity.

While there are a number of GUI utilities for managing the system, you will find that Linux is ultimately managed at the command line. Linux is a Unix clone, meaning early distributions of Linux relied on a command set similar to Unix, which were (and are) run from the command line. These commands allow you to configure and monitor the system.

For example, you can add users to the system using the command line. Figure 10.6 shows switches and syntax for the adduser command. The figure also shows the adding of a user "kimrich" with a password of "password" (we discuss user administration in the next section).

Figure 10.6. You can perform system management tasks such as adding users from the command line.

Since an exhaustive study of the Linux command line is beyond the scope of this book, we will take advantage of GUI tools (when available) as we discuss the various network services and configuration options for Red Hat Linux. This will provide you with an overview on how some of these services are made available to your network users.

Depending on your installation choices there should be a fair number of administrative tools available through the KDE or GNOME menu system (depending on the GUI that you are using). KDE is actually my personal preference. Some of the GUI administrative tools available for administering a server environment are

  • Disk Management. The disk management (or user mount tool) allows you to view the different drive devices and partitions on your system. The tool allows you to mount devices and format partitions. It is accessed un the System Tool menu by clicking Disk Management (on a KDE system).

  • Hardware Browser. The hardware browser allows you to view CD-ROM, floppy, and hard drives installed on the system. You can also use the tool to view the SCSI devices, sound cards, and USB devices installed on the computer. The hardware browser is found under the System Tools menu on the KDE desktop.

  • KDiskFree. KDiskFree is a KDE utility that provides you with statistics on your different partitions including the amount of free space. The utility can be configured to launch a popup window when a disk is almost full.

  • System Logs. This utility allows you to browse the Boot, Security, System, and other service logs generated by the server. We will look at this utility in the section "Monitoring the System and the Network."

  • Service Configuration. The Red Hat config-services utility allows you to view the status of system services and start, stop, and restart these services.

  • Domain Name Service. The DNS tool allows you to configure the settings for a Linux server that will serve as a DNS server on the network. You can add forward and reverse lookup zones using the utility. DNS is discussed later in the chapter.

  • Apache Configuration. The Apache Configuration utility allows you to specify the server name and configure your Web site, such as the location of the default directories for the site. You can also configure the number of connections allowed and the timeout parameters for the server. On a KDE desktop system, you can access the Apache Configuration utility by selecting Server Settings, then HTTP Server on the KDE menu.

  • Network Configuration. The network configuration tool (or "neat" as it is referred to) allows you to view and configure network hardware devices (look at Figure 10.10). It also provides you with the ability to configure TCP/IP protocol settings for a network interface. You can also create host name to IP address mappings using the tool and enter information related to the DNS settings for your computer, such as the hostname and DNS server settings. The network configuration tool is opened by selecting System Settings, then Network on the KDE menu.

As you can see from the short list provided (this is certainly not a list of all the possible Linux GUI utilities), Linux provides many of the same types of configuration and system tools that were found in other network (and client) operating systems such as Windows and NetWare. As far as configuration tools that will be used by both regular users and the super user (the root account), the System Settings menu on the KDE menu provides tools for configuring the display, keyboard, language, mouse, printing, and a number of other useful tools.

We will look at some of the other Linux GUI utilities later in this chapter as we discuss various network services and monitoring the system. To take a look at yet another GUI utility, administering a Linux server, let's look at user management.

Note

You should always keep in mind that using system configuration tools at the command line or in the GUI will in most cases require that you provide the root password. The root account is to Linux as the admin account is to NetWare. There are not that many settings that you can change as a regular user. When you do log in as root (or provide the root password) you are considered in the super user mode.


Working with Users

Users can be added to the system using the command line (as shown earlier in the chapter) or using a GUI tool. Red Hat version 8.0 provides the Red Hat User Manager (to open it using KDE, select the KDE menu, System Settings, then Users and Groups). Figure 10.7 shows the Red Hat User Manager.

Figure 10.7. The Red Hat User Manager can be used to manage users and groups on the Red Hat system.

Users that you added to the system during the installation process will be listed in the Red Hat User Manager (as shown in Figure 10.7). To add a new user, click the Add User button on the User Manager toolbar. The Create New User box will open (see Figure 10.8). You must supply the user name and password. You can also supply the home directory for the user if you wish to select a directory other than the default (home).

Figure 10.8. Supply the user name and password for the new user.

After supplying the information for the user, select the OK button. You will be returned to the User Manager and the new user account will be added to the user list.

As with other operating systems, group membership can be used to provide different permission levels to a user in reference to a particular file or service on the system. For more about users and group membership in relation to system security, see Chapter 20.

Red Hat Linux does supply Standard Groups (groups created on the system by the installation program). These groups can be used to provide administrative abilities to users. There are standard groups such as sys and adm, and groups for particular services such as apache (the Apache Web server). In most cases you will not want to add regular users to these groups because it greatly extends their abilities to create mischief on the system. For example, including a regular user in the adm group will provide the user with administrative privileges over the system not typically afforded to any account other than the root account.

You can create groups using the Red Hat User Manager. Click the Add Group button in the User Manager and then supply the name of the new group. Click OK to create the new group. Once the group has been created, you can add users to the group. The most straightforward way to add users to the group is the following:

  1. In the Red Hat User Manager, click the Groups tab.

  2. Select the group that you want to add the users to.

  3. Click the Properties button on the User Manager toolbar. The Properties box will open for the group.

  4. Click the Group Users tab on the Properties box (see Figure 10.9).

    Figure 10.9. Users can easily be added to groups.

  5. You can add users to the group by selecting the check box for those users.

  6. When you have finished adding the users, click the OK button.

You will be returned to the User Manager. When you have finished working the User Manager, you can close it by clicking the Close button.


Working with Red Hat Network Services

Servers running Red Hat (and other Linux distributions) can be configured to offer any number of network services, such as DNS, DHCP, and the Apache Web server. They can also provide file and print services (discussed later in the chapter). Linux distributors such as Red Hat provide special editions of their Linux products that provide a more robust networking platform than the basic Linux distribution that we are discussing in this chapter.

Tip

You can quickly switch from normal user to root user in a terminal window by typing su and then pressing Enter. You will be asked for the root password. The terminal is now running in the super user mode, allowing you to change service configurations and otherwise adjust system settings.

To provide services such as DNS, DHCP, or a Web server, you should install these packages when you install Red Hat on your system. If you neglected to install a particular package, you can add it using the Package Management tool shown in Figure 10.10. This tool can be launched from the KDE desktop by selecting the KDE menu, then System Settings, and then Packages.

Figure 10.10. You can add packages using the Package Management utility.

Once you have the appropriate packages for the service or services you wish to offer on the system, you can configure that particular service. Each service is configured using one or more configuration files. These files can be edited at the command line in a terminal (running as root).

Most of the services also have GUI configuration utilities available. For example, you can configure the settings for a DNS server using the Domain Name Service utility. On the KDE desktop, you can start the Domain Name Service utility by selecting the KDE menu, selecting Server Settings, and then selecting Domain Name Service (running this utility requires root privileges). Figure 10.11 shows the Domain Name Service utility.

Figure 10.11. The Domain Name Service utility allows you to configure the DNS server.

The Domain Name Service utility allows you to add both forward and reverse lookup zones to the DNS server and add records to the DNS database. For information on DNS basics see Chapter 12. For example, to configure a new forward lookup zone for your DNS server, click the Add button.

The Select a Zone Type dialog box opens, where you can select the type of zone you wish to create, such as a forward master zone or reverse master zone. All you have to do is select the zone type and provide your domain name (and click OK). This opens the Name to IP Translations dialog box, which is actually used to configure the zone. You can also add records to the zone as you configure it.

Other services such as the Apache Web Server also have their own GUI utilities. The utility allows you to configure the server name and available addresses, and configure virtual host settings such as the site configuration and the default directories for the site files. Figure 10.12 shows the Apache Web Server GUI utility. For more about the basics of hosting your own Web site, see Chapter 16, "Hosting a Web Site."

Figure 10.12. A GUI tool is also available to configure the Apache Web Server.

As with other network operating systems, your Linux servers can fill different roles such as DNS server, DHCP server, File server, or Firewall. If you plan on deploying a number of services on a single server, make sure that the server has the appropriate hardware configuration for handling multiple services.

Before we leave the subject of adding and configuring network services on a Linux server, we should take a look at Linuxconf. This is a "catch-all" configuration tool that allows you to configure a number of server services using one GUI (it is also available in a text-based utility as well). Figure 10.13 shows the Linuxconf GUI utility. Notice that the left side of the utility provides a list of the different settings that can be configured using Linuxconf. You can both set up client networking parameters and configure network services such as the Apache Web Server and the Domain Name System.

Figure 10.13. Linuxconf allows you to configure a number of networking-related settings on a Linux system.

Linuxconf also provides you with the ability to configure file sharing on the computer using Samba and the Network File System, both of which we discuss in the next section. Not only does Linuxconf provide you with the ability to configure a variety of services and computer settings, but it also can start the necessary services when you exit the utility.

I noted early in the chapter that a problem with the Linux platform is that many software utilities and packages come and go as Linux slowly evolves into a true desktop and server alternative. Linuxconf is another example of an excellent tool that may or may not be available as time passes. As of the writing of this book not all the help screens for Linuxconf had been developed, and Red Hat 8.0 did not include Linuxconf as part of the basic installation packages (although Red Hat 7x did include the utility). So, while Linuxconf is an incredible tool, be advised that a day may come when you will have to return to alternative ways of configuring network services and software on Linux systems.

Tip

For more about downloading and setting up Linuxconf check out http://www.solucorp.qc.ca/linuxconf/.


Sharing Network Resources

As with other network operating systems, you can share files and printers on a Linux computer. Linux actually provides a number of different ways that you can share resources on the network. For example, you can create an FTP server on any Linux computer and use it to serve up files to other users on the network. The easiest way to configure the FTP server is using the KWuFTPd utility on the KDE desktop. It allows you to configure anonymous and guest logons to the FTP server.

Using an FTP server on the network allows you to provide files across different operating system platforms. The only software required on your client machines is a Web browser or other FTP client.

Another alternative for sharing files is the use of Samba. You can deploy a Samba server that allows you to share files with Windows clients and other Linux computers on the network. Samba is pretty secure and provides encrypted password support and other security features. Linux computers on the network can be configured as both Samba servers and clients. For more about configuring and using Samba, see Chapter 6, "Configuring Peer-to-Peer Networks," in the section "Combining Linux and Windows."

You can also share files on a Linux computer using the Network File System (NFS). NFS was developed by Sun Microsystems and allows Linux computers to share files using a Virtual File System interface that runs on top of the TCP/IP protocol. Shared files can be manipulated by users as if the resources were stored locally on their computers. Let's take a look at configuring NFS on a computer running Red Hat.

Configuring the Network File System

NFS is a good example of a client/server environment where a Linux computer can be configured as both an NFS client and server. To configure the NFS server, you can use the NFS Server Configuration tool in a GUI environment such as Gnome or KDE. Directories that you share using NFS are referred to as shares.

To open the utility from the KDE desktop, select the KDE menu, point at System Settings, and then select NFS Server. Figure 10.14 shows the NFS Server Configuration tool.

Figure 10.14. You can configure the NFS server using the NFS Server utility.

To create a new share, follow these steps:

  1. Click the Add button in the HFS Server Configuration tool. The new share dialog box opens.

  2. Supply the directory name that you wish to share (you can use the Browse button to locate it).

  3. Specify the hosts that you will allow to access the share. You can specify hosts by host names (FQDN names) or IP addresses. To allow access from a number of hosts you can use the asterisk (*) as a wildcard. For example, in Figure 10.15 the entry 192.168.186.* allows all hosts in the 192.168.186 subnet to access the share.

    Figure 10.15. Specify the directory for the share and the hosts that can access the share.

  4. You can set the permissions to Read-only or Read/Write by selecting the appropriate option button.

  5. You can also allow anonymous access to the share and set other access parameters such as allowing remote root users to have local root privileges. Select the User Access tab on the Add NFS Share dialog box. Select the appropriate check boxes. You can also specify that anonymous users be assigned the privileges of a local user or assign the anonymous users to a particular group on the Linux computer (see Figure 10.16).

    Figure 10.16. Set user access options for the share on the User Access tab.

  6. When you have completed entering the information for the new share, click the OK button. The share will be listed in the NFS Server utility window.

Once the share is configured, you must start the NFS service to make the share available. Click the Apply button in the NFS Server utility window. A message box will appear asking you if you wish to start the NFS service. Click Yes.

You can also configure NFS shares using the command line or the Linuxconf GUI configuration tool. We will look at how a client browses for network resources such as NFS shares later in the chapter.

Sharing Printers

Providing print services to network clients is one of the roles fulfilled by network servers. You can share local printers (a printer attached directly to the Linux server) on the network and also attach to remote printers. Linux workstations can access printers shared through Samba, Unix printers (local printers hosted by other Linux computers), NetWare printers, and printers connected directly to the network (direct connect printers). For an explanation of the basics of network printing see Chapter 7, "Network Operating System Overview."

The most straightforward method of connecting to a local printer or configuring a remote printer in Red Hat is to use the Red Hat Printer Config utility. To open the utility from the KDE desktop, select the KDE menu, point at System Settings and then click Printing.

To add a local or remote printer to the computer, select the New button in the utility window. The Add a New Print Queue dialog will open. You can click Forward to bypass the initial screen.

On the next screen you enter a queue name for the new printer (the name is up to you, as long as the name begins with alphanumeric characters) and then you select the queue type, as shown in Figure 10.17.

Figure 10.17. Select the queue type for the new printer.

Once you select the type of queue, you are walked through the process of adding the printer. In the case of Local Printer, you will need to select the device that the computer is attached to, such as the parallel port (lp0) or a USB port. You then select the driver for the printer from a number of supplied drivers (there are a large number of drivers available for most of the popular printer manufacturers and their products). Once the driver is selected, you are ready to test the printer connection.

In the case of remote printer connections such as Unix or Windows printers, you create a queue name as you do for a local printer and then you supply the name of the print server (the fully qualified domain host name for the computer that hosts the printer) and then select the appropriate print driver.

No matter whether you are attempting to attach to a local or remote printer, the Add a New Print Queue dialog walks you through all the necessary steps. Once you have completed the configuration of the print queue, you can test your printer settings by clicking the Test menu in the Red Hat Printer Config window and selecting one of the test print jobs listed.

You can make local printers available on the network using Samba, which is very useful in cases where there are Windows clients. However, in the case of a network that is made up of Linux servers and Linux clients, it is easier to configure the Linux clients with their default printer queue pointing to a remote printer hosted by another Linux computer. All you have to do is configure the print clients as we have discussed in this section using the Red Hat Printer Config utility.

On the Linux computer that is serving as the print server for the printer (the computer that the printer is actually connected to), you will have to place a file named /etc/hosts.lpd that contains the IP address or hostname of each computer that should have print privileges for the printer.

You will have to create this file as root (log in as the root account) and then you can create the file using any text editor supplied by Red Hat. Make sure that you save the hosts.lpd file in the etc directory on the computer that will provide the print services.

Browsing for Resources

You will want to set up your Linux clients so that they can browse for shared files on the network. A client can browse for resources on the network using the Conqueror file/Web browser that is provided as part of the KDE desktop.

Before a client begins to look for network resources, you might want to configure and enable Lisa on the system. "Lisa" is short for LAN Information Server. Lisa uses the TCP/IP protocol stack to create a network neighborhood in the Conqueror browser. Getting Lisa up and running is a two-step process.

First, you can automatically configure Lisa using the LAN-Browsing KDE Control Module shown in Figure 10.18. To open the configuration utility on the KDE desktop, select the KDE menu, point at Preferences, then point at Network, and then select LAN Browsing.

Figure 10.18. Configure Lisa automatically.

To auto-configure Lisa, click the Guided LISa Setup button. You will be walked through the process of configuring Lisa, including the way Lisa contacts other computers (Ping packets or NetBIOS broadcasts) and the range of IP addresses that should be contacted.

After Lisa has been configured, you must start Lisa. All you have to do is open a terminal window and using the root account (type su and then the root password to operate as root in the terminal), type the command lisa. Lisa will be enabled.

You can then browse the network from the computer using Konqueror. The easiest way to open Konqueror on the KDE desktop is to select the Home icon (which resides on the desktop). To browse the LAN, type lan://localhost in the Konqueror address box. Figure 10.19 shows the results of browsing a network with Lisa. A number of hosts appear in the Konqueror window.

Figure 10.19. Browse the network with Lisa enabled.

To access any resources provided by a particular host, double-click to open the host icon. You can also browse specifically for Windows clients on the networks by typing smb://computer name, where computer name is the host name of the Windows client.

NFS shares on the network can be mounted from the command line using the mount command. To mount shares you must be enabled as root. Mounting a share basically takes the remote share and mounts it in an existing directory on the local machine. So, you need to have a mount point on the local machine, meaning a directory that can be hijacked to host the remote directory. When you mount the remote share to the local directory, you won't be able to get at any files that were originally in the local directory. So, you will probably want to create an empty directory on the local machine to specify as the mount point for the remote share.

In a terminal window where you are logged in as root, you would use the following command to mount a remote share:

mount hostname:/misc/project100 /project

where hostname would be the name of the computer, such as popeye.spinach.com. The share being provided by popeye.spinach.com would be /misc/project100, which identifies the exported NFS directory. The /project at the end of the command specifies the local directory that you want to use as the mount point for the remote share.

After the share is mounted, you can use the Konqueror browser to locate the mount point directory. When the directory is opened on the local machine the remote files will be available.

Tip

You will want to set up Lisa so that it starts automatically when you boot the Linux box. For information on downloading, configuring, and starting Lisa, check out http://lisa-home.sourceforge.net. You can also get additional information related to Lisa at the KDE Web site—www.kde.org.


Monitoring the System and Network

As with any other operating system platform, Red Hat Linux provides a number of tools for viewing system performance and also for capturing data packets on the network to analyze network traffic. For example, you can monitor system resources using the Red Hat System Monitor. To start the monitor from the KDE desktop, select the KDEO menu, then System Tools, then System Monitor. The monitor provides two tabs. The Process Listing tab allows you to view all running processes. It can also be used to end processes that have locked up or stalled. The System Monitor tab of the System monitor shows you CPU usage and memory /swap usage, as shown in Figure 10.20.

Figure 10.20. Use the System Monitor to view CPU and memory usage.

For monitoring network traffic, there is the Ethereal Network Analyzer. It allows you to capture network packets, including those using specific protocols such as TCP, NetBIOS, and IPX. You can start the Ethereal Network Analyzer from the KDE desktop by selecting the KDE menu, pointing at System Tools, and then selecting Network Analyzer.

To start a capture, click the Capture menu, and then click Start. A Capture Options dialog box will open, allowing you to select the interface used for the captures. You can also set capture limits that stop the capture after a certain amount of time has passed or number of packets has been captured. You then click OK to start the capture.

Figure 10.21 shows the Ethereal Network Analyzer screen after a capture has been completed (by clicking Stop). The top pane of the analyzer shows the captured packets.

Figure 10.21. The Ethereal Network Analyzer is a GUI network protocol analyzer.

When you select a packet in the top pane, the middle pane provides details for the captured packet, such as frame type and protocols for the packet. The actual hexadecimal code for the packet is provided in the bottom pane of the analyzer.

Capturing packets from the network allows you to analyze network traffic. It also provides you with clues to connection problems or even malfunctioning devices, such as a bad network interface card that is flooding the network with bad packets.

Tip

Although it is not a monitoring tool per se, you should definitely become familiar with the Service Configuration utility. It allows you to see a list of all the services on the system. You can see the services that were started when the system booted (they will have a check mark next to them). You can also select a service that has not started and start it from the utility. On the KDE desktop, you access the Service Configuration utility by selecting the KDE menu, then System Settings, then Services.

The number of system and network tools you install on your Linux server is really a matter of how much research and downloading you want to do. There are many open system tools for monitoring the health of your Linux system and network. Take a look at www.linux.org as a starting place for your explorations. Linux is certainly the most experimental of the network operating systems that we have discussed in this book. However, it does provide as solid an alternative for deploying network services as industry standards such as Microsoft Windows Server 2003 and Novell NetWare.

The Absolute Minimum

In this chapter we took a look at the Linux operating system platform in the form of Red Hat Linux 8.0. We discussed installing the software, and we also looked at providing network services using Linux, as well as a number of the GUI tools that can be used to administer a Linux system.

  • Three important aspects of installing Red Hat are creating the Linux and swap partitions, selecting a boot loader for the system, and creating a password for the administrative root account. Both the text and GUI installation interfaces walk you through the steps of installing Red Hat.

  • Linux systems (specifically Red Hat) provide a number of GUI administrative tools, including the Network Configuration utility, Hardware Browser, and the Service Configuration utility. All aspects of the system administration can also be accomplished using commands in a terminal when logged in as root.

  • Linux provides network services such as DNS and DHCP, and can act as a Web server, file server, and print server.

  • Files can be shared in a number of different ways on a Linux system. The possibilities include FTP, Samba, and NFS. Shared resources can be located using the Conqueror browser or mounted via the command line.

  • Printers can be shared on Linux systems. Local and remote printers can be installed on a Red Hat Linux computer using the Printer Config utility.

  • Linux also offers tools for monitoring system resources and analyzing network protocols. The Red Hat System Monitor allows you to view running processes and view CPU and memory usage. The Ethereal Network Analyzer allows you to capture and analyze packets from the network.


Chapter 11. Working with Applications on the Network

In this chapter

  • Deploying user applications on the network

  • Understanding groupware products

  • Using GroupWise

  • Working with Lotus Notes

  • Understanding Exchange Server

  • Working with shared databases

  • Understanding Microsoft's .NET Initiative

So far we have concentrated on how networks actually function: We've discussed network protocols, the OSI model, peer/client operating systems, and network operating systems. Our next area of focus is the application. Application software provides us with the various productivity tools we use to actually get work done. Users on a network can take advantage of all sorts of applications; although we usually think of word processing and spreadsheet software as typical applications, other client applications are used to access special servers. These applications provide communication services and access to special databases.

Let's begin our discussion of applications with a short discussion on how selecting the software to be used on your network should be approached. We can then look at specific productivity software, such as Microsoft Office.


Selecting Application Software

Before you can deploy application software either directly on client computers or over the network (both of which are discussed in the next section), you must first select the applications that will allow your various users to get their work done. The process for selecting software for end users should not only revolve around the features provided by the software but also the overall usability of the interface that the software provides.

While in an ideal world, cost would not be an issue in choosing the best software for your company or home office, we, of course, do not live in an ideal world. So, you will have to weigh software features and the user-friendly factor in light of the cost of the software.

Before selecting new software, you should test the software. This might mean buying a copy or two of the software package and testing it in a "mock" network setting to get a picture of the overall usability of the software and how it performs in a network setting. Since, on a small network, buying "test" copies might be prohibitive, take advantage of the fact that most software vendors do provide limited-use demo copies of their software either in the form of shareware or trial versions. Usually the cost of a trial CD is limited to shipping and handling. Testing the software first can save a lot of headaches in the future.

Ideally, setting up an end-user focus group to test the software and then comment on its strengths and weaknesses can help you determine the overall usability of the software. Using this information, along with other factors such as cost and licensing issues, can help you decide whether or not the software will be appropriate for your network (and your users). Many software vendors also supply white papers and various case studies that allow you to see how other companies have deployed and used the software.

Having worked in the computer networking field for a number of years, I have sat in meetings and presentations on a number of occasions where I have heard network administrators and information systems managers say the following:

"I see no compelling reason to deploy or upgrade to that particular software product."

Now, reading between the lines this statement can mean a number of things. It can mean that the network administrators have not done their homework and know nothing about that particular software product. It can also mean that the features provided don't outweigh the overall cost (both in terms of the time needed for configuration and deploying the new software and the budgetary hit) that will be required to deploy the software on a companywide basis.

Corporate executives will often (unless there is a real budget crunch) want to have the latest and greatest software running on their networks. It almost seems to be a status thing, so that they can say they are running "Super Software 2005" on their network when they are playing racquet ball or golfing with their executive buddies.

Network administrators must do their homework and also exercise great diplomacy in guiding corporate officers into making the right decisions in regard to selecting software for end users. Keep in mind that you will have to support software on the network and poor software selections will only reflect on you, because you have to keep them up and running.

When selecting software, use the following list of questions as a starting place:

  • How much will it cost for the software and software licenses necessary to deploy the software on the network?

  • How many administrative hours will be required to deploy the new software?

  • Will client computers or servers on the network need to be updated to run the new software (and what will be the cost)?

  • Will end-user training be required for users to get the most out of the new software?

  • Does the new software supply features and functionality that are not currently available using software already available on the network?

  • Is the software compatible with software currently running on the network?

When choosing new software, go slow, do your research, and get as much input from your user base as possible. And don't reject new software versions outright just because it will mean more work for you. Having a network that runs well but doesn't provide the proper productivity tools for end users will eventually come back to haunt you.


Using Application Software on the Network

In the pre-Windows days of the PC revolution, applications such as Lotus 1-2-3, dBASE, and WordPerfect were the primary productivity tools for business users of the PC. Over time, the single application has been displaced by the application suite, which provides an integrated group of applications that share a common interface.

Suite products, such as Microsoft Office, Sun's StarOffice, and Corel's WordPerfect Office, provide a word processor, spreadsheet, database, and variety of other applications (depending on the application suite you are using). Suite products also typically offer versions that run on different operating systems. Microsoft Office is available for both Windows and the Apple OS. StarOffice runs on Windows PCs as well as Unix and Linux workstations. WordPerfect Office provides multiple-platform support and is even available in a platform-independent Java-based version.

The network administrator (meaning you) must make a major decision related to end-user applications: Should they be installed on each client machine or run over the network? Both of these scenarios have pros and cons. Let's take a look at each.

Client-Based Applications

Installing end-user applications on client PCs requires that the PCs have the appropriate hard drive space to accommodate the software files. You must also purchase a separate copy of the software for each client PC or purchase a license for each client.

Having the software files for the application suite actually reside on the client machines can make them more vulnerable to "accidents," such as end users who decide to clean up all those "unneeded" files on their PCs. Applying updates and other fixes to the software can also be a hassle because the update files will have to be placed on every client computer.

So far I've been emphasizing the downside of installing applications on your network clients, but there are some compelling issues on the upside. First of all, running applications locally on client computers does not put additional stress on network servers or eat up a lot of network bandwidth. Running applications locally also means you won't have the added cost of deploying an application server. Another plus of installing applications on the client computers is that the users can continue to work even if the network goes down.

Note

Selecting the appropriate suite product for your network users should revolve around issues such as features, cost, your network operating system, and the OS running on your client computers. You should also carefully weigh other issues, such as product support and the user learning curve, when you select an application suite for your user base.

Network-Based Applications

As mentioned in the previous section, running applications from a network application server can result in network slowdowns. However, providing software applications from a network server means that only a subset of the applications' files need to reside on the network clients, meaning you don't have to deploy client computers with large hard drives.

Keeping applications on the network also makes it easier for you when updating the software, and you can protect the actual application files from "accidents." Licensing network clients to use applications running on a server can also (in some situations) be cheaper than licensing the software for installation on each client.

As is the case with every other deployment issue we've discussed in this book, you need to do some research before you select an application suite for your network users. It also makes sense to do some testing (and some research to find case studies) to see whether running an application from a server is a better way to go than installing the application on each client computer.

Sharing Application Files with SharePoint

Although we have already discussed sharing folders and directories in Chapter 7, "Network Operating System Overview," I wanted to briefly discuss a new option provided by Microsoft for sharing files on an extranet (a network that operates outside your LAN). One of the largest extranets available to companies and organizations is the Internet.

Microsoft has developed a new product called SharePoint Portal Server. While users have always been able to connect to LANs using dial-in remote access and Virtual Private Networking (secure connections over the Internet; both remote access and Virtual Private Networking are discussed in Chapter 17, "Networking on the Run"), Microsoft has built a new feature into the Microsoft Office 2003 applications (such as Word and Excel) that provides the ability to save files and access files over the Web (or any corporate extranet). The files are stored on the SharePoint server (your company can deploy its own SharePoint server or take advantage of the SharePoint services provided by Microsoft).

Users do not really have to do anything special to take advantage of the storage space on the SharePoint server. All they need is access to the Internet (and the SharePoint server) and be able to create a document workspace within one of the Microsoft Office 2003 applications.

Let's take a look at how you (or any user on your network) would create a document workspace in Microsoft Word as an example (knowing that the ins and outs of deploying a SharePoint server are beyond the scope of this introductory book); first you would open the document (or create it) that will be available in the shared workspace. Then you select Tools, then Shared Workspace. The Shared Workspace task pane opens as shown in Figure 11.1.

Figure 11.1. A shared workspace can be created for your Office documents.

You then type the URL (uniform resource locator, or Web address) for the workspace that will serve as the holding area for the shared document in the Location for New Workspace box (this would be the URL for the SharePoint server).

When you click the Create button in the task pane, a connection box will appear that requires you to enter your user name and password for the shared workspace. After entering the information, click OK. The shared workspace will be created (on the Web site you designated) and a copy of the current document will be placed in the workspace.

As the creator of the site, the user is designated as the site owner (this allows your users to control their own sites that hold their documents). The user can then add new members to the site, which provides them access to any documents that are stored on the site. The user can also view who is currently online and working on the document. Figure 11.2 shows a document that is shared in a workspace. Note that the Shared Workspace task pane lists the current users of the workspace and whether or not they are currently online. Tools provided in the task pane allow you to quickly email workspace users and to update the workspace status.

Figure 11.2. The Shared Workspace task pane allows for the management of the workspace and its users.

Using document workspaces in Microsoft Office 2003 applications allows your users to access files, such as Word documents and Excel workbooks, from anywhere they have access to the Web. This allows workers at home or on the road to access files and collaborate with other employees as needed.

Working with Groupware Products

Allowing users to communicate and collaborate is a very important aspect of deploying a corporate network. Communication services and collaboration tools are provided on a network by a communication server. Its purpose is to offer different avenues for user-to-user communication on the network. This type of server provides services such as electronic mail, shared scheduling, and discussion groups (for the posting of messages).

A communication server operates in a true client/server fashion, where client applications are used to communicate with different communication services on the server. The client/server software that runs on a communication server is often referred to as groupware. Groupware is best described as a suite of client communication software used to communicate with a communication server package.

Groupware applications are designed for user communication and collaboration. They offer such services as the following:

  • Electronic mail system. The groupware communication server serves as the mail server for internal email systems and/or Internet email.

  • Group scheduling. A centralized scheduling system is maintained on the communication server.

  • Discussion groups. Users can read and post messages to a discussion database. Discussion groups can be created for the discussion and development of projects by users on the network.

  • Information databases. Databases such as an employee handbook and a centralized employee address book (including email and phone extension information) can be hosted by the communication server.

  • Task automation. Forms can be developed that allow users to order office supplies online and invite users to a meeting.

The fact that all these communication resources are centrally held on the communication server means any user on the network can access a particular service, such as email or the calendar/scheduling service. Even remote users can log on to the network and access the services on the groupware server.

Groupware products run on top of an existing NOS on a network server. These communication packages can experience a large number of user connections at any one time. Not only does a server used to run a groupware product need the appropriate muscle to run the underlying NOS, but it also needs to be able to process numerous requests and store a number of online databases. Large hard drives (or multiple drives in a stripe set), generous amounts of memory, and perhaps even multiple processors are typical hardware needs for a communication server. Because information stored on the server hosting the groupware applications can change by the minute, it is also important to perform a daily backup of the communication server (for information about server backup strategies, see Chapter 18, "Protecting Network Data").

A number of groupware products are available on the market. These include GroupWise from Novell, Lotus Notes, and Microsoft Exchange Server. Let's take a look at each of these groupware environments individually.

Using GroupWise

GroupWise 6.5 (the version available during the writing of this book) is Novell's groupware product. It allows users to send email messages and enter tasks and appointments. GroupWise also provides a Contacts folder and allows real-time communication with other users via the GroupWise Messenger (which is similar to Internet communication mediums such as AOL Instant Messenger and Yahoo! Chat).

GroupWise is a client/server communication platform. You must configure a GroupWise server to provide the post office and communication services for your network users. User computers must have the GroupWise client installed on it.

The GroupWise server product not only runs on a Novell NetWare server but can also be deployed on computers running other operating systems such as Windows (Windows 2000 or NT for example). The GroupWise client can run on computers running Windows, the Mac OS, and Linux.

User accounts for GroupWise are actually maintained in the Novell eDirectory (GroupWise actually extends the eDirectory to handle the GroupWise user accounts when GroupWise is installed on the server). This means that you create the various user accounts using the NetWare Remote Manager or the ConsoleOne tool. If you are running the GroupWise server on a platform other than NetWare you can use the Console1 tool to create your user accounts as shown in Figure 11.3.

Figure 11.3. Create user accounts in the eDirectory and add them to the GroupWise post office.

As mentioned before, you must install GroupWise on your server and then configure a post office. Once the post office is up and running, you can install the GroupWise client on your network client computers. GroupWise makes this an easy task since the client software needed is placed on the server. You can share the folder that contains the client software and install it on clients over the network as needed.

The client software provides an application window that provides access to the user's mailbox, calendar, and other GroupWise items. Figure 11.4 shows the GroupWise client with the Calendar folder selected.

Figure 11.4. Create user accounts in the eDirectory and add them to the GroupWise post office.

As with any groupware product, GroupWise allows a user to send and receive email. A GroupWise address book provides easy access to the email addresses of other users on the network. An email address can be selected from the address book and then email can be sent to that user as shown in Figure 11.5.

Figure 11.5. Email can be sent (and received) from the GroupWise client.

You will most often find GroupWise deployed on NetWare networks (although, as I said at the outset, it can be run from servers other than NetWare servers). It provides all the communication tools that you would expect from a groupware product. Managing the GroupWise environment also provides additional challenges to a network administrator who works with a NetWare network implementation.

Note

Running the GroupWise server product on a platform other than a NetWare server requires that you also provide the NetWare eDirectory. There is actually a version of the eDirectory that will run independent of a NetWare server. For more about the basics of eDirectory see Chapter 8, "Networking With Novell NetWare 6.5".

Using Lotus Notes

Lotus Notes provides a client/server groupware environment that can be run on a number of different network platforms. As was the case with GroupWise, Lotus Notes has both a client and a server side. The client side is referred to as Lotus Notes and the server side is called Lotus Domino Server. The Lotus Notes client software can be run on a number of Windows clients. Figure 11.6 shows the Lotus Notes (Release 6) client software interface on a PC running Windows XP.

Figure 11.6. The Lotus Notes client software provides users with easy access to communication services on the Lotus Domino Server.

The server product is called Lotus Domino Server. It is an add-on communication server that is compatible with Windows Server, NetWare, and Sun Solaris. Lotus Notes supports communications using a number of different network protocols, including TCP/IP, NetBEUI, and IPX/SPX. Figure 11.7 provides a look at Lotus Domino Server running on a Windows 2000 Server.

Figure 11.7. Lotus Domino Server runs on top of an existing NOS.

Lotus Notes Administration

As you can see from Figure 11.7, Lotus Domino Server can be monitored and controlled using a command-line interface. Fortunately, Lotus provides an administrative tool—the Domino Administrator—that has a fairly easy-to-use interface for managing the Domino server.

The Notes administrator (who could be the network administrator or someone assigned the duties of managing the communication server) can monitor, manage, and add resources to the Domino Server. The Domino Administrator software can be installed on any network client to manage the Domino software remotely (much like the NetWare Administrator). For example, the Notes administrator can use the Domino Administrator tool to view the different communication servers on the network and the users and groups on the server (see Figure 11.8).

Figure 11.8. Domino servers and the resources they offer on the network can be monitored using the Domino Administrator.

The Domino Administrator software can also be used to create new resources on the Domino server, such as a discussion database. Figure 11.9 shows the creation of a new discussion database on a Domino server. Users provided access to this database (resource security is another aspect of managing the communication server) will be able to read and post messages in this database.

Figure 11.9. A discussion database, as well as other types of new resources, can be created using the Domino Administrator software.

Although the Domino Administrator software's easy-to-use interface might make it easy to manage the communication server running Lotus Domino Server, the actual management tasks required to properly control the Notes/Domino groupware environment—such as creating user accounts and creating new Notes databases—are not. As with any NOS or special network service, it is important that you get the training or have the experience necessary to provide network users with a stable and consistent network resource.

Lotus Notes Client Operation

Because the Notes/Domino environment provides communication services, the Notes client provides a network user with the tools to send email messages, set up meetings, schedule appointments, and read and add information in different Notes databases.

For example, a Notes client can send email to a user or users on the network. If the Domino Server has been configured to handle Internet email, the Notes client can also send email to anyone with an email address. Figure 11.10 shows the new message screen used to compose email with the Notes client.

Figure 11.10. The Notes client provides an email tool for composing new messages.

Users on the network access resources on the Domino server using the Notes client. The Notes client provides access to all the different communication services provided by the Domino server, such as email (which was already mentioned), a calendar, a global address book, and discussion newsgroups.

One thing to remember about a groupware platform such as Notes/Domino is that all data related to a particular user is stored on the Lotus Domino Server machine. This makes it possible for the communication server software to verify whether a particular employee is available for a meeting. It also allows users to temporarily have their email inboxes managed by other users when they are away. User collaboration is the theme of groupware such as Lotus Notes.

Using Microsoft Exchange Server

Microsoft Exchange Server is Microsoft's take on groupware. Microsoft Exchange Server runs on a server-class computer that is configured with the Microsoft Windows 2000 Server or Microsoft Windows Server 2003 NOS. Microsoft Exchange is tightly integrated with the Windows Active Directory. This means that not only are certain Exchange Server administrative duties handled from the Active Directory, but information in the Active Directory database, such as users and groups, is shared with Exchange Server.

Installing Exchange Server on a server requires a very solid knowledge of the Windows server environment and the Active Directory, and so is beyond the scope of this book. Before you can even install the Exchange Server software, utilities must be run that upgrade the Active Directory forest and domain (for more about the Active Directory hierarchy, see Chapter 9, "Networking with Microsoft Windows Server 2003").

Exchange Server offers email services, discussion groups, and shared calendars—all the communication services that you would expect from a groupware product. The client application used to communicate with Exchange Server is Microsoft Outlook. Outlook is part of the Microsoft Office suite.

Exchange Server Administration

Exchange Server administration is actually handled by two different tools on the server: the Active Directory and the Exchange System Manager. Because the Active Directory is used to manage user accounts and other objects on the network, it's no surprise that new email accounts for users are actually created in the Active Directory Users and Computers snap-in (see Figure 11.11) when you create a new user.

Figure 11.11. Exchange email accounts for network users are created in the Windows Active Directory.

Administrative functions related to Exchange Servers on the network and different global address lists are handled using the Exchange System Manager. This utility can also be used to view user folders (such as the Inbox, calendar appointments, and so on) stored on the Exchange server. Figure 11.12 shows the Exchange System Manager (this is the manager used in Exchange Server 2003).

Figure 11.12. The Exchange Server environment is managed using the Exchange System Manager.

Outlook Client Operation

Microsoft Outlook can be used as a standalone product or as a client for Microsoft Exchange Server. Outlook supports a number of different email services, including the following:

  • Microsoft Exchange Server. This type of account makes Outlook an Exchange Server client, and mail boxes and other resources, such as shared public folders, are managed on the Exchange Server computer.

  • POP3. POP3 is a protocol that allows a POP3 email server to function as a mail drop. This means that your Internet email is forwarded to the POP3 server and sits there until you connect with your email client (Outlook) and download the mail to your computer.

  • IMAP. IMAP is a protocol that allows Outlook to download email from an IMAP mail server. IMAP differs from POP3 in that your email is not removed from the mail server when you connect to the server with your email client (Outlook); you are only provided a list of saved and new messages, which you can then open and read. IMAP is particularly useful when one email account might be accessed by more than one computer (or other remote devices), allowing the same messages to be available from more than one device.

  • HTTP. The Hypertext Transport Protocol is the set of rules that allows you to browse Web sites using a Web browser. HTTP email is accessed via a Web site, and your inbox actually resides on a server that is hosted by the provider of the email Web site, such as Microsoft (in the case of Hotmail) or Yahoo! (in the case of Yahoo! mail). Outlook can be configured to act as your email client for HTTP mail such as Microsoft Hotmail.

When Outlook is used as an Exchange Server email client, users are afforded special abilities not available when Outlook is used as an Internet email client. Sent messages can be given expiration dates, and messages that have not been read can even be deleted from a recipient's mail box or updated with new versions of these messages.

Using Outlook on an Exchange server also provides users with access to the global address book, making it easy to send email to other users on the network or to create distribution lists for messaging, as shown in Figure 11.13.

Figure 11.13. Outlook can access address books including Outlook Contacts and the global address book on the Exchange Server.

Outlook provides easy access to a user's inbox, calendar, contacts list, and other communication/organizational tools (see Figure 11.14, which shows Outlook 2003). An Outlook user can create meetings that automatically invite the participants, as well as create tasks that are assigned to other users on the network. Outlook and Exchange Server provide a fairly user-friendly groupware environment that enables network users to collaborate with each other.

Figure 11.14. Outlook provides personal informational management tools that can be used by network users to collaborate with each other.

    [ Team LiB ]


Understanding Microsoft .NET

Before we leave the realm of Microsoft communication server strategies, a few words should be said related to Microsoft's .NET initiative. Microsoft's .NET initiative revolves around sharing applications and data over the Internet using XML Web services (and other Web connectivity tools and programming languages). Microsoft promises that this technology will not only connect computers to computers on the Net, but will also link smart devices such as cellular phones and PDAs to the application and data network that .NET services provide.

The real power of .NET (and other non-Microsoft strategies being pursued by developers) is that services, including applications, can be shared over the Internet using secure HTTP. This means that simple hardware devices (remember the stripped-down Web computer concept?) will be capable of accessing complex applications and databases on servers using existing Web protocols.

Microsoft has taken a broad approach as it attempts to make .NET a reality. It has provided developers with a number of tools (.NET Visual Studio, for instance) for creating XML Web services and has also developed the network operating systems that will be deployed on servers that distribute XML applications, content, and other .NET–connected applications. Server products such as Windows Server 2003 actually provide a tool for deploying XML applications on a network called the .NET Framework Configuration tool.

XML, the .NET Framework, and other strategies for data exchange on the Web constitute a huge body of information that will be necessary for managing the enterprise networks that evolve over the next few years. Two good resources that will help you begin to build your own .NET knowledge base are these books: Sams Teach Yourself .NET XML Web Services in 24 Hours and Building e-Commerce Sites with the .Net Framework. Also check out www.microsoft.com for white papers and other information related to .NET.


Understanding Client/Server Databases

Another client/server environment found on corporate networks is the shared database. Shared databases allow users to access information that is held centrally on a database server. This central database may hold customer information, employee information, or data related to a particular project.

The centralized database is certainly not a new concept to computing; large database systems were an integral part of early mainframe and miniframe environments. Oracle Corporation's powerful Oracle client/server database environment started out as a product for the miniframe environment but has evolved into a multiplatform client/server system that can also be run on Pentium-based LAN servers.

Client/server databases require both a dedicated server and a client front end. The database server software, also referred to as the database engine, is designed to accept requests for information (a request to a database for information is called a query) from clients on the network. The actual query is made by the client software on the user's computer. Because the exchange of data between the database server and the database client is transparent to the user, the features and functionality provided by the database client will be the same as if the database resided locally on the user's computer.

An excellent example of a client/server database system is Microsoft's SQL Server (SQL stands for Structured Query Language; it is the language used by the database client software to send queries to the database server). SQL Server is an add-on product that runs on an existing Windows server.

The client front end used to query SQL Server is Microsoft Access. Microsoft Access is a powerful standalone database software application in its own right. It provides all the tools needed to create complex relational databases. Figure 11.15 shows an Access window and an open Access/SQL project.

Figure 11.15. Shared databases need a client front end, such as Microsoft Access.

Client/server technology has been changing by leaps and bounds because of the Internet and the desire of companies to try their hands at e-commerce. Any time you book an airline reservation online or order a book from an online bookstore, you are taking advantage of client/server database technology. We will talk more about e-commerce in the section "The Internet and Your Corporate Presence" in Chapter 16, "Hosting a Web Site".

Note

SQL databases accessed by Access are called projects. All the familiar Access objects, such as tables, forms, queries, and reports, are used when working with a SQL database project. This provides any end user with some experience in Access an easy-to-use front end for creating queries, entering new data, and printing out reports as he or she communicates with the database server.

The Absolute Minimum

In this chapter we looked at using applications and groupware products on the network. Novell GroupWise, Lotus Notes, and Microsoft Exchange Server were discussed. We also took a look at Microsoft's .NET Framework and how client/server databases operate.

  • Software suites have replaced standalone applications as the primary productivity tools for end users. Applications suites such as Microsoft Office can be installed on client computers or run from a network server.

  • Groupware products provide communication tools for network users. These tools include email, discussion groups, and shared scheduling. Examples of groupware products are Novell GroupWise, Lotus Notes, and Microsoft Exchange Server.

  • Microsoft (and other companies) are looking at different strategies for moving data via the Web. Microsoft's .NET Framework supplies programming tools and server platforms for deploying XML applications and other Web connectivity strategies.

  • A shared database provides a client/server environment where network users can query the database, which is located on a server.

  • A shared database requires a server platform and a client that can act as the front end for the database.

  • Microsoft's SQL Server provides a shared database environment where users on the network can use Microsoft Access as their front-end client.


Part III: Expanding Your Network

TCP/IP Network Administration

Expanding a LAN with WAN Technology

How the Internet Works

Connecting a Network to the Internet

Hosting a Web Site

Networking on the Run


Chapter 12. TCP/IP Network Administration

In this chapter

  • Working with IP addresses

  • Working with DHCP

  • Understanding DNS

  • Understanding IP routing and subnetting

  • Introducing IPv6

In Chapter 5, "Network Protocols: Real and Imagined," the basics of the TCP/IP protocol stack were discussed. TCP/IP has become the de facto standard for networking. In this chapter we look at issues related to IP addressing and the TCP/IP protocol stack, including name resolution (DNS) and the Dynamic Host Configuration Protocol (DHCP), which allows you to dynamically assign IP addresses, subnet masks, and other information related to IP to network clients. We will also look at how IP communication takes place via ports and sockets. A basic primer on IP subnetting and IP routing are also provided, as is a discussion of the newest version of IP, IPv6.


Working with IP Addresses

As was discussed in Chapter 5, the addressing scheme used by the TCP/IP protocol stack is provided by the IP protocol. As you already know (if you read Chapter 5), the IP addressing scheme has been divided into three classes: A, B, and C. Each of these classes has a default subnet mask.

For devices to communicate on the network, they must be configured with a valid IP address and subnet mask. One way to configure a computer or network printer with an IP address and subnet mask is to manually configure the device. We will look at configuring a PC with an IP address and subnet mask in a moment.

For a computer (or other device) to communicate properly on an IP network, there are also other IP-related parameters that need to be configured on the computer. For example, computers on a network need to be configured with the IP address of the network DNS server (or servers). DNS is used to resolve "friendly names" to IP addresses (and vice versa). DNS is discussed later in the chapter.

Note

Acquiring a range of IP addresses for your network (in effect, leasing them from a service provider), as well as the advantages of using a proxy server or Network Address Translation in relation to network IP addressing, are discussed in Chapter 15, "Connecting a Network to the Internet".

Computers also need to be configured with a default gateway. The default gateway is the router for the segment of the network that the computers belong to. Each segment connects to a router interface that has its own IP address (just like a network interface card—routing is discussed later in the chapter).

If you are still using legacy versions of the Windows operating system on client computers (pre-Windows 2000 versions) on a Microsoft Windows network, the computers (and some legacy applications) rely on NetBIOS names to communicate. On an IP network, there must be a mechanism that resolves NetBIOS names to IP addresses. A server running the Windows Internet Naming Service (WINS) can resolve NetBIOS names to IP addresses. If you use WINS on the network, it makes sense to configure the IP settings of your clients so that they know the IP address of the WINS server.

So, you can see that there is more to configuring an IP client than just providing a unique IP address and the appropriate subnet mask. Let's take a look at how you configure the various IP related settings discussed in this section. We can then look at an alternative to manually configuring IP clients.


Configuring IP Addresses

Whether you are dealing with a server or a network client, the computer must be configured with an IP address and subnet mask or configured to request this information from a server running the Dynamic Host Configuration Protocol (DHCP), which is discussed in the next section.

The TCP/IP protocol stack is added to a computer's configuration by default by most client and network operating systems. For example, when you install Red Hat Linux on a computer, you are asked during the installation process to either enter an IP address and subnet mask or allow the computer to request the IP addressing information from a DHCP server (for more about Red Hat installations see Chapter 10, "Networking with Linux").

In the case of Windows servers and clients (the clients are used on both NetWare and Microsoft networks), TCP/IP is the default protocol for networking. By default the computers are configured to receive their IP addressing from a DHCP server. In the cases of network servers, however (especially those that serve as domain controllers running the Active Directory), you must configure the computer with a static IP address (the opposite of a dynamic address received from a DHCP server).

For example, to configure the TCP/IP settings for a server running Windows Server 2003, you open the Local Area Connection Properties dialog box on your server. Then click the Internet Protocol (TCP/IP) and select Properties. The Internet Protocol (TCP/IP) Properties dialog box opens (see Figure 12.1).

Figure 12.1. You can configure the IP address, subnet mask, and other settings in the Internet Protocol Properties dialog box.

In the Properties box, you can configure the IP address and subnet mask for the server and the default gateway and preferred DNS server. As was mentioned in the previous section, other settings related to the TCP/IP stack can also be set.

To configure advanced settings such as additional gateways, DNS servers, and WINS servers, click the Advanced button in the Properties dialog box. The Advanced TCP/IP Settings dialog box appears. A separate tab is provided for gateway, DNS, and WINS settings, as shown in Figure 12.2.

Figure 12.2. The Advanced TCP/IP Settings dialog box.

Note

WINS servers (the WINS service is available on Windows Server 2003) cut down on the broadcast messages that are used by computers as they attempt to resolve NetBIOS names to IP addresses. Deploying a WINS server helps conserve network bandwidth by cutting down on client broadcast messages.

Windows clients have dialog boxes similar to those shown here for the TCP/IP settings on a Windows server. As you can see, configuring a large number of network clients with IP addresses, subnet masks, and the other TCP/IP settings (such as default gateway and DNS server) would require a fair amount of time and labor. The alternative to statically configuring client computers is deploying a DHCP server. Let's take a look at DHCP.


Working with DHCP

DHCP allows you to dynamically assign IP address to your network computers and other devices. IP addresses are taken from a pool of addresses and assigned to computers either permanently or for a fixed lease time. When you consider that you must configure every client computer on an IP network with such things as an IP address, a subnet mask, a default gateway address, and a DNS server address, you can see that there is an incredible margin for error.

DHCP provides a dynamic environment for assigning IP addresses to computers and devices on the network. It actually simplifies much of the drudgery that would be involved in manual assignments of IP addresses. Most network operating systems including Novell NetWare and Microsoft Windows Server 2003 provide the DHCP service, which can be configured on a network server that provides other services or on a standalone network server (which provides only the DHCP service). We will look at configuring a server for DHCP in a moment. First, let's discuss how DHCP clients request an IP address from a DHCP server.

Note

DHCP evolved from a protocol called BOOTP. BOOTP was used to assign IP addresses to diskless workstations. BOOTP did not assign IP addresses dynamically, however, but pulled IP addresses from a static BOOTP file was created by the network administrator.

DHCP Client Address Requests

Before a computer can request an IP address and other IP-related information from a DHCP server, it must be configured as a DHCP client. Most client operating systems are actually configured as DHCP clients by default. For example, Windows XP Professional is configured to obtain its IP address and the address of the DNS server automatically, as shown in Figure 12.3.

Figure 12.3. A computer must be configured as a DHCP client.

Once a network client is configured as a DHCP client, it is ready to obtain IP settings from the DHCP server. When a DHCP client boots up for the first time, it goes looking for an IP address. The client initializes TCP/IP (a stripped-down version) and broadcasts a DHCPDISCOVER message, which is a request for an IP lease that is sent to all DHCP servers (addressed to 255.255.255.255, meaning all nodes on the network). This broadcast message contains the host name of the client (which in most cases is also the client's NetBIOS name) and the MAC hardware address of the client.

In the next step, a DHCP server (or servers, if more than one is available) on the subnet will respond with a DHCPOFFER message that includes an offered IP address, an accompanying subnet mask, and the length of the lease. The message also contains the IP address of the DHCP server, identifying the server. The DHCPOFFER message is also in the form of a broadcast, because at this point the client does not have an IP address.

When the client receives the first DHCPOFFER message (it may receive multiple offers, but it will go with first appropriate offer that it receives), it will then broadcast a DHCPREQUEST message to all DHCP servers on the network, showing that it is accepting an offer. This broadcast message will contain the IP address of the DHCP server whose offer the client accepted. Knowing which DHCP server was selected allows the other DHCP servers on the network to retract their offers and save their IP addresses for the next requesting client (yes, it does sound a little bit like a used car lot).

Note

The MAC address is the hardware address burned into a ROM chip on a device such as a network interface card or router interface by the device manufacturer.

Finally, the DHCP server that supplied the accepted offer broadcasts an acknowledgement message to the client, a DHCPACK message. This message contains a valid IP address lease and other TCP/IP configuration information. Windows DHCP clients store the information received from the DHCP server in its Windows registry.

IP addressing and other information received from the DHCP server is considered a lease. This implies that the lease will expire at some point. You can actually configure the length of IP address leases on a DHCP server. On a Windows network, the DHCP client will actually begin to broadcast a request message when half the lease time has expired.

If your network is fairly static as far as the movement of devices and bandwidth is an issue, longer leases lessen the number of DHCP broadcasts because computers do not have to renew their IP leases all that frequently. Fewer broadcasts mean less bandwidth is soaked up by the broadcast traffic.

Configuring a DHCP Server

Most network operating systems supply the DHCP service as either a part of the operating system software or as an add-on to the network operating system. Both Windows Server 2003 and Novell NetWare 6x provide DHCP as part of the NOS software. You can either install the DHCP service on these network operating systems when you first install the server software or you can add the DHCP service to the server's configuration after the server is up and running. For example, Windows Server 2003 uses the Configure Your Server Wizard to add a service such as DHCP (the NetWare and Linux environments also have utilities for adding services to a server's configuration) as shown in Figure 12.4. Selecting the DHCP Server role and then clicking Next installs the service on the Windows server.

Figure 12.4. The DHCP service can be added to a server's configuration.

Once you have installed the DHCP service on a server, you must configure it. No matter what NOS you are using, there are several configuration parameters that all DHCP servers will need. These parameters are as follows:

  • IP address scope. The scope is the range of IP addresses available for the DHCP clients.

  • Subnet mask. This is the subnet mask that will be assigned to all DHCP clients.

  • IP address exclusions. You can exclude IP addresses from a scope that you configure on the DHCP server. The excluded addresses are addresses that you have used on the network for the assignment of static addresses to servers or other devices that require a static IP address.

  • Lease duration. The length you assign to the IP leases provided by the DHCP server.

  • Default gateway address. The IP address of the router interface that the clients use as their default gateway.

  • DNS server address. The IP address of the default DNS server to be used (which can be the same server you are configuring DHCP on).

  • WINS server address. The IP address of the WINS server to be used by the clients.

Configuring these parameters on a DHCP server is a fairly straightforward matter. For example, on a server running Windows Server 2003, a New Scope Wizard is used to create the scope, create exclusions, and configure other DHCP parameters. This wizard is run from the DHCP snap-in, which is installed on the server when you add the DHCP server role to the Windows configuration. Figure 12.5 shows the New Scope Wizard.

Figure 12.5. The New Scope Wizard is used to create the IP address scope for the DHCP server.

As already mentioned, DHCP is managed using the DHCP snap-in on a server running Windows Server 2003. The snap-in allows you to add additional scopes, view IP address leases, and otherwise manage the DHCP service. Figure 12.6 shows the DHCP snap-in.

Figure 12.6. The DHCP snap-in is used to manage the DHCP service on a Windows server.

On a NetWare server, an administrator can manage the different aspects of the DHCP service from the NetWare iManager. The iManager provides the ability to create scopes and manage leases on the network. Figure 12.7 shows the iManager and the scope creation utility.

Figure 12.7. The Novell iManager is used to manage DHCP on the NetWare network.

Once the DHCP server is up and running on the network, the DHCP clients can begin to request IP address leases. Now while DHCP seems to be a fairly automatic service, it does require active management from a network administrator. And all the ins and outs of DHCP management are certainly beyond the level of coverage that we can provide in an introductory book.

For example, deployment issues related to DHCP require planning. The number of DHCP servers you deploy on the network should be directly related to the number of network clients on the network (to handle all those requests for IP address leases). In situations where you have a network that is segmented into subnets by routers, you will have to decide whether you deploy DHCP servers on every subnet or use a DHCP Relay Agent to help clients on subnets that do not have a DHCP server acquire IP addresses from the available DHCP servers on the network.

One thing that you should take away from our discussion of DHCP is that it typically cuts down on the number of IP configuration problems that will be introduced to the network. This is because once you set up the scope and other DHCP parameters, it basically takes care of IP addressing automatically.

Think of the large number of possible errors that could be introduced to computers on the network if you configured each one of them individually with a static IP address and subnet mask. If you assign the same IP address inadvertently to two devices, neither will be able to connect. If you type an address incorrectly in the client's TCP/IP configuration, again, the client won't be able to connect. So, DHCP is not only a time saver (since you don't have to configure clients individually) but it will cut down on communication problems related to IP addressing errors (since there shouldn't be any if you set up the DHCP server correctly).

Note

Routers do not forward broadcast messages such as those used to negotiate an IP address lease with a DHCP server. DHCP servers are typically deployed on each router segment, or a DHCP relay agent is used in cases where DHCP is not deployed on each router segment.


Understanding DNS

An extremely important part of managing IP networks is understanding the Domain Name Service. The Domain Name System (DNS) provides a hierarchical name resolution strategy for resolving a Fully Qualified Domain Name (FQDN) to an IP address. DNS servers provide this "friendly name" to logical address (the IP address) resolution on TCP/IP networks such as the Internet. For example, when you type Microsoft.com into your Web browser address window, a DNS server somewhere on the Internet actually resolves the FQDN (Microsoft.com) to the IP address of the Microsoft Web site.

So in terms of TCP/IP networks and the Internet in particular, each organization will deploy DNS servers that provide FQDN resolution to IP addresses. In effect, each large company, organization, or service provider manages the name resolution duties for their own portion of the Internet. In fact, when a company registers a domain name with InterNIC, the company must provide the IP addresses of two internal DNS servers that will handle the name resolution duties for that domain (for individuals that register a domain name, the DNS server addresses are typically provided by your service provider).

Servers maintained by InterNIC provide the mechanism for a local DNS server to resolve a FQDN to an IP address on a remote portion of the Internet. Since the InterNIC servers hold a database that provides a listing of all domain DNS servers and their IP addresses, the local DNS merely queries the InterNIC server for the IP address of the DNS server that services a particular domain (using the friendly name). Once the local server receives the IP address of the remote DNS server, it can then query it directly for the resolution of the remote FQDN to an IP address.

With each network really responsible for the local mapping of friendly names to IP addresses using DNS servers, the DNS database is a distributed database. Each organization maintains its part of the overall DNS database. This means that each organization will typically deploy its own DNS servers (which handle most of the local DNS related queries). We will discuss deploying a DNS server in a moment. First, we need to take a look at the DNS namespace.

The DNS Namespace

To understand how DNS or FQDN names are determined, you need to understand the domain namespace, which is an integral part of how Internet Web sites are named. The domain namespace is the actual scheme used to name domains that are at different levels in the DNS domain hierarchical tree. The domain namespace also provides for down level names of individual computers and other devices on a network.

The first thing that we should define is what a domain is in relation to DNS. Each division on the DNS tree (which takes the form of an inverted or upside-down tree) is considered a domain.

At the base of the DNS tree is the root domain. The Internet's root domain is represented by a period (see Figure 12.8). Below the root domain are the top-level domains. The top-level domains consist of suffixes such as .com, .edu, and so on. Some of the top-level domain names available are

  • com. Used by commercial organizations. For example, quepublishing.com is the domain name for Que Publishing.

  • edu. Reserved for educational institutions. For example, une.edu is the domain name of the University of New England.

  • org. Used by noncommercial organizations and institutions. For example, gsusa.org is the domain name of the Girl Scouts of America.

  • gov. Reserved by the United States for governmental entities. For example, senate.gov is the domain for the U.S. Senate.

  • net. To be used by companies involved in the Internet infrastructure, such as ISPs.

  • country names. .bs for the Bahamas, .ga for Gabon, and many more.

  • biz. A new top-level domain added recently to accommodate businesses.

  • info. Another new top-level domain recently added, which can be used for informational Web sites (or just about anybody looking for a domain name).

Below the top-level domains are the second-level domains; these secondary domains consist of company, institutional, and private domains that we commonly use to access a Web site on the Web, such as quepublishing.com (Que Publishing's domain name) and une.edu (the domain name of the University of New England in Biddeford, ME). Under the second-level domains are subdomains. These subdomains are typically used to divide a larger secondary domain into geographical or functional units. For example, if I have a company that uses the secondary domain name of Habraken.com and my business is divided into two distinct divisions (consulting and sales), I could create the two subdomains, consulting.Habraken.com and sales.Habraken.com (see Figure 12.8).

Figure 12.8. The domain name space tree provides the naming conventions for domains as well as objects that reside in domains such as hosts.

Second-level domains (and subdomains) will also contain hosts, which are the computers and other devices that reside within the second-level domain or subdomain namespace. For example, if I have a computer named joe1 and it is in the sales.Habraken.com subdomain, it will be referred to as joe1.sales.Habraken.com using the DNS nomenclature.

How DNS Works

Now that we've looked at the DNS naming hierarchy, we should delve into how DNS resolves FQDNs to IP addresses and vice versa. The DNS service consists of two different entities: the resolver and the server. The resolver is software built in to a WinSock application such as a Web browser that queries the server when a host's FQDN needs to be resolved to an IP address. The server component of DNS is handled by the DNS server.

When a client computer attempts to resolve a FQDN to an IP address, the resolver will check a local cache (if the resolver is set up to maintain a local cache) and see if the FQDN to IP address resolution information is available. If the information is in the cache, the process is over; the FQDN is resolved to an IP address by the client computer itself.

Note

All Windows clients (and other OS clients) maintain a DNS cache, which helps a DNS client to quickly resolve a DNS query basically by itself. The cache is typically only useful when trying to resolve a friendly name to an IP address for a resource that is used often. All other queries will go to the DNS server.

If the information is not available in the cache, the resolver software obtains the IP address of the local DNS server using the settings found in the client computer's TCP/IP settings (or provided by a DHCP server as discussed earlier in the chapter).

The client sends a request to the preferred DNS; if the FQDN to be resolved is for a host computer in the local DNS domain, the DNS server looks up the name in the DNS database and returns the appropriate IP address to the requesting computer. If the name is for a computer not on your domain, two things can happen: One possibility is that the name can be resolved using the cache that is maintained by the local DNS server; the server will cache or remember host names that it has previously resolved. If the information is in this cache, the DNS server provides it to the requesting client.

In cases where the information is not cached on the DNS server, your DNS server will contact the root server for the host name's top-level domain by querying it with the host name. The root server will use the host name to determine the IP address of the authoritative DNS server for the domain that the particular host belongs to. Once your DNS server has the IP address of the other domain's DNS server it can query that server, which will then supply the FQDN-to-IP address resolution information. The local DNS server can then pass this information on to the original requesting host.

Configuring a DNS Server

Now that you've seen how DNS works, let's take a look at configuring DNS on a server. As with DHCP, DNS is a service that you can add to the configuration of a network operating system (or install it when you first install the network operating system). For example, NetWare, Windows Server 2003, and Linux all provide support for DNS. Windows Server 2003 uses the Configure Your Server Wizard (as discussed earlier in the chapter in relation to DHCP) to add services such as DNS to the server.

Once you have the DNS service installed on a network server, you must configure DNS. The first thing you must add to the DNS configuration is a forward lookup zone. A forward lookup zone allows for forward lookup queries, in which a host can find an IP address by querying a DNS server with the host name of a particular computer or device. For DNS to work, at least one forward lookup zone is required.

When you create the forward lookup zone, you have to name it. The name of the zone will be the same as the DNS domain name for that portion of your network. For example, if your DNS domain for the network is spinach.com, the zone name would be spinach.com.

Figure 12.9 shows the iManager screen that is used to configure DNS on a NetWare server. Note in the figure that a name must be supplied for the zone and the zone type.

Figure 12.9. The Novell iManager is used to configure DNS zones.

There are two types of forward lookup zones: primary and secondary. A primary zone is the master copy of the DNS database. The primary zone is administered on the server the zone was created on. So, the server would be considered the authoritative DNS server for the zone. A secondary zone uses a database file that is a read-only replica of an existing zone. The DNS server configured with the standard secondary zone helps the primary DNS server handle the name resolution required for the network.

Another type of zone that should be configured on the DNS server is a reverse lookup zone. A reverse lookup zone allows for the resolving of IP addresses to host names, which is called a reverse lookup query. To name the reverse lookup zone, you provide your network ID. The network ID is the portion of an IP address that does not contain any references to host address. For example, in the Class C IP address 192.168.5.1, only the fourth octet contains host address information (the default class C subnet mask of 255.255.255.0 basically tells you which octet is used for host addressing). This means that the network ID would be 192.168.5. Figure 12.10 shows the New Scope Wizard, which is used to create reverse lookup zones (and forward lookup zones) on a server running Windows Server 2003.

Figure 12.10. A reverse lookup zone can also be created on the DNS server.

Once the zones have been configured on the DNS server, records must be placed in the zones. Depending on the implementation of DNS you are using (meaning the NOS you are using), you might have to create certain zone records. One example is the A record, which provides host name and IP address information for a particular host device on the network (such as a computer). In the case of Windows Server 2003 DNS, which is also called Dynamic DNS, a number of the records used by DNS to handle queries are automatically generated in the appropriate zones.

Figure 12.11 shows the DNSMGMT snap-in that is used on a Windows 2003 server to manage DNS. The forward lookup zone spinach.com holds an A Host record that was automatically generated for the server (Hermes1) that is providing the DNS service. The DNS server shown in the Figure 12.11 had just been newly created and so the number of records in the forward lookup zone is minimal; as the Windows DNS server listens to the network, it will acquire additional A Host and other records until it is able to resolve all local DNS queries.

Figure 12.11. Windows Dynamic DNS automatically generates A Host records for hosts on the network.

As you can see, Host records provide a host's name and a host's IP address. There are also other record types found on DNS servers that are used for various purposes. Table 12.1 provides a list of record types that are found in a DNS database.

Table 12.1. DNS Resource Record Types

Record Type

DNS Snap-in Name and Description

SOA

Start of Authority—Identifies the name server that is authoritative for data within the domain, and is the first record in the zone database file. It is created automatically when you bring your primary name server online.

NS

Name Server—A record is created for each name server assigned to the domain.

A

Host—Provides the host name to IP address mapping in a forward lookup zone.

PTR

Pointer—This type of record is the reverse of an A record and points to a host record. Found in the reverse lookup zone, the PTR record provides for IP address to host name mappings.

SRV

Service—This type of record shows which services are running on a particular host computer. For example, SRV records could identify the domain controllers on the network.

MX

Mail Exchanger—This record type identifies the mail servers on the network, as well as what order the mail servers should be contacted in.

CNAME

Canonical Name or Alias—This type of record is used to create an alias for an existing record. This allows you to point several different names at the same IP address. This would be particularly useful for pointing at your Web server on the network.

HINFO

Host information—This record type can be used as a sort of low-rent resource tracking tool for your DNS server. This record can provide information on the CPU, operating system, and other software/hardware information.

WINS

WINS—This type of record supplies DNS with the ability to use WINS to help resolve a host name.

Managing DNS has become another important task for the network administrator. Before it became necessary to deploy IP networks, DNS was not an issue, particularly on networks that ran other protocol stacks such as IPX/SPX. While many small companies will leave the DNS management to the Internet service provider, larger networks will require internal DNS implementations. For more about DNS and other TCP/IP topics you may want to check out the book Special Edition Using TCP/IP from Que Publishing.


Routing and Subnetting IP Networks

Local area networks often grow beyond a single physical location. For example, your company may start out with one office location but then decide to expand the business and locate a satellite office in another part of town (or in another state, or in another country). When networks grow to the point where they are a collection of connected LANs at different locations, they are referred to as internetworks. So, an internetwork is a network of networks. And how are these different networks connected? They are connected by internetworking devices such as routers.

We discussed routing briefly in Chapter 3, "Networking Hardware," in the section "Working with Network Connectivity Devices." Routers such as Cisco routers use their own proprietary operating systems. In the case of Cisco routers, the OS is called the Internetworking Operating System or IOS. The IOS is used by the network administrator to configure the router and its interfaces and monitor the traffic on the internetwork.

Routers use their interfaces to connect the various segments of the network. For example, an Ethernet interface would be used to connect one segment of an Ethernet network to the router. Ethernet interfaces have MAC hardware addresses just like network interface cards.

As with network computers, each network interface on a router must be configured with an IP address and a subnet mask (remember the router interface functions as the router's NIC). Let's take a quick look at how a router interface would be configured on a Cisco router and then we can tackle some of the basics if IP subnetting.

Configuring a Router Interface

To configure a Cisco router, a computer is physically connected to the router by a console cable. The cable is connected to a console port on the router and a serial port on the PC. You talk to the router using any terminal emulation software (this software is command-line communication software that allows you to talk to the router's operating system).

Configuring an Ethernet interface on a router for IP is just a matter of configuring the router interface with an IP address and a subnet mask. Figure 12.12 shows the command sequence that is used to configure an Ethernet interface on a Cisco router.

Figure 12.12. Configure the router interfaces with IP addresses.

Each router interface will be configured with its own IP address and subnet mask. The IP address for each interface would need to be an address from the subnet that the router interface connects to. We will discuss how to create the subnet IP addresses in the next section.

Routers must also be enabled for routing by configuring a routing protocol on the router. A number of IP routing protocols exist, including RIP (Routing Information Protocol) and OSPF (Open Shortest Path First). The routing protocol builds the routing table that is used to move the data traffic to the router interface, which allows the data to travel on to its final destination. Figure 12.13 shows the router command for enabling the RIP routing protocol on a router.

Figure 12.13. Enable a routing protocol on the router.

Obviously there is more to configuring and monitoring routers than just configuring the interfaces and the routing protocol. For more about Cisco routers, the Cisco IOS, and internetworking, check out the book Practical Cisco Routers from Que.

Okay, so the router interfaces and the PCs on the network (that connect to the various router interfaces via hubs or switches) need to be configured with appropriate IP addresses. This is where subnetting comes in.

Subnetting IP Address Pools

Routed IP environments require that your pool of IP addresses be subnetted. This allows each subnet to see itself as a separate segment of the larger internetwork. The router then ties together the various subnets into one network. The router knows how to route traffic to the correct segment because it builds a routing table. The routing table is basically the networks roadmap.

IP subnetting is fairly complex, and so to make this discussion informative but still digestible at an introductory level, we will limit our exploration of subnetting to one class of IP addresses; we will look at an example of subnetting a Class B range of IP addresses. The mathematical tricks that we use to subnet the Class B network can also be used to subnet a Class A or Class C network (although subnetting Class C networks greatly limits the number of usable IP addressed that you end up with).

Subnetting is a two-part process. First you must determine the subnet mask for the network (it will be different than the default subnet masks; for example, the default for Class B is 255.255.0.0). After figuring out the new subnet mask for the network, you must then compute the range of IP addresses that will be in each subnet.

Okay, let's cheat a little before we do the math of subnetting a Class B network. I think it will aid in the overall understanding of the subnetting process. Table 12.2 shows the new subnet masks, the number of subnets, and the number of hosts per subnet that would be creating when using a certain number of bits for subnetting (the Bits Used column).

Table 12.2. Class B Subnetting

Bits Used

Subnet Mask

# Of Subnets

Hosts/Subnet

2

255.255.192.0

2

16,382

3

255.255.224.0

6

8,190

4

255.255.240.0

14

4,094

5

255.255.248.0

30

2,046

6

255.255.252.0

62

1,022

7

255.255.254.0

126

510

8

255.255.255.0

254

254

So, what's the deal with "bits used?" Well normally when you have a Class B network to work with such as 130.1.0.0 (this would be the network address assigned to you by InterNIC or other IP address provider; see Chapter 15 for more about acquiring IP addresses), you have the third and fourth octet available for host addresses; 130.1 is the network designation assigned to you.

To create subnets on the Class B network (130.1.0.0) we would actually "borrow" bits from the third octet and use them to create the subnets. So the Bits Used column in Table 12.2 shows the number of bits borrowed and the resulting subnet mask, number of subnets that can be created, and the number of hosts created. Notice when you borrow more bits (such as 7) you get more subnets but fewer host addresses. So the creation of the subnets does cost you bits and therefore reduces the number of usable addresses for devices on the network.

Note

Charts such as the one shown in Table 12.2 are available for Class A and Class C networks as well. There are also IP subnet calculators that do all the math for you and help you create subnets. Do a search for subnet calculators on the Web and you will find several, including some that are freeware.

IP addresses are actually seen by devices on the network as a bit stream; for example the IP address 130.1.16.1 would be represented in binary as

10000010 00000001 00010000 00000001

Notice that the bits have been divided into four groups of 8, or octets. just as the dotted decimal version of the address was (130.1.16.1).

This is how you convert dotted decimal numbers to binary (bits). Each octet has 8 bits. The decimal value of the bits in an octet from left to right are

128 64 32 16 8 4 2 1

So the decimal number 130 (the first octet in our address) is 128 + 2. This means the first bit (the 128 bit) and the seventh bit (the 2 bit) are both turned on (they are represented by 1s in the binary format). So to convert the decimal to the binary, you mark the bits that are on with 1s and the rest with 0s. This gives you 10000010 (which is what we see above in the binary format of the IP address).

Now about subnetting: Since the network ID portion of IP addresses is fixed (it is provided by your Internet service provider or another provider of IP address ranges), you will actually borrow some bits from the host ID portion of the address to create subnets (remember, you can't mess with the network ID portion of the IP address because it is assigned to you). Let's walk through an example of subnetting.

Let's say that we want to divide the Class B network 130.1.0.0 (this is the network address we were assigned by our IP address provider) into 30 subnets.

You can't touch the first or second octets because they have been assigned. But you can borrow bits from the third octet. So, you have to determine how may bits you must borrow from the third octet to create 30 subnets. The number of bits that you borrow will determine the new subnet mask for your network (which lets all devices on the network know that 30 subnets have been created) and the bits you borrow will also help you determine the range of IP addresses that will be in each subnet.

Borrowing Bits

First let's borrow the bits; you use the decimal values of the bits in the third octet to do this. We want to come up with 30 subnets. And the formula that we use to do this is the sum of lower order bits, minus 1. Look at the bit values again (shown below). The lower order bits are the ones on the right (1, 2, 4, and so on). So you add 1 + 2+ 4+ 8 + 16, which equals 31. Then we subtract 1; we get 30. So we used the 1, 2, 4, 8, and 16 bits; we borrowed 5 bits.

128 64 32 16 8 4 2 1 <- low order bits

Note

We have to subtract the 1 because you cannot use subnet 0, which is what you derive when you steal only the first lower-order bit (the 1).

Okay, so we borrowed 5 bits. Now the next thing we need to do is determine the subnet mask for the subnetted network. The bits on the left of our decimal values (the 128, 64, 32, 16, and so forth) are referred to as the higher order bits. So, you take the first 5 higher order bits and add them together:

High order bits -> 128 64 32 16 8 4 2 1

128 + 64 + 32 + 16 + 8 = 248

The default subnet mask for a class B network is 255.255.0.0.

We borrowed 5 bits from the third octet, so our new subnet mask is 255.255.248.0. If you check Table 12.2, when you borrow 5 bits from a class B network you get the subnet mask that we have derived.

Computing the number of host addresses available per subnet is very straightforward. The formula you use is 2x-2; where X is the number of bits left for host addresses after bits have been borrowed for subnetting.

Computing Host Address Per Subnet

We have 30 subnets (remember that what we decided to divide our IP address range into at the outset of this problem). So, now let's find out how many addresses we will get for each of our 30 subnets. Normally on a Class B network we have two octets reserved for host addresses. Our network address is 130.1.0.0, so we originally had two full octets (the third and fourth) available for node addresses. This would be 16 bits total (8 bits from each octet). Now we borrowed 5 bits from the third octet, so 16 – 5 = 11. So we have 11 bits left over for node addresses after borrowing 5 bits to create the 30 subnets.

Now we use the formula 2x - 2. 2 to the 11th – 2 on my trusty calculator is 2048 – 2, which equals 2046 (just as Table 12.2 shows). We get 2,046 addresses per subnet.

Computing Host Ranges

So, we have 30 subnets with 2,046 addresses each. Now we need to figure out the starting and ending IP address for each subnet. This is rather easy compared to what we've been through so far. What was the lowest of the high order bits that we used to create the new subnet mask for our subnetted network? We used 128, 64, 32, 16 and 8, so the lowest of the high order bits is 8. This number, 8, becomes the increment for your subnet address ranges.

Our network address is 130.1.0.0. So the first subnet would start with the address 130.1.8.1 (you can't have a 0 in the last position of the address). This subnet would end with 130.1.15.254 (you can't end an address with 255 in the last octet).

Table 12.3 shows the range of addresses for the first five subnets (of 30) using our network address of 130.1.0.0.

Table 12.3. Address Ranges for First Six Subnets

Subnet

Address Range

1

130.1.8.1 to 130.1.15.254

2

130.1.16.1 to 130.1.23.254

3

130.1.24.1 to 130.1.31.254

4

130.1.32.1 to 130.1.39.254

5

130.1.40.1 to 130.1.47.254

Notice that you can easily come up with the start of each subnet range by simply adding 8 to the third octet. The end of range addresses are just 1 less (in the third octet) than the start of the next subnet. You could easily continue this table to show all 30 subnets (why don't you consider it "homework").

Class A and C network addresses can be subnetted in a like manner. Just remember that Class A networks provide you three octets of node address space (the second, third, and fourth), where a Class C network address only supplies one octet (the fourth).


Introducing IPv6

Before leaving the subject of TCP/IP administration, we should introduce IP Version 6. IP Version 4, which is the current version of IP used, provides a 32-bit addressing system (as represented by the four octets in the dotted decimal format of an IP address). This supplies more than 3,560,000,000 total addresses.

The problem with IP Version 4 is that the IP address pool has been nearly exhausted. This is amazing, considering that even as little as 10 years ago, no one would have imagined the possibility of running out of unique IP addresses.

IP Version 6, which will become more prevalent as time goes by, uses a 128-bit addressing system that provides 340,282,366,920,938,463,463,374,607,431,768,211,456 addresses. This is a very large number of IP addresses, and it will be difficult to exhaust this pool.

Note

The IP Version 6 address is a hexadecimal address that consists of eight 16-bit parts. A sample address is FEDC:BA98:7654:3210:FEDC:BA98:7654:3210.

A number of new server products such as Windows Server 2003 and Novell NetWare provide support for IP Version 6. IP Version 6 is also compatible with Version 4, and the two can cohabitate on a network with no problems.

While the Internet Engineering Task Force (IETF) has had specifications for IP Version 6 in place since the late 1990s, there has not yet been a stampede to adopt this new IP addressing scheme. It should be phased in over the next couple of years, which means that subnetting and addressing concerns will change dramatically to accommodate the new address format.

The Absolute Minimum

In this chapter we had the opportunity to take a look at some of the issues related to administering a TCP/IP network. We discussed configuring IP addresses, DHCP, DNS, routing, and IP subnetting.

  • Computers on an IP network must be configured with an IP address, subnet mask, and other TCP/IP settings such as default gateway, DNS server address, and WINS server address.

  • The Dynamic Host Configuration Protocol (DHCP) can be used to supply DHCP clients with IP addresses, subnet masks, and other TCP/IP settings dynamically. A DHCP server leases the IP addresses to the DHCP clients.

  • The Domain Name System (DNS) provides the logical hierarchy for the Internet and TCP/IP networks. A DNS server is able to resolve the DNS friendly name (the name as determined by the DNS hierarchy for the network) of a device to an IP address (and vice versa).

  • DNS servers field requests from devices on the network for resolving DNS names to IP addresses. A forward lookup zone is required on a DNS server and holds the A records that provide a device's DNS name and its IP address. Reverse lookup zones on a DNS server hold records that allow IP addresses to be resolved to friendly names.

  • An internetwork is a network of networks. Routers are used to connect LANs into an internetwork. Each segment or subnet of the internetwork is connected to a router interface. The router uses a routing protocol to build routing tables. These routing tables are used to route the data from the subnets to the appropriate destinations.

  • IP subnetting allows you to borrow bits from a network address and create logical subnets. The creation of the subnets requires that a new subnet mask be computed for the network and that subnet address ranges be created to be assigned to the devices on each subnet of the network.


Chapter 13. Expanding a LAN with WAN Technology

In this chapter

  • Defining the wide area network

  • WAN technology and the Plain Old Telephone System

  • Working with asynchronous and synchronous modems

  • Understanding the T-carrier system

  • Differentiating between circuit- and packet-switching WAN technologies

Our exploration of networking has, so far, centered primarily on the local area network (LAN). LANs, however—even the largest—are isolated; they can only connect computers and other devices in a fairly small geographical area. Large companies and institutions that span multiple sites need to be able to connect all their LANs into one large network. Wide area networks (WANs) are networks made up of a number of LANs. So, a wide area network can be defined as a collection of LANs that extend over a wide geographic area.

To connect LANs at different locations, some sort of technology must be used that can move data across great distances but still have it arrive at its final destination intact. A number of different technologies exist that can be used to move data from physical site to physical site.

This chapter will concentrate on the different WAN technologies that are in use today. Many of these technologies make use of the Plain Old Telephone System or POTS. The use of VPNs or Virtual Private Networks is a way to take advantage of the infrastructure supplied by the Internet. Secure private connections can be made between networks over the public Internet. We will discuss VPNs in Chapter 17, "Networking on the Run." In this chapter we concentrate on technologies that are used by larger companies and institutions (although they don't have to be huge companies; they just have to be able to afford the technology). WAN technologies have actually been around since the days of the mainframe.

Note

You might be wondering what the difference is between an internetwork and a WAN. An internetwork is a network of networks, but it doesn't necessarily span large geographical areas. An internetwork can exist at one site of a large company and is more about ways of expanding a LAN or LANs and still conserving network bandwidth or getting different network architectures to talk to each other on the same network. A WAN is a network that makes use of some of the same devices as an internetwork, but it exists primarily because of the need to connect LANs at different physical locations.


Working with the Plain Old Telephone System

The telephone system in this country has been around for more than a hundred years. And when you think about the actual physical infrastructure that makes up the POTS, you can see why it made sense and still makes sense to take advantage of the miles and miles of copper wire to connect computers at different sites.

The telephone system is a switched network. This means that as a connection is established on the telephone system's network, it can be switched along different paths. For example, when you make a phone call, your voice communication does not necessarily always move along the same route, even though you dial the same phone number when you call a particular person.

As far as the transfer of data is concerned, the telephone system offers more than one possibility for moving information from source to destination. This includes dial-up connections, dedicated leased lines, and different packet-switching technologies. One of the newest technologies for data transfer over the POTS is Digital Subscriber Line (DSL). This technology allows for digital communication over existing phone lines and is fast becoming a viable choice for data transfer by home users (such as for high-speed connection to the Internet) and companies who can't justify the cost of some of the other data communication possibilities such as Frame Relay or ATM (both discussed later in this chapter).

Before concentrating on the different possibilities for data movement on the POTS, we need to take a look at some terminology related to the physical infrastructure of the telephone system. If you have ever dealt with your local phone company, just in terms of voice telephone service, you know that you're typically responsible for the wiring and equipment inside your house (unless you purchase some kind of special service contract from your local phone company). The lines outside your house are the phone company's responsibility.

In the business world, the phone or LAN equipment inside the company would be called the customer premise equipment (CPE). The place where the CPE ends and the phone company's line begins is called the demarcation. The actual physical wires that connect the business to the nearest phone company switching station is called the local loop. Figure 13.1 provides a diagram showing these different areas.

Figure 13.1. The CPE is connected to the phone system by the local loop.

Note

The telephone system is also often referred to as the Public Switched Telephone Network (PSTN).

Tip

The POTS actually started out as a system where the switching was handled by humans operating plugboards (everyone has seen an old television show or movie where the operator is actually switching the calls by physically connecting wires to a plugboard). The system progressed from human switching to electromechanical switching; switching on the POTS is now handled by digital technology.


Working with Dial-up and Dedicated Connections

As already mentioned, the POTS offers more than one alternative for connecting LANs at different locations. Two of these options relate to dial-up connections using modems and connections that used dedicated lines.

In both of these connection strategies, you will run into a device called a modem. Two types of modems exist: asynchronous modems and synchronous modems. Let's take a closer look at how modems are involved in dial-up and dedicated connections over the POTS.

Tip

The customer premise equipment will be terminated by some kind of device, such as a router or a digital service unit. We will talk more about the different types of equipment used to connect a company's LAN to the local loop when we discuss specific LAN technologies, later in the chapter.

Asynchronous Modem Connections

The simplest and least expensive type of dial-up connection uses a modem to connect two computers. Because computers work with digital information, the digital data—that is, the ones (1) and zeros (0)—must be converted so that it can be carried by the analog phone line. This conversion from digital information to analog information is called modulation. When analog information is received on the modem connected to the destination computer (such as a server that is configured with a modem to allow dial-in connections), the data must be converted from analog back to digital. This process is called demodulation. You can see that the name for these devices, modem, is taken from modulation and demodulation.

An asynchronous modem is designed to move data over a regular analog voice-grade telephone line, and it is asynchronous modems that most of us are familiar with. They are used to dial into a network server for telecommuters and are also used by millions of people to connect to the Internet.

An asynchronous modem uses start and stop bits as the way to let the receiving modem know when a particular packet of data starts and stops. Beyond the start and stop bits, many modems incorporate some type of error checking to ensure that the data is sent correctly across the telephone line. The simplest method of error checking involves including a parity bit when transmitting each byte. Essentially, parity checking works like this: The sending modem counts how many 1s are in the data stream. If the number is odd, the parity bit is set to 1. On the other end, the receiving modem also counts the number of 1s and determines whether the number is odd or even. The receiving modem then compares its results with the parity bit. If the results match, the data is probably okay and is sent on for processing. If the parity bits don't match, the data is rejected and the destination computer requests a resending of the data.

Note

While WANs extend over large distances, the WAN equipment deployed at a specific site becomes part of the responsibility of the local LAN manager. Keeping the WAN connection up and running is as important as maintaining the local network and its hardware.

Tip

Modems used for dial-in connections to Internet service providers and networks using TCP/IP typically use the Point-to-Point Protocol (PPP). PPP provides a secure connection and also provides for error checking. PPP is now used for most dial-in connections to remote access servers (discussed in Chapter 17, "Networking on the Run," in the section "Understanding Remote Access").

Modems are generally available for either internal or external connections to a computer. An internal modem plugs into an expansion slot on the motherboard of your computer and provides an RJ-11 jack (a four-wire telephone jack) from which you can connect a standard telephone cable between the modem and your wall telephone jack.

An external modem is a separate box that is connected to your computer by way of a serial cable (known as an RS-232 cable). A number of external modems are also available that can be connected to a computer via a USB port. External modems have an RJ-11 jack for your connection to your telephone and normally have lights to indicate various status conditions. Figure 13.2 shows a U.S. Robotics 56K external modem. External modems have a slight advantage over internal modems in that you can reset an external modem (turn it off, and then on) without having to reboot the computer.

Figure 13.2. External modems can easily be connected to a computer's COM or USB port.

Modem speed is measured in terms of the number of bits per second (bps) that can travel across the phone line. As shown in Table 13.1, the International Telecommunications Union has developed the so-called V series of standards for modem speed. Note that some standard designations contain the words bis or terbo. These designations have nothing to do with speed and are merely the French words for second and third, respectively, indicating that these are revisions of earlier standards. V.90 was declared as the standard for modems in 1988 by the International Telecommunication Union (ITU). V.90-compliant modems can access nearly a 56K connection over ordinary phone lines.

Table 13.1. ITU Standards for Modems

Standard

Bps

Year Introduced

V.22bis

2400

1984

V.32

9600

1984

V.32bis

14,400

1991

V.32terbo

19,200

1993

V.FastClass (V.FC)

28,800

1993

V.34

28,800

1994

V.42

57,600

1995

V.90

57,600

1997

There is some confusion between the bps rate and the baud rate of a modem. Baud is an older term that refers to the oscillation of a sound wave on which one bit of data is carried, whereas bps refers to the actual number of bits transmitted each second. In early modems, the baud rate and the bps rate were equivalent. For instance, an early 300bps modem did, in fact, have 300 oscillations of sound waves each second. However, as technology evolved, engineers developed methods to compress information and manipulate analog signals to send multiple bits with each sound wave oscillation. These improvements rendered the baud rate obsolete as a measurement of speed. For instance, a modem transmitting at 28,800bps might in fact be transmitting at only 9,600 baud.

Note

The adoption of V.90 as the standard for 56K modems by the ITU settled a long battle between competing modem technologies offered by 3COM (X2) and Rockwell Semiconductor (K56flex). Even many older 56K modems can be upgraded to the V.90 standard by the use of software that flashes the modems ROM.

Synchronous Modems

A synchronous modem doesn't use start and stop bits; instead, the sending and receiving modems actually use synchronization bits to set up the timing for the transmission. Because synchronous modems do not need the start and stop bits used by asynchronous modems, they can achieve much higher data transfer rates than asynchronous modems. However, because synchronous modems are not designed for communication over regular phone lines, they are generally only found in use with dedicated leased lines.

Dedicated leased lines provide a full-time connection between two networks through the POTS or another service provider. Lease lines are typically digital lines and provide much more bandwidth than analog lines; they are also less susceptible to the line noise and interference found on voice-grade connections.

Digital lines commonly used for data transfer include digital data service (DDS) lines and the T-Carrier system, which provides a range of line types for different data rates (T-Carrier lines are discussed in the next section). A DDS line can provide bandwidth of up to 56Kbps and supply your network with a permanent, full-duplex connection (data can be sent and received at the same time).

DDS line connections are actually becoming a thing of the past and are fast being replaced by other WAN technologies. Cheaper T-Carrier rates and other connection possibilities, such as DSL connections (discussed later in "Digital Subscriber Line") and even broadband cable connections, are also making the use of DDS lines a thing of the past.


The T-Carrier System

The T-Carrier system is a telecommunication technology that consists of high-speed digital lines made up of multiple channels. It is another one of the communication possibilities provided by the POTS. The T-Carrier system can be used for the high-speed transfer of voice, video, and data. Each channel on a line can provide 64Kbps of throughput. By combining a number of channels into one line, different elements, such as voice and data, can be moved at the same time over the same line (with each carried by a different channel).

The device that combines signals carried on these separate channels (when data must be sent over the digital line as a single data stream) is called a multiplexer or MUX. A demultiplexer is typically built into a MUX to split a received data stream into the appropriate channels. A demultiplexer actually works along the same lines as a cable-ready television or VCR. A single data signal comes into your home from the local cable television provider, and your cable-ready television or VCR contains a multiplexer that breaks the data feed down into the 200+ television channels that you are constantly surfing (no one ever said that more channels would provide better programming). That's what broadband transmission is all about—multiple channels on a single feed.

The number of channels on a T-Carrier line obviously defines the amount of bandwidth that the line supplies, and different T-Carrier lines are available. The T-1 line is the basic unit of the T-Carrier system. It provides 24 64Kbps channels, which can be combined to provide a total transmission bandwidth of 1.544Mbps. Several other T-Carrier lines exist that can provide a large number of channels and extremely high data rates. Table 13.2 provides a summary of the different T-Carrier lines available.

Table 13.2. The T-Carrier Lines

Carrier Line

Channels

Total Data Rate

T-1

24

1.544Mbps

T-2

96

6.312Mbps

T-3

672

44.736Mbps

T-4

4,032

274.760Mbps

The cost of leasing T-Carrier lines has actually dropped in recent times. However, for most companies, even a T-1 line can seem a bit pricey. Many companies lease one T-1 and use some of the channels for data and others for the company's phone systems. Many local phone providers also have begun offering Fractional-T connections, where a company only leases a specified number of channels on a T-1 line.

Tip

The T-1 line is the basic unit of the T-Carrier system. All the other T-Carrier lines available can actually be thought of as simply particular multiples of T-1 lines. A T-2 line, for example, consists of four T-1 lines, a T-3 line consists of 28 T-1 lines, and a T-4 line consists of 168 T-1 lines.


Understanding Switched Networks

Another WAN alternative for moving data between different LAN sites is switched network technology. A switched network allows multiple users to take advantage of the same line. This makes the overall cost of this WAN technology cheaper than dedicated leased lines.

On a switched network, your LAN (or your multiple LANs at different locations, if your company is connecting multiple sites) is connected to the wide area network by a switched network service provider or the POTS. Data leaving your LAN through the WAN connection enters the switched network and then makes its way to the final destination. The path that the data takes, however, can be different each time. This means that many different users can take advantage of moving data on the switched network almost simultaneously.

Switched networks make it easy for companies to expand because additional remote sites can be connected to the switched network at any time. Switched networks come in two different flavors: circuit switching and packet switching.

Note

Using T-Carrier lines as a way to connect LANs at different locations requires a couple different pieces of equipment. We've already mentioned the multiplexer/demultipexer (MUX), which actually combines multiple channels into one stream of information or breaks down the data stream into the individual channels. A piece of equipment called a Channel Service Unit/Digital Service Unit (CSU/DSU) actually sits between the LAN multiplexer and the connection to the local loop.


Circuit Switching

Circuit switching establishes a circuit (a circuit being all the phone lines used to connect the sending and receiving devices) during the communication session between sender and receiver. This means that, temporarily, the lines are dedicated to that communication session. Then, when the session is over, the circuit is immediately "torn down" and becomes available for another communication session.

Every time you pick up the telephone and make a phone call, you are taking advantage of circuit-switching technology. A circuit is established during your phone call. However, the circuit might be different (meaning different phone lines are used) each time you call the very same person. Two important WAN technologies that are circuit-switched are ISDN and DSL. Let's take a closer look at each.

ISDN

ISDN is available from local phone providers and takes advantage of digital phone switching systems. The cost of an ISDN connection will be dictated by how often the line is used for data transfer. Your usage charge is determined by the connection charge (and there is also often a recurring monthly charge for being connected to the service). ISDN moves data on different channels like the T-Carrier system. ISDN comes in two flavors: Basic Rate ISDN (BRI) and Primary Rate ISDN (PRI).

Basic Rate ISDN uses three channels. Two data-carrying channels, called B channels, each provide 64Kbps of bandwidth for data transfer. The third channel, the D channel, is not used for data transfer and, operating at 16Kbps, is used exclusively for setup and control information used during the communication session. BRI can be used for both voice and data communications by dedicating a B channel for each. Typically, however, the two B channels are combined in BRI to provide a data transfer speed of 128Kbps.

For businesses with a need for more bandwidth, there is Primary Rate ISDN. PRI uses a T1 line and provides 23 B channels (each operating at 64Kbps). One D channel is also necessary (as with BRI) to handle setup and to control the connection. All or any number of the 23 B channels available can be combined for data transfer. Some channels can also be used for voice communication.

Tip

When selecting a provider for WAN connections, you will find that there are a large number of possibilities. This is due to that fact that regional phone companies are not operating out of their original areas of operation due to mergers and deregulation. Companies other than the Baby Bells—such as Sprint—also have their own WAN infrastructures, meaning your choices even extend beyond the typical services provided by the POTS.

Digital Subscriber Line

ISDN is rapidly being eclipsed (particularly in the BRI arena) by DSL (Digital Subscriber Line) connections. DSL offers voice and data communication over the regular phone lines with speeds of up to 7Mbps (in research situations, connections of 50Mbps have been realized). The great thing about DSL in the small office environment is that the data and voice communication can take place simultaneously over the very same phone line. DSL shares the line with the analog voice signal by using a different frequency for the digital data (that is sent and received using the line). This means you can make a phone call while sending data over the line.

Note

ISDN is actually a suite of protocols defined by the ITU-T (International Telecommunication Union-Telecommunication Standardization sector) that provides digital communication over existing phone lines.

One of the problems with DSL is that there are several different flavors: ADSL, HDSL, IDSL, SDSL, and others. They are often referred to as xDSL. The most common DSL service for home and small business use is Asymmetric Digital Subscriber Line (ADSL). ADSL gets its "asymmetry" from the fact that it supplies three different avenues (or pipes) on a single phone line. Each pipe provides a different level of bandwidth (and is therefore asymmetrical). One of the pipes is called the POTS pipe, and it takes care of the analog traffic on the phone line, such as telephone calls. The second pipe provides a medium-size upstream pipe, and the third pipe provides a large downstream pipe.

Tip

For ISDN BRI, your LAN will be connected to the local loop by a router containing a special BRI interface or a device called an ISDN modem. It is actually not a modem but an ISDN terminal adapter that is used to connect the LAN to the POTS local loop.

The fact that a standard has not been chosen by the Baby Bells and other providers of DSL means that the equipment used to connect a home or company to the provider's network and the bandwidth available will vary from place to place. Figure 13.3 shows a Cisco DSL router used to connect to the QWEST (formerly U.S. West) DSL network. As already mentioned in this section, DSL providers typically offer more bandwidth downstream (meaning you get a very fast connection to another network, such as the Internet) and less bandwidth upstream (it will take longer for you to send data than receive it). This, again, depends on the service provider you use.

As with the other WAN technologies we've discussed, DSL requires a device (such as the Cisco ADSL router, as shown previously in Figure 13.3) to connect your LAN to the provider's switched network. This device is considered customer premise equipment (this means you have to buy and maintain this device, although some providers have been giving away these devices to get customers to subscribe to their DSL services). The availability of DSL is also determined by the distance between the provider's nearest switching station (also called the central office or CO) and your home or company's location. In many cases, the limit is currently two to three miles (although in some markets five miles is the limit).

Figure 13.3. A customer premise device, such as the Cisco 675 ADSL Router, is used to connect the LAN to the DSL provider's network.

The big question is this: How does the DSL provider take the numerous client connections and move that data on the provider's switched network? This task is handled by a Digital Subscriber Line Access Multiplexer (DSLAM). Typically located at the provider's central office, it receives signals from multiple customer DSL connections and puts the signals on a high-speed backbone using multiplexing techniques (meaning that all the data is multiplexed into a single signal, just as we discussed in relation to T-Carrier channels). The high-speed backbone can use technology such as ATM (Asynchronous Transfer Mode), which is discussed later in this chapter.

Although DSL is currently marketed as an avenue for high-speed Internet connection, it can be used to connect telecommuters and different corporate sites by using Virtual Private Networking (VPN). We will discuss both remote access and VPN in Chapter 18.

Note

A DSL connection is usually cheaper than an ISDN BRI connection (and offers more bandwidth). This is because DSL charges are typically a flat fee, whereas BRI charges can be based on the amount of time the BRI connection is used.


Packet-Switching Networks

In WAN connections that use packet switching, the data is divided into packets. The small packet size used in packet switching provides fast and efficient delivery of data.

Each packet has its own control information and is switched through the network independently. This means that data packets can follow different routes through the WAN cloud and reach the destination out of sequence. Sequencing information included with the packet (it is placed in the packet's header) is used by the receiving device to reassemble the data in the appropriate order.

Packet-switching networks take advantage of virtual circuits when transferring data. A virtual circuit establishes a defined route across the service provider's network so that all the data packets move to the destination along the same route (remember that this route is shared by packets from a lot of other users because switched networks use shared lines). The use of virtual circuits in packet-switching networks can improve the overall performance of your data transfers.

A number of packet-switching technologies exist, such as X.25, Frame Relay, and ATM. The X.25 standard was actually originally developed for connecting mainframe computers at different sites. By today's standards, X.25 (which became available in the late 1970s) is considered slow because it does a great deal of error checking (due to the low quality of phone lines available at the time it was developed). Despite the fact that there are faster technologies such as Frame Relay and ATM (two packet-switching technologies that we discuss in a moment), X.25 is still used by some companies.

Tip

Packet-switching networks have been available since the late 1970s when X.25 became available. The lower cost of packet-switching networks (when compared to dedicated leased lines) led to a fairly rapid evolution of packet-switching protocols such as Frame Relay and ATM. Although the X.25 protocol seems older than the hills now (when compared to Frame Relay and ATM), it is still used by some companies and institutions for WAN connections. It is, however, rapidly being replaced by other packet-switching alternatives.

Frame Relay

Frame Relay is the successor to the X.25 protocol and is faster because it has shed some of the error-checking functions that slowed the packet-switching capabilities of X.25. Frame Relay operates at the Data Link layer of the OSI model (look back at Chapter 5, "Network Protocols: Real and Imagined," for more about the OSI model) and uses permanent virtual circuits for communication sessions between different points on the WAN.

A permanent virtual circuit (PVC) is actually created between two points on the WAN by configuring devices such as routers (that terminate a LAN that is connected to the WAN) with a number that is provided by the service provider. This number, the Data Link Connection Identifier (DLCI), designates the PVC that will connect the two LANs via the WAN. Logical addresses such as IP addresses are then mapped to the PVC, providing a path through the WAN for the movement of data between the connected LANs.

The odd thing about Frame Relay is that it places the data in packets of varying sizes (this is like moving envelopes of different sizes through the same mail slot). This does not significantly impede data flow, but it does introduce some latency into overall throughput. Latency is a fancy word for lag time; the different size Frame Relay packets take some additional time to process by WAN switches, thus the latency. ATM, which we discuss in the next section, actually uses fixed-size packets to increase the potential throughput.

The Frame Relay protocol was originally developed for use over ISDN connections. It is now used over T-Carrier and Fractional-T connections.

Asynchronous Transfer Mode (ATM)

Asynchronous Transfer Mode (ATM) is a WAN packet-switching technology that uses a 53-byte packet called a cell to move data such as voice and video across public networks (such as the POTS) and private WANs. The ATM protocol stack consists of protocols that reside at the Data Link and Physical layers of the OSI reference model. ATM networks support the multiplexing of information, meaning that several channels of information can be contained in one data stream.

ATM uses a virtual channel as the connection between a sending and a receiving device. A virtual channel is basically equivalent to a virtual circuit (refer to the preceding section on Frame Relay). If a company wants redundant virtual channels connecting sites, several channels can be bundled together. This bundle of virtual channels is referred to as a virtual path. Virtual channel numbers and virtual path numbers are supplied to the customer by the service provider. These numbers are then used to configure devices such as routers that sit between the LAN and the provider's switching station (connected by the local loop).

ATM is typically run over high-speed fiber-optic networks. For example, Synchronous Optical Network/Synchronous Digital Hierarchy (or SONET, as it is typically known) is one of the Physical layer specifications for ATM. SONET can provide a throughput of 155Mbps over fiber-optic cabling. ATM backbones are widely used in the telecommunications industry. Many providers of DSL actually connect their DSL customers to the WAN using a high-speed fiber-optic backbone that uses the ATM WAN protocol.

Tip

To make things a little confusing, ATM is now being used as a LAN protocol. ATM switches that are used on a LAN use LAN Emulation (LANE) to emulate a LAN on top of the ATM network. This is accomplished by the LANE protocol, which can emulate either an Ethernet or token-ring network. In simple terms, this means that ATM is able to provide a high-speed environment over twisted pair wire by pretending to be either an Ethernet or token ring LAN. LANE is an advanced topic related to switching devices (switches are discussed briefly in Chapter 3, "Networking Hardware"), which we won't get to in this introductory book.


A Word Regarding Remote Access

While many of the technologies that we discussed in this chapter are related to expanding LANs beyond a particular geographical location, some of the technologies such as modems, ISDN lines, and DSL connections are also commonly used by remote users to connect to the corporate LAN. Not every company or business—especially small businesses and home offices—will make use of WAN technology to expand the range of their LAN. However, even the smallest of businesses (including a home business) might need to allow users to dial in to the local area network and access resources on the LAN as if they were directly connected to the network.

For remote access to work, both the remote user and a special server on the LAN, called a remote access server, must be outfitted with some sort of WAN communication strategy. And while modems have been commonly used on both remote access client computers and on remote access servers on the LAN, other technologies—such as ISDN and even X.25 connections—can be used.

Remote access servers that handle numerous dial-in connections are often outfitted with multiple phone lines and multiple modems. A collection of modems on a remote access server is called a modem pool.

While expanding the LAN through remote access must certainly be considered a deployment of WAN connectivity, the use of dial-up connections certainly isn't as glamorous as many the WAN technologies that we have discussed in this chapter, such as the T-Carrier system and ATM. However, managing remote access is an important aspect of being a network administrator. We will discuss setting up remote access servers and remote access clients in Chapter 17.

The Absolute Minimum

In this chapter we had an opportunity to take a look at the different WAN technologies used to connect LANs at different locations. Some of these technologies—such as modems, ISDN, and DSL connections—are also used by users who connect to the network remotely.

  • The POTS (Plain Old Telephone System) provides a number of different strategies for WAN connectivity.

  • Dial-up connections over regular analog phone lines using modems provide a relatively inexpensive method of expanding a LAN.

  • Asynchronous modems move data over regular phone lines. Synchronous modems are often used on leased digital lines to provide WAN connectivity.

  • The T-Carrier system provides high-speed digital lines that can transfer voice, video, and data.

  • ISDN and DSL are WAN technologies that allow for the transfer of data on regular phone lines.

  • Frame Relay and ATM are both packet-switching WAN technologies that provide for the high-speed movement of data over switched networks.


Chapter 14. How the Internet Works

In this chapter

  • Figuring out where the Internet came from

  • Understanding the FTP protocol

  • Working with Internet email addresses and protocols

  • How HTTP and HTML make the Web work

  • Exploring other Internet Onramps

Now that you are pretty well rooted in LAN technology and have had a chance to peruse some information on TCP/IP networking and WAN connectivity, it's time to take a look at the biggest network in the world—the Internet. In Chapter 12, "TCP/IP Network Administration," we took a look at IP addressing, DHCP, IP routing, and more importantly the Domain Name Service (DNS). Understanding how the TCP/IP protocol stack works and how services like DHCP and DNS work provides you with insight into how data moves on the Internet and how individual users connect to the Internet.

How the Internet was built is somewhat shrouded in mystery. Interestingly enough, many people were not even aware of the Internet's existence prior to the advent of the World Wide Web.

Although in this chapter we will concentrate on looking at how the Internet works and explore the various utilities and protocols used on the Internet's infrastructure, we will start with a look at the innovations that led to the birth of this mega-network.


Where Did the Internet Come From?

The Internet's origins in the United States began in the 1960s. The Advanced Research Projects Agency (ARPA) of the Department of Defense was doling out a great deal of research money to universities and other research centers around the country. ARPA quickly realized that having some sort of data network that would connect the various research sites would make it much easier for research scientists and ARPA officials to share information.

A great deal of theory related to packet-switching networks was developed (much of this early research was done at MIT) and then tested by ARPA by the late 1960s. Two issues that were of supreme importance in developing the packet-switching network envisioned by ARPA scientists were the protocol that would provide the rules and transmission scheme for data on the network and the devices that would actually switch the data along a particular path as it moved from a sending to a receiving device.

The development of the hardware switches, called Interface Message Processors (IMPs), actually preceded the finalization of the network host-to-host protocol, and these switches were tested as early as 1969. The IMP was actually the precursor to the router. In 1970 work was completed on the host-to-host protocol that would be used on the ARPA network, now called ARPAnet. This protocol, the Network Control Protocol, was further developed and eventually rehabilitated into the much more robust TCP/IP protocol suite.

Tip

As mentioned in Chapter 5, "Network Protocols: Real and Imagined," TCP/IP is actually a stack of protocols that each serve a particular purpose in the overall communication scheme. Some protocols, such as FTP and HTTP, supply the user interface and network connection, whereas other protocols in the stack, such as TCP or UDP, actually provide the mechanism for transporting the data packets on the network.

The number of computers on the ARPAnet grew rapidly in the 1970s, as the ARPAnet infrastructure was expanded throughout the United States. Networks designed to serve research and higher education institutions such as BITnet (used to send out electronic postings using LISTSERV software), Usenet (a huge electronic bulletin board full of newsgroups, still in use today and discussed in this chapter), and NSFnet (developed by the National Science Foundation) were developed, thus further expanding the range and number of devices on the packet-switching network that began as ARPAnet.

With the expansion of the Internet backbone by for-profit companies beyond the infrastructure built for educational and research facilities, the Internet has become as integral to business and personal communication as the telephone. You would have to go a long way to find a company of any size without a connection to, and a presence (a Web site) on, the Internet. The number of home connections to the Internet is growing daily at a very rapid pace worldwide.

On a personal level, most people use the Internet to send and receive email and to browse information on the World Wide Web. As far as companies and institutions go, email is also important to corporate communications, as is the presence of companies on the Web.

One thing you should keep in mind as you read through the information in this chapter is that the technology developed to make the Internet a reality is also often used on private networks that do not allow public access. This use of Internet protocols and Internet technology to provide networking services on a private network creates what is called an intranet. Therefore, an intranet would be the private equivalent of what we see on the public Internet. A company simply uses the TCP/IP protocol, Web servers, FTP servers, and other Internet technologies to exchange information on the corporate network.

Let's take a look at some of the different Internet services available, such as FTP and the Web. We can then take a look at some of the other onramps to the Internet, which can also be used for data communication.


Working with the File Transfer Protocol

One of the oldest of the TCP/IP stack protocols used on the Internet is the File Transfer Protocol (FTP). FTP is used to send and receive files over a TCP/IP network, regardless of the operating systems used on the computers sending and receiving the data.

FTP supplies the user interface and the various functions of the Application, Presentation, and Session layers of the OSI model. Although FTP is considered a protocol in the TCP/IP stack, it is also a full-blown application used on the Internet to send and receive files.

FTP uses TCP (which we discussed in Chapter 5, when we looked at the entire TCP/IP stack) at the Transport layer, so a real-time connection is set up between the sending and receiving computers on the Internet. IP addressing provided at the Network layer of the OSI model by the Internet Protocol provides the mechanism used by FTP to identify different nodes on the Internet (DNS plays a role in identifying computers on the Internet and is discussed in "Understanding DNS," in Chapter 12, "TCP/IP Network Administration").

To use FTP to send and receive files on the Internet, you need two things: an FTP server and an FTP client. FTP is a good example of a client/server environment, where the software needed to transfer files is split between the server and the client. Let's take a look at FTP on the server side first.

FTP Servers

An FTP server is a computer that allows other computers on the network to connect to it. Therefore, FTP servers can be large network servers found on corporate networks and the Internet that have been configured with server software that allows them to share files with computers using an FTP client (FTP servers were extremely important to the ARPAnet for sharing files between different sites). FTP servers can also be client computers that are running some kind of FTP server software.

A number of different software packages are available for FTP servers on company networks or the Internet. Linux server distributions provide the FTP server function, as do Microsoft Windows Server platforms such as Windows Server 2003. Each of these network operating systems use different utilities to configure Web services such as FTP. Figure 14.1 shows the Default FTP Site Properties dialog box of the Internet Information Services snap-in tool that is used to configure and monitor Web sites, FTP sites, and newsgroups on a server running Windows Server 2003.

Figure 14.1. Windows Server 2003 uses the Default FTP Site Properties dialog box of the IIS snap-in to configure FTP sites.

Novell NetWare also provides the software and the utilities to configure and manage an FTP server. NetWare 6x uses the Apache2 Server to deploy Web and FTP sites on a NetWare server. Figure 14.2 shows the NetWare Web Manager, which provides support for configuring Web and FTP sites.

Figure 14.2. NetWare provides the NetWare Web Manager.

A number of third-party software companies provide FTP server software, which can be used to turn just about any computer running any operating system into an FTP server. These add-on software products are just fine for setting up an FTP server that will be used to share files with co-workers or with friends over the Internet. Some client operating systems, such as Windows XP Professional and the Mac OS, also provide you with the ability to configure an FTP server using a service built into the OS.

In production environments (a fancy way of saying on a large corporate intranet or a server on the Internet), FTP sites can experience a large number of "hits." So, in most cases you will want to run your FTP site on a server machine (a computer with all the hardware muscle typically found on a server) rather than a client computer.

Once the FTP server software is installed or the FTP service built in to the NOS is activated, the directories that will be accessed by users need to be created. A root directory provides the holding tank for the directories that will be created (in essence they are subdirectories of the FTP root). These directories are then populated with the files that will be available to your FTP clients.

Anonymous FTP

FTP provides a file-sharing environment that can control access to the file server by requiring a logon name and password. This means that the FTP server must validate a user and her password before she can access files on the server.

On the Internet, many public FTP sites allow an anonymous logon. This means that anyone can log on to the FTP site using a username of "anonymous." The password for an anonymous logon is often your email address. A site allowing anonymous logons is often referred to as an anonymous FTP site. Figure 14.3 shows Caldera.com's anonymous FTP site (Caldera is another flavor of Unix), which has been accessed using the Internet Explorer Web browser.

Figure 14.3. Anonymous FTP sites are quite common on the Internet.

Notice that on a Linux-based computer the directories on the FTP site appear in the Web browser window the same as local directories would (these directories would appear the same in Internet Explorer on a computer running Windows). You are potentially accessing files that reside on a computer clear across the world, but the computer's connection to the Internet makes the directories and files appear as if they are local.

FTP Clients

As you've already read in the discussion of anonymous FTP sites, Web browsers such as Netscape Navigator and Microsoft Internet Explorer can act as FTP clients. You can actually download files from an FTP site by locating them in the browser window and then using the copy command. Files can also be uploaded to an FTP site (that is, if the site allows uploads; many sites are "read only," meaning you can copy files from the site but cannot upload files to the site).

You can also use an FTP client to connect to FTP sites. There are FTP clients for just about any operating system. FTP clients can take the form of add-on software, such as WS_FTP, which is shown in Figure 14.4. The local drives and directories are shown on the left side of the FTP client window, and the remote or FTP directories are shown on the right side.

Tip

FTP client capability is built into Web browsers such as Netscape Navigator, the Mozilla Web browser, and Microsoft Internet Explorer. You can download files from, and upload files to, FTP sites. These sites are usually referenced by a link on a Web page. Most of these sites are also anonymous FTP sites.

Figure 14.4. FTP clients provide a way to move files from a local computer to an FTP site, and vice versa.

Many operating systems, such as Microsoft Windows and Linux-based systems, also allow you to connect to an FTP server from the command line. Figure 14.5 shows the command-line commands used to connect to a local FTP server (on the company intranet) from a Microsoft Windows client computer.

Figure 14.5. Connections to an FTP server can also be established using command-line commands.

The actual connection to the FTP server is established either by specifying the IP address of the FTP server or by using the fully qualified domain name (FQDN), or friendly name, of the server. The role of FQDNs is covered in the section, "Understanding DNS," in Chapter 12.

Once the connection is established, file directories on the FTP server can be viewed by the client. Files can then be downloaded or uploaded as binary files or in ASCII text format. One of the most compelling reasons for using FTP is that it supplies you with the ability to move files easily between different types of operating systems.

Tip

Many FTP clients can be downloaded from sites on the Web, such as TUCOWS (The Ultimate Collection of Winsock Software). Both freeware and shareware versions of clients for a number of different operating systems are available on the TUCOWS site at http://www.tucows.com/.


Understanding Electronic Mail

Electronic mail (email) was not actually part of the plan when ARPA began to build the data communications network that would eventually evolve into the Internet. However, after being introduced to the ARPAnet in 1972, electronic mail quickly became the most-used application on the network.

It can also be safely said that, on the Internet, email is one of the most widely used applications, and a large percentage of the total traffic on the Internet relates to email. Internet email has a client side and a server side, just like FTP and the Web (this is discussed in the section "Working with the Web," later in this chapter).

Note

ASCII (American Standard Code for Information Interchange) is the basic character set used by most computer operating systems.

On the client side, there are a large number of different Internet email clients. Web browsers such as Netscape Navigator and Microsoft Internet Explorer have built-in or associated email clients. A number of different email clients, including some freeware clients, can be downloaded from numerous sites on the Web.

The ability to receive Internet email has also been integrated into popular Personal Information Managers such as Microsoft Outlook and Lotus Notes (both of which are considered groupware products, as discussed in Chapter 11, "Working with Applications on the Network"). Figure 14.6 shows the Microsoft Outlook window and the Inbox with the highlighted message in the Reading pane. Multiple views and options exist with such email clients, providing a reasonable level of customization.

Figure 14.6. A number of different clients, including Microsoft Outlook, are available for email.

Email Addresses

Email addresses take the form of name@domain.suffix. For example, if I worked at a company named SureFire Fireworks, my email address might be joeh@surefire.com.

The first part of the address is the mailbox or email username. In the case of the preceding example, joeh would be used to specify a particular user and the mailbox in which a mail item addressed to joeh@surefire.com should be placed on the SureFire Fireworks email server.

The second part of the address (in this case, surefire.com) is the Internet domain name of the company and is used to specify the mail server. Domain names are covered in more detail later in the chapter when we take a look at DNS.

In developing an understanding of how email servers on the Internet (or an intranet) work, one needs to remember that the sending and receiving of email on the Internet or a company's intranet is tightly woven into how data is moved from one location to another by the different protocols in the TCP/IP stack (discussed in Chapter 5). The three TCP/IP protocols that we need to discuss in terms of email are the Simple Mail Transfer Protocol (SMTP), the Post Office Protocol 3 (POP3), and the Internet Message Access Protocol (IMAP).

SMTP

SMTP is a protocol that works at the Application, Presentation, and Session layers of the OSI model (see Chapter 5 for an explanation of the OSI model). It uses TCP at the Transport layer for connection-oriented transport of packets.

SMTP's purpose is to transfer email from a sending computer (for example, someone sending email) to a receiving computer (the SMTP email server). So, SMTP functionality is built into the email client and the email server software. SMTP is also the protocol that moves email between email servers (such as from the origin email server to the destination email server).

SMTP clients actually identify the location of a particular email server by using the domain name that accompanies the actual email account name. For example, the domain name in our example joeh@surefire.com is surefire.com. With the help of a DNS server (discussed in Chapter 12), the client can resolve the domain name information (along with the fact that it is looking for an SMTP mail server) to the actual IP address of the mail server.

At one time SMTP was used for both the sending and receiving of email messages. This works fine in situations where the clients and the mail server are on the same network. This is because SMTP uses a connection-oriented strategy for moving mail messages (as was already mentioned). However, the Internet isn't necessarily the type of environment where all the computers that use this internetwork are online all the time. Therefore, some sort of strategy had to be developed in which email could be held on a mail server until a particular user logs on to the Internet to retrieve his mail. This is where POP3 comes in.

POP3

POP3 is a TCP/IP stack protocol used by email clients to connect to a POP3 email server. The POP3 mail server basically functions as a mail drop.

The POP3 mail server will have a persistent connection to the Internet, allowing it to accept and hold email intended for the clients that use the server. When a client connects to the Internet, it can use a POP3 email client to connect to the POP3 server and download any available mail.

The client's logon name and a password are used to access the appropriate mailbox on the POP3 server. Once the client connects, all the mail is removed from the server and downloaded to the client computer.

A POP3 session actually goes through three different stages: authorization, transaction, and update. The authorization stage requires that the user provide the appropriate authorization credentials, such as the user name and password (as we discussed in the previous paragraph). Once the user has been authenticated to the server, the client accesses the email on the server, which in most cases is downloaded to the client computer. The update stage involves tasks that are to be carried out when the user terminates the connection to the mail server. For example, most Internet service providers require that all downloaded email (sent to the client during the transaction stage) be removed from the mail server.

You will find that most email server software supports both SMTP and POP3. So, many companies or Internet service providers will have one server that provides SMTP and POP3 functionality.

Note

You should keep in mind that all the protocols in the TCP/IP stack use IP addresses to identify the source or destination of data packets or datagrams such as email messages. IP addressing is managed by the IP protocol, which operates at the Network layer of the OSI model. To make a long story short, I think you can see that protocols in the TCP/IP stack operate at different layers; to maintain communication between these protocols at different OSI layers, each protocol has been assigned a well-known port number. For example, SMTP uses port 25, and POP3 uses port 110. When a port number is combined with an IP address, a socket is created, which actually provides the communication conduit between the applications. Port numbers also serve as an avenue for hackers and crackers to break into your network or computer. See the section "Protecting a Network from Outside Attack" in Chapter 20, "A Network Security Primer."

IMAP

IMAP is an email transport program that provides an alternative to the POP3 protocol. IMAP mail servers do not immediately dump all the available mail from the server to the IMAP client when the client connects. Rather, the server sends a listing of waiting messages. The messages themselves are kept on the server. This allows a user to view both saved messages and new messages on the IMAP mail server.

IMAP is particularly useful when one email account might be accessed by more than one computer or device. For example, a user with a computer and an email-enabled cellular phone or a Personal Data Assistant, such as a Palm Pilot, that is outfitted to connect to the email server might access his email from more than one device, depending on whether he is in the office or on the road.

Because the mail is maintained on the server, even after it has been read, the status of each message can be viewed each time the user logs on to the IMAP mail server, regardless of whether he accesses the server with his personal computer or email-ready cell phone. This is useful when you're on the road because you would see the status of messages as you left them after accessing mail on your office computer, meaning email messages will not be replied to more than one time, and even read messages can be accessed from the any email-ready device.

Popular Web-based email services such as Yahoo! mail and Microsoft Hotmail take advantage of IMAP. Figure 14.7 shows the Inbox for a Hotmail account. All the email is held on the mail server until the user deletes the messages.

Figure 14.7. Systems such as Hotmail store email messages on the server until they are deleted by the user.

Most email clients support SMTP, POP3, and IMAP. Email server software such as Microsoft Exchange and Lotus Domino (the server for Lotus Notes) also supports these different email protocols.

Configuring an Email Client

Configuring an email client on a client computer is a matter of specifying the SMTP and POP3 (or IMAP) servers that provide the client with the ability to send and receive email. It goes without saying that the client computer also needs to be configured for an Internet connection either via a dial-up or other connection type such as a direct LAN or broadband connection (such as cable broadband or DSL).

To configure an email client you must provide the email account name (in the format name@providername.com) and the user password to access the account. You must also provide the name of the incoming and outgoing servers (POP3 usually serves as incoming; whereas SMTP serves as outgoing). Figure 14.8 shows the configuration wizard for the Mozilla email client running on a computer using the Lycoris (Linux) operating system.

Figure 14.8. Configuring an email client requires the account name, password, and the name of the mail servers.

Once the account and mail server properties have been configured, the email client can be used to send and receive email.


Working with the Web

The software bells and whistles for the World Wide Web (WWW) didn't actually surface until 1991. Scientists at the CERN research laboratory developed the Hypertext Markup Language (HTML) so that they could exchange information about their projects over their TCP/IP network.

HTML is the file format used to create documents that can then be read by a Web browser such as Microsoft Internet Explorer or Netscape Navigator. HTML consists of tags that are used to format a document so that it can be viewed in a Web browser. HTML offers a rich environment for creating documents that can include graphics, sound, video, and links to other HTML documents, such as other Web sites.

Hypertext Transport Protocol (HTTP) is the TCP/IP stack member that provides the connection between an HTTP client (a computer outfitted with a Web browser) and server (which would be a Web server, in this case). A Web client sends a connection-oriented request using HTTP, which uses TCP for the connection, to a particular Web server, typically using the Uniform Resource Locator (URL) for the Web server, which is the DNS name of the server. To make a long story short, the URL is the name that you type into your browser address window. DNS handles the resolution of the URL to an IP address.

The Web server holding the HTML documents or Web site requested by the Web client will respond to the client with a connectionless HTTP communication that uses UDP at the Transport layer of the OSI model. This allows the Web client to access the actual Web site.

I think just about everyone is familiar with the different Web browsers (clients) available. As far as Web servers go, in the Unix/Linux world, the Apache Web server is quite popular. Netscape offers the Netscape Enterprise server, which can run on Windows, Linux, and Unix operating systems. Microsoft bundles Internet Information Server with Windows Server 2003 and Windows 2000 Server.

Your choice of Web server software will depend on the NOS you run on your Web server. We will take a look at hosting a Web site in Chapter 16, "Hosting a Web Site."


Other Internet Onramps

Although email and the Web predominate user access to the Internet, other tools can be used to access various information repositories on the Net. One of the earliest TCP/IP protocols used for connecting one computer to another was the Telnet protocol. Very useful in the Unix environment, Telnet can be used to connect to another computer and access resources on that computer. Although Telnet is still used a great deal to configure and monitor routers and switches on large internetworks, it isn't used all that much to access the Internet.

Two other protocols that can be used to access information on the Internet are NNTP and Gopher. A fourth Internet onramp is Internet Relay Chat, which provides a real-time discussion venue. These three Internet onramps are discussed in the sections that follow.

Newsgroups

Newsgroups have been around since 1979, when newsgroup servers were set up at Duke University and the University of North Carolina. Usenet, a network of news servers connected to the Internet, is still around today. Most news servers are run by educational institutions and large companies. Internet service providers also typically have their own news servers, and they choose which of the newsgroups available on the Internet to carry on their servers and offer to their subscribers. Information on news servers is broken into categories. Each subject area is called a newsgroup. Figure 14.9 shows the Xnews newsgroup client window. Xnews is a Windows-based freeware newsreader.

Figure 14.9. Thousands of newsgroups are available on Usenet.

Newsgroups are kind of like an electronic bulletin board, where users can post or read messages. As with other information services on the Internet, newsgroups have a client and a server side. The TCP/IP protocol that allows the exchange of information from a newsreader (the client-side application) to a news server is the Network News Transfer Protocol (NNTP).

NNTP uses TCP to negotiate a connection between the client newsreader and the news server. The client lets the server know which articles in a particular newsgroup it has already viewed, and only a list of new or unread articles will be provided to the client.

Each posting in a newsgroup contains a header that provides the subject of the news post. It is the headers that are downloaded by the client from the server. When the header for a particular article is selected, the entire message is then uploaded from the server to the client.

Users can respond to messages listed in a newsgroup or create new posts. Figure 14.10 shows a new message being created in Outlook Express.

Figure 14.10. Newsreaders allow you to create and post messages to a news group.

Many different news clients are available. Outlook Express, the email companion to Internet Explorer, also has the ability to act as a newsreader, as does Netscape Navigator. The Apache Server software available for Unix/Linux platforms can act as a news server, as can Internet Information Services, which is a service provided with Microsoft Windows server products such as Windows Server 2003. A number of standalone news server products also exist, such as the DNEWS Server.

Tip

The usefulness of newsgroups has certainly caught on in the corporate world. Both Lotus Notes and Microsoft Exchange offer newsgroup features that allow employees involved on projects to create their own discussion groups, which operate very much like the Usenet newsgroups.

Internet Relay Chat

One of the "old guard" communication venues on the Internet is Internet Relay Chat (IRC). IRC first became available in the late 1980s. Many universities and other organizations host IRC servers. A client computer connects to an IRC server using an IRC client. IRC "conversations" are conducted on a particular channel. Channels are available for a variety of topics: everything from sports to movies to computer hardware.

A number of IRC chat clients are available for download on the Web. Figure 14.11 shows the mIRC IRC client. The user has connected to the irchelp channel, which provides help on using IRC.

Figure 14.11. IRC provides a real-time chat environment.

All messages posted by users connected to the channel can be read by all users on the channel. Most IRC clients also provide the ability to "whisper" to a particular user during the session.

Once the client software is installed on a computer, the client connects to any of a number of IRC servers (each client provides a list of default servers that can be used for the connection). Once connected to the IRC server, a user can browse the various channels available and connect to a particular channel.

In retrospect the concept of online chats was an extremely important addition to the Internet. Proprietary chat clients from Microsoft, Yahoo!, and AOL have sprung up on the Web and provide real-time chat forums similar to those offered by IRC. An open-source product, Jabber, provides both an open-source server and a number of free Jabber clients that allow users to connect in an environment similar to Yahoo! chat and the other chat software available via the Web. The fact that Jabber's server is open source means that organizations can outfit their own communication server, making the chat environment available on an intranet or over the Internet.

The Absolute Minimum

In this chapter we sorted out the Internet and some of the different TCP/IP protocols that were developed to access information on the Internet. Key points covered are as follows:

  • ARPA began the planning and building of the ARPAnet in the 1960s. ARPAnet eventually evolved into the public TCP/IP network we call the Internet.

  • FTP is used to send and receive files on a TCP/IP network, such as the Internet.

  • Internet email uses the SMTP protocol to move mail from a mail client to the SMTP mail server.

  • Email clients come in the format username@domain.suffix. The username is actually the email mailbox for the user, and the other information specifies the domain name of the company or institution.

  • Email clients use the POP3 protocol to retrieve mail from a POP3 mail server. All the mail on the server is uploaded to the client computer.

  • IMAP is an email transport program that retrieves a list of email on the server without downloading the mail. This means that a user can connect to the IMAP server from different devices and view the same email messages and their status.

  • HTML is the coding language to create Web site pages. The Web uses HTTP as the transport mechanism between Web browsers and Web sites.

  • Usenet provides newsgroups in a bulletin board environment where users can read and respond to messages.

  • Internet Relay Chat provides users with the ability to join online channels that provide a real-time chat environment. A number of companies such as AOL, Yahoo!, and Microsoft have built on this idea and provide their own form of real-time chat using a variety of client software.


Chapter 15. Connecting a Network to the Internet

In this chapter

  • Selecting an Internet service provider

  • Working with an Internet access provider

  • Understanding the Internet backbone infrastructure

  • Connecting a network to the Internet

  • Understanding cable modems

  • Working with proxy servers

  • Using network address translation

In the previous chapter, we took a look at how the Internet has evolved over the last 30 years from a government-funded project in packet-switching technologies to the very public global network that we are familiar with today. We also discussed some of the different protocols that have come and gone (and stayed) as programmers developed different avenues and interfaces for accessing the Internet.

In this chapter, we discuss issues related to getting your company online. We will take a look at sorting out the different possibilities for connecting to the Internet and how you would go about creating a presence for your company on the Internet. Let's begin our discussion with issues related to connecting your LAN to the Internet.


Connecting to the Internet

Our discussion of networking thus far has been fairly company-centric, meaning we have talked about LAN and WAN technology in terms of providing a network infrastructure for a single company or institution. Even our discussion of wide area networking was a look at providing data communication avenues between remote sites and the company's central LAN.

Another important aspect of networking the enterprise involves providing users with a conduit to the Internet. Although the rationale for connecting a company to the Internet can at times seem to be based on nothing more than a high-placed corporate officer shouting "Everyone else is doing it" at a board meeting, it falls on the network administrator or the administration team to determine the best way to connect the company's network infrastructure to the Internet backbone. This usually means researching local Internet service providers (ISPs) and different WAN technology options for the connection between the corporate network and the ISP (with the ISP providing the onramp to the Internet backbone). Before we talk about ISPs and some of the issues related to selecting a connection type (we discuss the various WAN technologies used to connect to the Internet in Chapter 13, "Expanding a LAN with WAN Technology"), let's take a look at how the Internet backbone is structured to provide communication among Internet service providers.

Accessing the Internet Backbone

When ARPAnet was first being developed, its creators wanted to create a packet-switching network that provided redundant paths for data transfer. ARPAnet was to serve as an internetwork (a network of networks) connecting government and educational institutions that could still move data even if sites or network paths became disconnected from the network backbone (that is, destroyed in a nuclear holocaust). As the ARPAnet evolved into the Internet, however, businesses and individuals wanted connections to the Internet backbone. This is where the Internet service provider (ISP) or Internet access provider (IAP) comes in.

Although the terms ISP and IAP are often used interchangeably when referring to companies that provide Internet access, for our discussion, I'd like to differentiate between the two. ISPs typically serve the little guy, such as a home user or small business, who wants to connect to the Internet and take advantage of Internet email, the WWW, and other Internet services. So, let's say that ISPs (because of the word service in the name) provide Internet connections to users and companies and offer services such as Internet email, Web browsing, FTP, and newsgroups—all the typical Internet services. They may even provide some space on their Web servers for user Web pages and may also provide the DNS servers required for connection to the Internet.

An ISP doesn't have to be a monster organization that is directly connected to the Internet backbone. An ISP can actually lease its connection to the Internet from an IAP.

So, what's an IAP? An IAP would be a communications company that only provides a connection to the Internet. The companies served by an IAP (usually larger companies and even ISPs) would be responsible for their own DNS servers, mail servers, and so on. The IAP only provides the onramp to the Internet and actually connects to the Internet backbone via a network access point (NAP). An NAP is a public exchange facility that provides connections for any number of IAPs to the Internet backbone.

So, now you are probably wondering how these different network access points are connected. The different NAPs are actually connected by a set of trunk lines (which are part of the Internet backbone). Sprint is an example of a company that operates a NAP.

Each of the NAPs rests on one of the Internet trunk lines, and these trunk lines allow the Internet access providers to communicate with each other (the end result of their communications is the movement of data over the Internet). An Internet trunk line (and there are currently seven in the United States) is referred to as a metropolitan area ethernet (MAE). The first MAE line was created in Washington, D.C., and is referred to as MAE East. The MAE that primarily serves the Silicon Valley is referred to as MAE West (kind of figures, doesn't it?).

So, to make a long story short, unless you are a very large company, you probably won't be directly connected to the Internet backbone by an NAP. Your connection will be downstream of the backbone, provided by the linking of your ISP to larger IAPs or companies that have NAP connections.

Note

The MAE network is managed by the MFS Communications Company. This company was awarded the contract to manage the MAE backbone by the National Science Foundation.

Choosing an Internet Service Provider

It really goes without saying (although I'm going to say it anyhow) that you should carefully research the different ISPs available for connecting your company to the Internet. Depending on where your business is located, there might be as many ISPs to choose from as used-car dealers. You should also exercise the same caution in choosing an ISP that you would when buying a used car.

While selecting an ISP for a home network or small office isn't as crucial as selecting an ISP for a large corporate network (unsatisfied home networks and small companies can usually switch ISPs fairly quickly without that much disruption to the business), you should be sure that you select an ISP that provides good support in case you have problems configuring your network computers to connect to the Internet. You should also look for an ISP with a good track record and one that supplies you with extras such as additional email accounts at a reasonable fee.

Obviously, how your company or small business is planning to use the Internet will color how you choose your ISP. For example, if your Internet connection is extremely important to how your company does business, you will want to select an ISP that can ensure a consistent connection. The following list of questions provides some issues that you will want to explore when selecting your ISP, particularly in situations where you are connecting a larger company to the Internet:

  • Is the ISP redundantly connected to its upstream link? It's important for you to know how many redundant links the ISP maintains with its "big brother" IAP. Redundant connections assure you of a more consistent connection through your ISP to the Internet backbone.

  • Who will supply the equipment for the ISP/LAN connection? You need to find out if the ISP provides and configures necessary equipment, such as routers, as part of the connection cost or if you will have to purchase and maintain your own WAN connectivity devices.

  • Can the ISP provide you with a pool of IP addresses for your network and obtain your domain name for you? Having your own pool of IP addresses to work with provides you with flexibility in bringing new clients onto the network and configuring Web servers or DNS servers that require fixed IP addresses. It's certainly not that difficult to obtain your own domain name (as discussed later in this chapter), but if the ISP will do it for you and maintain the DNS servers required, this is one less thing you have to worry about when building your IP network. Be advised, however, that if you obtain your own domain name, you can easily take it to another ISP if needed.

  • Will the ISP help you secure your IP network? You need to know what the ISP is willing to do to help protect your LAN from invasion over the Internet connection. Find out if the ISP offers firewalls (we discuss firewalls in Chapter 20, "A Network Security Primer," in the section "Understanding Firewalls").

  • What kind of technical support is offered by the ISP? Find out if the ISP offers 24/7 technical support or if it's closed every time there is a local Star Trek convention.

Although this list doesn't take into consideration any special requirements or your actual Internet connection needs, you probably get the picture that your choice of ISP shouldn't be based totally on price (the same goes with used cars). You need to take the time to be sure the ISP has the experience and connectivity muscle that will assure you of a consistent and cost-effective connection to the Internet. Don't be afraid to ask an ISP for references. Taking the opportunity to talk to other clients of the ISP might prove to be the most valuable research you do when selecting an ISP.

Choosing a Connection Type

Your connection to your ISP can take advantage of any of the different WAN connectivity strategies we discussed in Chapter 13. The connection type you choose should provide enough bandwidth to handle the movement of data between your network users and your ISP. For example, a small business might be able to get away with a 640Kbps DSL connection. A larger business might require a fractional T-1 or a full T-1 carrier line to provide the appropriate data transfer pipe.

During your initial dialogue with a prospective ISP, you need to find out how much experience it has with the different WAN possibilities for connecting your company to it. An ISP with a proven track record of providing connections for businesses can also provide you with information on the type of connections it provides to other clients.

One connection type that we didn't take a look at when we discussed the various WAN technologies in Chapter 13 is the cable modem. It provides an alternative for small companies looking for a connection to the Internet in markets where DSL isn't available or in situations where ISDN just doesn't provide enough bandwidth. Cable companies such as Time Warner (which is known as Bright House in some markets) offer cable modem connections.

Cable modem connections take advantage of the cable TV infrastructure. Data is moved on different frequencies (or channels, if you prefer). Upstream and downstream data typically require separate frequencies. Although cable modem technology and the methods for allocating bandwidth are still being developed, bandwidths in excess of 2Mbps (with the possibility of speeds up to 30Mbps) can be experienced using the technology (the more bandwidth you want, the more you pay the provider). Because a cable company that offers broadband cable modem connections also serves as the ISP for these connections, a small company that wants a connection to the Internet, but does not necessarily consider the connection to be mission critical, might want to consider broadband as a possible connection.

A number of cable television providers, such as Time Warner, now offer cable modem connections for home networks, small businesses, and even larger businesses. Different connection packages are available that supply varying amounts of bandwidth. The cable modem itself supplies the connection between the ISP (the cable company) and its Internet gateway server. The cable modem is connected to a regular television coaxial cable outlet. You can then connect the cable modem to your router, switch, or hub using CAT 5 twisted-pair cabling.

In many regional cable markets, even the basic home cable modem package will provide dynamically assigned IP addresses and enough bandwidth for five networked computers. It is a very good way to share an Internet connection in a home or small office situation.

Regardless of the technology you choose for your connection to your ISP, you need to be sure you understand that particular WAN technology and how to secure IP traffic between your network and the ISP. The use of firewalls and other security strategies such as IPSec (firewalls and IPSec are discussed in Chapter 20) should also play a part in your overall planning of the connection of your network to the Internet.


Getting Your Own Domain Name

For your company to have a presence on the Internet, you need a domain name. The domain name is the friendly name that is used to locate your Web site or FTP site and to label email messages to or from your domain. Domain names can often be procured for you by your ISP (and this works well in cases where the ISP will also host your domain). Alternatively, you can apply for your domain name yourself.

You apply for domain names that end in .com, .biz, .org, .info, or .net by contacting a domain name registration provider (sites ending in two-letter country codes are handled by other providers). For example, InterNIC Domain Services, a registration provider at http://internicdomainservices.com, can be used to register your domain name (this is just one of many providers and is only being used as an example, not as a recommendation). InterNIC Domain Services also supplies a search engine you can use to determine whether the domain name you wish to use is already taken. For example, I searched for Habraken.com and Habraken.net. Both of these domains are already taken, as shown in Figure 15.1 (who knew that so many Habrakens were running loose on the Web).

Figure 15.1. Registration providers supply search engines you can use to see whether your desired domain name is already taken.

When you apply for your domain name, you will also need to know how DNS services will be handled for your domain (DNS is covered in Chapter 12, "TCP/IP Network Administration"). This means that you will either deploy your own DNS servers or use DNS servers provided by your ISP.

The cost of a domain name is fairly nominal when you consider that it can help to greatly increase the visibility of your company when used to establish your presence on the Web. To register a domain name using InterNIC Domain Services, you pay $29.95 up front. There is also a fee to keep your domain name active. For the first two years, InterNIC Domain Services charges $70. Believe it or not, the fees for registering and maintaining your domain name will vary among domain name registration providers. You should do a little research before you select a provider. Also be advised that ICANN limits the leasing of a particular domain name to 10 years.

You certainly don't have to have a domain name just to connect your small business to the Internet (and don't let an ISP tell you that you do). If having your own domain is going to enhance your business or if your business is going to revolve around e-commerce, you will want to have a domain name.

Just keep in mind that not everyone needs to have a domain on the Internet. If you have a very small company that is establishing its client base through other means, having a domain name and company Web site (which is discussed in Chapter 16, "Hosting a Web Site") might be nothing more than a luxury.

Note

In the not-so-distant past, all requests for domain names were made directly to InterNIC, an organization entrusted by the U.S. government to handle domain name registration. InterNIC also initially handled the allocation of IP address pools. A new organization (which has absorbed InterNIC), the Internet Corporation for Assigned Names and Numbers (ICANN), now handles domain name registration. You can check out a list of ICANN-accredited domain name providers at http://www.internic.net/.


Getting Your IP Addresses

Another aspect of connecting to the Internet involves how you will get the IP addresses that computers on your network will need to connect to the Internet. Many ISPs use the dynamic assignment of IP addresses to individual users and small companies. This means that your client computers receive their IP addresses from a DHCP server run by the ISP. Using dynamic addresses is fine if you have a small peer-to-peer network, but in cases where you are running your own servers on the network, you will need some static IP addresses. For example, Windows 2000 servers, NetWare servers, and Solaris servers all require static IP addresses to operate properly. Servers need a static IP address because many of the services that they provide to client computers find that service using that particular IP address.

You can lease static IP addresses directly from your ISP. Charges vary from ISP to ISP, but based on my experiences with leasing additional static IP addresses for my own small business network, I have found the cost to be around $20 to $30 per month for each static IP address.

If you work at a large company and need a large pool of IP addresses, you can go to the actual source of IP addresses, the American Registry for Internet Numbers (ARIN), to lease your addresses. ARIN is a not-for-profit organization established to register (and administer) IP addresses for North America, South America, the Caribbean, and sub-Sahara Africa.

The minimum number of addresses that can be leased from ARIN is 4,096, which costs $2,500 per year. So, unless you work for a very large company, you will have to acquire IP addresses from your ISP. For more information about ARIN, check out its Web site at http://www.arin.net/.

Note

You can forgo directly connecting all the PCs on a small network to the ISP by using a proxy server or a host computer running an OS such as Windows XP (both the Home and Professional versions) or Windows 2000 Professional. Server products including Windows Server 2003 and Windows 2000 Server also support Internet connection sharing (which is discussed later in this chapter). This means that only the computer providing the Internet connection will need an IP address that is statically or dynamically assigned by your ISP. So, how do the other computers on the network get an IP address? We will discuss that later in the chapter when we look at Internet connection sharing.


Sharing an Internet Connection

For a very small business or a home-based business, where the use of the Internet by employees is somewhat minimal, you can choose to not connect all the computers directly to an ISP. Instead, one computer can be connected to the Internet via an ISP and then this connection can be shared with other computers on the network.

Actually setting up the Windows OS to share the connection is very simple. You right-click the connection that is to be shared (such as a network or modem connection listed in Network and Dial-up Connections) and then select Properties on the shortcut menu that appears. Figure 15.2 shows the Sharing tab of a connection's Properties dialog box that is used to configure the sharing of an Internet connection. Notice that it's really just a matter of selecting a check box.

Figure 15.2. Windows 2000 provides an Internet connection sharing feature that allows you to share one Internet connection on a small network.

On first inspection, sharing an Internet connection using an OS such as Windows 2000 (or Windows XP) looks extremely easy. However, there are some hardware issues related to sharing an Internet connection that must be dealt with, and you need an understanding of how IP addressing is going to be handled on the "internal" network to get this whole thing to work properly.

Note

IP addressing for the rest of the world is managed by two other organizations. The RIPE Network Coordination Centre handles Europe, the Middle East, and the parts of Africa not serviced by ARIN. APNIC (Asia Pacific Network Information Centre) handles the Asian Pacific region.

Hardware Required for Sharing an Internet Connection

To accomplish Internet connection sharing using an operating system such as Windows XP, the computer that shares the connection will need two connections: one to the ISP and one to the other computers on the network. In cases where the computer is connected to the ISP using a modem, the connection to the rest of the network will be provided by the computer's NIC (sharing a modem connection is going to provide a very slow connection when shared among multiple computers, but it can be done).

In cases where the computer that will share the connection is connected to the ISP by a DSL router or a cable modem, a NIC is used to connect to the DSL router or cable modem, and this NIC will have to be configured with either a static IP address supplied by the ISP or configured to accept a dynamically configured IP address from the ISP's DHCP server.

So, how does this computer connect to the rest of the network once it is connected to the Internet? It will require a second network card. This second network card will be connected to the hub that connects the other computers on the network.

Note

Some DSL and cable broadband routers/modems now support USB connections. This means that you can connect the computer providing the shared Internet connection to the ISP using a USB port. A network card provides the connection to the computers that will share the connection.

IP Addressing for the Computer Sharing the Connection

Now, you are probably wondering where the networked computers and the second NIC (the one connected to the network hub) on the computer sharing the Internet connection are going to get their IP addresses? They actually get their IP addresses automatically, but not from a DHCP server. Windows XP embraces a feature called Automatic Private IP Addressing. This feature automatically assigns an address to a computer's NIC using a range of IP addresses from 169.254.0.1 to 169.254.255.254, with the subnet mask 255.255.0.0.

Automatic addressing only takes place when you configure the IP properties on the NIC so that the computer expects to receive its IP address from a DHCP server. Figure 15.3 shows how you would configure a Windows client to take advantage of automatic private addressing. You actually configure it to get its IP address from a DHCP server.

Figure 15.3. Computers running Windows that can't find a DHCP server will use the Automatic IP Addressing feature.

When the computer can't find a DHCP server on the network to supply an IP address, it configures itself with an IP address from the reserved range. Because the computers on the network are constantly talking to each other, they make sure that no two computers use the same IP address.

So, due to the fact that the computers have all automatically assigned themselves addresses from a specific range of IP addresses (actually addresses that all fall into one network range), the computers use these addresses to communicate. They communicate with the computer that provides the Internet connection as well as with each other.

When you use the Internet connection sharing feature on a Windows computer, you are basically turning the computer into a proxy server (even though you don't configure Web browsers on computers sharing the connection to use a proxy server, as discussed in the preceding caution). Proxy servers are the subject of the next section.

Note

The Internet Assigned Number Authority (IANA) has actually reserved the IP range of 169.254.0.1 to 169.254.255.254 for private addressing. Therefore, these addresses aren't going to conflict with any IP addresses on the Internet.


Sharing an Internet Connection with Windows Server 2003

Microsoft server products such as Windows Server 2003 also provide you with the ability to share an Internet connection on a small network. In effect, the Windows server acts as a proxy server supplying the connection to other computers on the network (proxy servers are discussed in the next section).

Setting up Windows Server 2003 to share an Internet connection is very straightforward (almost as straightforward as setting up Internet sharing on a Windows operating system such as Windows 2000 or XP). You configure the network connection that is configured with the public IP address and connected to the Internet service provider.

Right-click on the network connection (it can be a Dial-up, LAN, or High Speed Internet connection) that will be configured for the public IP address (it can be a network card with a fixed IP address or configured as a DHCP client or a modem) and will provide the connection to the Internet. Select Properties from the shortcut menu. The Properties dialog box will open. Select the Advanced tab on the connection's Properties dialog box. Figure 15.4 shows the Advanced tab of a connection's Properties dialog box.

Figure 15.4. Microsoft servers can also share an Internet connection.

On the Advanced tab, select Allow Other Network Users to Connect Through This Computer's Internet Connection. Click OK to close the dialog box.

A message box will open, letting you know that the LAN connection for the server will be set to 192.168.0.1. This is an automatic address and should remind you to set up all the computers in the workgroup for dynamic IP address configuration so that they also are assigned an address in the same range of private addresses.

Caution

You will also have to configure Web browsers such as Internet Explorer and Netscape Navigator on the computers that will use the shared Internet connection (don't do this on the computer that supplies the shared connection). Oddly enough, for connection sharing to work with the Web browser, you need to be sure that features such as the automatic detection of the proxy server or the use of a proxy server are not selected. You also want to disable dial-up features provided by the browser so that it does not attempt to automatically dial a connection of its own.

Note

Windows Server 2003 also provides a basic firewall that can be configured to help negate outside access to the server that is providing the Internet connection to the network. Firewalls are discussed in Chapter 20, "A Network Security Primer."


Working with Proxy Servers

When you connect your network to the Internet using an ISP or an IAP, you are setting up an environment that provides an unrestricted flow of information between your network and just about everyone else in the world (everyone with an Internet connection). Now, because you know and trust (at least somewhat, hopefully) the users on your internal network and have implemented some security measures on the LAN, you can consider it a trusted network. However, because you don't know everyone else in the world and have very little control over security on the Internet itself, you would have to consider the Internet an untrusted network.

Every time one of your network users connects to the Web or downloads files from an FTP site, information such as the IP address of the user's computer can be recorded by the Web or FTP site the user connects to. A way to hide important information that can easily be collected (and potentially used to crack into your network) when your users access the Internet is to use a proxy server.

A proxy server sits between your trusted network and an untrusted network, such as the Internet (see Figure 15.5). When a user on your network attempts to access the WWW with a Web browser, the request goes to the proxy server. The proxy server strips off the IP addressing information from the data packets that make up the request from the user and affixes addressing information specific to itself. The proxy server then contacts the Web server requested by the user. The proxy server will actually download the requested Web page and then supply it to the user.

Figure 15.5. Proxy servers sit between your network and the Internet and intercept communication requests.

Using proxy servers totally hides the IP addressing information on your internal network. Proxy servers can supply additional security by also serving as firewalls (that is, if the proxy server software you use provides firewall features; firewalls are discussed in Chapter 20).

Proxy servers can do more than just hide information about the internal, trusted network. Proxy servers can be configured to filter requests made by users on the trusted network to the Internet. For example, you might want to make certain Web sites off limits to your users, and the proxy server can be set up to deny requests for certain types of Web information.

Proxy servers can also actually speed up requests that are made by your users for information on the Internet. For example, a proxy server can cache Web pages that are accessed by your users. This means that the pages will be readily available (in the proxy server's cache) the next time the user or users access those Web pages.

Proxy server software is available from a number of different vendors, including Microsoft Proxy Server, Netscape Proxy Server, and Sun's iPlanet Proxy Server. There are a large number of proxy servers that exist for small businesses and home offices. Check out www.tucows.com if you want to try out some of these different proxy server packages (we will take a look at a freeware proxy server, called AnalogX Proxy Server, in the section on NAT, which is coming up next).

I've already mentioned the fact that proxy servers can also function as firewalls. Another feature that proxy servers can offer is Network Address Translation (NAT). We'll take a look at NAT next.


Understanding Network Address Translation

Network Address Translation (NAT) allows you to hide a group of computers (such as a network) behind one public IP address. In the Unix world, this is known as IP masquerading. Basically, your network sits behind the NAT server, which also is typically a proxy server and/or firewall. This means that you only need one "legal" IP address for the server running the NAT software. The IP addressing scheme that you use on the computer network behind the NAT server is really up to you (although there are ranges of IP addresses reserved for this purpose, which we will discuss in a moment).

The Internet connection sharing service provided by Windows 2000 and Windows XP (discussed earlier in the chapter) is really an example of the use of NAT. Windows Server 2003 also offers a full-blown version of the NAT service as part of its Remote Access and Routing features.

Because the purpose a proxy server is to hide a trusted network from an untrusted network, many proxy servers also offer NAT. For example, AnalogX Proxy Server is freeware provided by AnalogX (check out the Web site at www.analogx.com; it offers a number of very useful freeware utilities and applications). AnalogX allows you to connect several computers to one Internet connection. In theory, it works in a fashion that is similar to the Internet connection sharing feature provided by Microsoft Windows.

The AnalogX Proxy Server software is installed on a computer that is outfitted with two NICs. One of the NICs is configured with an IP address provided by your ISP (or receives its IP address from the ISP's DHCP server) and is connected to the ISP. The other NIC is connected to your network and configured with an IP address that is consistent with the pool of addresses you use for your internal network. ARIN has actually blocked out a range of IP addresses in each of the three address classes (A, B, and C), as shown here:

  • Class A: 10.0.0.0 to 10.255.255.255, with a subnet mask of 255.0.0.0

  • Class B: 172.16.0.0 to 172.31.255.255, with a subnet mask of 255.255.0.0

  • Class C: 192.168.0.0 to 192.168.255.255, with a subnet mask of 255.255.255.0

The great thing about using a proxy server with NAT capabilities (or a NAT server) is that you can use as many IP addresses as required internally. For example, you can treat your internal network as if it is a Class A or Class B network, which provides a huge number of addresses. Remember, NAT only requires one "official" IP address for the proxy or NAT server that sits between your network and your ISP.

AnalogX Proxy Server is actually quite amazing in that it provides proxy server caching, NAT, and some firewall capabilities. It also runs on a number of different versions of Microsoft Windows, making it easy to implement for a small office or home business. Figure 15.6 shows the simple interface provided by AnalogX Proxy Server.

Figure 15.6. The AnalogX Proxy Server software provides a simple proxy server that also provides network address translation.

It allows you to toggle Internet services such as HTTP and FTP on and off, and it also allows you to configure email aliases for users on the network. This allows you to use any number of email accounts provided by your ISP (without the need for an IP address for each computer accessing an email account).

Proxy servers and NAT not only provide security and filtering capabilities for large networks, but a proxy server with NAT capabilities can offer low-cost connection options for small companies and home businesses that want to attach more than one computer to a single Internet connection. As with anything else you do associated with networking your business, you need to do research on the options available for the particular client OS and NOS platforms you are running on your network.

The Absolute Minimum

In this chapter we took a look at the issues of connecting a network to the Internet. Issues related to ISP selection, acquiring a domain name, and using proxy servers and Network Address Translation were also discussed.

  • The Internet backbone is made up of a number of metropolitan area ethernets (MAEs). Connection to an MAE is provided by a network access point (NAP). Communications companies such as Sprint operate NAPs.

  • Internet service providers (ISPs) provide a full complement of Internet services, including email and Web hosting.

  • Any of the WAN technologies can be used to connect to an ISP or an IAP, including T lines, Frame Relay, and DSL. Cable television companies also offer cable modem connections to the Internet.

  • Domain names are procured from domain registration providers. IP addresses can be obtained from your ISP or, for large corporations, directly from ARIN.

  • Microsoft Windows 2000, Windows XP, and Windows Server 2003 offer Internet connection sharing, which allows you to connect a number of computers to the Internet using one Internet connection.

  • Proxy servers provide a barrier between trusted networks and untrusted networks. Proxy servers can provide Web page caching, Network Address Translation, and some firewall capabilities.

  • Network Address Translation allows you to masquerade a number of computers through one "legal" public IP address.


Chapter 16. Hosting a Web Site

In this chapter

  • Creating your corporate presence on the Web

  • Using the Web as a marketing tool

  • Selling products on the Web

  • Understanding secure online transaction methods

  • Hosting a Web site

  • Creating a Web site

So far, we've discussed what the Internet is (in Chapter 14, "How the Internet Works") and how a company or institution can connect to the Internet (Chapter 15, "Connecting a Network to the Internet"). In this chapter, we take a look at establishing a corporate presence on the Internet in the form of a Web site.

We've also already discussed how you obtain a domain name, but it's how you actually use that domain name in association with your Web site and other services you provide your customer base via the Internet that makes the Internet a positive addition to your business plan.

In this chapter, we discuss issues related to creating a Web page and getting your business on the Web. We look at the options of creating your own Web site or having your Web site created by a company that specializes in Web site development. We also look at how you can use Web pages to enhance communications on a corporate intranet. Let's start our discussion with the reasons why you might want to have a Web site for your business or company.


The Internet and Your Corporate Presence

Although the Internet may have been conceived as a network superhighway with the noble mission of sharing information worldwide, it seems that the Internet has become, particularly in the case of the WWW, an often-congested turnpike littered with thousands and thousands of billboards. Although this might seem a rather cynical view of the Web, I think most people would agree that many (if not most) of the thousands of Web sites on the Web serve as marketing, advertising, and sales media for businesses, both large and small.

Regardless of what you think of the Web, most businesses (again, the big and the small) feel compelled to have some sort of presence on the Web. Using the Web as another avenue for advertising or sales should definitely be a part of your business plan. How large of a role the Web should play in your business plan should be determined by the type of business you do.

For example, let's say you run a furniture company that has its own outlet. People travel from all over the region to buy your furniture. But would you like to expand your business range? You might take a look at the Web and say, "Wow, we can sell furniture right on the Web." Of course, upon further exploration, you realize that the shipping costs for delivering sectional sofa arrangements and oak armoires from your outlet to the customers buying online is roughly equivalent to the Gross National Product of many third-world countries. It might also dawn on you that people like to sit on furniture before they buy it.

So, rule number one for determining how you will use your Web site is to make the Web site fit into your overall business strategy, not turn it upside down. Many Web sites involving products that are difficult to ship (such as furniture and large appliances) have closed shop on the Web over the last couple of years.

Your use of the Web should be carefully analyzed the same way you analyze all the other potential sales and marketing avenues you use. If trying to sell directly on the Web requires a support infrastructure that costs a ton of money, you might be better off just using the Web as another advertising venue. The number of "dot coms" that have turned to "dot bombs" in the last couple of years proves that you can't sell just anything on the Web.

Although the Web isn't necessarily the end-all marketing tool or sales platform, it does provide you with the ability to reach very large audiences. Let's take a look at some of the marketing strategies that can be used on the Web and some of the issues related to selling on the Web.

Marketing on the Web

The Web provides a large number of content possibilities for marketing your business or company. Information can be presented in a variety of formats, including print, pictures, and even audio and video. All these different content types can then be presented in one place—your Web site.

Here are some of the possibilities:

  • Company mission statement and product offerings. A business Web site should make it clear who you are and what type of service or product you sell.

  • Testimonials. Testimonials from satisfied customers can greatly enhance the marketing success of your Web site.

  • Online product lists. Even if you aren't selling your product on the Web, you can let potential customers know what you sell and why they should buy it from you.

  • White papers. A white paper allows you to provide a potential customer with background information and case studies related to the product or service that you sell.

  • Frequently asked questions (FAQ). You can include a list of questions that are typically asked by your customers related to your product or service.

  • Contact information. Providing potential customers with the ability to ask you questions via email allows them to get answers to questions that are not covered by your FAQ.

  • Downloads. Downloads can include product catalogs, software demos, newsletters, or other material that will enhance the desirability of your service or product.

  • Video, audio, and interactive content. The Web offers you the ability to include video and audio content describing your product or service. You can also have interactive content that allows a prospective customer to become better acquainted with your product or service.

To make a long story short, the Web offers more avenues for the delivery of marketing information than any other advertising medium. The Web also provides a platform that can be quickly updated to meet business conditions. For instance, if you can no longer offer a particular service or product, you can remove it from the Web site. Removing a discontinued product or service from a printed catalog would be a lot more problematic than removing the same information from a Web site.

Selling on the Web

Selling on the Web is definitely not for everyone. Not only do you need to have a Web site that provides an up-to-date online catalog, but you also must have the ability to make secure transactions. Web sites that provide online transactions must have some way to track orders and inventory as well as validate customer purchases using various credit cards.

Providing an online store means setting up a fairly complex system of servers. First of all, your Web server will provide the communication interface, such as the catalog and the order form used by the customer. So, the front end for your online store is the Web server that hosts your Web site.

On the back end of your online store, an application server will have to provide databases, such as your inventory database, orders database, and customer database. The Web site will provide the interface for customer interaction with these different databases. Figure 16.1 provides a diagram of how different server types are used for online transactions.

Figure 16.1. Online transactions require communication between your Web server and an application server.

Transaction Security

Not only is the hardware and software infrastructure more intense for Web stores when compared to a simple Web site, your online store must also offer a high level of security for transactions. Having someone crack your marketing Web site and mess up some of your Web pages is a lot different from having a cracker break in and steal credit card numbers from your customer database. Secure communications on the Web is accomplished using methods such as encryption and digital certificates. A digital certificate is basically an electronic identification card. It is used to verify the identity of the sender of an encrypted message.

Note

Although you should really research the ins and outs of deploying a Web-based store, software packages are available that you can use to quickly get a Web-based store up and running. In the case of small business owners who don't wish to operate their own Web server, you will find that many Web hosting services can quickly set up an online store for you with a variety of features. An excellent example of a hosting service that also provides you with the ability to choose some of the layout options and features on your site is Microsoft's bCentral at http://www.bcentral.com/. This online hosting service provides links that allow you to quickly create any number of different types of company Web sites—even online stores that are then hosted by Microsoft.

Here are three of the most popular security strategies for securing online transactions:

  • Secure Socket Layer (SSL). SSL was developed by Netscape to secure online transactions. SSL uses a combination of encryption and digital certificates (the certificates are used to verify the merchant's identity) to secure the transfer of information from a Web browser to the Web site store. Popular Web browsers such as Netscape Navigator and Microsoft Internet Explorer support SSL.

  • Secure Electronic Transaction (SET). SET is a new standard for securing credit card transactions on the Internet. SET was developed by Visa and MasterCard and provides very strong 128-bit encryption (the more bits, the better the encryption; therefore, 128-bit encryption is harder to decode than 64-bit encryption). SET also uses digital certificates to identify both the merchant and the buyer involved in the transaction. Because SET uses digital certificates (also known as digital signatures) to identify a buyer, actual credit card numbers don't actually have to pass between the online merchant and buyer. SET has not been widely implemented because it requires Web shoppers to acquire a digital certificate, and SET requires more bandwidth overhead when compared to SSL.

  • Secure HTTP (SHTTP). SHTTP is a superset of the HTTP protocol that provides mechanisms to secure online transactions. SHTTP was developed by Enterprise Integration Technologies and is now the property of Terisia Systems. SHTTP provides for the encryption of transmissions between server and clients. SHTTP also supports the use of digital certificates. Although SHTTP was submitted to the Internet Engineering Task Force (IETF) in 1995 in a request to have it named the standard for secure messaging on the Internet, SSL seems to actually be a more popular method for securing online communications.

Tip

Not only will you need a Web site designed for online transactions, but you will need a merchant account (which is a special type of bank account) that allows you to accept credit card orders on your Web site. There are a number of merchant status providers on the Web, such as InternetSecure at wwf. These online services can be used to set up your "merchant status." You will find that this is not cheap, however. You must pay an up-front fee and a per-transaction fee. A fairly consistent volume of business would be required to substantiate the expense of becoming an online merchant. An alternative is PayPal (at www.paypal.com). It provides a method of transferring funds from a buyer to seller. Ebay recently acquired PayPal and it is one of the preferred methods of payments for auctions held on the Ebay Web site (www.ebay.com).

Research and planning are important aspects of any network rollout, including a Web site that offers an online store. In the case of Web transactions, it might not be a bad idea to talk to a consultant or company that specializes in transaction security. Keeping customer information secure is a total must for any online sales endeavor.

Remember, also, that running an online store has some of the same pitfalls that you face running a storefront business. There are taxes, insurance, potential liability, and, of course, risks.


Who Will Host Your Web Site?

Before we take a look at the basics of creating a Web page, we should discuss issues related to hosting your Web site. You can choose to deploy your own Web server, or you can choose to have your Web site hosted by an ISP that offers Web hosting as one of its services. Let's take a look at hosting your own Web site first, and then we can take a look at using a Web-hosting service.

Hosting Your Own Web Site

If you have the budget and the know-how, you can deploy your own Web servers. A Web server can be run using a number of different network operating systems. You can run the Apache Web Server on Linux, Solaris, and Windows platforms. NetWare also provides the NetWare Enterprise Web server and even provides the WebSphere application server, which can be used to host back-end applications that interface with your Web site.

Another popular Web server platform is provided by Microsoft Windows Server in the form of Internet Information Services (IIS) (the version 6 of IIS that ships with Windows Server 2003 is the most recent version of the IIS software). Microsoft Internet Information Services makes it easy for you to configure Web sites, FTP sites, and NNTP newsgroups (see Figure 16.2).

Figure 16.2. Microsoft's Internet Information Services allows you to deploy Web sites, FTP sites, and newsgroups.

Management of Web servers has become more intuitive as management tools have been added to the various server products. As already mentioned, Novell provides a Web-based configuration tool for your NetWare Web server. In the Apache server environment, you can configure some of the Apache server settings using the Apache Configuration utility, as shown in Figure 16.3.

Figure 16.3. Apache Web server configuration settings can be accessed using the Apache Configuration utility.

Other add-on programs such as Webmin (Webmin, written in the Perl programming language, has to be added to the Linux configuration; it can be downloaded from www.webmin.com) can also be used to configure the Apache Web server from a Web browser. Microsoft also provides a Web server configuration tool (see Figure 16.4) that can be opened in a Web browser; this configuration tool allows you to set a number of parameters related to the site and site access.

Figure 16.4. Web server products typically provide a configuration tool that can be accessed in any Web browser.

Selecting the NOS and the Web server software for your Web server should be approached as you would approach determining the software configuration of any specialized server on your network. Ease of use, scalability, and compatibility should all be points that you consider when putting together the specifications for your Web server.

Hardware considerations for a Web server are the same as those for any other server on your network. Your hardware specifications need to at least coincide with the minimum for running the particular NOS and the add-on Web server software. Running the Web server with only the minimum hardware requirements, however, will quickly become undesirable. Web servers require a lot of RAM, disk space, and very fast processing to handle the amount of traffic they will experience once they are brought online.

Be advised that hosting your own Web sites on your own Web servers may also require that you deploy your own DNS servers. If your Web site will provide online transactions, you will also have to provide the appropriate application server or servers to manage the transaction databases. Firewalls, proxy servers, and other specialized servers might also be necessary to protect your site from outside attack. Adding Web server management to your network administration duties can stretch one person and even a small staff very thin.

Note

The Apache Web server, developed by the National Center for Supercomputing Applications (NCSA), currently has the most installations of a Web server product in the world.

Using a Hosting Service

An alternative to hosting your Web site on your own Web server is to farm your site out to an ISP or other company that provides Web hosting. Companies offering Web hosting provide a secure environment for your Web site (some more so than others). So, you don't need to worry about security issues related to the Web server. All you have to do is design your site and then upload the Web pages to the Web server.

Rates vary for Web hosting, depending on the amount of space you require on the Web server and the features you require for your site. A Web site designed for online transactions will require more back-end support than a simple site designed as a marketing tool. When choosing a Web host, you should find out what types of features it provides (SQL databases, transaction servers, and so on) and the type of support it provides.

Obviously, another key issue in selecting a Web-hosting service is cost. You need to find out how the Web host charges for disk space and if it has additional charges related to the bandwidth that activity related to your site may use.

Caution

There is a lot more to hosting a Web site than just setting up a Web server and placing Web pages on a computer. Securing the Web site from outside attack and keeping the Web content up to date are also important aspects of managing a Web site. Depending on the size of your company, the management of the Web site is often delegated to a Webmaster. This is an employee who not only understands networking using TCP/IP but also has some design and Web page construction experience. TCP/IP administration is discussed in Chapter 12, "TCP/IP Network Administration".

An excellent source for researching Web-hosting companies can be found at http://www.hostinglocator.com/. This Web site allows you to search for Web-hosting services by platform (such as Unix or Windows Server) and also provides some tips on selecting your Web host. Even after developing a "short list" of Web-hosting services based on cost and features, you might want to correspond with each service by email (or even by telephone). Try to get a general feel from the provider to see if customer service is even in its vocabulary.

An alternative to working with an ISP that provides Web hosting is to use an online Web-hosting service, such as those provided by Microsoft and Yahoo!. Microsoft's bCentral provides Web-hosting and Web design software to create the Web pages that will populate your Web site. bCentral even gets you your domain name and provides email accounts specific for your domain name. Figure 16.5 shows the Microsoft bCentral Web page that describes its various Web-hosting services.

Figure 16.5. Web hosting is also offered online by providers such as Microsoft.

Tip

Because you can upload your Web files to a Web server anywhere on the Internet, you aren't limited to using a local ISP to host your Web site. However, if you have firsthand testimonials from other people or businesses who are familiar with the Web-hosting track record of a local ISP, there might be some very compelling advantages to doing your business locally.

Yahoo! also offers similar services. You can check these out at http://website.yahoo.com/. These online Web hosting services do offer advantages in that it is easy to go online to the actual Web hosting site and change the content on your site using the various Web-based utilities provided by the online service (in the case of an ISP, you need to become familiar with some sort of Web design software if you are going to change the content of your Web site). Since these services are offered by large Web players such as Yahoo! and Microsoft, the servers used to host your Web site are state of the art and offer quick response to potential clients browsing your site. Not all ISPs can offer Web servers of this quality or speed.


Creating a Web Site

Although the development of the Hypertext Transport Protocol (HTTP) provided the underlying communication structure for the World Wide Web, the authoring language used to create Web pages is the Hypertext Markup Language (HTML). HTML consists of embedded tags that tell a Web browser how to display or act upon information found on a Web page.

Your Web site, no matter how modest, will typically consist of multiple Web pages; the home page, which is the main page for the site, will provide the table of contents for the site. Each additional page on the site will be referenced on the home page by a hyperlink. A hyperlink is basically a pointer that allows you to refer to other local Web pages, graphics, and multimedia content on a page. When a hyperlink is clicked in a Web browser window, the user is taken to that page or a particular event is activated (such as the playing of video or audio content or the displaying of a picture). Hyperlinks can also be used to refer to remote Web pages or other locations, such as an FTP site.

In the Web's infancy, Web pages primarily consisted of text and hyperlinks. Images were used to provide some respite, but it took some time to develop tools that provided more complex multimedia content on a Web page. Java applets now provide us with applications that can be run directly from Web pages. Also, multimedia plug-ins such as Macromedia Shockwave and Flash, Real Player, and Windows Media Player provide you with the ability to access audio and video content in a Web page.

As far as Web page design goes, your aim is to produce a Web site that is informational, easy to navigate, and esthetically pleasing. Web site design not only requires an understanding of HTML (and any plug-in technologies that you use), but it also requires an eye for design. Although I'm not saying you need to be an artist or a design expert to create a decent Web site, it certainly doesn't hurt to understand some basic design and layout concepts.

Although we will take a quick look at how you would create a Web site using either HTML or a software design tool, there are many other resources that can walk you through the entire process of Web site creation and help you develop some appreciation for design concepts. In fact, there are probably enough books on Web site design and the various tools for creating Web sites to bridge the Atlantic Ocean between the United States and Europe. Check out www.quepublishing.com or www.samspublishing.com for a number of titles.

Working with HTML

If you want to create your Web pages from scratch, you can use any text editor. As already mentioned, HTML is made up of a system of tags that are applied to text in an ASCII text file. All HTML tags are written in the format <code>, where code would be the actual HTML tag you are using. For example, to center text on a Web page, the HTML code would appear as follows:

<CENTER>This text will be centered</CENTER>

Note that one tag is used to turn the centering on (<CENTER>) and a very similar tag that includes a slash (/) turns off the centering (the </CENTER> tag).I think you can see that HTML is somewhat intuitive.

When you begin a Web page that you are creating in HTML, the first tag at the top of the HTML document is <HTML>. Other tags follow as needed. For example, the <HEAD> tag is used to specify the part of the HTML document that contains the title for the Web page. The title of the Web page is then specified using the tag <TITLE>. For example, let's say I want to create a simple Web page using Windows Notepad. My HTML code will actually start with the tag <HTML>. To end the page, I use the tag </HTML>. Every "on" tag has a counterpart "off" tag.

Figure 16.6 shows the beginnings of a very simple Web page written in HTML using Windows Notepad. Your text files need to be saved with the extension .htm to be read by a Web browser.

Figure 16.6. Web pages can be created directly in HTML using a text editor such as Windows Notepad.

As you work on your HTML documents, you can check your work by opening the file in any Web browser. Figure 16.7 shows the HTML document in Figure 16.6 as it would appear in Internet Explorer.

Figure 16.7. HTML documents can be viewed in any Web browser. This way, you can see how your HTML coding is working out.

The Web actually provides some very good resources for learning HTML. For example, check out an online HTML tutorial at http://davesite.com/webstation/html/. A good HTML reference book that will also provide you with some background information on Web design is Special Edition Using HTML and XHTML, from Que.

Web Design Tools

A number of Web design tools are available that allow you to create Web sites and Web pages without having to face the laborious task of coding each page in HTML. Examples include Macromedia Dreamweaver and Microsoft FrontPage (and there are many others).

These Web design tools provide a number of different strategies to help you with page design and adding special elements to your Web pages, such as pictures and multimedia content. For example, Microsoft FrontPage provides a number of wizards that can be used to create different types of Web sites (see Figure 16.8).

Figure 16.8. FrontPage provides a number of wizards that can be used to create different kinds of Web sites.

Note

Web pages can be greatly enhanced with DHTML (or Dynamic HTML), which is a term that really defines a number of different programming languages. You can use JavaScript and ActiveX controls to energize any Web site with interactive content. XML coding (Extensible Markup Language) also provides you with the ability to push and pull data between Web servers.

These wizards can create Web sites that range from a corporate-presence Web site, to a customer-support Web site, to a simple one-page Web site. Each of these wizards walks you through the creation of the different pages and objects that will be part of the Web site by asking you a series of questions.

Figure 16.9 shows the pages and Web site structure that is created when you use the Corporate Presence Web Wizard in FrontPage 2003. Each page can then be edited and enhanced as needed. Tools such as FrontPage and Dreamweaver function a great deal like desktop publishing software.

Figure 16.9. The Web page structure for complex corporate sites can be created using Web development tools such as Microsoft FrontPage.

Web design tools certainly make it easier for you to initially create your Web site and update content as required. These tools even provide you with methods for uploading your Web site to your Web server or the ISP server that will host your Web site. For example, FrontPage has a Web publishing feature that uploads your entire site to a specified server.

Tip

Although there are a number of design tools available for creating your Web site, there is something to be said for having your Web site created by someone with some Web design experience. There are design companies and seemingly no end of freelance Web designers.


Taking Advantage of an Intranet

Because a network administrator's sphere of influence will vary from company to company, you might find that your company's Web site is either managed by a Webmaster or taken care of by a company that provides Web design and Web hosting. This doesn't mean you can't use Web technology to enhance your internal network, however. Any TCP/IP network can take advantage of Web technology and other Internet-based services. Using Internet technologies on a private network means you are building an intranet. You can have Web sites on an intranet just like you find on the Web, but they are private.

Web sites in an intranet setting can actually be used for a number of different purposes. You can build Web sites that allow users to easily access data on a database running on an application server. Because just about everyone knows how to use a Web browser, the need for training users to use the front end for the database server is almost nonexistent. Web sites can also be used for exchanging files between users, and Web sites designed for specific company projects can be used for discussions between the various participants in a project.

A number of large companies have also found that intranet Web sites can be used to promote company morale. For example, "water cooler" Web sites are provided for employees to post information such as employee birthdays or to invite employees to special celebrations. Providing this type of site can actually cut down on the amount of email used by employees for personal communication with other employees.

Intranets also provide an excellent platform for you to test Web server hardware and your Web site itself. Opening up a Web system to employees on the intranet as a test can allow you to diagnose problems and access overall performance before you actually roll the Web site out onto the WWW.

The Absolute Minimum

In this chapter we took a look at some of the options for creating a corporate presence on the Web. We discussed options for hosting your own Web site and the use of a Web hosting service.

  • Your corporate presence on the Web can take the form of marketing Web sites, or you can use the Web as a platform for an online store. Web sites make good marketing tools in that they allow you to provide customers with varied content, such as print, pictures, sound, and video. A Web site can deliver more content types than any other advertising medium.

  • Hosting your own Web site requires that you have the proper hardware infrastructure, including a Web server and perhaps other servers, such as a firewall, application server, and so on.

  • Web server software is available for a variety of NOS environments. NetWare and Microsoft Windows Server both include Web servers as part of the NOS. Apache Web Server is a popular Web server used on Unix/Linux servers.

  • Web-hosting services can provide the hardware infrastructure and the appropriate servers to host your Web site and supply a secure Web environment. Online hosting services provided by Yahoo! and Microsoft make it easy for a small business to have a Web site, and these services will even help you get your domain name.

  • Web design software makes it easy to create complex Web sites. Web design tools such as Macromedia Dreamweaver and Microsoft FrontPage provide wizards and other features that allow for the creation of Web pages without HTML coding.

  • Building an intranet allows you to take advantage of Internet-based services such as Web pages for internal corporate use.


Chapter 17. Networking on the Run

In this chapter

  • Understanding laptop computer screen technology

  • Working with laptop expansion cards

  • Understanding remote access

  • Configuring dial-up access

  • Working with Virtual Private Networking

  • PDAs and the network

In this chapter, we take a look at business on the run—mobile computing. With increasing numbers of employees either working on the road or telecommuting from home (for at least a portion of the work week), the ability to connect these remote users to the corporate network has became an important aspect of managing network users and resources.

We have already taken a look at WAN technology in Chapter 12, "Expanding a LAN with WAN Technology." A number of different technologies were discussed, ranging from dial-up connections to leased lines, to packet-switching technology such as Frame Relay. For telecommuters and employees working on the road (such as the corporate sales force), connecting to the company's network usually revolves around using dial-up connections or accessing the corporate network through the Internet using a Virtual Private Network (VPN). Both these connection types have their pros and cons, and both have different security issues to deal with.

Not only do "roaming" employees connect remotely to the network using PCs, but many now access email and even files using personal digital assistants (or PDAs). Let's start our discussion of computing on the run with a general look at the evolution of mobile computing devices. We can then concentrate on laptop computers, remote connectivity strategies, and the different types of PDAs.


The Evolution of Mobile Computing Devices

The need for road-ready portable computers has been recognized since the early days of the PC revolution. Computer manufacturers followed fairly quickly behind the launch of the IBM PC with a number of different types of portable computers.

Compaq launched the Compaq Portable in 1982. This DOS-based IBM PC clone provided a 5.25-inch floppy drive and a built-in 9-inch amber monitor. These suitcase-size computers (which weighed almost as much as a desktop PC) could run the same applications as an IBM desktop PC. The desire for mobile computers was proven by the fact that Compaq sold over 50,000 units in the first year.

Other companies, such as Osborne and Tandy, went their own direction and produced portable computers that did not provide compatibility with DOS-based business computers. Tandy probably should get the award for one of the first truly mobile computers—the Model 100. The Model 100 was introduced in 1983 and had a small LCD display (less than 3 inches high and 6 inches across). The Model 100 ran a built-in version of BASIC and came equipped with a simple text editor. ROM chips were also available for these lightweight portables (they weighed less than 3 pounds) that contained productivity software, such as word processing, spreadsheet, and database applications. These portables also shipped with a built-in 300-baud modem.

Apple also entered the portable computing market in 1989 with the Macintosh Portable. This 16-pound portable computer, which ran the Mac OS, provided a faster processor than Macintosh SE and boasted a 40MB hard drive. This portable computer eventually evolved into the Macintosh PowerBook.

Note

The first "luggable" PC was created by Osborne. The Osborne 1, which actually predated the IBM PC, was a suitcase computer that was introduced in 1980. The Osborne had 64KB of memory and a disk drive. It also came with bundled software, including WordStar (a word processor) and SuperCalc (a spreadsheet). Obviously, because you don't have to worry about networking Osborne portable computers (most people don't even know that they ever existed), the Osborne is just another one of those computer history footnotes.

Portable and laptop computers have evolved as rapidly as desktop PCs, and in the last decade, laptop technology has advanced to the point where a 4-pound laptop computer can pack the processing and storage power found on a much larger business computer. Let's take a closer look at some of the laptop technologies, including screen design and networking capability, found on today's portable computers.


Working with Laptops

The laptops that we now drag along with us on business trips are very different from early portable PCs, such as the Compaq Portable. Advances in processor technology, such as processors built specifically for mobile computing (Intel's Centrino processor for laptops being an example) and motherboard design, have lead to a much smaller form factor for the modern laptop.

Two areas of laptop design that are particularly interesting in light of technology advances are the laptop screen and the expansion cards used in laptop PCs. Laptop screens use liquid crystals sandwiched between two electrodes. This is why laptop screens are referred to as liquid crystal displays.

The liquid crystal diodes are placed on a fine matrix of wires. When a portion of the LCD display must be activated to show output from the computer, the diodes on that portion of the display are supplied current. Each diode serves as a pixel, and all the "turned on" pixels provide you with an image.

Two basic LCD screen types evolved for laptops: passive matrix and active matrix. Most new laptops now provide an active matrix screen, but let's look at the differences between these two screen types.

Passive matrix displays merely hit the liquid crystals with current at a prescribed refresh rate. Active matrix screens, on the other hand, use transistors to control each of the diodes. This means that active matrix displays are brighter and easier to view at different angles than passive matrix displays. Figure 17.1 shows an active matrix display on a Gateway laptop.

Figure 17.1. Active matrix LCD screens provide a brighter, crisper screen than the passive matrix alternative.

Note

For those of you who require a definitive reference for PC hardware, including laptops, checkout Upgrading and Repairing PCs, from Que. At more than 1,000 pages, this book provides information on every aspect of PC hardware.

Another advance in computer technology embraced by laptop manufacturers (and a reason why laptops don't weigh a ton) is the type of expansion slots they use. In the 1980s, the Personal Computer Memory Card International Association (or PCMCIA, which was originally made up of a number of computer memory vendors) sought to establish a standard expansion card specification for portable computers. The result was the PCMCIA card, which is now typically called the PC card.

The PC card is about the size of a credit card (although slightly thicker) and allows for the addition of memory and peripherals, such as modems and network interface cards, to a notebook computer. PC cards are actually designed to be "hot swappable" and can be removed or added while the computer is running (depending on the OS you are running on the laptop).

PC cards come in three different flavors or types: Type 1, Type 2, and Type 3. One difference you will find as you examine each of the card types is that they get progressively thicker. This is because each PC card type was designed for certain types of add-ons. Here's a description of each PC card type:

  • Type 1. Used to expand the RAM on a portable computer. Type 1 cards have also been available as ROM memory cards that actually contain specific software applications.

  • Type 2. This type of PC card will typically be a modem or network interface card that fits into an internal slot on the portable computer.

  • Type 3. The Type 3 PC cards have been designed to allow support for devices such as removable hard drives and CD-ROM drives.

Figure 17.2 shows a PC card slot on the side of a Gateway Solo notebook. Notice that this particular laptop is configured with both a modem and a NIC. The modem uses an RJ-ll connector (the same as a telephone) and the NIC uses an RJ-45 connector (the type of connector found on twisted-pair network cabling).

Figure 17.2. PC card slots provide a way to add peripherals to notebook computers without taking up a lot of space.

The Personal Computer Memory Card International Association continues to create standards for portable device peripherals and has been involved in the development of standards for SmartMedia cards (if you have a digital camera, you probably have a SmartMedia card). The booming PDA and cellular phone industry has also led to PCMCIA standards for miniature card technology, such as memory upgrade cards for handheld computers.


Understanding Remote Access

Although wireless technology will definitely change our options for connecting to a network from a remote location in the next few years, the asynchronous modem still serves as the typical connection device and uses the public phone lines as the communication conduit. Any desktop PC or laptop computer can be outfitted with a modem. Almost all client operating systems also provide a dial-up client that can be used to connect to a network using a modem. Millions of people use modems and dial-up clients to connect to their Internet service providers so that they can check their email and browse the World Wide Web.

For a user to be able to connect to a corporate network from a laptop (or any computer) using a modem, there has to be a computer at the company that will accept the call and allow the user to log on to the network. This type of computer is called a remote access server.

The Remote Access Services (RAS) server must be running a NOS that allows remote access, and it must be configured to allow dial-in connections. Communications hardware such as an analog modem (or several modems in a modem pool to allow a number of connections from users), an ISDN modem, or some other connectivity device is required so that the RAS server can field the incoming calls.

Microsoft's Windows Server 2003, Novell NetWare, Linux Red Hat, and Sun Microsystems's Solaris—all the big players in the NOS market—offer remote access (although some of these network operating systems require additional software to provide remote client access). Remote access servers use a technique called tunneling in which packets from your network, which are encapsulated into a particular frame type by the network protocol you are using (such as TCP/IP or IPX/SPX), are moved across the public switched telephone network in a virtual tunnel that is hosted by a particular wide area networking protocol or access protocol, such as the Point-to-Point Protocol (which we discuss later in the chapter).

Setting up remote access really is a two-part process. First, you must install and configure a RAS server. Once the RAS server is up and running and can accept an incoming call, you need to configure the remote client computer (or the user must be walked through the process of configuring the remote client). Let's take a look at the server side or the RAS equation first.

Note

For more about remote access and Windows Server 2003, check out Sams Teach Yourself Microsoft Windows Server 2003 in 24 Hours or Microsoft Windows Server 2003 Unleashed. For Red Hat Linux, check out Red Hat Linux 9 Unleashed (the "Unleashed" books are published by Sams). For Novell NetWare, see CNE Update to NetWare 6 from Que.

Configuring an RAS Server for Dial-Up Access

Depending on the size of your network, the RAS server can be your primary network server or an additional server on the network that is specifically charged with handling remote access connections. Configuring a server for remote access involves the following tasks:

  • Installing network protocols on the server. You must install the network protocols on the server that will be used by the remote hosts to access network resources and services. For example, Microsoft Windows Server 2003 allows remote clients to use TCP/IP, IPX/SPX, AppleTalk, or NetBEUI (even though NetBEUI is no longer a supported protocol) to connect to network resources.

  • Installing connectivity hardware. Before you can configure the Remote Access Service on the server, you must connect your modem or other connectivity device to the server and install the appropriate software drivers for the device (meaning the modem or other device needs to be functional before you can configure the Remote Access Service on the server).

  • Configuring the Remote Access Service on the server. Each network operating system will supply a utility for configuring the Remote Access Service server. For example, Windows Server 2003 uses the Routing and Remote Access (RRAS) snap-in, shown in Figure 17.3, to start and configure the RAS server.

    Figure 17.3. NOS utilities such as the Windows Server 2003 RRAS snap-in are used to configure a remote access server.

Once the RAS server is configured, user accounts must also be enabled for dial-in. On a Windows Server 2003 network, user accounts are enabled for dial-in using the Windows Active Directory. Figure 17.4 shows the Properties dialog box for a user account. The Dial-In tab is used to enable remote access for the user.

Figure 17.4. Users must be configured for dial-in access.

Note

When remote access servers are configured, another issue that pops up is authentication. Different authentication protocols can be used that must be negotiated by the remote clients for them to connect to the remote access server. A number of different authentication protocols are available. Some authentication protocols provide greater security than others. For example, the Password Authentication Protocol (PAP) uses clear text login names and passwords (clear text means that the login and password are transmitted over the line as text), which makes it easier for hackers to steal logon and password information. Other protocols, such as Challenge Handshake Authentication Protocol (CHAP), use encryption and other methods to provide a more secure environment when the clients negotiate access.

Caution

Configuring a server for remote access makes it convenient for remote users to get at network resources, but it also opens up a possible avenue for unauthorized access to the network. If you take a look at Figure 17.4, you will find that some security measures can be implemented to help control user access. For example, the remote connection can be configured so that the server will hang up after authenticating the user and then call back the user's phone number to reestablish the connection. This is one way of keeping out unauthorized users who have stolen a username and password.

Configuring an RAS Client

Once the RAS server has been set up and configured for dial-in connections and the user account of the individual who will dial in to the RAS server has been enabled for remote access, you need to configure the client computer. The client computer must be configured with a LAN protocol or protocols that match those supported by the RAS server and the network.

The client computer must also be outfitted with a device that allows it to remotely connect to the RAS server. In most cases, this means that the remote client must be configured with a modem.

Once the client computer has been set up with the appropriate LAN protocols and a modem, the client computer must be configured with a dial-up connection that is used to dial the RAS server. Most types of client software have built-in dial-up clients. Windows clients, such as Windows 2000 Professional, even provide a connection wizard that can be used to set up the computer to dial in to a remote access server.

In Windows XP Professional, the dial-up connection is created using the Make New Connection icon in the Network and Dial-Up Connections dialog box. Figure 17.5 shows the Network Connection Wizard dialog box. The wizard can create dial-up connections to private networks (meaning to an RAS server). This wizard is also used to enable connections to a remote network over a Virtual Private Networking connection (which we discuss later in this chapter).

Figure 17.5. Windows XP provides a wizard to create the dial-in access to the remote server.

Once you select the Dial-Up to Private Network option, all you have to do is provide the phone number for the RAS server and then supply a name for the dial-up connection. An icon for the connection is placed in the Network and Dial-Up Connections dialog box.

When the user double-clicks the connection icon in the Network and Dial-Up Connections dialog box, the Connect dialog box opens. All the user has to do is supply the correct password and then click Dial. The phone number of the RAS server will be dialed and a connection will be made to the server.

Once clients are connected to the RAS server, they can access the company network and its servers and printers. The network resources that clients can access will be determined by the privileges or rights that have been assigned to the users (just like any other users on the network, including those who log on to the network from computers that are on the LAN).


Understanding Access Protocols

For the dial-up connection to work between the remote client and the RAS server, a protocol must be used that takes the data packets exchanged between the client and the server and encapsulates them for movement over the POTS network. Encapsulation is just a fancy term for taking a particular frame type (such as an Ethernet frame) and placing it in a sort of electronic baggy. The frames can then move across the alien public phone network and still maintain their integrity as a particular frame type.

This electronic bagging or encapsulation of frames for movement across the phone network is handled by an access protocol. Two common access protocols are SLIP and PPP.

The Serial Line Internet Protocol (SLIP) is an access protocol that was developed primarily to allow PCs to connect to the Internet using a modem. It operates at the OSI model's Physical layer and allows data to flow across the telephone line to a remote system. SLIP provides no data compression or error checking and only supports connections to TCP/IP networks. The use of SLIP has all but evaporated because of the introduction of PPP.

The Point-to-Point Protocol (PPP) provides a reliable connection between computers, and PPP supports multiple network protocols, such as IP, IPX, and NetBEUI. PPP also provides compression and error checking and is therefore more reliable than a SLIP connection. PPP also supports password encryption, which allows for a more secure connection between the remote client and the RAS server.

You only really need to remember SLIP in terms of its historical significance; it was the first remote access protocol used for dial-in connections. PPP is used by default by most network operating systems and client operating systems. Whether you set up RAS for a NetWare network or a Windows network, PPP will be used as the access protocol for dial-up connections. PPP supports TCP/IP, IPX/SPX, and even NetBEUI. This means that the RAS client and the remote server can use a variety of LAN protocols to communicate over the PPP tunnel.


Managing Remote Connections

Once the user is attached to the remote access server and the network, the remote access software that you are using on your server will provide you with the ability to monitor that remote connection and any other remote connections on the server. This means that you can monitor the activity of the remote client in terms of the number of bytes that are sent and received and the time that the client has been logged on to the network.

On a Windows Server 2003 remote access server, dial-in connections are monitored and managed using the Routing and Remote Access tool, as shown in Figure 17.6. Not only can the connection be monitored, but the connection can be terminated by the network administrator. This allows you to sever unattended connections and free up modems for other dial-in connections. Hey, the network administrator giveth, and the network administrator taketh away.

Figure 17.6. Remote access connections can be monitored.

Obviously there is much more to managing remote access than monitoring connections and occasionally knocking a remote user off the network. A plan must be developed that allows remote users to get at the network resources they need to get their jobs done. Remote access should not become a way for remote users to connect to the network and thus gain free access to the Internet. You will have to make sure that only a subset of your users is configured for remote access and that the dial-in connections are used for business purposes. This might not make you the most popular employee at your company, but it will allow you to provide remote connections for the users who truly need them.


Working with Virtual Private Networks

Another possibility for remote connections to the company network involves the use of a Virtual Private Network (VPN). A VPN is a secure, dedicated, point-to-point connection over a public IP internetwork, such as the Internet. Using a VPN means that you don't have to configure the RAS server with a modem pool or other WAN connection type. The RAS server just needs to be connected to the Internet, and the remote client will connect to the company network by tunneling through the Internet.

A VPN connection has both a client and server side (as do remote access dial-up connections). The tunnel server provides the server side of the connection. Most network operating systems provide support for VPNs in their remote access software. The VPN client is referred to as the tunnel client and will need remote access software configured to connect to a VPN tunnel server. The actual connection between the server and the client is referred to as the tunnel.

VPN connections or tunnels are managed by the Point-to-Point Tunneling Protocol (PPTP). PPTP is an extension of the PPP protocol and provides for the encapsulation of the data that moves between the remote client and the RAS server over the Internet. Basically, your data frames (such as Ethernet frames) are encapsulated by PPP and then encapsulated again by PPTP. This means that any frame types can be transmitted over the Internet between the remote client and the RAS server. When encapsulated data frames reach their destination, they are "unencapsulated," meaning the PPP and PPTP "baggies" are stripped from the data frames.

Note

A VPN can also be used to create a connection between a branch office and the main corporate office. As long as the branch office can connect to the Internet, data can be securely routed over a VPN tunnel to and from the corporate network. This can actually be a cost-saving measure because a dedicated line, such as a leased phone line or some other WAN connection, doesn't have to be maintained between the branch and main offices.

Configuring a Tunnel Server

A number of network operating systems provide support for VPN remote access. In some cases, the Remote Access Service that is configured for remote dial-up connections can also be configured for VPN. For example, the Windows Server 2003 Routing and Remote Access snap-in provides a wizard (just like it does for dial-up connections) that can be used to quickly configure the VPN.

Figure 17.7 shows the Windows Server 2003 wizard for configuring VPNs. The NIC that provides the connection to the Internet for the server must be specified as the connection for incoming VPN connections.

Figure 17.7. Network operating systems such as Windows Server 2003 also provide remote access to the network via VPN.

The remote access server can also be configured to supply IP addresses to VPN clients that connect to the RAS server (or the RAS server will allow the network DHCP server to assign appropriate addresses). Such an IP address is actually assigned to the PPP virtual adapter that is created on the tunnel client (once it has been configured for VPN). This assigned IP address does not mess up the IP address that has been assigned to the client's dial-up adapter by the ISP used by the client to connect to the Internet. The client will actually be simultaneously connecting to two different IP networks because of the VPN tunnel (one network being the ISP's network; the other being the Windows network that the client is connecting to via the VPN).

Note

Windows Server 2003 VPNs also provide a second tunneling protocol. L2TP is an industry standard tunneling protocol that can also be used to create VPN connections over the Internet. L2TP does not require IP communication between the client and the server, as does PPTP. This means that L2TP can be used with other media than the Internet such as X.25, Frame-Relay, and Asynchronous Transfer Mode (ATM).

Configuring a Tunnel Client

Once the tunnel server is configured on the network (and connected to the Internet), the tunnel client needs to be set up. The client needs to be outfitted with a modem or some other connectivity medium and have an account with an ISP for a connection to the Internet.

The tunnel client is configured using the dial-up client software provided by the client's operating system. For example, on a Windows 2000 VPN tunnel client, the VPN connection (and the addition of PPTP to the computer's protocol list) is handled by the Network Connection Wizard (in the same manner as a dial-up connection is created). During the configuration process of the client, the IP address of the tunnel server (the RAS server on the network) must be specified, as shown in Figure 17.8.

Figure 17.8. The IP address of the tunnel server must be specified when the tunnel client is being configured.

Once the tunnel client is configured, it's just a matter of double-clicking the VPN connection icon that is created during the client setup (on the client computer, it is found in the Network Connections window of the Control Panel). The username and password of the tunnel client are verified by the tunnel server when the connection is requested by the remote client.

Monitoring VPN Connections

Once the tunnel client has connected to the tunnel server, the VPN connection can be used to move data between the two computers. In essence, the tunnel client is now connected to the network just like any other LAN clients are connected. The user will have access to any network resources that she has the appropriate privileges for.

Remote access servers that provide VPN support also supply you with the ability to monitor remote connections (as do remote access servers that supply dial-in access). Not only can you view the number of total connections but you can view statistics related to each individual connection such as the time connected and the activity (such as the amount of data moved) that has taken place on the connection.

Both dial-up and VPN connections allow you to expand your network beyond the confines of your LAN infrastructure. This allows you to accommodate employees on the road, employee telecommuters, and employees working at remote corporate sites.

Tip

RAS servers supplying dial-up or VPN connections can also control these remote connections. As the network administrator, you can actually close a connection if you wish. You can also monitor connection time and the amount of data that has been moved on a remote connection.


PDAs and the Network

Another family of devices that is rapidly changing the way that we communicate and connect to network resources is the personal digital assistant. So, what is a Personal Digital Assistant (PDA)? PDAs started out as handheld devices that made it convenient to take information such as addresses, phone numbers, and appointments on the road. These devices were really just electronic organizers with a limited amount of memory; however, these early PDAs still provided a user with the ability to sync with Personal Information Managers (PIMs), such as Microsoft Outlook and Lotus Organizer (or PC-based programs included with these handheld devices that provided address book and calendar features).

PDAs have evolved into handheld computers, and for our purposes we will limit our discussion of PDAs to devices that actually have processing power (meaning you can manipulate data, even send and receive data, on the PDA without being attached to a PC). This means that the PDA must have a processor, memory, and an operating system.

PDAs are basically built with two major designs in mind: handheld pen devices and slightly larger units that provide an attached keyboard (although keyboards are available for nearly all the PDAs as add-ons). PDAs come in a variety of sizes and price ranges. For example, the Palm Pilot, which runs its own Palm operating system, provides a range of devices that vary in functionality and price. Other PDAs that also run the Palm OS include devices from Handspring (which recently joined forces with Palm) and Sony. Figure 17.9 shows a Handspring Visor Deluxe, which uses the Palm OS and provides an expansion port for add-on devices, such as a modem and a cellular phone.

Figure 17.9. PDAs such as the Handspring Visor are pen-based, handheld computers.

Another family of PDAs runs the Windows CE .NET operating system. A number of companies have handheld devices on the market that run the Windows CE .NET OS, including Microsoft, HP, Compaq, Casio, and Hitachi.

Applications on a Windows CE device are launched either via the Start menu or by using icons on the desktop. Figure 17.10 shows the Windows CE desktop on an HP color handheld device.

Figure 17.10. Windows CE handheld devices provide the familiar Windows environment.

PDA and PC Synchronization

PDAs are designed primarily for offline "on the road" computing. However, PDAs outfitted with a modem or cellular connectivity technology can connect to a service provider and access email or the Web, or even the corporate network. For example, in the Windows CE environment, Microsoft has developed a Terminal Server client for Windows-based PDAs. This allows these handheld devices to become mobile network clients that can directly access network applications using a modem or wireless connection.

In most cases, however, the most common method of moving information to and from the PDA is synchronizing the PDA with a PC. For example, in the Palm environment, the Mail, Address Book, and Calendar applications can all be synchronized with the different services provided by Microsoft Outlook (Inbox, Contacts, and the calendar). In the Pocket PC environment, the pocket version of Outlook can be synchronized with the desktop version of Outlook on the PC.

The implication of synchronization is that information temporarily held on the PDA ends up on the desktop computer. What's more, if the computer is connected to a network where groupware applications such as Outlook are used to share calendar information, the PDA information will eventually dovetail with information that can be accessed by different users on the network (in an environment where groupware applications are being used).

In fact, Palm has developed an Ethernet cradle; Palm devices placed in the cradle can be synchronized directly on the network using Palm's Hotsync Server software. This means that a network administrator could allow users to sync their Palm devices with groupware applications found on a Microsoft Exchange Server or in a Lotus Notes environment. The Hotsync Server software allows handhelds to be basically managed like any other device on the network.

Synchronizing a PDA with a PC typically requires a physical connection. All the PDAs available support serial synchronization, where a connection is made between the PDA and a COM port on the computer. Many PDAs also can be synchronized to a PC or Macintosh computer via a USB connection.

In the case of both Palm OS-based handhelds and Windows CE devices, the synchronization software is part of the default application installation on the PDA itself. The software that resides on the PC has to be installed and is typically provided with the PDA on a CD-ROM. Synchronization itself can be initiated from the PDA; in many cases, a button on the sync cradle begins the sync process. The sync software residing on the PC can also be used to initialize synchronization between the PDA and the PC.

Understanding BlackBerry

Before leaving the subject of PDAs, we need to take a look at relatively new technology called BlackBerry. BlackBerry, developed by Research in Motion, Limited (or RIM as it is often referred to), provides a wireless (and secure) environment that allows a BlackBerry device to access email, the Web, and other communication services. While many cellular providers are providing connectivity for BlackBerry devices, a company can actually deploy its own BlackBerry server, which provides wireless connectivity directly to the corporate network.

BlackBerry devices can access communication platforms such as Lotus Domino and Microsoft Exchange. This means that a BlackBerry user can directly connect to network messaging services such as email and scheduling. BlackBerry devices can also access Web data, and most of the newer BlackBerry devices provide cellular phone support.

BlackBerry devices provide a simple-to-use operating system and a full functioning keyboard. Figure 17.11 shows the BlackBerry 6700.

Figure 17.11. BlackBerry devices provide an easy-to-use operating system.

Note

BlackBerry technology can provide a client/server environment that includes BlackBerry devices, network PCs, and a server running BlackBerry Enterprise Server. The server software provides the connectivity to corporate communication software such as Microsoft Exchange or Lotus Domino.

BlackBerry devices are now being made available by a number of cellular phone providers such as T-Mobile and AT&T. Compaq and other makers of PDAs are also creating new handhelds that provide BlackBerry support. BlackBerry devices are even sold by Internet service providers such as Earthlink in combination with connection packages that provide wireless Web access and access to email accounts provided by the ISP.

The Absolute Minimum

This chapter took a look at devices used for networking on the run such as laptops and PDAs. We also looked at strategies for remote connections to the network such as remote access and Virtual Private Networking.

  • Portable computers quickly followed on the heels of the PCs introduced in the 1980s. Today's laptops provide the power and storage capabilities found on desktop computers.

  • Remote access servers supply remote clients with the ability to connect to the network using either dial-up or VPN connections. Most network operating systems support remote access.

  • Dial-up connections are controlled by an access protocol such as PPP or SLIP. PPP is now used in most cases and provides encryption and compression for the connection.

  • A Virtual Private Network (VPN) allows remote clients to connect to the LAN over the Internet. The remote connection is accepted by an RAS server configured for VPN.

  • A PDA is a handheld computer that actually provides processing power and data storage. The two most popular PDA operating systems are the Palm OS and the Windows CE OS.

  • PDAs provide users with the ability to work both offline and online (using a modem or other cellular technology). Popular PDAs include those running the Palm OS, Windows CE, and the BlackBerry OS.


Part IV: Keeping the Network Running Smoothly

Protecting Network Data

Network Troubleshooting

A Network Security Primer

Glossary


Chapter 18. Protecting Network Data

In this chapter

  • Working with hard drives

  • Understanding hard drive partitions

  • Using RAID to protect data

  • Backing up network and server data

  • Working with different types of backup strategies

  • Protecting devices with an uninterruptible power supply

In previous chapters, we've taken a look at networking hardware and cabling as well as the hardware and software used for network servers and clients. We've also looked at issues related to serving up a Web site. An important aspect of managing a network, and something that we definitely need to discuss, is how you protect the important data on the network.

Now, I'm not talking about network security issues here, such as strategies for keeping intruders from hacking into your network (these are discussed in Chapter 20, "A Network Security Primer"). I'm talking about strategies that allow you to protect data in situations where a file server's hard drive fails or an employee accidentally erases an important database file. In this chapter, we will look at strategies that add redundancy to a network. This redundancy can take many forms. It can be a backup of all the important files on the network, or it can be a set of redundant disk drives that contain exactly the same information.

Making sure important computers such as file servers keep running, even during a power failure (at least until you can shut them down correctly), is another issue related to protecting data on the network. The main issue we will look at here is building fault tolerance into a LAN, which is a fancy way of saying we don't want to lose any data, no matter what happens to our servers and other network devices.

Let's begin our discussion with a look at the different data-protection schemes that use redundant disk drives. We'll then take a look at issues related to backing up data on a network, and then we can explore the use of uninterruptible power supplies.


Understanding Hard Drives

Hard drives (or fixed disks) store information magnetically. They are actually made up of rigid cylinders and have a read/write head, much like any other magnetic recording device.

Because hard drives have extremely rigid, durable cylinders, they can spin at very high speeds. This means that the data on the disk can be accessed quickly (definitely faster than floppy drives and most removable media drives). Disk speed (or access time) is measured in milliseconds and is related to the time it takes a drive to access data. The lower the access time, the faster the drive. For example, an 11ms drive would be faster than a 28ms drive.

We already talked about the different hard drive types—IDE and SCSI—in Chapter 3, "Networking Hardware". Regardless of which of these drive types you use, the drive typically has to be partitioned and formatted before you can actually install an operating system or other software onto it. Let's take a look at drive partitions and then the formatting process.

Drive Partitioning

Hard drives come in a variety of sizes. Although plenty of hard drives churning away on networks are not as large as you would think and have less than 10GB of drive space, newer computers boast drives with sizes of in excess of 120 gigabytes (a gigabyte is 1,073,741,824 bytes or 1,024MB). As computer operating systems and network operating systems have become more user friendly and more sophisticated at the same time, the hard drive capacity they need in order to operate has grown dramatically.

While drive capacity has grown, drive price has actually dropped in relation to the amount of storage space that you get for your money. The original 10MB hard drive for the IBM PC cost about the same amount as a 200GB drive you would buy today.

A partition is a logical portion of a hard drive that is actually read by the computer's operating system as a separate drive (see the following note). Therefore, you can have a hard drive with just one partition encompassing the entire space on the drive (the maximum size of a partition can be limited by the file system used) or you can partition a hard drive into several different logical drives.

Note

The maximum size you can make a hard drive partition will depend on the file system you format the drive with. The Mac OS supports disk partitioning and sees it as a way to divide a large storage space into more manageable subsets. Partition sizes on a Mac are not limited, however. In the IBM/compatible PC realm, there are actually three different file systems now available for hard drives: FAT16, FAT32, and NTFS. FAT16 (FAT stands for file allocation table), the file system used by DOS and early versions of Microsoft Windows, only supports partitions of up to 2GB. With the second release of Windows 95, the FAT32 file system became available. It supplies support for partitions in excess of 2GB (up to 8GB). NTFS (NT File System) can be used on computers running Windows XP and Windows 2000 and provides for partition sizes larger than 2GB. The newest version of NTFS (NTFS 5, available in Windows 2000 Server and Windows Server 2003) also provides an "active disk" format that makes it easier to create and extend partitions on drives.

A number of different tools are available for partitioning drives; on IBM/compatible PCs (which is what we focus on in this chapter) partitions have been created on hard drives since the early days of DOS using a utility called FDISK (see Figure 18.1). FDISK is a DOS command-line utility that provides a menu system used to create and delete partitions on a hard drive. It is available in all the various versions of DOS and Windows.

Figure 18.1. FDISK is a DOS utility used to manage hard drive partitions.

Operating systems such as Windows 2000, XP, and Windows Server 2003 provide GUI utilities that you use to create and manage partitions. For example, Windows Server 2003 provides the Disk Management utility, which allows you to view the various partitions on hard drives (see Figure 18.2). This utility also makes it very easy to create new partitions on a drive.

Figure 18.2. Some operating systems, such as Windows Server 2003, provide a GUI drive-management utility for partitioning and formatting drives.

Drive Formatting

How you format your drive will depend on the operating system you are using. Every operating system offers some type of utility for formatting drives. When you format a drive, you completely remove any data that the drive may have held. Therefore, it's important to be sure you don't need that data before blowing it away.

For example, formatting a drive using a DOS boot disk (such as the installation disk included with versions of Windows such as Windows 9x) is very straightforward. At the DOS command line, you type format C:, where C is the letter of the drive you wish to format.

Formatting a drive is necessary because the appropriate "geography" used by a particular file system for storing and accessing files must be placed on the drive. These areas in which files will be stored are called sectors.

Note

FDISK is included on the boot disk that is provided with the different flavors of Windows, such as Windows 9x (the disk is in the box with the CD). Insert the disk and boot the computer. You can then type fdisk at the command prompt that appears. Once FDISK is up and running, the menu system it provides makes it easy to create any number of partitions on a hard drive. More sophisticated operating systems such as Windows 2000 and XP actually provide you with the ability to create partitions and format them during the installation process.

Most operating systems require that you partition and format at least one drive (in cases where the computer has multiple drives, which is typical for servers) before or during the installation of the operating system. Some operating systems, such as Microsoft Windows XP, also give you the option of changing the partitions on a drive (or drives) and formatting a drive with a different file format during the installation process (such as formatting a FAT drive with the NTFS file system).


Working with RAID

Redundant Array of Inexpensive Disks (RAID) is a group of strategies designed to provide fault tolerance for files stored on hard drives. In general, using RAID means that you are placing data on more than one disk; if a disk in the RAID set goes down, you still can get to your data because you either have a complete copy of that data (on another disk in the RAID set) or can regenerate the data on the failed disk from the data and parity information (something we will discuss when we look at RAID 5) on the remaining disks in the set.

In the simplest terms, RAID allows you to take more than one drive and combine them into a disk set (or array) that functions just like a single drive. RAID can be hardware supported or software supported. Hardware RAID will be available on a computer where the SCSI controllers found on the motherboard support RAID. Some sort of configuration utility will be provided to set up RAID on a computer that supports hardware RAID. You can also buy add-on boards such as a SCSI controller card.

With software RAID, the operating system you are running (and this is pretty much limited to network operating systems and Windows 2000 and XP Professional clients) supports RAID. Windows 2000 and Windows Server 2003, Novell NetWare, some Linux distributions, Sun Solaris, and other network operating systems provide support for software RAID.

Note

You will notice that computer drives are assigned numbers starting with 0. Therefore, your first drive will be drive 0, your second drive will be drive 1, and so on. Because computers (especially servers) can have more than one drive controller, such as multiple SCSI controllers, you could potentially have more than one drive designated as drive 0. Just remember that this is the first drive on a particular drive controller. The controllers themselves will be designated as controller 0, controller 1, and so on.


Understanding the RAID Flavors

RAID comes in eight different flavors, numbered from 0 to 7. The actual types of RAID available with a RAID hardware device or with a network operating system that offers RAID software support will vary. For example, Windows Server 2003 supports RAID 0, 1, and 5. Before we actually take a look at the different types of RAID, I need to define what a volume is. A volume, which in some cases is exactly the same as a partition, is a portion of a hard drive that can function as a separate and discrete drive. In the case of RAID, a volume (which appears to the computer as one drive) is actually spread over two or more drives.

Another piece of information you need before we look at the different types of RAID involves the role parity bits play in RAID arrays. Parity information is extra bits of information included with data that is striped across the drives in a RAID array. These extra bits provide enough information about the data striped across the drives that it can actually be used to reconstruct the data on any one of the drives if one happens to fail. Network operating systems such as Windows NT and Windows 2000 that support RAID sets that use parity bits all have utilities you can use to regenerate any data that is seemingly lost when one of the drives in a RAID array fails (you just put in a new drive and regenerate the entire data library of the RAID set).

Let's take a quick look at the different RAID types. A description of all the RAID flavors, 0 through 7, is provided in Table 18.1.

Table 18.1. RAID Types

Type

Name

Description

0

Disk striping

Data is written across the disks in the array. RAID 0 is not a fault-tolerance method; it's actually used to speed disk access.

1

Mirroring

Two drives (such as partitions or volumes) are mirrored so that each disk in the array is an exact copy of the other disk.

2

A proprietary disk striping Data is striped across a disk set and method that uses Hamming code error detection and a correction

Data is striped across a disk set and parity information is written on a set of parity drives (which are not part correction of the data set). This requires a minimum of seven drives.

3

Disk striping with a single-parity disk

Data is written across multiple disks in a stripe set with the parity information stored on a single drive that is not part of the data set.

4

Disk striping with a single-parity disk using block parity

This is the same as RAID level 3; however, the parity information is arranged in defined data blocks.

5

Disk striping with distributed parity

Data is written across a striped set of multiple disks with the parity information distributed across the disk array.

6

Disk striping with distributed parity and block of double-parity bytes

This is very similar to RAID 5: Two sets of parity blocks are created for each data stored on the array. However, RAID 6 is slower than RAID 5.

7

Disk striping with a single-parity disk and disk caching

This is a proprietary system,similar to RAID 3 and 4, that is patented by the Storage Computer Corporation. It requires additional hardware and software.

Tip

Large RAID arrays can actually be housed in their own RAID storage cabinets. These special RAID cabinets provide hardware RAID support and also provide bays for a number of disks. For some background information on hardware RAID and a look at some RAID hardware devices, check out Adaptec's site at http://www.adaptec.com/worldwide/product/prodindextech.html. This site also provides white papers on various storage issues.

Now that you've had a brief introduction to the different RAID flavors, let's take a closer look at the RAID types you are most likely to run into. These are supported in hardware RAID systems and by network operating systems that provide RAID software support.

RAID 0

RAID 0 does not actually provide any fault tolerance, even though RAID is considered a strategy for building fault tolerance into servers. It is actually a trick for providing users with faster access to data on file servers and for taking a couple of small drives and combining them to provide more disk space. Because the data is striped across (that is, spread across) two or more disks rather than one, read and write functions are faster because both (or all) the drives are working simultaneously. Figure 18.3 shows how a RAID 0 array spreads data over multiple drives. Remember that the array of drives would actually be seen by the computer as just one drive with a drive letter designation such as E: (where E: is the actual drive letter).

Figure 18.3. RAID 0 is used to stripe data across multiple drives.

Note

When you combine the space on multiple disks into a RAID array, the available disk space (the partition or volume) on the drives must be equal.

RAID 0 was used a great deal in the days when hard drives were small and slow (not like the incredibly fast gigabyte monsters you can buy now) and there was a need to speed up access to the files on the server and provide an appropriate amount of working storage space. RAID 0 requires at least two hard drives.

Because RAID 0 provides no fault tolerance, when one hard drive in the RAID 0 array goes belly up, so goes your data. In other words, if one drive in the set fails, you lose all your data.

RAID 1

RAID 1, also known as disk mirroring, allows you to create an exact duplicate of a drive partition on another disk. This means that the system partition on a server (the partition where all the startup and important NOS files live) could be mirrored onto another drive. If the main drive fails, the mirror-image drive can be used to keep the server running.

Disk mirroring is supported by a number of network operating systems, including Microsoft Windows Server 2003 (this would be software RAID supported by the NOS). Windows Server 2003 actually supplies a wizard called the Create Volume Wizard that makes creating a mirror set very easy. Figure 18.4 shows this wizard, which walks you through the process of creating a mirror set.

Tip

Disk mirroring actually allows you to boot a server where the primary drive has failed. Because the mirror provides all the boot and system files found on the drive that the server normally boots to, it can also provide a successful system boot. Although it takes a little work, you typically create a boot disk for the server that specifies that the server should boot to the mirror drive rather than the primary drive. For example, in Windows 2000, you create a boot disk and then edit a text file called boot.ini (on the floppy disk) by changing the location of the drive on which the computer should look for the boot files.

Figure 18.4. Network operating systems that support RAID typically provide an easy-to-use utility for creating RAID arrays such as mirror sets.

To create a RAID 1 array, you just need to have an extra drive that has at least the same amount of free space as the drive partition you want to mirror. The really cool thing about mirror sets is that if one of the drives in the set fails, you can replace the bad drive and then use the network operating system's disk-management software (or the software that allows you to use a proprietary hardware RAID implementation) to regenerate the mirror set onto a new drive.

RAID 5

Using disk striping with parity (RAID 5) is considered a good way to build a fault-tolerance safety net for your drive arrays. You need at least three hard drives to configure RAID 5 on a server. A large number of drives can be made part of a RAID 5 array; the actual maximum number will depend on the hardware or software RAID scheme you use. For example, Windows 2000 Server and Windows Server 2003 (both of which use software RAID) can support up to 32 disks in a RAID 5 array.

Note

You can increase the fault tolerance of mirror sets and other RAID arrays by actually having separate drive controllers for each drive you use. This might be considered overkill, but if all your drives (such as SCSI drives) operate off of one controller, that controller's failure can bring down all your drives. Using separate drive controllers on drives in a mirrored set is called disk duplexing.

RAID 5 works very well on file servers where you have users accessing data all day. The disks in the stripe set actually speed user access time to the data because you don't have a single drive churning away as people open and save files.

When a drive in a RAID 5 set fails, the data on the failed drive is actually regenerated using the data and the parity information that has been stored on the other drives in the stripe set. In cases where a server has hot-swappable drives that are easy to remove and replace, you can regenerate a RAID 5 set with a minimum of server downtime.

RAID 5 arrays require that the same amount of storage space be available in the partitions on the separate drives that will be part of the RAID 5 array. Most network operating systems will not allow you to include the partition that contains the operating system's boot and system files.

When you create a RAID 5 array, all the partitions (on all the drives in the set) are assigned one drive letter and seen by the server (and users accessing the server) as one drive. Figure 18.5 shows a RAID 5 array in the Windows Server 2003 Disk Management utility. Notice that all the partitions in the RAID 5 stripe have been assigned the single drive letter E.

Figure 18.5. RAID 5 allows you to stripe data across three or more disks, providing fault tolerance and faster data access.

    [ Team LiB ]


Backing Up Data

Although RAID arrays are pretty cool (network administrators love to sit around and talk about their RAID arrays), the most foolproof of all the fault-tolerance schemes is to simply make a backup copy of important data. Performing regular backups is essential to truly protecting valuable information on the network (and often is considered a foolproof method for keeping your job as network administrator).

When you spec out your network server (some considerations for network server hardware is discussed in Chapter 3), it makes good sense to consider some type of tape backup unit for your server. You can use an internal tape backup drive or an external drive. Backup devices can range from portable units with one drive bay, to backup "towers" that include several tape drive bays and can back up terabytes of data. You even have choices for SCSI tape drives, IDE tape drives, and tape drives that attach to your computer's parallel port.

A number of different hardware manufacturers make tape backup drives, including Seagate, Hewlett-Packard, and Iomega (the list goes on and on). Some of these products come with decent backup software and some don't (you might have to buy the backup software separately). Most network operating systems also supply some type of backup utility. Some are better than others, and you will have to assess whether you can get by with the NOS backup software or you need something more sophisticated. For example, Windows Server 2003 provides a very easy-to-use backup utility (named Backup) that can be used to back up files in a shared directory.

Also, a number of different types of tapes can be used in the various backup drives available. Some of the popular tape backup types are as follows:

  • Digital Audio Tape (DAT). Developed for sound recording, this small high-density tape format can store around 12GB of data per cartridge. DAT has a moderate transfer speed but isn't as fast as some of the others (such as DLT and 8mm).

  • DLTtape (or just DLT). A half-inch tape format that holds up to 70GB of data and has transfer speeds of 5MB per second (a great Web site that provides all sorts of information on DLTtape can be found at www.dlttape.com).

  • 8mm. Similar to the 8mm video format, these 8mm cartridges can hold around 30GB of data and can transfer data at speeds up to 3MB per second.

You can also back up data to floppy disks (this is probably only practical in peer-to-peer situations where a relatively small amount of data needs to be backed up) or removable media drives, such as the Zip and Jaz drives made by Iomega. You can also copy files to CD-ROM, if you have access to a CD-ROM burner.

One plus related to using backup software is that these software packages use some type of compression scheme that allows you to squish the data you actually back up to a tape. This means that the data takes up less space on the backup media than it actually does on the file server's hard drive. Of course, the only way you can get the data off the tape backup and restore it to a computer is to use the backup software to uncompress and restore the files to the server's fixed disk.

Whichever backup device, media type, or backup software you select, the whole point of backing up data is to restore the data when a drive (or RAID array) on a network server fails. On larger networks, where you must back up a great deal of data, you need to put together some kind of strategy that allows you to back up the most up-to-date copy of each important file. This can be difficult because, on networks with a great deal of users, the data is actually changing by the minute.

Most types of backup software actually provide you with the ability to perform different types of backups, including full (or normal) backups, differential backups, and incremental backups, all of which we will discuss in a moment. Because backing up network data takes time, it's not always practical to back up each and every important file every day. Let's take a look at the different backup types, and then we can take a look at how you formulate a backup strategy that allows you to back up your network on a schedule that supplies you with a recent backup of your data without taking up a lot of your time.

Backup Types

As mentioned earlier, there are basically three different backup methods: full, differential, and incremental. These different types of backups are possible because of file markers. A marker is an attribute placed on a file (in other words, the file is tagged). Typically, any operating system you work with will mark or tag a file once that file has been backed up. A file that has changed since its last backup will also be tagged. It is the use of these tags or markers to denote which files have been backed up and which files have not that allows backup software to perform different types of backups. Here's a breakdown of how these backup methods work:

  • Full backup. This type of backup is also called a normal backup or a daily backup (depending on the backup software you're using). A full backup takes all the files that you select for backup and backs them up (no matter how the files are currently marked). The files' attributes are then changed to mark the fact that they have been backed up (if you change the file after the backup, the marker will change and indicate that the file has not been backed up since the last changes were made).

  • Differential backup. This type of backup only backs up the files that have changed since their last backup. The differential backup does not, however, change the marker attribute indicating that the file has been backed up. It leaves the marker alone, meaning the file will still read that it has not been backed up since it was last changed.

  • Incremental backup. This type of backup backs up only the files that have been changed since the last backup (just as a differential backup does). An incremental backup changes the archive marker on the files that are backed up to identify those files as having been backed up (which differs from the differential backup method).

As stated earlier, just about any backup software will provide you with the ability to do full, differential, and incremental backups. Figure 18.6 shows the types of backups you can perform using the backup utility provided with Microsoft Windows Server 2003 (it is also provided with Windows XP).

Figure 18.6. Different backup types are offered by most backup software.

So, we have three different types of backups we can perform. The million-dollar question is: How do we use these different backup types to be sure we have a valid backup of our files without spending every waking hour performing backups? The next section, which explores creating a backup strategy, answers this question.

Note

Depending on the backup software you're using, you might run across other backup possibilities. For example, Windows Server 2003 actually provides a service called Shadow Copy that backs up different versions of files as network users work on them. This allows a network user to "roll back" a file version to a previous version of a document. For more about Windows Server 2003 see Sams Teach Yourself Microsoft Office 2003 in 24 Hours.

Creating a Backup Strategy

The type of backup schedule you create for your network will have a lot to do with the amount of data that needs to be backed up. If the mission-critical files for your company only take about 20 minutes to back up, you could perform a full backup every night and always have a fairly recent version of all the important data files (your backup does not hold any changes that were made to the files during the day, however).

In most cases, however, network file servers hold a lot more data than can be backed up in 20 minutes. This is why backup strategies will usually consist of a combination of full backups and differential or incremental backups.

Now, before we actually look at using differential or incremental backups in conjunction with full backups, I will say that servers typically don't give you advance notice when they are going to fail. So, to be in a situation where absolutely no data is lost, you have to be pretty lucky.

Let's assume that you have a fairly decent size network (a couple hundred users) and a lot of activity as far as data file changes go. One approach to backing up the data would be to do a full backup of the network when network activity is low. This means on Friday night or sometime on the weekend, you would perform a full backup (many backup software packages allow you to schedule a backup where you don't even have to be present for the backup to take place).

So, you now have a complete backup of all the files. On Monday morning, users will begin to access and change those files, making our backup tape out of date. Now you need to find a way to back up the files that have changed without waiting for everyone to go home and then performing another full backup during the night.

One strategy that you can use is to combine incremental backups with a weekly full backup. Remember that incremental backups only back up the files that have changed since the last backup and then mark those files as having been backed up. Therefore, you can run an incremental backup every night using a different backup tape. You would label the tapes Monday, Tuesday, and so on (ending up with tapes for Monday through Friday).

Note

Backups shouldn't just consist of important data files. It is also important to back up system files on key servers on the network. Therefore, you might typically perform a fairly time consuming backup on file servers (ones that hold a lot of data) and also do backups on other servers on the network so that their system files can be restored in the event of a problem with these particular servers.

The incremental backups you run each night will be fairly fast (in relation to the full backup you run on the weekend). This is because you will only be backing up the files that have changed since the previous evening.

If the server has a drive failure, you would first restore the full backup tape (from the weekend) and then restore each of the incremental backup tapes for Monday through Friday. Although this seems like a lot of work, you will have lost very little data using this backup scheme. This strategy does require that you have a pretty large pile of tapes handy.

An alternative to the full/incremental backup strategy does exist. It does not provide quite the high level of data security, but it does allow you to use fewer tapes.

You would still perform a full backup on Friday night or sometime during the weekend. Then you would perform a daily differential backup on each night using a second tape. Remember that a differential backup will back up files that have changed since the last full backup (the backup on the weekend), but it does not mark files as having been backed up.

Therefore, you can use the same tape (a tape other than the one used for the full backup) to perform a differential backup each night. This differential backup will take longer as the week progresses because you are overwriting the previous night's files and backing up any file that has changed since the weekend's full backup.

If you need to restore data after having used this full/differential backup scheme, you are only dealing with two tapes. You restore the full backup tape from the weekend and then you restore the differential backup tape from the night before.

You don't necessarily have to back up a network every night as we have discussed. If important files on the network don't change that often, you might be able to back up the data less frequently. The frequency of backups is something that all network administrators must decide for themselves.

On the other hand, having no backup schedule or strategy for a network is pretty much the kiss of death. Yes, I have known network administrators who have been extremely lackadaisical about backups and were extremely lucky in that their networks never had a major data meltdown. It is probably better to be safe than sorry (and unemployed), however, and put together a backup strategy that will allow you to get your file servers up and running when a drive problem occurs or important data is accidentally erased.

Tip

You should put your backup procedure on paper and then test it using files that are not mission critical. Perform your various backups over a specified time period and then restore the data. This allows you to take a look at how your backup procedure will actually work when you deploy it on the network.


Working with Uninterruptible Power Supplies

One other fault-tolerance strategy that we should take a look at involves the use of an uninterruptible power supply (UPS). A UPS is a device outfitted with some type of battery that can supply temporary power to a server when there is a power failure. Many UPS devices will also offer surge protection; this will help protect an important device from any voltage surges that may occur during an electrical storm or other power surge problem.

A UPS sits between a server and an electrical outlet. The UPS is plugged into the electrical outlet, and the server is plugged into the UPS. Because the UPS is a peripheral device, it also connects to the computer via a serial cable or a UPS port. The serial cable used is not your typical serial communications cable and will be included with the UPS.

UPS devices also come with their own software that needs to be installed or configured with the appropriate drivers offered by the operating system you are using. This way, they can relay alerts to the operating system related to electrical spikes and brownouts.

A UPS really serves as a silent partner to the server until there is an electrical problem. When power from the outlet is available, the server will be powered by that electricity. At the same time, the UPS is charging its battery.

If the electricity goes out, the UPS will step in and power the server using its battery. This typically supplies the server with 5 to 30 minutes of power. This basically gives you, the network administrator, time to shut down the server properly so that there is no data lost.

It makes sense to use a UPS on servers because most network operating systems can become corrupt or experience problems when they power up again if they have not been shut down correctly. How sophisticated the UPS devices should be on your network (in terms of the alerts they can supply and the amount of battery power they can supply) will depend on how quickly you can get to the servers and actually shut them down. Some UPS devices can even be outfitted with a modem and can be configured to call your pager when there is an electrical problem.

You can also use a UPS to protect other mission-critical failure points on your network. A UPS can be attached to switches, routers, hubs, or any other device that you wish to keep up and running for a short period of time when there is a power failure.

The Absolute Minimum

In this chapter we explored how drives are portioned and formatted. We also looked at strategies for creating redundancy on servers using RAID. Backing up important data was discussed, as was the use of uninterruptible power supplies.

  • Hard drives can be divided into different partitions, each of which function as a discrete drive with its own drive letter. Tools such as FDISK and the Windows Server 2003 Disk Management utility allow you to partition fixed disks.

  • RAID (or Redundant Array of Inexpensive Disks) is a strategy for building fault tolerance into network servers such as file servers. RAID can be hardware- or software-based.

  • Performing regular data backups is the best way to build fault tolerance into a network and avoid the loss of important information.

  • A backup strategy that includes full backups and/or incremental and differential backups can help ensure that a fairly up-to-date version of every file on a server can be restored in case of a disk failure.

  • An uninterruptible power supply (UPS) is used to temporarily supply power to servers in case of a power failure.


Chapter 19. Network Troubleshooting

In this chapter

  • Educating your users to work on the network

  • Using event logs to determine server problems

  • Setting performance baselines for network servers

  • Monitoring network traffic

  • Checking network connections

Most of the information supplied by this book thus far has revolved around either a theoretical look at how things work on a network, such as protocols and data communication media, or the nuts and bolts of setting up and configuring network servers and clients. An important aspect of network administration that we have yet to discuss is network troubleshooting.

No matter how well-planned and how well-implemented a network is, a day will still come when there is a problem—a user won't be able to access the server or users won't be able to print to their default printer. This chapter looks at some of the tools you can use and provides an approach you can take when troubleshooting problems on small, medium, or large networks.


It's Not Always User Error

When users experience problems on a network, the root cause of those problems will almost always boil down to three possibilities: user error, software problems (including operating systems), and physical connectivity problems. Although it is a convenient way to dismiss a problem outright and return to surfing of the Web (okay, so not all network administrators sit and surf the Web all day), not all network glitches can be blamed on user error. Software issues on client machines and servers alike can cause access and connectivity problems on the network. A missing or corrupt driver for a printer or network interface card can cause printing or connectivity failure. Physical connectivity problems such as shorted-out cables, an unplugged hub, or a router with a bad Ethernet interface can also cause problems on the network, and sometimes physical connectivity snafus can be some of the hardest to track down or troubleshoot.

In terms of user error, one way to limit the damage that your users can potentially do to the network is to have a well-informed and well-trained user base. A little bit of well-planned group training for your users can actually negate a lot of potential problems on the network. Some sort of educational opportunity for your users should be built into your overall plan for your network implementation and management.

Documentation that the users can actually read and refer to as they use the network can also greatly cut down on user error. A brief and concise manual that explains basic network logon and resource access can be a real help to your users. This also gives you an opportunity to establish written policies for network use; for example, you might establish rules such as no software downloads from the Internet and no floppy disks or CDs from home. Both of these rules could actually help reduce the risk of virus infection, and no downloads mean that local hard drives remain pretty clean (users can fill up their hard drives with junk pretty fast if they have a high-speed Internet connection and some free time on their hands).

Caution

In the case of small business networks or home LANs, the network administrator (this means you) probably wears a number of hats and doesn't necessarily have the time (or, in the case of a home network, the patience) to instruct users on the actual use of the network. In these cases, keep things simple. Don't password protect drives or folders that everyone needs to access and don't make really important files available on the LAN at all. Your best defense against problems on a small network is to regularly back up important files. In the case of teenage users, definitely use some type of antivirus software if an Internet connection is part of your LAN configuration, since they will download music files such as MP3s. In cases where you might want to limit Internet access, use a product such as Net Nanny (see www.netnanny.com).

Caution

Allowing users to install unlicensed software is a very good way to bring the Software & Information Industry Association's anti-software piracy folks down on your company. They take software piracy very seriously (as should you). For more information about the Software & Information Industry Association, check out www.siia.net/.

Establishing user policies for your company's network not only provides a set of rules for the network users, but it allows you to assume (although users are not always going to follow all the rules) that network client machines will only be running software that is appropriately licensed and correctly configured and that important user files are stored in the appropriate place so that they can be periodically backed up.

Although everyone is aware of the often overused anecdote that accompanies the word assume when an assumption proves to be wrong, at least assuming that computers have been configured in a particular "standard" way allows you to concentrate on other issues when attempting to troubleshoot network problems.

Most networking operating systems, including NetWare and Windows Server 2003, provide you with ways to control the user environment and protect local machine configurations from being radically changed by the user or users that sit at that computer. An example of an environment that provides a system of policies for protecting local software installations and configurations is Windows Group Policy. We discuss Group Policy in Chapter 9, "Networking with Microsoft Windows Server 2003."

So, let's assume that you have done everything you can to lock down local computer configurations. You are still going to have problems on the network (we are ruling out user error) and these are going to be caused by either software or hardware. Let's take at look at some approaches to troubleshooting software and hardware problems on the network.


Identifying Network Operating System Problems

All network operating systems provide some sort of utility (or utilities) that you can use to troubleshoot problems related to the network operating system software. These utilities allow you to perform tasks such as seeing whether software drivers for hardware devices such as NICs have loaded correctly (as the system boots up) and whether a particular application has failed.

In the Microsoft Windows Server 2003 environment, a utility called the Event Viewer is provided. The Event Viewer allows you to view three different types of log files: the System Log, the Application Log, and the Security Log (we discuss the Security Log in more detail in the next chapter).

As far as operating system problems go, the log you would want to take a look at is the System Log. The System Log shows information such as driver failures and failed server services. Any events related to server services and system resources will show up in this log. Figure 19.1 shows the Event Viewer's System Log. Note that errors, warnings, and other information are recorded in the Event Viewer's System Log.

Figure 19.1. The Windows 2000 Server Event Viewer allows you to view software-related alerts on your server.

Details on a particular event can be viewed by double-clicking that event in the Event Viewer Window. Windows Server 2003 also supplies other log files, including the Application and the Security logs. The Application log records events related to applications running on the system. The Security log records events related to audit policies that you have configured on a server such as the auditing of unsuccessful logons or access to a particular file on a file server.

NetWare 6.5 also provides access to different log files that record errors and server status information automatically. For example, the SYS$LOG.ERR file lists server errors and general status information related to the server. Another server log file available in the NetWare environment is the Server Health Log File, health.log. You can view these various log files using the NetWare Remote Manager. Under the Diagnose Server category in the Remote Manager, a Reports/Log Files category is provided. Figure 19.2 shows the Remote Manager and the System Error log file.

Figure 19.2. The NetWare Remote Manager makes it easier to access server log files.

The NetWare Remote Manager also allows you to create configuration, security, and inventory reports for a NetWare server. These reports can be viewed in the Remote Manager window or they can sent to a particular email account and viewed. Figure 19.3 shows a server configuration report that was generated in the Remote Manager (for more about the NetWare Remote Manager, see Chapter 8, "Networking with Novell NetWare 6.5").

Figure 19.3. Server reports can be generated in the NetWare Remote Manager.

Note

For an overview of Windows Server 2003, check out the book Sams Teach Yourself Microsoft Windows Server 2003 in 24 Hours. It provides information on installing, configuring, and monitoring a Windows Server 2003 network.


Diagnosing Hardware Problems

It's pretty easy to diagnose a hardware problem once a device has completely died. The fact that a network interface card that has been working is suddenly showing no activity light on the back of the card might be a pretty good indication that the NIC is shot. And when you fire up a server in which a drive has gone belly up or the video card has gone bad, the system BIOS will usually alert you to a major hardware problem and provide a series of beeps as a tip off. An important part of troubleshooting a network is actually avoiding troubleshooting major hardware problems by staying one step ahead of the potential hardware pitfalls.

Most network operating systems will help you keep track of hardware performance. Not only can you monitor hardware devices such as the drives on a server, but you can also discern the relative health of the network itself using various network-monitoring software.

In the Windows environment, you can monitor server hardware performance, such as the processor and RAM, using a tool called Performance Monitor, and network performance can be tracked using a tool called Network Monitor.

Novell provides the NetWare Remote Manager, which can be used to view server logs and also quickly check the health of the server. The Health Monitor (accessed via the NetWare Remote Manager) provides a snapshot of the server's health in a table format (see Figure 19.4).

Figure 19.4. The Health Monitor provides a look at the server's overall health.

The Health Monitor not only provides statistics related to server processes and hardware use such as CPU utilization, but it can be used to create notifications so that you know when a particular server health statistic reaches a particular threshold. You can also view the statistics provided by the Health Monitor in a graph. Figure 19.5 shows the graph for the server's CPU utilization.

Figure 19.5. The Health Monitor provides graphs of server processes.

When you monitor server hardware and server processes' performance, you are trying to identify bottlenecks. A bottleneck can be a hardware component on a server, such as the processor or the memory, that is being overtaxed and slowing down overall system performance.

Once your server is configured and your network is up and running, it is important to use your server monitoring software to establish a baseline. A baseline is a set of initial readings when the network is fully operational and typically running well. This set of baseline readings can then be used for comparison when you take readings on server performance in the future.

The different server monitoring tools in the different network environments will obviously all operate differently. In the NetWare environment, the Health Monitor can be used to track the CPU utilization and other processes. In the Windows network environment, hardware and service performance are tracked using Performance Monitor. To help illustrate some issues related to monitoring server processes, let's take a closer look at how the Performance Monitor works.

Tip

As far as servers go, three areas you should keep an eye on for potential bottlenecks are the processor, the paging file (which helps diagnose memory issues), and the physical drives.

On a Windows server, any process that can be measured is referred to as an object, and performance objects are added to a graphing system as counters. For example, let's say you want to monitor the processor on a server running Windows Server 2003. Once you get the Performance Monitor tool open, you need to add a counter to the monitor for processor performance.

The Windows Performance Monitor provides a dialog box that groups different counters into categories, such as Processor, Physical Disk, and Paging File (which is the virtual memory on your computer; too much access of the paging file shows that the computer could use a little more RAM). Figure 19.6 shows the Performance Monitor's Add Counters dialog box.

Figure 19.6. Counters used to monitor server performance are easily added to the Windows Server 2003 Performance Monitor.

Once a counter is added to the Performance Monitor, the performance of the particular object (such as processor time) can be viewed. Figure 19.7 shows the histogram chart for processor time on a Windows server.

Figure 19.7. Processor use on the server can be monitored using the Performance Monitor.

Once you set up your particular performance monitor with the appropriate counters, you can actually save the data as a log file. This provides you with a baseline you can use to compare with future performance data.

Many of the Performance Monitor tools also allow you to create alerts. An alert actually "alerts" you when a predefined threshold has been reached on a particular counter. For example, you might want to create a performance alert that alerts you when a file server's drive (or drives) has reached a certain percent of total capacity. The Windows Performance Monitor actually sends the alert to the Windows Event Viewer's Application Log.

Tip

Most performance monitors also provide you with different views of the data. For example, the Windows Performance Monitor provides the chart and histogram views (the histogram view looks like a bar chart). Also, the data can be viewed in a report format.

NetWare 6.5 also provides you with the ability to create alerts related to different server processes. Default thresholds are set for different server processes such as CPU utilization; you can change the threshold settings in the Remote Manager. Figure 19.8 shows the threshold settings for a NetWare server on the Remote Manager.

Figure 19.8. Event alerts can be used to help you stay on top of server use issues and can be configured in most server environments.

Regardless of the network operating system you use, it is important to set up some sort of system where you monitor server resources and then compare them against benchmarks that you have established. When monitoring server performance, try to build some consistency into your measurements by logging information at times of peak network use and by consistently measuring the same parameters so that you have data for comparison.


Monitoring the Network

Another aspect of keeping your network healthy is monitoring network traffic and looking at the various processes and events related to network protocols. This means you actually have to be able to view the communication processes that actually take place on your network as data moves from servers to clients (and vice versa). Network monitoring is the process of viewing and analyzing network traffic, and network monitoring software packages are used to capture network data frames and examine them. A software package that can analyze protocol information in a data frame is often referred to as a protocol sniffer.

Caution

Protocol sniffers and network monitoring software can be a big help in managing a large network. The problem with these types of software packages, however, is that they can also be used to actually steal and read information on a network, such as usernames and passwords. Protocol sniffers are often used by hackers to gain information about networks they wish to steal information from. We will talk more about hacking/cracking in Chapter 20, "A Network Security Primer."

A number of software companies make network monitoring software and protocol analyzers. For example, Sniffer Technologies sells a range of network monitoring software for both the LAN and WAN environments. For the Unix/Linux environment and the Windows environment, a free network analyzer called Ethereal can be downloaded from www.ethereal.com.

Windows Server 2003 provides the Network Monitor, which can be used to capture frames (a frame being a data packet) and monitor network activity. The Network Monitor provides many of the features that you would find in other network monitoring software packages. Most network monitoring and packet sniffing packages are geared for Ethernet networks because it is the most commonly used network architecture.

Let's take a quick look at the Windows Network Monitor and how it displays the information that it captures. The Network Monitor window is actually divided into a number of different panes that provide different types of information. Figure 19.9 shows the Windows Network Monitor. This data is collected when you (the network administrator) use the Capture command to begin a capture session.

Figure 19.9. Network Monitor provides information on network traffic and can sample data frames traveling on the network.

The Network Monitor provides statistics such as the percentage of network utilization and the number of frames per second (this would be the number of frames traveling by the computer running Network Monitor; data is sampled by the computer's NIC). These more general statistics are listed in the Graph pane, which resides in the upper-left area of the Network Monitor window. The Total Statistics pane to the right of the Graph pane provides summary information.

The Session Statistics pane provides information on each session captured (a session being communication between two computers or devices on the network). The first column in this pane provides the hardware address (the MAC address of the device's network interface card) of the device that is sending the packets (the packets you are capturing). The second column provides the number of frames (packets) sent to the receiving device from the sending device during the communication. The third column shows the number of frames sent back to the initiating device, and the last column in the Session Statistics pane provides the hardware address of the receiving device participating in the session.

The Station Statistics pane appears below the Session Statistics pane in the Network Monitor window. It provides statistics related to your computer's activity on the network. A number of different columns of information appear in this pane :

  • Network Address. This column provides the network address that frames were captured from.

  • Frames Sent. This column provides the number of frames that were sent from the network address appearing in the first column.

  • Frames Rcvd. This column shows the number of frames received (by the local computer) from the device hardware address appearing in the first column.

  • Bytes Sent. This column displays the number of bytes sent by the device whose hardware address is listed in the Network Address column (the first column in the pane).

  • Bytes Rcvd. This column tells you how many bytes were received from the network address listed in the Network Address column.

  • Directed Frames Sent. This column shows the number of non-broadcast and non-multicast frames that were sent over the network by the device whose hardware address is listed in the first column of the record.

  • Multicasts Sent. This shows the number of times the address listed in the Network Address column has sent frames to a subset of computers on the network (a multicast is a broadcast message to certain computers on the network).

  • Broadcasts Sent. This column shows the number of times the address listed in the Network Address column has sent broadcast messages to all computers on the network (a broadcast message is a message sent to all the devices on the network by a particular computer).

Data collected by monitoring software such as Network Monitor can often be saved to a log file that you can view at a later time. This allows you to capture information related to the network and save it as a baseline. Data collected over time can then be compared to the baseline information. If there is a great deal of disparity between your baseline (or benchmark) readings and the new capture information, you know that there must be a problem with the network. For example, if there are tons of broadcast messages from a particular MAC address, a computer on the network might have a malfunctioning network card.

Note

The version of Network Monitor that ships with Windows Server (2003 and 2000) is not a full-blown version of the product. You will find that some of the menu choices won't work, and to get all the features you must acquire a copy of the Microsoft Systems Management Server Network Monitor tool. While there are free LAN analyzer software packages available on the Web, if you are monitoring a network of any size (and your data has definite value to your company) you will want to research and then buy an appropriate network analyzer tool.


Dealing with Connectivity Issues

Like the other potential server and client computer problems we've discussed in this chapter, problems with connectivity can revolve around software and hardware. In the case of software, many connectivity problems can be caused by incorrect LAN protocol configurations. For example, two computers inadvertently configured with the same IP address will knock each other off the network.

In terms of connectivity problems related to hardware, networking cables, hubs, network interface cards, and just about any other hardware devices that are important to the network communications can cause connective problems if they are malfunctioning. Although connectivity problems can be difficult to troubleshoot, there are tools you can use to troubleshoot network protocol and hardware issues. Let's take a look at each of these areas individually, starting with some of the tools that can be used to help diagnose network configuration problems. Then we can take a look at some of the devices used to diagnose hardware connectivity problems.

Checking Settings and Connections from the Command Line

Because IPX/SPX (and other LAN protocols such as NetBEUI or AppleTalk) pretty much configures itself as far as computer identification on the network goes, the protocol stack that seems to offer the most pitfalls as far as configuration goes is TCP/IP. Fortunately, there are commands that allow you to quickly check the configuration of a computer or check the connection between two hosts on the network. Let's take a look at these commands: ipconfig, ping, and traceroute.

Ipconfig

Ipconfig is a command (ipconfig) that can be used on Windows NT, 2000, and XP clients or on any Windows server to quickly check the IP configuration. This is particularly useful when you are using automatic addressing of computers on the network using a DHCP server (DHCP is discussed in Chapter 12, "TCP/IP Network Administration") and want to make sure the client is receiving the appropriate IP settings from the DHCP server. Figure 19.10. shows the results of the ipconfig/all command issued on a Windows server.

Figure 19.10. Ipconfig can be used to view the current IP settings of a Windows server or client.

Ipconfig comes with a number of different switches that allow you to view more IP-related information or to release or renew the computer's current IP address provided by a DHCP server. In the Windows 9x environment, the command winipcfg is launched from the Run box (started by clicking Start, Run). It provides the same type of information that the ipconfig command does.

Ping

An excellent way to check the connection between two computers or other devices on an IP network is to use the ping command. Ping stands for Packet InterNet Groper and uses ICMP echo packets to test the connection. The command syntax is ping ip address, where ip address is the IP address of the target device.

Note

Internet Control Message Protocol (ICMP) is a messaging service and management protocol for IP. It resides at the Network layer of the OSI model (the same layer inhabited by IP). ICMP messages are used by both ping and traceroute (we discuss traceroute in the next section).

You can also use the ping command using the FQDN name of a computer or other device on the network (DNS provides this capability because it resolves the friendly FQDN to the appropriate IP address). Figure 19.11 shows the ping command used to check the connection with a local computer on the network using the destination computer's IP address (10.0.1.1). Figure 19.11 also shows the results of the ping command when it is used to check the connection with a remote mail server. The remote server is designated by FQDN, which is converted to the appropriate IP address by a DNS server on the network.

Figure 19.11. Ping can be used to check the connection between any two computers or devices on an IP network, including the Internet.

Traceroute

Traceroute (or trace; or on a Windows machine, tracert) allows you to actually see the route that data packets take on the network. Traceroute is a tool used for checking data flow on larger networks (internetworks) that include routers; it is very useful in situations where you want to check and see whether a particular router has malfunctioned or whether other equipment is not working properly, causing certain routes to be down on the internetwork. Figure 19.12 shows the tracert command used on a Windows client to check the route to a remote host on the Internet.

Figure 19.12. Traceroute is used to determine the route that packets take from one network device to another.

In Figure 19.12, the ICMP packet that was sent to the remote host took 13 hops to reach its final destination (a hop is one router on the internetwork). If the traceroute command is used in the future to check the route to this same IP address, any change in the number of hops or the intermediary routers would show that something has happened on the network to affect the route that the packets have taken from source to destination device.

Although most of our discussion has been limited to commands used on PCs, both the ping and traceroute commands are often used on other network devices, such as routers, to check connections and the routing of packets between two devices. On a router (such as a Cisco router), the trace command is used to determine the route between two devices. It is commonly used to make sure that routers on the network are working and that the paths you assume are up and running are indeed functional. Figure 19.13 shows the traceroute command (on a Cisco router that command is abbreviated as "trace") being used to check the route between two routers on a network (Alice and sweetpea).

Figure 19.13. Traceroute is used to determine the route that packets take from one network device to another.

Note

This introductory book to networking can only really provide you with an overview of networking and the various clients, servers, and other devices you would encounter on different-sized networks. Understanding routers and the routing of information on internetworks is definitely a whole story in itself. Cisco Systems actually offers a number of different levels of certification for network administrators who work in routed environments. For a primer on routing, internetworking, and Cisco routers in particular, check out the book Practical Cisco Routers, from Que.

Basic Connectivity Troubleshooting Tools

Although commands such as ping and traceroute are very useful for checking network connectivity, there are devices available that can be used to check connectivity problems related to physical cabling. Physical cabling is always suspect when you are experiencing connectivity problems. Network cables can experience disconnections, breaks, shorts, and other problems. Diagnosing these types of problems is done using various tools, ranging from voltmeters to time domain reflectometers (TDRs).

A digital voltmeter is a simple device that can be connected to a cable to test the cable for a break or a short. Basically, the voltmeter can tell you whether the cable is bad or not and whether you are looking at a short or break. If the cable has a short, replace it. If there is a break, you must trace the cable (have fun crawling around in the drop-ceiling) to find where the break has occurred.

A time domain reflectometer (TDR) is a more sophisticated device that can diagnose shorts and breaks in a cable, but it can also provide you with information on where the short or break exists on the cable. The TDR actually emits short pulses down the cable and is able to use a timing mechanism that estimates the distance that the pulse has traveled.

As I've already mentioned, network cabling is always suspect when there is a network problem. For example, people moving furniture can disrupt cable connections, and a leaky roof can cause cabling in the ceiling to become soaked with water (sometimes leading to shorts)—all sorts of weird things can happen to cables that can sever the connections they provide. Always check cables first.


Your Approach to Troubleshooting

Troubleshooting is really an art and definitely an acquired skill. Every network has its own particular quirks (just like a used car), and actually maintaining a particular network is the best way to accumulate the information needed to enable you to troubleshoot that network when problems rear their ugly heads.

One way to make troubleshooting problems a little easier is to keep good documentation related to the network. This includes server configurations, network client configurations, and problems that you have experienced and then solved. Even in cases where you are working with a relatively small network, some sort of map that shows how the network cabling has been run and the addressing of the network devices can be a big help in troubleshooting situations.

Note

A number of companies make time domain reflectometers, such as Agilent Technologies at www.tm.agilent.com. These devices are expensive (I'm talking a couple of thousand dollars or more) and the best way to learn more about how they work is to check out the Agilent product line (their site includes operating manuals) or do a search for time domain reflectomer using your Web browser. Voltmeters are inexpensive devices and can be picked up at just about any hardware or electrical supply store.

When actually attempting to solve a problem on the network, try to use a systematic approach to problem solving. First, identify the problem; then gather facts related to the problem. You might want to make a list of the possible hardware and software failures that can cause a particular problem.

Then, systematically go through your list of possible causes one at a time and troubleshoot the problem. This is a much better approach than the "shotgun" approach, where you run around and change a bunch of server and client settings and physical connections all at once. This never allows you to pinpoint the actual cause of the problem. The problem just kind of goes away (because you fixed it with one of the many solutions you implemented). If the problem appears again, rather than immediately being able to provide the correct solution, you will again have to result to voodoo and run through a whole list of fixes.

As you are working through the list of possible problems, you will find that a good, general approach to troubleshooting is to work from the basic to the complex. Check things that will result in a simple fix; for example, make sure the power cables are connected on computers, hubs, and other network devices before assuming the problem is a complex NOS configuration problem with the server. In many cases a disconnected cable or an unplugged hub, rather than a malfunctioning server, will be causing the problem on the LAN.

Troubleshooting basic issues first also allows you to attempt to fix the network without getting way over your head in terms of software and hardware configurations. If you reach a point as you tick off basic issues that could cause the problem where you are in unfamiliar territory, you might wish to call your software or hardware vendor for technical support. There is no disgrace (even for the seasoned network administrator) to try to get help in solving a network problem.

The Absolute Minimum

In this chapter we took a look at some of the basics of troubleshooting a network. We discussed issues related to your network users and looked at the monitoring of server hardware and the network.

  • Monitoring hardware and establishing baselines allows you to determine whether hardware on a server (such as the processor and memory) is being overtaxed and could lead to server failure.

  • Tools such as the Windows Server Performance Monitor allow you to add various counters to the Performance Monitor chart, which allows you to view counter statistics in real time. NetWare also provides the ability to view graphs of server performance using the Remote Manager.

  • Network usage and traffic can be monitored using network monitoring software such as protocol sniffers. For example, the Windows Network Monitor provides you with the ability to view network traffic and capture network frames generated on the network.

  • The ipconfig command can be executed from the command line to view the IP configuration of a Windows computer. Other commands, such as ping and traceroute, can be used with a number of different operating systems to check the connection between two network devices or the route that data takes when moving from a sending to a receiving device on the network.

  • Cable connection problems can be checked with devices such as voltmeters and time domain reflectometers.

  • Troubleshooting requires good documentation and a logical approach to problem solving.


Chapter 20. A Network Security Primer

In this chapter

  • Understanding user accounts and passwords

  • Working with resource permissions

  • Using groups to control resource access

  • Protecting against computer viruses

  • Understanding worms and Trojan horses

  • Becoming familiar with the types of outside network attacks

  • Understanding IPSec

  • Working with firewalls

In this chapter, we take a look at network security. The issues related to securing a network have changed dramatically over the last decade, particularly due to the fact that most LANs are now connected (in some way) to the Internet.

Network security was once a very company-centric pursuit. It revolved around securing resources and information on an isolated network. Security concerns had to do mainly with the assigned levels of user access to important network resources and protecting systems from virus attacks (often spread initially from computer to computer by an infected floppy disk).

Today, due to the fact that most networks are connected to the Internet and that many companies maintain a Web presence in the form of a Web site, network security now focuses on attacks from the outside. These attacks often take the form of direct attacks by hackers (or crackers as the hacking community prefers to refer to those who maliciously attack networks). A number of new products, such as proxy servers and firewalls, have evolved over the last few years to deal with these latest security threats. Let's take a look at some of the LAN-centric issues related to network security (such as user/administrator interaction) and then we can take a look at some of the tools that can be used to protect a network from outside attack.


Administrators and Users

Even a pack of wild dogs will have a leader—the alpha dog. The alpha dog serves as the leader of the pack and determines the pack's administrative pecking order. Although most network administrators do not resort to growling or the baring of fangs to maintain control on a network (although I know some who do), the network administrator is the alpha dog and determines all the conditions for user access to the network.

There are really two different aspects that an administrator deals with when working with network security and user access: user authentication and access permissions. User authentication is handled by assigning a user a logon name and a password. Other parameters, such as when a user can log on and whether a user can log on using a remote connection, are also configured by the administrator when he creates the user's account. We will discuss user accounts and different logon issues in a moment.

Access permission involves the level or the rights that an administrator assigns a user in relation to a particular resource on a network. For example, a user may have the ability to open and read files in a particular share on the network but not edit those files. We discussed the basics of network shares in Chapter 7, "Network Operating System Overview," and will discuss access permissions in more detail in this chapter after we spend some time sorting out user accounts.

Note

In a nutshell, users gain access to the network by being authenticated by their username and password. Their actual ability to access a resource on the network will be related to the permissions they have been assigned for that particular resource.


Working with User Accounts

A user can't log on to a network without a valid username and password. Therefore, user accounts are really the network administrator's first line of defense as far as network security is concerned. When a user logs on to the network from a client computer, her username and password are used to generate an access token. This access token validates the user to the network (allowing the logon) and also is used to determine the access level that the user will have to resources on the network.

The access token, which is a concept that you run into no matter what NOS you are using, is kind of an electronic identification card, not that different from an ATM card, really. An ATM card validates you to your bank's ATM network and allows you to access certain resources, such as your checking or savings account. The access token generated in relation to your username is also used to determine the resources that you can negotiate on the network and the degree of access you can have.

The network administrator is responsible for creating user accounts. Every network operating system provides a built-in administrator's account that is used to create and modify network user accounts and manage the resources on the network. This administrator's account is given different names in different operating systems, such as root, Admin, and Administrator (Linux, NetWare, and Windows, respectively).

Each network operating system also offers some sort of utility that is used to create new user accounts. Figure 20.1 shows the New Object - User dialog box used in the Windows Active Directory to add a new user account.

Figure 20.1. Network operating systems such as Microsoft Windows Server 2003 provide administrative utilities to add and edit user accounts.

Every network operating system shares some common rules for governing usernames. These rules are as follows:

  • Each and every username must be unique. Although this rule is a no-brainer, it is important to keep in mind.

  • Usernames are limited to a specific number of characters. Although the number of characters that can be used to create a username will vary from NOS to NOS, every operating system has naming conventions that you should be aware of before you create your user accounts. For example, Windows provides you with 20 characters for a username. NetWare NDS usernames can be up to 64 characters.

  • Certain characters cannot be used in usernames. Typically, characters such as the slash (/), backslash (\), and other special characters cannot be used in usernames. Some operating systems allow spaces to be used in the usernames, and others do not. Again, you need to know your network operating system's naming conventions before you create usernames.

Although each network operating system will supply you with conventions that control the creation of usernames, it also makes sense for you (as the administrator) to create a plan related to the creation of usernames. This plan should include the naming conventions you will use when you create the usernames for your various users. For example, if your basic naming convention for usernames is to use employees' first initial and last name, you need to be consistent and use this convention for all usernames you create. Your plan should also include how you will differentiate two users when they have the same first initial and last name.

This user account plan should also include your strategy for how you will assign passwords to your users. Network operating systems allow you to stipulate a password that cannot be changed or assign an initial password that must be immediately changed by the user. Let's take a closer look at passwords and why they are important to network security.

User Passwords

Because user authentication requires a valid username and a valid password, your strategy for assigning passwords to your users will have a lot to do with how secure your network is. A lot of network administrators in the networking industry use first initial and then last name as their basic format for usernames. This means that if someone knows my name is Joe Habraken, it wouldn't be that hard for him to guess that my username on the network is probably jhabraken.

Therefore, it is really the password component of the user account that builds some security into the logon process. This means that you need to make an effort to keep user passwords secret (meaning users must be taught to keep their passwords to themselves).

Most network operating systems now counsel you to use strong passwords for your network user accounts. Strong passwords are defined somewhat differently by each network operating system but the bottom line is that you want to have passwords that cannot be easily guessed by someone who has malicious intent toward your network.

Microsoft defines strong passwords as passwords that contain at least seven characters; do not contain user, real; or company names; do not contain complete dictionary words; and contain a combination of numeric, alphanumeric, and nonalphanumeric characters. In fact when you create the administrator account on a server that is running Windows Server 2003, a message box appears urging you to use a strong password, if you have chosen to leave the administrator password blank or have entered what is considered a "weak" password.

As with creating user accounts, each network operating system puts a slightly different spin on how you assign a password to a user account. It is typically configured in the same dialog box where you configure the user account. NetWare 6.5 allows you to view a user's properties in the ConsoleOne management tool. In the properties dialog box you can set the password for the user (see Figure 20.2).

Figure 20.2. Network operating systems such as Windows Server 2003 provide you with different options for assigning passwords to your users.

As you saw in Figure 20.1, Windows Server 2003 provides several options when you assign the initial password to the user, such as User Must Change Password at Next Logon and User Cannot Change Password. NetWare also gives you the option of allowing the user the ability to change their password if they wish. Using these various options as food for thought, let's discuss some different possibilities for ensuring that password protection remains a security asset on your network. Here are some general thoughts:

  • You can allow users to control their own passwords. Allowing users to create their own passwords can be particularly useful in situations where you have set an expiration time limit on passwords and require all users to change theirs. However, if you are going to put users in charge of their passwords, you need to educate them that using their first name or just the word password as their password probably isn't going to provide the level of security you are after.

  • You can completely take control of user passwords. You can assign passwords for your users that they can't change. If you have a lot of users, however, this is going to require a lot of work. This is especially true if you plan to have the passwords expire every so often. What's more, thinking that you can supply a devilishly complex password that no one will ever guess never seems to work, because users often will write down difficult-to-remember passwords on sticky notes and attach them on their computer monitors.

  • You can require that passwords be changed at a defined interval. It is definitely a good idea to have some sort of password-cycling strategy. Having passwords that never expire only gives people intent on breaking into your network plenty of time to guess the password that goes with a particular user account. Periodically changing passwords makes your network more of a moving target.

Caution

People who are intent on breaking into your network certainly aren't limited to imprecise techniques such as guessing usernames and passwords. In Chapter 19, "Network Troubleshooting," we discussed protocol sniffers that can be used by hackers to actually view network traffic. Being able to capture data packets means that information such as usernames and passwords can be also be learned because they are transmitted as text. Strategies involving encryption are used to make it more difficult to take captured information and use it to break into a network. We will discuss encryption later in the chapter.

In essence, you need to come up with some sort of plan for password assignment that is easy for you (the administrator) and your users to deal with and also provides some security for the network. Certainly how you assign passwords to your network users will be colored by the number of users and the importance of the resources on the network.

Other options related to user accounts can also help you build some security into the overall login process. Let's take a look at some of these options, such as logon hours and the user's ability to create more than one concurrent connection to the network.

Other User Account Options

As far as security is concerned, there are some additional measures you can take to keep unauthorized folks from accessing your network using your users' accounts. Although each NOS will provide different tools for configuring these options, nearly all the network operating systems provide you with the following options:

  • Logon hours. You can control when a user can log on to the network. For example, you may choose to allow the user access to the network from 9 to 5 on workdays (meaning during those times when you know the person is at work and needs to access the network). Weekend access or late-night access both could be denied. This would keep someone nasty from using the account to break into the network during non-business hours. Figure 20.3 shows the Windows 2000 Server Logon Hours dialog box, which is used to set the logon hours for a particular user.

Figure 20.3. You can limit the logon hours for users in a Windows 2000 network in the hopes of making the network more secure during non-working hours.

  • Concurrent connections. A single username and password can often be used to make concurrent (or simultaneous) connections to the network from different client computers. Limiting the number of concurrent connections can help negate the unauthorized use of a user account. If the user is already logged on to the network and you are only allowing one concurrent connection for that user, no unauthorized attempt can then be made to use that same user account to access the network. Figure 20.4 shows the Login Restrictions settings in the NetWare Administrator. Note that concurrent connections have been limited to one concurrent connection.

Figure 20.4. You can limit the number of concurrent connections to the NetWare network to minimize the possibility of unauthorized access.

  • Disabling user accounts. Another option available to the network administrator is the ability to disable a user account. Not only is this useful in cases where you think an account is being used to illegally access the network, but it is also useful in cases where a user has left the company and you know that the position will soon by filled by a new employee. Rather than creating an entirely new account for the new employee, you can change the name on the existing account so that the new employee will have the same access to network resources that were available to the employee who has left. This is because certain permissions have been made available to the account (permissions are discussed in the next section). If you look back at Figure 20.1, you will see that Windows supplies you with a check box that can be used to quickly disable a user account.

Tip

Microsoft Windows uses the term permission to define the different access levels given to a user for a particular network resource. In the Novell NetWare environment, permissions are known as rights (just different terms for the same resource security strategy).

Other options related to user accounts can be used to help secure your network. For example, you can specify the client computers that users can actually use to log on to the network. You might want to only allow users to log on to the network using their own PCs (which means local files stored on the computer are not at risk) or, if a user works throughout your corporate building, you might want to make it easy for him to check email by being able to log on to several different computers throughout the building.

You can also specify whether particular users can log on to the network through remote connections, such as a dial-up connection using a modem. We discussed remote access and dial-up connections in Chapter 17, "Networking on the Run."

How you use these various options to help secure your network should be part of the plan you create when you sit down to figure out how you will assign usernames and passwords. Having some sort of defined plan to work with allows you to be consistent as you build the accounts for your users.


Understanding Share Permissions

Once users have gained access to the network, they will need to access network resources. An important aspect of sharing information on the network is keeping highly sensitive or proprietary data secure while it is shared. This means some users will have access to the information and some won't. It also means that your users will have different levels of access to the data.

Note

Microsoft Windows networks running Windows 2000 Server or Windows Server 2003 also provide you with the ability to secure resources right down to the file level. This is because NTFS (NT File System) provides different access levels to files, folders, and drives. Because a folder on a Windows network can be both protected by share permissions (as we've discussed here) and NTFS permissions, figuring out the actual rights that a user has to a particular resource can become quite a brainteaser. For example, if a user is given full access to a folder due to the share permissions set on that folder, but is assigned an NTFS permission of no access, the user will not be able to access the folder. These two different permission systems combine so that the most restrictive access provided is realized by the user. For more detailed information regarding access permissions on a Windows network, check out Sams Teach Yourself Windows Server 2003 in 24 Hours.

Access level to shares on the network is handled by permissions. A permission is the access level for a resource that you assign to a user or group of users (we will talk about user groups later in the chapter). Because you can potentially assign a different permission level to each user for every resource on the network, you can really fine-tune the access security for important information on the network.

In the Windows network environment, when you create a new share, it is assigned the read-only permission for the Everyone group, which is a special administrative group that includes all the users in the Windows domain (more about groups in a moment). Figure 20.5 shows the default share permissions for a Windows server share.

Figure 20.5. On a Windows network, new shares are automatically made available to all users on the network as read-only.

This means that the network administrator has to determine whether the share's security setting needs to be changed to accommodate different users on the network. For example, read-only may work fine for a number of "basic" users, but other users may need to be able to edit the contents of the share in question.

As you can see in Figure 20.5, additional users or groups can be added to the Properties box of the share and then different permission levels can be set for that group or user, such as Full Control or Change. You will find that organizing users into groups and assigning permission levels to the group makes more sense than assigning permissions to each individual user. Group permissions are discussed in the next section.

The NetWare environment also provides administrators with the ability to assign different rights to users in relation to resources such as folders shared on the network. Users can be assigned rights, such as Read, Write, Create, Erase, and Modify, to the share. Figure 20.6 shows the NetWare Remote Manager tool, which can be used to specify the rights (or permissions) that a user will have to a resource such as a folder on the network.

Figure 20.6. Users in the NetWare environment are assigned different rights to a resource such as a network folder.

Once a user has been assigned permissions (or rights) to a particular resource on the network (such as a folder), those permissions will dictate how the user can interact with that resource. For example, if the user has only been assigned the Read permission for a folder on a server, he won't be able to add any files to that folder or delete items in that folder.


Using Groups to Provide Access Levels

If you have a large number of users on your network, assigning different permissions (or rights) to these users can be a gargantuan task. Network operating systems allow you to place users into groups. A group is a logical administrative container that holds a collection of user accounts.

Placing users into groups makes it much easer for you to assign permissions to your users. For example, if you have a shared folder where 20 users need to be able to add and delete files in the folder, you could place all these users in a group and then assign the appropriate permissions to that group. If another subset of your users only needs the Read permission for files in that shared folder, you could create a second group and assign the appropriate permission level.

Groups really become security containers that allow you to provide permission levels by group membership. For example, if a new employee joins your company and needs a certain access level to a resource, all you have to do is make him a member of the appropriate group.

Most network operating systems make it very easy for you to create groups and then assign these groups different permission levels related to network resources. For example, in the Windows network environment where a server is running Windows 2000 Server or Windows Server 2003, the network administrator uses the Active Directory to create new groups; the new groups are created as objects in the Active Directory. Figure 20.7 shows the New Object - Group dialog box accessed via the Active Directory Users and Computers snap-in.

Figure 20.7. New groups can be added to the Windows Active Directory.

Once the new group has been created, users can be added to the group. Assigning different access levels to the group is handled in the same way permissions or rights are assigned to individual users (as discussed in the previous section).

Keeping track of the permissions you have assigned to a few groups rather than a ton of users makes a great deal of sense. As with all the other aspects of building a network infrastructure, you should probably sit down and plan out how you will use groups in relation to resource access before you start banging away at the particular server utility that allows you to create groups.


Fighting Against Viruses

Another threat to your network's security is the virus. A virus is a self-replicating piece of software code. Because a virus can copy itself, it can easily (and unfortunately) be spread from computer to computer.

Viruses can be spread on floppy disks and other removable storage media. If you take an infected disk out of a computer and place it in another computer, you have spread the virus. Computers can also become infected with a virus that spreads over the network because of infected shares.

The Internet also serves as a source of virus infection. Viruses can inadvertently be downloaded from the Internet. Viruses can also be spread via email messages.

Interestingly, many viruses do little more than copy themselves; not all are designed to format your hard drive or corrupt a certain file type. A lot of the viruses you run into are just elaborate jokes (although this does not make them any less annoying).

One of the first viruses I remember dealing with, back in my college days, was the Brain virus. Brain was (and still is) a boot sector virus that can load itself into the computer's memory (we will discuss the different types of viruses in a moment). Well, to make a long story short, Brain quickly spread to nearly every floppy disk being used on the college campus (this is in the days of 360KB, 5 1/4'' floppy disks). However, it was very easy to find the infected disks because the virus would change the volume name on the floppies to BRAIN. The virus really didn't do much more damage than that.

Although everyone fears viruses, many viruses don't do a whole lot more than replicate and spread. However, as the network administrator, it is your job to destroy viruses with impunity, whether they are just jokes or are designed to wreak havoc on your network data.

Note

Educating your users about the importance of network resources and providing some training to your users on how to use the network should also negate some of the network implosions you face as a network administrator. If you have a problem user account, you can also audit logon attempts by the user if you suspect the account is being used to access the network by someone other than the user. Auditing user logon attempts can be monitored in all of the different NOS environments. In Windows Server 2003, logon auditing is turned on using a security feature called Group Policy. Once auditing is enabled, unsuccessful logon attempts for your various users are compiled in the Event Viewer (discussed in Chapter 19).

Now, I don't want to understate the fact that viruses can do a lot of damage to a computer system. Viruses can delete programs and files, and they can completely overwrite a hard disk. Viruses can be backed up along with the files that you routinely back up on the network (say, from a file server). This means that in the case of a disaster, you only have infected data files to restore to your file server.

Viruses can even find the administrator's password and pass it on to someone outside the network. This person can then log on to the network as the administrator and do all sorts of damage. So, although many viruses are just annoying and take time and money to clean up, some viruses can pose a very large security risk to the network.

Note

Although many viruses are actually executable programs that, when launched, replicate and damage your computer system, there are other types of viruses (such as macro viruses) that can hide in a document or spreadsheet rather than an executable file. If you open the file containing the virus, you infect your computer system.

Types of Viruses

A number of different virus types have evolved over the years. These different types of viruses have been classified based on how they infect a computer:

  • Boot sector viruses. Some of the first viruses were boot sector viruses. A boot sector virus typically spreads through infected floppy disks or other removable storage media. Boot sector virus infections are helped along by user forgetfulness. If I place a boot sector virus-infected disk in my computer, nothing will happen unless I reboot the system (meaning turning it off for the day and then turning it on the next morning) and have forgotten to remove the infected disk from the floppy drive. On boot up, the boot sector virus is loaded into the computer's memory (because the computer will try to boot from the floppy). The virus can then infect the hard drive or any disks you place in the floppy drive once the computer is up and running. The Brain virus, discussed earlier, and the Exebug virus are both examples of boot sector viruses.

Note

"Hip" computer terminology seems to propagate faster than a computer virus. Viruses, worms, and other types of software designed to mess up your computer (and everyone's computer, for that matter) are often called malware (malicious software).

  • File viruses. Although fairly uncommon now, file viruses actually infect an executable file such as an EXE or COM file (and you know that your operating system is made up of a bunch of executable files). When the infected file is run, the file virus is loaded into the computer's RAM. It can then infect other executable files as they are run on the computer. One form of the file virus is the overwriting virus, which actually overwrites the executable file that it infects. Another form of the file virus is the companion virus. This virus will masquerade as a COM file with the same name as an EXE file on your system. When you run the program, the macro will run first because COM files take precedence over EXE files. The virus will do its thing and then the actual EXE program will run. This means you may not notice that the virus is actually on your system. Examples of file viruses are the Dark Avenger virus and the KMIT virus.

  • Macro viruses. The macro virus is a fairly recent virus type. Macro viruses are typically written in Visual Basic code and can infect documents and spreadsheet data files rather than executables. When an infected document is loaded into an application such as Microsoft Word, the virus code runs just like any other macro would in that particular application. Another scary thing about macro viruses is that they are not operating system-specific. Because Microsoft Excel can run on a Macintosh and a Windows-based PC, the macro virus can actually be spread between the two platforms if the infected Excel worksheet is shared. Macro viruses are also not confined to Microsoft applications and have popped up in other office suites, such as Lotus SmartSuite. An example of a macro virus is the famous Melissa virus, a Word macro virus that automatically spread itself via email.

  • Multipartite viruses. A multipartite virus has the characteristics of both a boot sector virus and a file virus. It can spread from the boot sector of a drive to another drive, and it can also attack executable files on the computer. Some multipartite viruses can even infect device drivers (such as the drivers for your network interface card). An example of a multipartite virus is Pastika. This virus is only activated on certain days of the month (typically the 20st and 22nd of the month) and can actually overwrite your hard drive.

The actual number of viruses "in the wild" (meaning those found on business computers and networks) at any one time varies, but in general the number is increasing. The number of macro viruses is definitely on the rise. At the time of the writing of this book, the PE_LOVGATE.J virus was a medium threat to PCs running Windows and spread via shared network drives and email. Another example of recent malware is the WORM_KWBOT.C worm that can cause file damage to PCs running Windows. Let's take a look at worms and Trojan horses and how they can threaten your network's security and resources, and then we can take a look at some strategies for protecting against virus infections.

Worms and Trojan Horses

Not all software-based threats to the network come in the form of viruses. There are also two other wonderful products from those demented folks who brought us computer viruses—worms and Trojan Horses.

A worm is a program that spreads itself from computer to computer on a network. It doesn't need to be activated like a virus. It just spreads all by itself. A worm can be potentially devastating on a worldwide network such as the Internet because it can quickly spread itself throughout the entire network. Worms typically are platform-specific and exploit some weakness in a particular operating system. For example, the Linux.Ramen worm only spreads itself among computers running Linux Red Hat.

A Trojan horse (or just Trojan as it is often referred to), on the other hand, is a program that appears to be perfectly benign, such as a screensaver or a game. For example, the HAPPY99.EXE Trojan horse, when executed, provides a nice little fireworks display on your screen and then immediately uses mail addresses found in your computer's email client to send off copies of itself to these addresses (this is similar to how the Melissa virus is spread).

One of the earliest Trojans was the AIDS Information Disk Trojan, which was actually a disk sent out to medical establishments as an AIDS-awareness product. After being executed, it created a hidden directory on the computer's hard drive and eventually encrypted the entire contents of the hard drive, making it unusable.

One of the biggest threats related to Trojans is that some are actually able to invade a computer and create a portal that allows complete access to the infected machine. This means that the cracker who controls the Trojan actually can do anything he likes with your computer. He can even use it to perpetrate a denial of service attack using your computer to help generate excess traffic that is focused on a particular Web site. Denial of service attacks are discussed later in the chapter, in the section "Protecting a Network from Outside Attack."

Tip

For a great site containing information on viruses currently found in the wild, check out http://www.f-secure.com/. F-Secure, who hosts this site, provides a range of network security products. Another good place to look for information related to viruses is the SANS institute. The SANS, at http://www.sans.org/, provides information on viruses and other network security issues.

Virus Protection

Protecting a network against viruses, Trojans, and worms really requires two major efforts on the part of the network administrator. First, you need to have some sort of virus protection plan. Then, once the plan has been created, it can be implemented.

Any anti-malware plan should include a list of rules that your users need to follow to keep the network safe from virus infection. These rules might include no disks from home and no personal email on the company's email system. Also, you might have to forbid file downloads from the Internet.

Although these rules might seem a little harsh, many companies have even more draconian behavior guidelines for their computer users. What's more, many companies have very harsh punishments for employees who don't follow the rules, including dismissal (which is probably because giving an employee a good flogging just isn't an option anymore). What a user does on his home computer is his business. But when you have users on a network, where the very lifeblood of the company is the data stored on the network, you really have to lay down the law as far as the rules for network computer use.

You also need to educate your users and provide them with a general overview of what a virus is and what it can do to the network. If users worldwide would have been a little more savvy, the Melissa virus might not have been able to spread so quickly across the entire globe. Although educating your users about the threat of viruses might lead to some employees crying wolf every time their computers slow down a little, having an aware user base might help to nip virus infections in the bud before they become a huge problem.

Your plan also needs to include the installation and maintenance of virus protection software. There are a number of companies that provide antivirus software: Symantec, McAfee, Norton, and Dr. Solomon's, just to name a few.

Antivirus software can be configured to protect client computers and network servers from infection. Most antivirus software can be configured so that a disk placed in a floppy drive is checked for viruses the moment a user slides it into the drive.

Tip

Because many antivirus companies provide their software in trial and shareware versions, you should test the different possibilities to make sure they will work for your particular network implementation. Setting up a test lab before implementing any type of new software is a good idea.

Antivirus software can come in a standalone version that must be installed on every computer or in a network version that runs whenever a computer boots up to the network. Some software companies that sell antivirus software also provide Web-based antivirus applications that check a computer for viruses. Figure 20.8 shows Norton Antivirus checking a computer for viruses.

Figure 20.8. Antivirus software checks a computer's drives and memory for virus infections.

Because new viruses and other malware are popping up all the time, your antivirus software has to be able to deal with the latest and greatest virus threat. This is done by downloading updates that allow the antivirus software to recognize new viruses and repair the damage they have done. Periodically checking for virus updates to your antivirus software should be part of your overall antivirus plan.

Note

Viruses seem to pop up almost as fast as new computing platforms. Even handheld computers, such as those running the Palm OS, are not free from possible computer virus infection. A number of antivirus software manufacturers, including Computer Associates, now offer antivirus software for the Palm OS. For more about handheld computers, see Chapter 17, "Networking on the Run."


Protecting a Network from Outside Attack

Another security risk for your network involves direct attack. Connecting your network to the Internet provides a nice wide conduit for folks who want to try to crack your network security and gain access to valuable network resources.

Direct network attacks can take different forms, and many of them are possible because of the way the TCP/IP protocol stack operates. Each protocol in the TCP/IP stack communicates on a particular channel, called a well-known port number (port numbers are discussed in Chapter 12, "TCP/IP Network Administration"). For example, HTTP operates on port 80, and FTP operates on port 21. There are, in fact, more than 1,000 well-known port numbers, and each of these ports is a potential path for an attack on your network. Firewalls provide a strategy for blocking these ports, and we will discuss firewalls later in the chapter.

Another way that direct attacks are engineered involves important information such as login names and passwords being discerned by a cracker using snooping software such as protocol sniffers, which are discussed in Chapter 19. A cracker can sit outside your network on the Internet and intercept data transmissions that can provide enough information for a direct attack on the internal network.

Note

All the ins and outs of network security, particularly those associated with outside attacks, could fill an entire book—and have actually filled a number of books. Companies lose a lot of money and time dealing with network attacks, both on the intranet (the private network) and on the Internet. For some big-picture information on network security, check out The Concise Guide to Enterprise Internetworking and Security, published by Que.

A number of different kinds of attacks can be made on an IP network. A brief description of each follows:

  • Eavesdropping. Also known as sniffing or snooping, eavesdropping is the ability to monitor network traffic because it is in an unsecured format. The eavesdropper basically listens in using some kind of network-monitoring software.

  • Password attacks. These attacks are typically a result of eavesdropping. Once a snooper is able to find a valid account (because this information is not always protected on the internal network), the attacker is able to gain access to the network and discern information such as valid users, computer names, and resource locations. This can lead to the modification, deletion, or rerouting of network data.

  • IP address spoofing. An attacker is able to assume a legal IP address and gain access to the network.

  • Man-in-the-middle attacks. The attacker is able to monitor, capture, and control data between the sending and receiving devices.

  • Denial-of-service attacks. The attacker gains access to the network and then sends invalid data to network services and applications, which causes these network services to operate erratically or to terminate. This type of attack can also materialize as a flood of data directed at a particular service or computer, which results in overload and shutdown. This type of attack has been used repeatedly to take down Web sites on the Internet.

Network administrators use all sorts of strategies to prevent these types of attacks. Secure routers provide one way to protect the internal network, and so do firewalls (discussed in the next section). Another method involves implementing Internet Protocol Security (IPSec), which is a suite of cryptography-based protection services and security protocols that can be used to secure internal networks, networks that use WAN solutions for connectivity, and networks that take advantage of remote access solutions (such as Virtual Private Networking, which we discuss in Chapter 17).

Note

IPSec uses all sorts of protection methods to secure network data. Cryptography is the coding or encrypting of data into an unreadable format. IPSec can also use certificates to protect data, where the data can only be read by a receiver with the appropriate certificate credentials. Obviously, implementing IPSec requires a very good understanding of the TCP/IP protocol stack and IPSec itself. For information on IPSec in relation to Windows Server 2003, check out Sams Teach Yourself Windows Server 2003 in 24 Hours.

Securing a network of any size will probably require more than one strategy. This means you need to create a security plan for your network. Once you have a plan, you can implement it with the appropriate hardware or software security tools. Network security is certainly a very hot topic and a very important aspect of any network administrator's job. Securing a network isn't easy, however. Even the big boys, such as Yahoo! and Microsoft, get hammered occasionally by network attacks. Let's end our discussion of network security on a high point with the discussion of a truly marvelous invention: the firewall.


Understanding Firewalls

Firewalls are designed to sit between your network and the Internet and protect the internal network from outside attack. A firewall will examine data leaving and entering the internal network and can actually filter the data traveling in both directions. If data packets do not meet a particular rule that has been configured, the data is not allowed to enter the internal network or leave the internal network. This means that firewalls not only protect a network from outside attack, but they can also control the type of connections made by users on the internal network to the outside (meaning that employees can be restricted from connecting to certain Web sites).

Firewalls are typically a combination of hardware and software, and they really don't look that much different from other connectivity hardware, such as hubs and routers. Firewalls are manufactured by a number of companies, including Cisco, 3Com, and Ascend Communications. Firewalls come in a variety of models that have been designed to protect different size networks. For example, 3Com manufactures the OfficeConnect firewall line as a security tool for small companies. For larger enterprise networks, 3Com offers the SuperStack 3 firewall. The SuperStack 3 firewall is designed to control large numbers of VPN connections (we discuss VPN, or Virtual Private Networking, in Chapter 17). This firewall also provides support for IPSec.

Software-only firewalls do exist. For example, a very popular personal software firewall is ZoneAlarm. Figure 20.9 shows a ZoneAlarm window and an alert that a computer attempted to connect to my computer using port 1026 (scary isn't it?).

Figure 20.9. Software firewalls can protect computers with a persistent connection to the Internet.

The software-only firewalls are primarily designed for personal use to protect a PC that has a persistent connection to the Internet through a DSL line or a cable modem. Windows XP actually includes a basic software firewall that you can use to protect your computer from attacks over the Internet.

I think that you will agree that Figure 20.9 helps make a fairly compelling argument that firewalls are an important addition to network security. I briefly mentioned in the previous section that TCP/IP ports provide avenues used by hackers to break into networks and computers. Now, depending on the size of your business and company network, you may think, "Why would anyone waste his time trying to break into my network?" But thinking that crackers only go after big networks such as Microsoft and the Department of Defense is a very wrong assumption.

I'm not sure why anyone would waste his time trying to crack into networks, but there are a lot of people out there who do try to crack into networks and even personal computers connected to the Internet. Figure 20.9 provides fairly convincing evidence that even the lone PC may be in danger of attack.

Plenty of people out there are looking for computers and networks they can probe and then connect to. As a sort of hands-on epiphany of your own related to the importance of firewalls, check out https://grc.com/default.htm. This site is maintained by Gibson Research Corporation and provides a link to a special site that it has created called Shields Up. The Shields Up site shows how vulnerable computers running the Windows operating system are to outside attack.

Make sure you click the link for Shields Up on the GRC home page. If you are not running a personal firewall on the computer, you will be surprised to find that the Shields Up Web site will greet you using the NetBIOS name of your computer. To make things even more scary, scroll down on the Shields Up page and click the Test My Shields button.

When I ran the shield test on a Windows computer configured for file and print sharing, the output screen from the shield test provided a list of all the folders and printers being shared on the computer. When I ran the probe port test, which is also accessed from the Shields Up page, a number of ports, such as HTTP, Telnet, and NetBIOS, were also shown to be wide open.

Caution

When you set up a computer connected to the Internet with a firewall such as ZoneAlarm (for more about ZoneAlarm, a really great personal firewall, see http://www.zonealarm.com/), some of the alerts that you receive will be probes and attempted connections from your service provider. So, not every connection attempt is a "bad guy."

Then I installed ZoneAlarm on the computer and reran the tests. The shield test showed that the computer was now operating in "stealth" mode and no information about the computer, such as the NetBIOS name and shared resources, was available. When I ran the port probe test, all the ports had been closed to the outside by the firewall. Figure 20.10 provides the results of the port probe. All ports are now unavailable as a potential route for someone trying to access data on the computer over the Internet.

Figure 20.10. Firewalls protect TCP/IP ports.

So, firewalls really do work. Let's take a look at the different types of firewalls available for protecting corporate networks.


Types of Firewalls

Firewalls are categorized as different types based on how they deal with network traffic and the layer of the OSI model at which they operate (if you need a refresher on the OSI model, take a look back at Chapter 5, "Network Protocols: Real and Imagined"). The higher the layer of the OSI model at which the firewall operates, the more sophisticated the firewall. Here are some specifics:

  • Packet filter firewall. This type of firewall uses a set of rules to determine whether outgoing or incoming data packets are allowed to pass through the firewall. The rules or filters designed to control the data traffic allowed by the firewall can be based on the IP address of the sending device and the particular port being used by the protocol that originated the data packet. A packet filter firewall moves data quickly and is the simplest type of firewall. It operates at the Data Link and Network layers of the OSI model. A router that uses access lists (rules for allowing or disallowing connections based on IP addresses) to filter data traffic can be considered a packet filter firewall.

  • Circuit-level firewall. This type of firewall is similar to the packet filter firewall (in that it filters packets based on a set of rules), but because circuit-level firewalls operate at the Transport layer of the OSI model, they have greater functionality. A circuit-level firewall can make packets sent from the internal network to a destination outside the firewall appear as if they originated at the firewall. This helps to keep information relating to hosts on the internal network secret. Circuit-level firewalls also can determine whether a connection between a network host and a computer on the other side of the firewall using the TCP protocol has been established appropriately (see Chapter 5 for more about TCP). If the connection has not been established appropriately, the firewall can terminate the connection. This cuts off any connection that has been hijacked by an outside attacker trying to sneak past the firewall.

  • Application-gateway firewall. This type of firewall operates at the Application layer of the OSI model. Application gateways use strong user authentication to verify the identify of a host attempting to connect to the network using a particular TCP/IP Application layer protocol such as Telnet or FTP. This type of firewall can also actually control the devices that an external host can connect to once the firewall has authenticated that particular user. Application gateways are even effective against IP spoofing (discussed earlier in the chapter) because they do not allow the connection to proceed inside the firewall unless the user can truly be authenticated to the network.

Note

Many firewalls also have proxy server capabilities and use Network Address Translation (NAT) to protect the internal network. For more about proxy servers and NAT, take a look back at Chapter 15, "Connecting a Network to the Internet."

You will find that some firewall products are actually a hybrid of the types of firewalls discussed here. For example, a firewall might combine circuit-level capabilities with application-gateway services.

The deployment of firewalls and the development of new firewall products are both proceeding at seemingly breakneck speed. Major news stories on the cracking of big corporate and government networks have only lead to a rise in the purchasing of firewalls and the manufacturing of more secure firewall products.

You will find that most of the network operating systems available also provide some sort of firewall protection. This includes NetWare, Linux, and Windows Server 2003.


A Final Word on Network Security

Securing a network and its resources is certainly the greatest challenge a network administrator faces. Even office politics can seem like a stroll in the park compared to the scramble that takes place when the internal network security has been breached by someone with mischief in mind.

Although this chapter certainly is not intended as the ultimate treatise on network security, I hope that you take a couple things away with you after reading it. First, assess the possible security risks to your network. Second, develop a security plan.

Every network needs a security plan that catalogs the possible threats to the network and the measures you plan to take to negate these threats. If the biggest problem on your network is users messing up important files, your security plan needs to lean toward user education. If you have highly sensitive data on your network, such as the cure for the common cold, your network may face attacks from employees bent on stealing corporate secrets and crackers on the outside who want to break into the network and steal your valuable data. This means you need to come up with a security strategy that can fight against internal and external attacks.

So, take my word for it: You need a security plan. Having a plan also makes it easier to justify the purchase of expensive pieces of equipment such as firewalls.

The Absolute Minimum

In this chapter we took a look at how you secure your network and its resources. We discussed issues related to users and groups. We also looked at threats to your network, including viruses and other malware.

  • The first line of defense for network security is user authentication. Users cannot access the network without a valid username and password.

  • User account options such as logon hours allowed and the number of connections allowed for an account can be used to increase network security.

  • Share permissions or rights are used to supply different levels of access to users in relation to a particular resource on the network. User groups can be created on the network and then assigned permissions for various network resources.

  • A virus is malicious program code that can replicate and spread from computer to computer on the network. A worm is malware that spreads itself from computer to computer without activation by a user (which differs from a virus). A Trojan is malware masquerading as a regular software program, such as a game or screensaver.

  • A number of different types of attacks can be launched from outside a network connected to the Internet. These attacks include eavesdropping and IP spoofing.

  • IPSec, a suite of IP security protocols that provide encryption and authentication methods, has been developed to help negate malicious attacks on IP networks.

  • Firewalls are hardware and software devices that can control the flow of data packets between an internal network and an external network such as the Internet.


Glossary

access permission

The level of access or the rights assigned to a user in relation to a particular resource on a network.

access protocol

A protocol that is used to move network data across a WAN connection. Access protocols provide the encapsulation that creates the virtual tunnel.

See also [tunneling]

access time

Measured in milliseconds, access time is the time it takes a drive to access data. The lower the access time, the faster the drive. For example, an 11-millisecond drive would be faster than a 28-millisecond drive.

Active Directory

This name refers to both the hierarchical tree structure provided in the Windows 2000 network environment and the utility used to manage users, computers, and other devices such as printers in the Windows 2000 network environment.

alert

An alarm or notification you can configure on the Windows Server Performance Monitor that alerts you when a particular threshold for a process, such as hard drive usage, has been reached.

American Registry for Internet Numbers (ARIN)

The central registry for IP addresses used in a number of countries. ARIN is a not-for-profit organization established to register (and administer) IP addresses for North America, South America, the Caribbean, and sub-Sahara Africa.

American Standard Code for Information Interchange (ASCII)

The basic character set used by most computer operating systems.

Anonymous FTP site

An FTP site that allows anonymous logons. FTP typically requires a logon name and password.

See also [File Transfer Protocol (FTP)]

AppleTalk

The built-in networking language (protocol stack) used by the Apple Macintosh OS.

Application layer (DoD)

This layer in the DoD stack is equivalent to the OSI Application, Presentation, and Session layers. This layer provides the user interface for the various protocols and applications that access the network, and it handles file transfer, remote login to other nodes, email functionality, and network monitoring. It also sets up the session between communicating nodes and manages the transport of data between them.

Application layer (OSI Model)

The top and seventh layer of the OSI conceptual model. This layer provides the user interface and services such as message handling and file transfer on the network.

ARPAnet

A internetwork developed by the U.S. government and various universities that provided a redundant, packet-switching infrastructure for the movement of data across wide geographical areas.

asynchronous modem

A device designed to move data over a regular analog voice-grade telephone line.

See also [modem]

Asynchronous Transfer Mode (ATM)

A high-speed packet-switching WAN technology used on optical networks. ATM is typically deployed on high-speed backbones such as SONET.

See also [Synchronous Optical Network/Synchronous Digital Hierarchy (SONET)]

attenuation

The degradation of the data signal over a run of cable or other medium.

Automatic Private IP Addressing (APIPA)

The ability of computers running Windows 2000, Me, or XP to automatically assign themselves an IP address when they cannot find a DHCP server on the network.

B channel

The data-carrying channels on an ISDN connection. Basic Rate ISDN uses three channels. Two data-carrying channels, called B channels, each provide 64Kbps of bandwidth for data transfer. The third channel, the D channel, is not used for data transfer. Instead, operating at 16Kbps, the D channel is used exclusively for setup and control information used during the communication session.

See also [ISDN]

backup domain controller

An additional server computer used on a Microsoft domain to provide some help to the domain controller with logging on and authenticating network users.

bandwidth

The data pipe or conduit provided by a particular network architecture. Bandwidth is the amount of data that can ultimately be pushed along the network medium under ideal conditions.

baseband

Data that flows in a single bit stream. Ethernet, token ring, and other LAN technologies use baseband transmissions.

baseline

A set of initial performance readings taken on a server or a network and then used for later comparison.

Basic Rate ISDN (BRI)

A form of ISDN that provides two B channels for the movement of data over regular phone lines.

See also [ISDN]
See also [B channel]

baud

The oscillation of a sound wave on which one bit of data is carried. Baud was once used as a way to classify modem speeds; it has now been replaced by bits per second.

See also [bits per second (bps)]

bit

The smallest unit of data found on a computer; bits are represented by either a one (1) or a zero (0).

bits per second (bps)

The number of bits moved per second by a device such as a modem. Modems and other devices are typically classified by bps.

boot loader

System code that allows a particular operating system to be booted when a computer is turned on. Each OS has a boot loader. Microsoft has its own boot loader software, and other platforms such as Linux have boot loaders such as LILO and GRUB.

boot sector virus

A virus that is typically spread to a system when an infected disk is left in the floppy drive when a user boots up a computer. The virus then replicates to the boot sector of the computer's hard drive.

bottleneck

A hardware component on a server, such as the processor or the memory, that is being overtaxed and is slowing down overall system performance.

bridge

An internetworking device used to segment networks that have grown to a point where the amount of data traffic on the network media is slowing the overall transfer of information. Bridges use MAC addresses to keep local data traffic on each segment of the network.

See also [MAC address]

broadband

Data transmission where a single line can carry multiple transmissions on different channels.

bus topology

A LAN topology where computers are connected at intervals to a main trunk line or network backbone. Bus topologies typically use a passive network architecture, where the computers on a bus just sit and listen. When they "hear" data on the wire that belongs to them, they accept that data.

cell

A 53-byte packet used by ATM to move data, such as voice and video, across public networks (such as the POTS) and private wide area networks.

See also [Asynchronous Transfer Mode (ATM)]

central office (CO)

The nearest POTS switching station to a company or institution.

channel

One carrier unit on a T-Carrier line. Each channel can provide up to 64Kbps of throughput, and channels can be combined to provide greater amounts of bandwidth.

See also [T-Carrier system]
See also [multiplexer (MUX)]

Channel Service Unit/Digital Service Unit (CSU/DSU)

A piece of equipment that sits between a LAN multiplexer and the network's connection to the local loop. It provides for the timing of the data transfer.

See also [local loop]
See also [customer premise equipment (CPE)]

circuit

The virtual path created for a communication session on a circuit-switching network.

See also [circuit switching]

circuit switching

Establishes a circuit during the communication session between the sender and receiver. This means that, temporarily, the lines are dedicated to that communication session. Then, when the session is over, the circuit is immediately "torn down" and becomes available for another communication session. ISDN is an example of circuit switching.

See also [ISDN]

Class A

A category of IP addresses used for very large networks. A Class A network provides more than 16 million node addresses.

Class B

A category of IP addresses used for large- and medium-size companies and institutions. There are 16,384 Class B network addresses available, with each Class B network supplying more than 65,000 host addresses.

Class C

A category of IP addresses used for small networks. There are more than 2 million Class C network addresses available. Class C networks only provide 254 node addresses, however.

client

A computer on a network that accesses resources provided by server computers.

connection-oriented transport

A protocol operating at the Transport layer of the OSI model that uses a system of acknowledgements to ensure data delivery and defines a static route on the network so that packets are delivered along the same route during the session. This is considered a reliable connection.

connectionless transport

A protocol operating at the Transport layer of the OSI model that does not use acknowledgements or a defined route on a network to move data from one node to another. Connectionless protocols do not require the network resources that a connection-oriented protocol does, but connectionless transport is considered an unreliable method of data delivery.

counters

The real-time graphs added to the Windows Performance Monitor. Graphs are used to monitor the performance of an object.

See also [object]
See also [Performance Monitor]

crackers

Another term for a criminal hacker; renegade computer users who attack computer systems and networks. Their arsenal includes viruses and a variety of attack strategies, such as denial-of-service attacks and IP spoofing.

crossover cable

A twisted-pair cable that has been configured to allow the direct connection of two computers that are outfitted with Ethernet NICs.

crosstalk

Interference passed between two closely located data wires.

CSMA/CA

Carrier Sense Multiple Access with Collision Avoidance. A network access strategy used by AppleTalk. A device that is ready to send data out onto the network will notify the other network nodes of its intention to place data on the network.

CSMA/CD

Carrier Sense Multiple Access with Collision Detection. A network access strategy used by Ethernet networks. If a node sending data detects that there has been a collision, it will wait to resend the data until the line is determined to be free of other data.

customer premise equipment (CPE)

The LAN devices and the telephone system inside a company or an institution.

cyclic redundancy check (CRC)

A mathematical calculation that is included in the trailer of a data frame. The CRC is calculated on both the sending and receiving computer. If the CRC checks are in agreement, the data contained in the frame is considered to be intact.

data bus

The parallel collection of wires provided by a motherboard for the movement of data between devices on the motherboard and the computer's processor.

data frame

Data packets moving down the OSI model are encapsulated by particular network architecture, such as Ethernet or token ring, into a frame. The frame makes the data packet compatible with the network architecture's media-access strategy.

Data Link Control protocol (DLC)

A mainframe communication protocol that is also used to allow computers on a network to communicate with printers directly connected to a network using devices such as an HP DirectJet box or HP DirectJet card.

Data Link layer (OSI model)

Responsible for the movement of data across the actual physical link between computers. It is also responsible for assuring that the data is received error free.

database engine

The software on a database server that accepts requests for information from clients on the network.

de-encapsulation

The process of moving raw data received by a node up the OSI stack into a format that can be accessed by a network user using a particular application.

default gateway

On IP networks that have been divided up into subnets, the default gateway is the router that provides the connection for a subnet to access the rest of the network.

demarcation

The place where the CPE ends and the phone company's equipment begins.

demodulation

The conversion of data from analog to digital. This data-conversion process is provided by a modem.

Department of Defense (DoD) model

A network communications conceptual model that was developed by the Department of Defense in the infancy of the Internet. The DoD model has four layers: Application layer, Host-to-Host layer, Internet layer, and Network Access layer.

differential backup

This type of backup only backs up the files that have changed since the last backup. The differential backup does not, however, change the marker attribute, which indicates that the file has been backed up.

DHCP server

A server that uses the Dynamic Host Configuration Protocol to dynamically assign IP addresses, subnet masks, and other TCP/IP configuration settings to computers that are configured as DHCP clients.

Digital Data Service (DDS)

Digital lines supplied by the POTS or other service provider that are used for data transfer. DDS lines include the T-Carrier system.

See also [T-Carrier system]

Digital Subscriber Line (DSL)

One of the newest technologies for data transfer over the POTS, the DSL technology allows for digital communication over existing phone lines.

Digital Subscriber Line Access Multiplexer (DSLAM)

A device located at a provider's central office that receives signals from multiple customer Digital Subscriber Line connections and puts these signals on a high-speed backbone using multiplexing techniques.

See also [Digital Subscriber Line (DSL)]
See also [multiplexer (MUX)]

direct connect printer

A printer that contains its own network interface, processor, and memory for print serving. Such printers are typically attached directly to a network hub using twisted-pair cable.

disaster recovery plan

The document that provides the blueprint for the activities that must take place for your company to resume doing business after a disaster strikes.

disk duplexing

Disk mirroring where separate drive controllers are used on drives in a mirror set.

See also [Redundant Array of Inexpensive Disks (RAID)]
See also [disk mirroring (RAID 1)]

disk mirroring (RAID 1)

This type of RAID is used to create an exact duplicate of a drive or drive partition. If the main drive fails, the mirror-image drive can be used to keep the server running.

See also [Redundant Array of Inexpensive Disks (RAID)]

DNS domain

A friendly name assigned to a company or institution that has a presence on the Internet. Domain names must be leased by an organization for use on the Internet.

DNS server

A server that resolves friendly domain names (URLs) to IP addresses (and vice versa). There are seven core DNS servers on the Internet.

domain

The basic structure or administrative unit for Microsoft networks running the Windows NT, 2000, and XP network operating systems. Each domain is managed by a server called the domain controller.

See also [DNS domain]
See also [domain controller]

domain controller

The server on a Microsoft network domain that maintains the database of user accounts. The domain controller can also offer network resources, such as printers and shared files.

domain name space

The actual structure or scheme used for DNS names. The domain name space is basically an upside-down tree in which the different domains branch out from a central branch or root.

Domain Name System

(DNS) The hierarchical, friendly naming system devised for the Internet. DNS servers are used to resolve these friendly DNS names to actual IP addresses.

dotted decimal

The format used to display IP addresses. This format consists of four decimal octets separated by periods.

dumb terminal

A keyboard and a monitor that are hardwired directly to a mainframe or miniframe computer allowing end-user access to the computer's resources.

electronic mail (email)

A network service that allows users to send and receive messages.

encapsulation

The process of moving user data down the OSI stack on a sending node through a number of intermediary formats.

eDirectory

The newest logical, hierarchical structure for NetWare networks, which is used to define and hold objects such as Network trees, servers, users, and groups.

enterprise network

The network infrastructure for a large company or institution that consists of multiple sites across a geographical area, a country, or even the world.

Event Viewer

A utility available on a Microsoft server that allows you to view different event logs related to the server's system and security. This utility is useful in determining whether drivers for devices such as an NIC have loaded correctly on the server.

Fast Ethernet

So named because of its "faster" throughput speed (when compared to the original 10Mbps flavor of Ethernet), Fast Ethernet provides a bandwidth of 100Mbps.

FAT

Stands for File Allocation Table. It is the file system originally developed for use in the DOS environment. It uses a file allocation table to store the name and location of files that have been saved to a disk. The original version of FAT is referred to as FAT16. A newer version of FAT called FAT32 was developed by Microsoft to provide support for larger drive sizes.

fault tolerance

The ability for a hardware system or software to recover from errors or physical problems. Fault tolerance on networks is increased by strategies such as server backups, RAID arrays, and antivirus software.

fdisk

A utility that exists as a separate entity in both the DOS and Linux environments. It is a tool that is used to partition hard drives.

Fiber Distributed Data Interface (FDDI)

A network architecture that provides high-speed network backbones that can be used to connect and extend the range of LANs.

file sharing

The ability of an NOS or OS to allow network users to connect to files or resources on a server or peer computer on the network. A number of operating systems and all the network operating systems provide strategies for sharing file and drive resources on peer-to-peer and server-based networks.

File Transfer Protocol (FTP)

A member of the TCP/IP protocol stack used to send and receive data between computers on the Internet or an intranet.

file virus

A virus that infects an executable file, such as an EXE or COM file.

firewall

A device designed to sit between your network and the Internet that protects the internal network from outside attack. A firewall will examine data leaving and entering the internal network and can actually filter the data traveling in both directions.

forward lookup zones

Records held on a DNS server that are used to resolve friendly names to IP addresses.

See also [DNS server]

fractional-T connection

A connection that uses a portion of the channels provided by a full T-Carrier line.

See also [T-Carrier system]

FTP server

A server that provides FTP services to network clients.

See also [File Transfer Protocol (FTP)]

full backup

This type of backup can also be called a normal backup or daily backup (depending on the backup software you are using). A full backup takes all the files you select for backup and backs them up (no matter how the files are currently marked).

full-duplex

Allows communication between a sending and a receiving device in both directions simultaneously.

fully qualified domain name (FQDN)

The complete DNS name for a computer on a TCP/IP network. An FQDN will include the Internet domain name and the name of the computer.

gateway

A computer or other device that uses software as a communication bridge between incompatible platforms or network architectures.

Gigabit Ethernet

Uses the same IEEE Ethernet specifications and the same data format as other versions of Ethernet. Gigabit Ethernet provides a data transmission speed of 1,000Mbps.

GNOME (GNU Network Object Model Environment)

A Graphical User Interface for Linux systems that provides a Windows-like desktop environment.

group

A logical administrative container that holds a collection of user accounts.

groupware

A suite of client communication software that is used to communicate with a communication server package.

GRUB

(GRand Unified Bootloader) A boot loader used on Linux systems.

See also [boot loader]

hacker

An extremely knowledgeable computer aficionado. A criminal hacker would also be described as a cracker.

See also [crackers]

half-duplex

Transmission of data can take place in two directions between a sending and a receiving device, but with half-duplex, data can only be transmitted in one direction at a time.

handshake

An electronic communication agreement between two computers exchanging data over a network.

hardware sharing

The ability to share hardware devices such as printers, CD-ROM drives, and hard drives on the network. The ability to share peripherals is built in to many operating systems. Network operating systems also provide the ability for a server to share hardware devices.

hop

Designates the number of routers that packets pass through on an internetwork as they move from source to destination. Each hop would be one router.

Host-to-Host layer (DoD)

Equivalent to the OSI Transport layer, this layer provides flow control and connection reliability as data moves from a sending to a receiving computer. This layer takes the data from the Application layer protocols and begins the process of readying the data for movement out over the network.

hostname

The machine-level designation provided to a computer or other device on an IP network.

hosts

A file that can be placed on a computer to provide host names to IP address mappings. Hosts files are useful on networks that use TCP/IP but do not provide the DNS service.

See also [Domain Name System]

hub

A device that does not enhance the signal, but supplies a central connection point for computers arranged in a star topology.

hyperlink

Basically a pointer that allows you to refer to Web pages, graphics, and multimedia content that are listed on a particular Web page. When a hyperlink is clicked on in a Web browser window, a user is taken to that page or activates a particular event (such as the playing of video or audio content or the displaying of a picture).

Hypertext Markup Language (HTML)

The language used to create Web documents that can be read by a Web browser such as Microsoft Internet Explorer or Netscape Navigator. HTML consists of tags that are used to format a document so that it can be viewed in a Web browser.

Hypertext Transfer Protocol (HTTP)

A TCP/IP stack member that provides the connection between an HTTP client (a computer outfitted with a Web browser) and a Web server.

IEEE (Institute of Electrical and Electronics Engineers)

An international organization whose mandate is to develop and share electrical and information technology specifications worldwide.

impedance

The resistance of a wire to data transmission. All cable types have impedance, which is measured in Ohms. The greater the impedance, the more energy required to move the signal over the wire.

incremental backup

This type of backup backs up only the files that have been changed since the last backup, but it does not change the marker attribute on the file as being backed up, as a differential backup does.

Interface Message Processor (IMP)

A hardware switch that was the precursor to the router. IMPs were used during the initial testing of ARPAnet.

See also [ARPAnet]

interference

Signals or noise from nearby devices that interfere with a wire's ability to move a transmission signal.

Internet

A giant, global internetwork that connects millions of computers. The current Internet evolved from government-sponsored packet-switching networks such as the ARPAnet.

Internet access provider (IAP)

A communications company that provides a connection to the Internet backbone. IAPs typically serve larger corporations that maintain their own DNS servers and other Internet services servers, such as email servers, and only require an onramp to the Internet infrastructure.

Internet layer (DoD)

This layer corresponds to the OSI Network layer, and is responsible for the routing of data across logical network paths, as well as providing an addressing system to the upper layers of the DoD stack. This layer also defines the packet format used for the data as it moves onto the network.

Internet Message Access Protocol (IMAP)

An email transport program that provides an alternative to the POP3 protocol. IMAP mail servers do not immediately dump all the available mail from the server to the IMAP client when the client connects.

See also [POP3]

Internet service provider (ISP)

A provider of Internet-based services. An ISP provides an Internet connection to users or companies in addition to other services, such as Internet email, Web browsing, FTP, and newsgroups. An ISP also typically offers space on its Web server for personal or corporate Web sites.

internetwork

A network of networks. An internetwork is a collection of LANS that uses different internetworking devices, such as routers and switches, to expand the range of the LANs.

InterNIC

The central authority for domain names in the United States.

intranet

A private, internal network that uses the TCP/IP protocol stack and different Internet technologies and servers to create an Internet-like environment for the users on the network.

IP Address

The unique logical address assigned to every computer and other devices, such as routers, on a network that uses the TCP/IP protocol.

IP Version 6 (IPv6)

A new IP addressing system that provides a greater number of bits (128 bits). IPv6 will offer billions more IP addresses than are currently available with IPv4.

IPSec (IPSecurity)

A suite of cryptography-based protection services and security protocols that can be used to secure internal networks, networks that use WAN solutions for connectivity, and networks that take advantage of remote access solutions.

IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange)

A proprietary LAN protocol stack developed by Novell. IPX/SPX provides its own unique system for node addressing and was originally developed for LANs using the Novell NetWare NOS.

ISDN

A suite of protocols defined by the ITU-T (International Telecommunication Union-Telecommunication Standardization sector) that provides digital communication over existing phone lines.

ISDN modem

A terminal adapter that is used to connect a LAN to the POTS local loop.

See also [ISDN]

KDE

A graphical user environment for Linux systems that provides a number of GUI tools and utilities.

latency

The lag time it takes data to move from one place to another. Some WAN technologies, such as ATM, use fixed-size packets to increase the potential throughput and decrease latency.

LILO (LINUX loader)

The standard boot loader for Linux systems.

See also [boot loader]
See also [GRUB]

Linux

A Unix clone created by Linus Torvalds when he was a student at the University of Helsinki. Linux is an open-system OS/NOS, and the kernel source code is free. A number of companies such as Red Hat sell different distributions of the Linux operating system.

Lisa (LAN Information Server)

A LAN browsing system for Linux computers that uses the TCP/IP protocol stack to create a listing of networked computers and their shared resources.

local area network (LAN)

A collection of personal computers and other peripheral devices connected at one location.

local loop

The actual physical wires that connect a business to the nearest phone company switching station.

local printer

A printer that is directly attached to a server. The printer is only local, however, in relation to the server it is attached to.

LocalTalk

The actual hardware devices, such as the built-in ports, on the back of Mac computers, and the special shielded twisted-pair cables that make up the physical connection for Apple networks.

Logical Link Control sublayer

This sublayer of the OSI's Data Link layer maintains the link between sending and receiving computers as data is moved across the physical media of the network.

See also [Data Link layer (OSI model)]

MAC address

The hardware address provided by the MAC sublayer of the OSI's Data Link layer. MAC addresses are actually burned into devices such as NICs and router interfaces. Each MAC address is unique.

See also [Data Link layer (OSI model)]

macro virus

Typically written in Visual Basic code, this type of virus affects documents and spreadsheet data files rather than executables. A number of Microsoft Word and Excel macro viruses have surfaced in recent years.

malware

Viruses, worms, and other software that are designed to mess up a computer.

marker

An attribute placed on files by the OS that differentiates files that have been backed up from those that have changed since the last backup.

Media Access Control sublayer (OSI model)

The sublayer of the Data Link layer that provides access to the network media and provides the addressing system used to move data frames on the network.

See also [MAC address]

Miniframe

A large, centralized computer that allows end-user connections through the use of dumb terminals.

modem

A device that can modulate and demodulate an analog transmission, providing for data communication over a regular phone line.

modem pool

A collection of modems on a remote access server. The modem pool provides for multiple dial-in connections.

modulation

The conversion of digital information on a computer to analog data carried on a phone line (modulation is handled by a modem).

See also [demodulation]
See also [modem]

multipartite virus

A virus that has the characteristics of both a boot sector virus and a file virus. It can spread from the boot sector of a drive to another drive, and it can also attack executable files on the computer.

See also [boot sector virus]
See also [file virus]

multiplayer gaming

A number of PC-based games are designed to allow multiple players to interact during a gaming session on a network. Individuals who set up home-based, peer-to-peer networks can take advantage of a large number of computer games that provide support for multiple players.

multiplexer (MUX)

The device that combines or divides the signals carried on the separate channels of a digital carrier line.

See also [T-Carrier system]

Multistation Access Unit (MAU)

A connectivity device containing an internal, logical ring that is used as the central connection point for computers on a token-ring network.

NADN (Nearest Active Downstream Neighbor)

The computer being passed a token is the nearest active downstream neighbor.

NAUN (Nearest Active Upstream Neighbor)

The computer that passes a token to the next computer on the logical ring is called the nearest active upstream neighbor.

NDS

Stands for Novell Directory Services. It is the logical, hierarchical directory tree used to manage users and devices on a Novell network. NDS became the structure for Novell networks with the release of NetWare 4.

NetBIOS Extended User Interface (NetBEUI)

A simple but fast LAN protocol stack designed for small networks. NetBEUI is a nonroutable protocol and was designed as an extension of Microsoft and IBM's NetBIOS protocol.

network

A group of connected computers that can share resources. Networks can be as small as two computers connected in a peer-to-peer arrangement or as large as global networks, such as the Internet, that use a number of different WAN connectivity strategies, including satellite technology.

Network Access layer (DoD)

This layer is equivalent to the Data Link layer of the OSI model and consists of the protocols that take the packets from the Internet layer and package them in an appropriate frame type.

Network Address Translation (NAT)

The ability to hide a group of computers using IP addresses behind one or more IP addresses. NAT is often used to hide friendly networks behind a proxy server.

See also [proxy server]

network architecture

The defining strategy for how computers on the network access the network media. The network architecture will also play some part in the network topology deployed on the network. Examples of network architectures are Ethernet and token ring.

network File System (NFS)

A virtual file system developed by Sun Microsystems that allows Linux computers to share files on the network.

network interface card (NIC)

A peripheral device containing a transceiver (a transmitter and receiver) that is able to convert data from parallel to serial, and vice versa. A NIC is the computer's connection to the network media.

Network layer (OSI model)

Responsible for the addressing of packets and their routing on the network.

Network Monitor

A Windows Server utility that allows you to monitor and track network performance and traffic.

network operating system (NOS)

Software that imparts special server capabilities to a computer. A server running an NOS can authenticate users to the network and share network resources.

network share

A drive or folder on a server that is made available to users on the network. Shares cannot consist of individual files.

newsgroup

An electronic bulletin board provided by a news server, such as those provided by Usenet. Information on news servers is broken into categories. Each subject area is called a newsgroup.

node

A client computer, server, or other device (such as a router) that is connected to the network.

Novell Directory Services (NDS)

The tree-like hierarchical structure that contains objects such as users and groups on a NetWare network.

See also [eDirectory]

NTFS

Stands for New Technology File System. NTFS is a file system available on computers running Windows NT, 2000, and XP that supports the spanning of large volumes and uses transaction logs, making it easier to recover data on a failed disk. NTFS is an improvement over the FAT file system that was originally developed for the DOS/Windows environment.

See also [FAT]

NWLink

Microsoft's clone of the IPX/SPX protocol stack.

See also [IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange)]

object

On a Windows server, any process that can be measured using the Performance Monitor is referred to as an object.

See also [Performance Monitor]

octet

One portion of the four-part IP address. Each octet in an IP address is equivalent to 8 bits of address information. Each IP address consists of four octets (or 32 bits).

OEM

Stands for Original Equipment Manufacturer. It refers to large resellers of computer equipment. Software manufacturers such as Microsoft often supply OEMs with special versions of their software that is highly compatible with the OEM's hardware.

OSI (Open Systems Interconnection) reference model

A conceptual model developed to illustrate how network protocols allow computers to communicate on the network. The OSI model consists of seven layers. Each layer serves a specific function as data moves through several intermediary forms before it is transmitted by a computer onto the network.

packet

A blanket term for data that is being processed to be sent over a network. In theory, a packet is created at the Transport layer of the OSI model when data is segmented into small data packages.

packet switching

In WAN connections that use packet switching, the data is divided into packets. The small packet size used in packet switching provides fast and efficient delivery of data.

parity bit

Extra bits placed in a data stream sent by a modem. The parity bits are used to check for errors in the transmission.

partition

A logical portion of a hard drive that is actually read by the computer's operating system as a separate drive.

peer

In a peer-to-peer network, the computers on the network functions as peers. Each peer has the capability to access and serve up resources such as files and printers.

peer communication

Information placed by a protocol operating at a particular layer of the OSI model in a data packet's header that is intended for a protocol operating at the same layer of the OSI model on the receiving computer.

peer-to-peer networking

A simple, low-cost method for connecting personal computers in situations where you want to share files and other resources, such as printers. The capability to provide peer services is built in to the OS that is running on the peer computers.

Performance Monitor

A utility available on Microsoft servers that allows you to monitor server hardware performance, such as the processor and RAM.

permanent virtual circuit (PVC)

A connection route set up between a sending device and a receiving device on a public switched network. The PVC is identified by a Data Link Connection Identifier (DLCI). Logical addresses, such as IP addresses, are then mapped to the PVC, providing a path through the WAN for the movement of data between the connected LANs.

Personal Digital Assistant (PDA)

A handheld computing device that provides productivity software for managing appointments, contacts, and other personal information.

Physical layer (OSI model)

This layer defines the actual physical aspects of how cabling is connected on a particular network topology.

PING (Packet Internet Groper)

A simple diagnostic command that uses echo packets to test the IP connection between two computers on a TCP/IP network.

Plain Old Telephone System (POTS)

The infrastructure of the public switched telephone network in the United States. The POTS provides a number of different WAN technologies.

plug and play

An operating system service that allows for the automatic recognition and installation of peripheral devices such as modems and printers.

Point-to-Point Protocol (PPP)

A TCP/IP protocol that provides a reliable connection between computers. PPP supports multiple network protocols, such as IP, IPX, and NetBEUI. PPP also provides compression and error checking and is therefore more reliable than a SLIP connection.

POP3

A TCP/IP stack protocol used by email clients to connect to a POP3 email server. The POP3 email server basically functions as a mail drop.

Presentation layer (OSI Model)

The converter layer of the OSI model. This layer converts the data into a format that can be read by the receiving computer.

primary DNS server

A DNS server on a network that serves as the premier DNS name-to-IP address resolver on the network. It is called the primary DNS server because client machines are configured to consult it first when trying to resolve friendly names to IP addresses (or vice versa).

Primary Rate ISDN

A faster version of ISDN for businesses. Primary Rate ISDN uses a T-1 line and provides 23 B channels (each operating at 64Kbps). One D channel is also necessary (as with BRI) to handle setup and to control the connection. All or any number of the 23 B channels available can be combined for data transfer. Some channels can also be used for voice communication.

print queue

The list of print jobs waiting to be printed. These print jobs are held in the print server's memory or hard drive in the form of a print queue.

print server

A computer used to queue up print jobs and control printer access. A print server typically has a printer directly connected to it.

print spooler

Software on a print server that accepts print jobs from network clients and readies them for printing.

printer pool

Several identical printers that have been configured to appear as one printer on the network. Because multiple printers can accept print jobs sent to the pool, print services are provided faster to network users.

program sharing

Involves applications such as spreadsheets and word processors being run over a network. File servers and special application servers provide the platform for sharing different applications over a network.

protocol

Software code that provides the rules for how computers communicate on a network. LAN protocols such as TCP/IP or IPX/SPX actually are made up of a number of protocols in a stack. There must be a common protocol for the computers to communicate.

protocol stack

A group of tightly associated protocols, each with its own function, that work together to prepare data for the communication process.

proxy server

A server that sits between your network (considered a trusted network) and an untrusted network, such as the Internet. The proxy server masks the computers that are hidden behind it on the trusted network.

public folder

A folder on a network server that can be accessed by network users who have the appropriate permissions.

query

A request to a database server for information from a network client.

RAID 0

A method of combining several drives into one RAID array that provides for faster access time. RAID 0 does not actually provide any fault tolerance.

See also [Redundant Array of Inexpensive Disks (RAID)]

RAID 5

A method of combining several drives into one RAID array so that the information is striped across the drives. If one drive in the array fails, the data can be regenerated using parity information contained on the other drives in the array.

redirector

Software on a client computer that handles the little "bait and switch" operation that makes the computer think a network resource is still just a local resource.

Redundant Array of Inexpensive Disks (RAID)

A group or array of hard drives that provides fault tolerance on a server and is seen by network clients as a single drive.

remote access server

A server that accepts incoming dial-in connections or virtual connections from remote client computers.

remote printer

A printer attached to a computer other than your server. The computer that the printer is attached to would consider the printer local. Whether a printer is local or remote will depend on which computer on the network you are using as your reference point.

repeater

A device that takes the signal received from computers and network devices and regenerates the signal so that it maintains its integrity along a longer cable run than is normally possible. Repeaters are also referred to as concentrators.

resolver

The software on an application such as a Web browser that contacts a DNS server for resolving a friendly name to an IP address.

resource

A hardware component on a server or a computer. A resource can be the memory, processor, or hard drive space on a computer.

reverse lookup zones

Zones on a DNS server that resolve IP addresses to friendly names.

See also [DNS server]

ring topology

A LAN topology where computers are arranged in a physical circle. The ring topology moves information on the wire in one direction and is considered an active topology. Computers on the network actually retransmit the packets they receive and then send them on to the next computer in the ring.

RJ-11 jack

A small jack that accepts RJ-11 or telephone connectors.

RJ-45 connector

The male end on a twisted-pair cable used to connect to various network devices such as a computer's NIC.

root

The administrative account for a computer running one of the various distributions of Linux.

router

A internetworking device used to connect LANs via LAN and WAN connections. The router uses a combination of hardware to route packets between networks.

routing protocol

A protocol used by routers to build routing tables and determine the best path for data on a routed network.

RS-232 cable

A cable used to connect a device such as a modem to a COM port on a computer.

Samba

A Linux add-on program that allows Linux computers to participate in Windows workgroups. Samba derives its name from Server Message Block (SMB). SMB is an important part of the NetBIOS/NetBEUI protocol stack and supplies the data blocks that make requests between client and server or between peers on a Microsoft network.

schema

The element that defines the objects that reside in a logical network hierarchical structure, such as NetWare's eDirectory or Microsoft's Active Directory.

scalable networks

Networks designed so that any number of clients or additional servers can be added to them. The scalability of a network will often depend on the network operating system being used on the network.

Secure Electronic Transaction (SET)

A system developed to secure credit card purchases on the World Wide Web. SET was developed by Visa and MasterCard and provides very strong 128-bit encryption. The more bits, the better encryption. Therefore, 128-bit encryption is harder to decode than 64-bit encryption.

Secure HTTP (SHTTP)

A superset of the HTTP protocol that provides mechanisms to secure online transactions. SHTTP was developed by Enterprise Integration Technologies and is now the property of Terisia Systems. SHTTP provides for the encryption of transmissions between servers and clients.

Secure Socket Layer (SSL)

A system used to secure online transactions on the Internet. SSL was developed by Netscape to secure online transactions and uses a combination of encryption and digital certificates (the certificates are used to verify a merchant's identity) to secure the transfer of information from a Web browser to a Web site store.

Serial Line Internet Protocol (SLIP)

An access protocol developed primarily to allow PCs to connect to the Internet using a modem. It operates at the OSI model's Physical layer and allows data to flow across the telephone line to a remote system.

serial ports

The communication (COM) ports on a computer. Serial ports are typically used to connect communication devices such as modems to a computer.

serial transmission

Data bits are lined up in a single bit stream for transfer over a network medium such as copper wire.

server

A computer that actually serves up the resources available on the network—everything from files to electronic mail post offices. A server running a network operating system also controls access to the network and authenticates users based on login name and password.

server-based networking

A networking model where user access and the sharing of resources is centrally controlled. Resources and user logon are controlled by a specialized network server.

service

A resource, such as email, newsgroups, or teleconferencing, provided by a communication server.

service access points (SAPs)

Communication channels that are provided by the Logical Link Control (LLC) sublayer of the Data Link layer of the OSI model. SAPs are used so that lower layers of the OSI model can communicate with upper layers in the OSI stack.

Session layer (OSI model)

The layer of the OSI model responsible for setting up the communication link or session between the sending and receiving computers.

share

A resource such as a drive, folder, or printer that is made available to other users on a network.

share-level security

A security scheme in which each resource on a network is managed separately and often requires a unique password for access. Share-level security is typical for the peer-to-peer networking environment.

shared database

A client/server environment where a shared database is held on a database server and is accessed using database client software on network client computers.

shared printer

A printer on a network that accepts print jobs from more than one computer.

shielded twisted pair (STP)

Network-grade twisted-pair cabling that is encased in a protective shielding.

Simple Mail Transport Protocol (SMTP)

A protocol that allows email servers to send and receive messages. This protocol operates at the Application, Presentation, and Session layers of the OSI model.

simplex

A type of transmission in which data can only be sent in one direction between a sending and a receiving device. Your thermostat and furnace are good examples of simplex transmission.

sneakernet

Sharing information from computer to computer by physically passing a disk holding the information.

SQL (Structured Query Language)

A language used to build complex client/server databases. SQL is also used by the database client software to send queries to the database server.

star topology

A LAN topology where each computer or device on the network is connected to a central device called a hub. Each computer is connected with its own cable (typically twisted-pair cable) to a port on the hub. Star LANs typically deploy a passive network architecture.

subnet

A logical division or subset of a large IP network. Each subnet is connected to the other subnets on the network by a router. Subnetting is the process of dividing an IP network into subnets.

supercomputer

A term typically reserved for some of the large mainframe and miniframe computers built in the last few decades. Cray Corporation actually marketed a powerful mini called the Cray Supercomputer.

SWAT (Samba Web Administration Tool)

A Samba configuration tool that can be accessed using a Web browser on a Linux computer.

See also [Samba]

switched network

A WAN connectivity strategy that allows multiple users to take advantage of the same line. Switched networks can take advantage of two different strategies: circuit switching and packet switching.

See also [circuit switching]
See also [packet switching]

Switches

An internetworking device that can be used to preserve the bandwidth on your network using segmentation. Switches are used to forward packets to a particular segment using MAC hardware addressing (the same as bridges).

See also [bridge]

Synchronous Optical Network/Synchronous Digital Hierarchy (SONET)

A Physical layer specification for high-speed fiber-optic networks. SONET networks typically used ATM as their WAN protocol.

T-Carrier system

High-speed digital lines made up of multiple channels provided by the POTS or other service provider. The T-Carrier system can be used for the high-speed transfer of voice, video, and data. Each channel on a line can provide 64Kbps of throughput.

thicknet

A heavy-gauge coaxial cable that is fairly inflexible and requires special equipment (over and above a simple network card) to connect a computer to the network backbone.

thinnet

A fairly flexible coaxial cable (RG-58A/U) used on Ethernet LANs.

time domain reflectometer

A sophisticated device that can diagnose shorts and breaks in a cable and can provide you with information on where a short or break exists on the cable.

token

A data packet that is passed from computer to computer on a network using a ring topology. Possession of the token is necessary for the computer to transmit data onto the network.

topology

The overall physical layout of a network.

Traceroute

A diagnostic command that can be used to see the route that data packets take between two computers on a TCP/IP network.

translator

A protocol that has the ability to transform data packets from one format to another. Translator protocols typically reside at the Presentation layer of the OSI model and make sure that data will be understandable when received by a computer on the network.

Transmission Control Protocol/Internet Protocol (TCP/IP)

A suite of protocols developed for the Internet. It is a routable protocol stack that is universally embraced by client operating systems and network operating systems.

Transport layer (OSI model)

Responsible for the flow control of data between communicating computers.

trusted network

Another name for the internal or corporate network. It is trusted because of the administrator's ability to control user activity.

See also [untrusted network]

tunnel client

A computer that remotely connects to a tunnel server using a VPN.

See also [Virtual Private Network (VPN)]

tunnel server

A server that provides the network connection for a Virtual Private Network session.

tunneling

Remote access servers encapsulate packets in a frame so that they can move through a virtual route or tunnel across the public switched telephone network. Virtual tunnel encapsulation is provided by the wide area networking protocol or access protocol that is being used to host the connection.

uniform resource locator (URL)

The friendly name of an Internet resource such as a Web server on the World Wide Web. A URL is defined by the registered domain name of a company and the domain name system hierarchy.

uninterruptible power supply (UPS)

A device outfitted with some type of battery that can supply temporary power to a server when there is a power failure.

Universal Naming Convention (UNC)

A naming system that uses "friendly names" to refer to resources on a network. The UNC for a share on a server takes the format \\server name\share name.

Unix

A multiuser, multitasking operating system that provides a client/server networking environment on a wide variety of hardware platforms.

unshielded twisted pair (UTP)

Network-grade twisted-pair cabling that is not encased in a protective shielding.

untrusted network

An external network such as the Internet that will be connected to the internal or trusted network. It is untrusted because the network administrator has no control over the users or activity on the external network.

See also [trusted network]

Usenet

A network of Internet servers that allows users to post and read messages in newsgroups.

See also [newsgroup]

user authentication

The process where the user is allowed access to the network by virtue of his login name and password.

user communication

A term that encompasses any number of different media for user communication on a network. These different communication media include electronic mail, newsgroups, and video conferencing.

username

The name that a user must provide when logging on to a server-based network.

Virtual Private Network (VPN)

A secure, dedicated point-to-point connection over a public IP network such as the Internet.

virus

A malicious, self-replicating piece of software code. Because a virus can copy itself, it can easily (and unfortunately) be spread from computer to computer.

voltmeter

A simple device that can be connected to a cable to test the cable for a break or a short.

volume

A portion of a hard drive or parts of several hard drives that can function as a separate and discrete drive. In the case of RAID, a volume (which appears to the computer as one drive) is actually spread over two or more drives.

well-known port numbers

Conduit numbers that have been assigned to TCP/IP protocols and are used in conjunction with IP addresses to form a connection between protocols functioning on a sending and receiving computer. For example, SMTP uses port 25, and POP3 uses port 110.

wide area network (WAN)

LANs at different locations connected together using various WAN technologies.

WINS server

A special server on a Microsoft network that resolves NetBIOS names to IP addresses.

workgroup

A group of peer computers that operate in the same logical network space.

workstation

A powerful standalone or network client computer that provides the memory and processing power to run more complex software, such as the design software used by engineers.

worm

A program that spreads itself from computer to computer on a network. Worms are self-replicating and do not require user interaction to spread throughout a network.

xDSL
See [Digital Subscriber Line (DSL)]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

.NET technology 2nd
/ (slash)
1000BASE-T
100BASE-FX
100BASE-T4
100BASE-TX
10BASE-2
10BASE-5
10BASE-FL
10BASE-T
10Gigabit Ethernet
802.5 Token-Ring
8mm (tape backup)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

A (Host) resource records
AARP (AppleTalk Address Resolution Protocol)
ables
attentuation
coaxial cables 2nd
connectivity strategies
copper wire
electrical wire 2nd
fiber-optic cables 2nd 3rd 4th 5th
troubleshooting
impedance
interference
phone wire 2nd
twisted-pair cables
CAT 1
CAT 2
CAT 3
CAT 4
CAT 5
CAT 6
crosstalk
unshielded twisted-pair 2nd
access permissions
access protocols [See protocols]
access tokens
accessing
Internet backbone 2nd 3rd
accounts
Active Directory user accounts
creating 2nd 3rd
passwords 2nd
creating
user accounts
access tokens
concurrent connections
creating 2nd
disabling
logon hours
passwords 2nd 3rd 4th
remote connections
usernames 2nd
Active Directory 2nd
Active Directory Domains and Trusts snap-in
Active Directory Sites and Services snap-in
Active Directory Users and Computers snap-in
server-based networks
user accounts
creating 2nd 3rd
passwords 2nd
Active Directory Domains and Trusts snap-in
Active Directory Sites and Services snap-in
Active Directory Users and Computers snap-in
active matrix displays
Active Monitor
active topologies
Adaptec Web site
Add a New Print Queue dialog box 2nd
Add NFS Share dialog box
Add Printer Driver Wizard
Add Printer Wizard
Address Resolution Protocol. (ARP)
addresses
AppleTalk 2nd
dotted decimal notation
email addresses 2nd
host addresses 2nd
IP
automatic
static
IP (Internet Protocol)
IP address spoofing
IP (Internet Protocol) addresses
address ranges 2nd
APIPA (Automatic Private IP Addressing)
configuring
IP addresses 2nd 3rd 4th 5th 6th 7th 8th 9th
Class A addresses
Class B addresses
Class C addresses
Class D addresses
Class E addresses
configuring 2nd 3rd 4th
converting
dotted decimal notation
dynamic addresses
IPv6 (IP Version 6) 2nd
static addresses
subnet masks 2nd 3rd
subnetting 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th
IPX/SPX addresses 2nd
MAC (Media Access Control) addresses 2nd
MAC hardware addresses 2nd
NAT (Network Address Translation) 2nd 3rd 4th
URLs (Uniform Resource Locators)
adduser command
administration
Lotus Notes 2nd 3rd
Microsoft Exchange Server 2nd
NetWare 2nd 3rd 4th 5th 6th
client configuration 2nd
ConsoleOne 2nd
DHCP (Dynamic Host Configuration Protocol) 2nd
directories 2nd 3rd 4th
DNS (Domain Name System) 2nd
groups 2nd 3rd
Health Monitor
iManager
iPrint clients 2nd 3rd
NetWare Remote Manager 2nd 3rd 4th 5th
NSS (Novell Storage Services)
printer sharing 2nd 3rd 4th 5th
storage pools 2nd 3rd 4th 5th
user accounts 2nd 3rd
volumes 2nd 3rd
peer-to-peer networks
administrators 2nd 3rd
access permissions
passwords
tips and guidelines 2nd
user authentication
ADSL (Asymmetric DSL)
Advanced NetWare
Advanced Research Projects Agency (ARPA) 2nd 3rd
Advanced TCP/IP Settings dialog box 2nd
AFP (AppleTalk Filing Protocol)
Agilent Technologies
AIDS Information Disk Trojan
American National Standards Institute (ANSI)
American Registry for Internet Numbers (ARIN)
American Standard Code for Information Interchange (ASCII)
AnalogX Proxy Server 2nd 3rd 4th
analyzing
network needs 2nd 3rd
analzing
network traffic 2nd
anonymous FTP (File Transfer Protocol) 2nd 3rd
ANSI (American National Standards Institute)
Apache Configuration tool (Linux)
APIPA (Automatic Private IP Addressing)
AppleShare
AppleTalk 2nd
addressing 2nd
stack protocols 2nd
AppleTalk Address Resolution Protocol (AARP)
AppleTalk Filing Protocol (AFP)
AppleTalk Transaction Protocol (ATP)
Application layer (DOD model)
Application layer (OSI model) 2nd 3rd
Application Log
application servers
application-gateway firewalls
applications 2nd
choosing 2nd 3rd 4th 5th
client-based applications 2nd
client/server databases 2nd
groupware 2nd 3rd
defined
GroupWise 2nd 3rd 4th
Lotus Notes 2nd
Domino Administrator 2nd 3rd
Domino Server
Notes clients 2nd 3rd
Microsoft .NET 2nd
Microsoft Exchange Server 2nd
administration 2nd
Outlook client 2nd 3rd
network-based applications 2nd
sharing
sharing with SharePoint Portal Server 2nd 3rd 4th
suite products
synchronizing
upgrading
architectures (network) 2nd
ARCnet
bandwidth 2nd
contention-bases architectures
data transmission speed
defined
Ethernet 2nd 3rd 4th
1000BASE-T
100BASE-FX
100BASE-T4
100BASE-TX
10BASE-2
10BASE-5
10BASE-FL
10BASE-T
10Gigabit Ethernet
collisions 2nd
configurations
costs
CSMA/CD
Fast Ethernet 2nd
Gigabit Ethernet 2nd
IEEE specifications 2nd 3rd 4th 5th
FDDI 2nd 3rd
Token-Ring 2nd
Active Monitor
beaconing
cabling specifications 2nd
Gigabit Token-Ring
IEEE specifications 2nd
MAUs (Multistaton Access Units) 2nd
NADN (nearest active downstream neighbor)
NAUN (nearest active upstream neighbor)
speed
tokens
ARCnet (Attached Resource Computer Network)
ARIN (American Registry for Internet Numbers)
ARIN Web site
ARP (Address Resolution Protocol)
ARPA (Advanced Research Projects Agency) 2nd 3rd
ARPAnet 2nd
arrays of drives
Artisoft
ASCII (American Standard Code for Information Interchange)
assigning
NTFS permissions
passwords 2nd
Asymmetric DSL (ASDL)
asynchronous modems 2nd 3rd 4th 5th
Asynchronous Transfer Mode (ATM) 2nd 3rd
ATM (Asynchronous Transfer Mode) 2nd 3rd
ATP (AppleTalk Transaction Protocol)
Attached Resource Computer Network (ARCnet)
attacks
denial-of-service attacks
eavesdropping
IP address spoofing
man-in-the-middle attacks
password attacks
protecting against 2nd
attentuation (cabling)
authentication
CHAP (Challenge Handshake Authentication Protocol)
PAP (Password Authentication Protocol)
Automatic Private IP Addressing
Automatic Private IP Addressing (APIPA)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

B channels
backbone (Internet)
accessing 2nd 3rd
backups 2nd 3rd
8mm tape
DAT (Digital Audio Tape) tape
differential backups 2nd 3rd
DLT tape
floppy disks
full backups
incremental backups 2nd 3rd
peer-to-peer networks
Shadow Copy
strategy 2nd 3rd 4th 5th
troubleshooting
bandwidth 2nd 3rd
baseband signals
baselines
Basic Input/Output System (BIOS)
Basic Rate Interface (BRI)
Basic Rate ISDN 2nd
baud rates
bCentral
bCentral Web site
beaconing
benchmarks
binary data
bindery
BIOS (Basic Input/Output System)
bits 2nd
parity bits
subnetting 2nd
bits per second (bps) 2nd
biz domain name
BlackBerry 2nd 3rd
Bluetooth
Boggs, David
books
Building e-Commerce Sites with the .Net Framework
CNE Update to NetWare 6
Microsoft Windows Server 2003 Unleashed
Practical Cisco Routers
Red Hat Linux 9 Unleashed
Sams Teach Yourself .NET XML Web Services in 24 Hours
Sams Teach Yourself Microsoft Office 2003 in 24 Hours
Sams Teach Yourself Microsoft Windows Server 2003 in 24 Hours 2nd 3rd
Sams Teach Yourself Samba in 24 Hours
Sams Teach Yourself Windows Server 2003 in 24 Hours
Special Edition Using HTML and XHTML
Special Edition Using TCP/IP
The Concise Guide to Enterprise Internetworking and Security
Upgrading and Repairing PCs
boot process
Red Hat Linux 2nd
boot.ini file
BOOTP
borrowing bits 2nd
bottlenecks
bps (bits per second) 2nd
Brain virus
braodband signals
BRI (Basic Rate Interface)
BRI (Basic Rate ISDN) 2nd
bridges 2nd
broadcast messages 2nd
broadcast traffic
Broadcasts Sent column (Network Monitor)
brokers (print) 2nd 3rd
browsers
configuring
FTP (File Transfer Protocol) support
browsing
Linux shared resources 2nd 3rd 4th
buffering
Building e-Commerce Sites with the .Net Framework
bus mastering
bus topology 2nd 3rd 4th
buses
bus mastering
EISA (Extended Industry Standard Architecture)
ISA (Industry Standard Architecture)
MCA (Micro Channel Architecture)
PCI
VESA (Video Electronics Standards Association)
businesses
Web sites
advantages 2nd 3rd
online marketing 2nd 3rd
online sales 2nd
transaction security 2nd
Bytes Rcvd column (Network Monitor)
Bytes Sent column (Network Monitor)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

cable modems 2nd
cables [See also topologies]2nd [See also topologies]3rd
coaxial cables
thicknet
copper wire
fiber-optic cables
peer-to-peer networks 2nd
Token-Ring networks 2nd
twisted-pair cables
Type 1
Type 3
unshielded twisted-pair cables
calbes
troubleshooting
Canonical Name (CNAME) resource records
capturing
network packets 2nd 3rd 4th
cards
Diamond Homefree
NICs (network interface cards) 2nd 3rd
choosing 2nd 3rd 4th
EISA (Extended Industry Standard Architecture)
installing 2nd 3rd 4th
ISA (Industry Standard Architecture)
MAC (Media Access Control) addresses 2nd
MCA (Micro Channel Architecture)
PCI
VESA (Video Electronics Standards Association)
Carrier Sense Multiple Access with Collision Detection (CSMA/CD)
CAT 1 cables
CAT 2 cables
CAT 3 cables
CAT 4 cables
CAT 5 cables
CAT 6 cables
categories
twisted-pair wire
cd command
cells
CENTER tag (HTML)
central offices (COs)
centralized computing models
Centrino
Challenge Handshake Authentication Protocol (CHAP)
Change permissions
Channel Service Unit/Digital Service Unit (CSU/DSU)
channels
channels (T-Carrier lines) 2nd
CHAP (Challenge Handshake Authentication Protocol)
chat
IRC (Internet Relay Chat) 2nd
choosing
applications 2nd 3rd 4th 5th
NICs (network interface cards) 2nd 3rd 4th
EISA (Extended Industry Standard Architecture)
ISA (Industry Standard Architecture)
MCA (Micro Channel Architecture)
PCI
VESA (Video Electronics Standards Association)
circuit switching 2nd
defined
DSL (Digital Subscriber Line) 2nd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
ISDN 2nd 3rd
Basic Rate ISDN 2nd
costs
defined
ISDN modems
Primary Rate ISDN
circuit-level firewalls
Cisco routers
configuring 2nd 3rd
Class A addresses
Class A addresses (IP)
Class B addresses
Class B addresses (IP)
Class B networks
subnetting 2nd 3rd 4th
Class C addresses
Class C addresses (IP)
Class D addresses
Class E addresses
classes
IP (Internet Protocol) addresses 2nd
clear text
client-based applications 2nd
client/server databases 2nd
client/server NOSs
clients 2nd 3rd 4th 5th 6th
client-based applications 2nd
client/server databases 2nd
configuration 2nd
defined
DHCP (Dynamic Host Configuration Protocol) 2nd 3rd
email client configuration 2nd
FTP (File Transfer Protocol) 2nd 3rd 4th
iPrint clients 2nd 3rd
Lotus Notes clients 2nd 3rd
NetWare
configuring
NetWare clients
configuration 2nd
network client software 2nd
Outlook 2nd 3rd
protocols 2nd 3rd
RAS (Remote Access Services) servers
client configuration 2nd 3rd
redirectors 2nd
tunnel clients 2nd
Web browsers
FTP (File Transfer Protocol) support
workstations
defined
CMOS 2nd
CNAME (Canonical Name) resource records
CNE Update to NetWare 6
coaxial cables 2nd
thicknet 2nd
thinnet
collisions
Ethernet networks 2nd
com domain name
COM ports
commands
cd
ipconfig 2nd
mount
nssmu
ping 2nd
traceroute 2nd
commands adduser
communication
between users
peer communication (OSI model)
communication protocols [See protocols]
communication servers
communications servers
Compaq Portable computers
compatibility
NICs (network interface cards)
compressing
backups
compression
conceptual models
Concise Guide to Enterprise Internetworking and Security, The
concurrent connections
config-services tool
configuration
Windows Server 2003 2nd
configurations
Ethernet networks
Configure Your Server Wizard
configuring
browsers
clients 2nd
DHCP (Dynamic Host Configuration Protocol) servers 2nd 3rd 4th 5th 6th
email clients 2nd
IP (Internet Protocol) addresses 2nd 3rd 4th 5th
IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange) 2nd
NetWare clients 2nd 3rd
node addresses
peer-to-peer networks 2nd 3rd 4th
cabling 2nd
cost considerations
file sharing 2nd 3rd 4th 5th 6th 7th
printer sharing 2nd 3rd 4th 5th 6th 7th
Samba 2nd 3rd 4th 5th 6th
TCP/IP 2nd 3rd 4th
Windows systems 2nd 3rd
workgroups 2nd 3rd 4th 5th 6th
protocols 2nd 3rd
RAD (Remote Access Services) clients 2nd 3rd
RAD (Remote Access Services) servers 2nd 3rd
Red Hat Linux
boot process 2nd
installation packages 2nd
network configuration 2nd
root configuration 2nd
upgrades 2nd 3rd 4th 5th
routers 2nd 3rd
Samba 2nd 3rd
servers 2nd 3rd 4th
tunnel clients 2nd
tunnel servers 2nd
Web sites
connecting
to Internet 2nd
cable modems 2nd
domain names 2nd 3rd 4th
Internet backbone 2nd 3rd
IP addresses 2nd 3rd 4th
ISPs (Internet service providers) 2nd 3rd
shared connections 2nd 3rd 4th 5th 6th 7th 8th
connection additive licenses
connection types
selecting 2nd 3rd
connection-oriented transport
connectionless transport
connections
troubleshooting 2nd
cables
digital voltmeters
ipconfig command 2nd
ping command 2nd
time domain reflectometers 2nd
traceroute command 2nd
connectivity devices 2nd
bridges 2nd
hubs 2nd 3rd
repeaters 2nd
routers 2nd
switches 2nd 3rd
connectivity strategies 2nd
cables [See cables]
infrared connectivity 2nd
radio connectivity 2nd 3rd 4th
Conquerer
ConsoleOne (NetWare) 2nd
contention-bases architectures
controllers (hard drives)
converting
IP addresses
copper wire 2nd
Corporate Presence Web Wizard
corporate Web sites
advantages 2nd 3rd
online marketing 2nd 3rd
online sales 2nd
transaction security 2nd
COs (central offices)
cost
domain names
Ethernet networks
FDDI
peer-to-peer networks 2nd
server-based networks 2nd
costs
DSL (Digital Subscriber Line)
ISDN connections
counters
CPE (customer premise equipment)
crackers [See also attacks]2nd
protecting against 2nd
CRC (cyclical reduncdancy check)
creating
intranets 2nd
Web sites
HTML (Hypertext Markup Language) 2nd
crossover cables
crosstalk
cryptography
CSMA/CD (Carrier Sense Multiple Access with Collision Detection)
CSU/DSU (Channel Service Unit/Digital Service Unit)
customer premise equipment (CPE)
cyclical redundancy check (CRC)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

daily backups
DARPA (Defense Advanced Research Projects Agency)
DAT (Digital Audio Tape) tape backup
data buses
data compression
data encryption
data frames
Data Link Connection Identifiers (DLCIs)
Data Link Control (DLC) 2nd
Data Link layer (OSI model) 2nd 3rd
data packets
routing
segmenting
data transmission 2nd 3rd 4th
data transmission speed
database engines
databases
client/server databases 2nd
Datagram Delivery Protocol (DDP)
DDP (Datagram Delivery Protocol)
DDR-SDRAM (Double Data Rate-Synchronous Dynamic RAM)
DDS (digital data service) lines
de-encapsulation
OSI model
decompressing
backups
dedicated connections
asynchronous modems 2nd 3rd 4th 5th
synchronous modems 2nd
dedicated lease lines
Defense Advanced Research Projects Agency (DARPA)
demarcation
demodulation 2nd [See also modems]
denial-of-service attacks
design
Web sites 2nd 3rd 4th 5th
development
of Internet 2nd 3rd 4th
of packet switching
of telephone system
devices [See hardware]
DHCP (Dynamic Host Configuration Protocol) 2nd 3rd
client address requests 2nd 3rd
NetWare 2nd
running
server configuration 2nd 3rd 4th 5th 6th
DHCPACK messages
DHCPDISCOVER message
DHCPOFFER messages 2nd
DHTML (Dynamic HTML)
diagnostic tools
digital voltmeters
Ethereal
Event View
Health Monitor 2nd
ipconfig 2nd
Network Monitor 2nd 3rd 4th 5th
Performance Monitor 2nd 3rd 4th
ping 2nd
protocol sniffers 2nd
Remote Manager 2nd
time domain reflectometers 2nd
traceoute 2nd
dial-up connections
asynchronous modems 2nd 3rd 4th 5th
synchronous modems 2nd
dialog boxes
Add a New Print Queue 2nd
Add NFS Share
Advanced TCP/IP Settings 2nd
Internet Protocol (TCP/IP) Properties 2nd 3rd 4th 5th 6th
Local Area Connection Properties 2nd
New Object - User
NT Network
Protocols tab 2nd
Printers
Properties
Sharing tab 2nd
Select a Zone Type
Select Network Component Type 2nd 3rd 4th 5th
Windows Shares 2nd
Diamond Homefree card
differential backups 2nd 3rd
Digital Audio Tape (DAT) tape backup
digital data service (DDS) lines
Digital Subscriber Line (DSL) 2nd 3rd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
Digital Subscriber Line Access Multiplexers (DSLAMs)
digital voltmeters
DIMMs (Dual Inline Memory Modules)
direct connect printers
Direct Memory Access (DMA)
Directed Frames Sent column (Network Monitor)
directories
creating 2nd 3rd 4th
eDirectory 2nd
defined 2nd 3rd
sharing 2nd
directory services
Active Directory 2nd
Active Directory Domains and Trusts snap-in
Active Directory Sites and Services snap-in
Active Directory Users and Computers snap-in
user accounts 2nd 3rd 4th 5th
defined
disabling
user accounts
disk drives [See hard drives]
disk duplexing
Disk Management tool
Disk Management utility
disk mirroring 2nd 3rd 4th
disk speed
disk striping 2nd 3rd 4th
disks [See drives]
fixed [See hard drives]
DLC (Data Link Control) 2nd
DLCIs (Data Link Connection Identifiers)
DLT tape backup
DMA (Direct Memory Access)
DNS (Domain Name Service)
FQDNs (fully qualified domain names)
DNS (Domain Name System) 2nd
forward lookup zones
how it works 2nd
namespaces 2nd 3rd
NetWare 2nd
resource records 2nd
reverse lookup zones
root domains
server configuration 2nd 3rd 4th
top-level domains 2nd
DNS servers 2nd 3rd
DNS tool (Linux) 2nd
documentation
DOD (Department of Defense) model
layers
Application
Host-to-Host
Internet
Network Access
domain accounts
domain controllers
domain names
cost
registering 2nd 3rd
domains
DNS (Domain Name System) 2nd
forward lookup zones
how it works 2nd
namespaces 2nd 3rd
NetWare 2nd
resource records 2nd
reverse lookup zones
root domains
server configuration 2nd 3rd 4th
top-level domains 2nd
domain names
cost
registering 2nd 3rd
FQDNs (Fully Qualified Domain Name)
root domains
top-level domains 2nd
Domains and Trusts snap-in (Active Directory)
Domino Administrator 2nd 3rd
dotted decimal notation
Double Data Rate-Synchronous Dynamic RAM (DDR-SDRAM)
downloading
FTP (File Transfer Protocol) clients
DRDOS, loading 2nd
Dreamweaver
drives [See hard drives]
hard
hard drives 2nd [See hard drives]
EIDE (Enhanced Integrated Drive Electronics)
formatting
hot-swappable
IDE (Integrated Drive Electronics)
parititioning
SCSI (Small Computer System Interface) 2nd
DSL (Digital Subscriber Line) 2nd 3rd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
DSLAMs (Digital Subscriber Line Access Multiplexers)
Dual Inline Memory Modules (DIMMs)
dumb terminals
duplexing
duplicating
partitions
dynamic addresses
Dynamic Host Configuration Protocol (DHCP) 2nd 3rd
client address requests 2nd 3rd
NetWare 2nd
server configuration 2nd 3rd 4th 5th 6th
Dynamic HTML (DHTML)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

eavesdropping 2nd
Ebay
eDirectory 2nd
defined 2nd 3rd
EDO (Extended Data Output) RAM
edu domain name
EIDE (Enhanced Integrated Drive Electronics) drives
EISA (Extended Industry Standard Architecture) bus
El Torito
electrical wire 2nd
electronic mail [See email]
email 2nd 3rd
addresses 2nd
client configuration 2nd
IMAP (Internet Message Access Protocol) 2nd
POP3 (Post Office Protocol) 2nd
processing
SMTP (Simple Mail Transport Protocol) 2nd
encapsulation
OSI model 2nd
encryption
Enhanced Integrated Drive Electronics (EIDE) drives
enterprise networks
equipment
ISPs
errors
user errors 2nd 3rd
Ethereal
Ethereal Network Analyzer 2nd
Ethernet 2nd 3rd 4th
1000BASE-T
100BASE-FX
100BASE-T4
100BASE-TX
10BASE-2
10BASE-5
10BASE-FL
10BASE-T
10Gigabit Ethernet
baseband signals
collisions 2nd
configurations
costs
CSMA/CD
Fast Ethernet 2nd
Gigabit Ethernet 2nd
IEEE specifications 2nd 3rd 4th 5th 6th 7th
Ethernet networks
Event Viewer 2nd
Exchange Server 2nd
administration 2nd
Outlook client 2nd 3rd
Extended Data Output (EDO) RAM
Extended Industry Standard Architecture (EISA) bus
Extensible Markup Language (XML)
external modems 2nd
extranets
sharing applications on 2nd 3rd 4th

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

F-Secure Web site
FAQs (frequently asked questions)
Fast Ethernet 2nd
Fast Page Mode (FPM) memory
FAT (file allocation table)
FAT file system
FAT16 file system
FAT32 file system 2nd
fault tolerance 2nd 3rd [See also RAID]
FDISK utility 2nd
FFDI (Fiber Distrubted Data Interface) 2nd 3rd
Fiber Distributed Data Interface (FFDI) 2nd 3rd
fiber-optic cables 2nd 3rd 4th 5th 6th
troubleshooting
file allocation table (FAT)
file servers 2nd 3rd
file sharing
file systems
FAT
FAT32
NFS (Network File System) 2nd 3rd 4th
NTFS
permissions 2nd 3rd 4th 5th 6th 7th
File Transfer Protocol (FTP)
file viruses
files
boot.ini
fault tolerance 2nd [See also RAID]
file systems
NFS (Network File System) 2nd 3rd 4th
log files
Application Log
Security Log
Server Health Log
SYS$LOG.ERR file
System Log
NTFS permissions 2nd
sharing
peer-to-peer networks 2nd 3rd 4th 5th 6th 7th
smb.conf
system logs
tarballs
filtering
networks
requests
firewalls 2nd 3rd 4th 5th 6th 7th
application-gateway firewalls
circuit-level firewalls
manufacturers
packet filter firewalls
proxy server capabilities
Shields Up Web site 2nd
software-only firewalls 2nd
ZoneAlarm
fixed disks [See hard drives]
floppy disks
backing up to
focus groups
folders
NTFS permissions 2nd
public folders
sharing 2nd 3rd 4th 5th 6th 7th
formatting
hard drives 2nd 3rd
FORTRAN language
forward lookup zones
primary zones
secondary zones
FPM (Fast Page Mode) memory
FQDNs (Fully Qualified Domain Name)
FQDNs (fully qualified domain names) 2nd
Fractional-T connections
Frame Relay 2nd
frames
frames (data)
Frames Rcvd column (Network Monitor)
Frames Sent column (Network Monitor)
frequency hopping
frequently asked questions (FAQs)
friendly names
FrontPage
FTP (File Transfer Protocol) 2nd 3rd
anonymous FTP 2nd 3rd
browser support
clients 2nd 3rd 4th
servers 2nd 3rd
full backups
Full Control permissions 2nd 3rd
full-duplex communication
Fully Qualified Domain Name (FQDNs)
fully qualified domain names [See FQDNs]
fully qualified domain names (FQDNs)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

gaming
multiplayer gaming
gateways
GCC Web site
GHz (gigahertz)
Gigabit Ethernet 2nd
Gigabit Token-Ring
gigabytes
gigahertz
GNOME (GNU Network Object Model Environment)
GNU Network Object Model Environment (GNOME)
gov domain name
graphical user interfaces [See GUIs]
Group Policy snap-in (Windows Server) 2nd 3rd 4th
groups
access levels 2nd
creating 2nd 3rd
Red Hat Linux networks 2nd
groupware 2nd 3rd
defined
GroupWise 2nd 3rd 4th
Lotus Notes 2nd 3rd
Domino Administrator 2nd 3rd
Notes clients 2nd 3rd
Microsoft Exchange Server 2nd
administration 2nd
Outlook client 2nd 3rd
GroupWise 2nd 3rd 4th
guest accounts
Samba
GUIs (graphical user interfaces)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

hackers
handshakes
HAPPY99.EXE Trojan horse
hard drives 2nd 3rd 4th
arrays
controllers
disk duplexing
disk mirroring 2nd 3rd
disk striping 2nd 3rd 4th
EIDE (Enhanced Integrated Drive Electronics)
formatting 2nd 3rd
hot-swappable
IDE (Integrated Drive Electronics)
parititioning
partitioning 2nd 3rd
Disk Management utility
FDISK utility
guidelines
RAID (Redundant Array of Inexpensive Disks) 2nd 3rd
parity bits
RAID 0 2nd 3rd
RAID 1 2nd 3rd 4th
RAID 2
RAID 3
RAID 4
RAID 5 2nd 3rd
RAID 6
RAID 7
types
volumes
SCSI (Small Computer System Interface) 2nd
sectors
volumes
creating 2nd 3rd
hardware 2nd
bridges 2nd
buying versus building 2nd
clients 2nd
hard drives 2nd 3rd [See hard drives]
EIDE (Enhanced Integrated Drive Electronics)
IDE (Integrated Drive Electronics)
SCSI (Small Computer System Interface) 2nd
hubs 2nd 3rd
memory 2nd 3rd
RAM (random access memory) 2nd
motherboards 2nd
NICs (network interface cards) 2nd 3rd
choosing 2nd 3rd 4th
EISA (Extended Industry Standard Architecture)
installing 2nd 3rd 4th
ISA (Industry Standard Architecture)
MAC (Media Access Control) addresses 2nd
MCA (Micro Channel Architecture)
PCI
VESA (Video Electronics Standards Association)
processors 2nd
repeaters 2nd
routers 2nd
servers 2nd 3rd 4th
hardware configuration 2nd
sharing
switches 2nd 3rd
IMPs (Interface Message Processors)
troubleshooting 2nd 3rd 4th 5th 6th 7th 8th
Web servers
Hardware Browser
hardware compatibility list
HEAD tag (HTML)
Health Monitor 2nd
Health Monitor (NetWare)
helf-duplex mode
help
documentation
HINFO (Host information) resource records
history
of Internet 2nd 3rd 4th
of packet switching
of telephone system
history of networking
peer-to-peer networks 2nd
history of networks
dumb terminals
mainframes
miniframes
PCs 2nd 3rd 4th
Home Phoneline Networking Alliance
Host (A) resource records
host addresses 2nd
Host information (HINFO) resource records
host ranges 2nd
Host-to-Host layer (DOD model)
Hosting Locator Web site
hosting Web sites
bCentral
hosting services 2nd 3rd
private Web servers 2nd 3rd
Yahoo!
hot-swappable drives
HTML (Hypertext Markup Language) 2nd 3rd 4th
HTML tag (HTML) 2nd
HTTP (Hypertext Transfer Protocol) 2nd 3rd
HTTP (Hypertext Transport Protocol) 2nd
hubs 2nd 3rd 4th
hyperlinks
Hypertext Markup Language (HTML) 2nd 3rd 4th
Hypertext Transfer Protocol [See HTTP]
Hypertext Transfer Protocol (HTTP) 2nd
Hypertext Transport Protocol (HTTP) 2nd

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

IANA (Internet Assigned Number Authority)
IAPs
versus ISPs
IAPs (Internet access providers)
versus ISPs
IBM
IBM Model 701 mainframes
PCs
Token-Ring 2nd
beaconing
cabling specifications 2nd
Gigabit Token-Ring
IEEE specifications 2nd
MAUs (Multistaton Access Units) 2nd
NADN (nearest active downstream neighbor)
NAUN (nearest active upstream neighbor)
speed
tokens
ICANN (Internet Corporation for Assigned Names and Numbers)
IDE (Integrated Drive Electronics) drives
IEEE
specifications
Ethernet 2nd
IEEE (Institute of Electrical and Electronic Engineers)
IEEE specifications
Ethernet 2nd 3rd 4th 5th
Token-Ring 2nd
IIS (Internet Information Services)
IIS6 (Internet Information Server 6.0)
iManager 2nd
iManager (NetWare)
IMAP
IMAP (Internet Message Access Protocol) 2nd
impedance (cabling)
IMPs (Interface Message Processors)
incremental backups 2nd 3rd
Industry Standard Architecture (ISA) bus
info domain name
infrared connectivity 2nd
infrastructures
installation
Windows Server 2003 2nd
clean installs 2nd
hardware requirements 2nd
installation process 2nd 3rd
supported file systems 2nd
upgrades 2nd
installing
NetWare 2nd 3rd 4th
DOS phase 2nd 3rd
GUI phase 2nd 3rd
NICs (network interface cards) 2nd 3rd 4th
NOS (network operating system) 2nd 3rd 4th
peripherals
protocols
Red Hat Linux 2nd 3rd 4th
boot process 2nd
installation packages 2nd
network configuration 2nd
root configuration 2nd
Institute of Electrical and Electronic Engineers (IEEE)
Integrated Drive Electronics (IDE) drives
Intel
Centrino
Interface Message Processors (IMPs)
interference (cabling)
International Business Machines [See IBM]
International Standards Organization (ISO)
International Telecommunications Union (ITU)
modem standards 2nd
Internet 2nd 3rd 4th 5th [See also Web sites]
connecting to 2nd
cable modems 2nd
domain names 2nd 3rd 4th
Internet backbone 2nd 3rd
IP addresses 2nd 3rd 4th
ISPs (Internet service providers) 2nd 3rd
NAT (Network Address Translation) 2nd 3rd 4th
proxy servers 2nd 3rd
shared connections 2nd 3rd 4th 5th 6th 7th 8th
DNS (Domain Name Service)
FQDNs (fully qualified domain names)
email 2nd 3rd
addresses 2nd
client configuration 2nd
IMAP (Internet Message Access Protocol) 2nd
POP3 (Post Office Protocol) 2nd
SMTP (Simple Mail Transport Protocol) 2nd
history and development 2nd 3rd 4th
IRC (Internet Relay Chat) 2nd
newsgroups 2nd 3rd 4th 5th
protocols
FTP (File Transfer Protocol) 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th
HTTP (Hypertext Transfer Protocol)
IMAP (Internet Message Access Protocol) 2nd
NNTP (Network News Transfer Protocol)
POP3 (Post Office Protocol) 2nd
PPP (Point-to-Point Protocol)
SMTP (Simple Mail Transport Protocol) 2nd
TCP/IP (Transmission Control Protocol/Internet Protocol)
well-known port numbers
security
Web
HTML (Hypertext Markup Language)
HTTP (Hypertext Transfer Protocol)
Web browsers 2nd
Web servers 2nd
Internet access providers [See IAPs]
Internet Assigned Number Authority (IANA)
Internet backbone
accessing 2nd 3rd
Internet Corporation for Assigned Names and Numbers (ICANN)
Internet Information Server 6.0 (IIS6)
Internet Information Services (IIS)
Internet layer (DOD model)
Internet Message Access Protocol (IMAP) 2nd
Internet Protocol [See IP]
Internet Protocol (TCP/IP) Properties dialog box 2nd 3rd 4th 5th 6th
Internet Protocol Security (IPSec
Internet Relay Chat (IRC) 2nd
Internet service providers [See ISPs]
InternetSecure Web site
Internetwork Packet Exchange (IPX)
Internetwork Packet Exchange/Sequenced Packet Exchange [See IPX/SPX]
internetworks 2nd
compared to WANs (wide area networks)
InterNIC 2nd
InterNIC Domain Services
InterNIC Web site
Interrupt Requests (IRQs) 2nd
intranets
creating 2nd
defined
IP
IP addresses
Class A addresses
Class B addresses
Class C addresses
Class D addresses
Class E addresses
converting
dotted decimal notation
IP (Internet Protocol)
addresses 2nd 3rd
configuring 2nd 3rd 4th
subnetting 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th
IP address spoofing
IP masquerading
IPv6 (IP Version 6) 2nd
security
IP (Internet Protocol) addresses
address ranges 2nd
APIPA (Automatic Private IP Addressing)
configuring
IP address spoofing
IP addresses 2nd 3rd 4th 5th
automatic
Class A addresses
Class B addresses
Class C addresses
Class D addresses
Class E addresses
converting
dotted decimal notation
dynamic addresses
static
static addresses
subnet masks 2nd 3rd
IP masquerading
ipconfig command 2nd
iPrint clients 2nd 3rd
IPSec (Internet Protocol Security)
IPv6 (IP Version 6) 2nd
IPX (Internetwork Packet Exchange)
IPX/SPX
(Internetwork Packet Exchange/Sequenced Packet Exchange)
addressing 2nd
advantages
configuring 2nd
stack protocols 2nd
IRC (Internet Relay Chat) 2nd
irchelp channel
IRQs (Interrupt Requests) 2nd
ISA (Industry Standard Architecture) bus
ISDN connections 2nd 3rd
Basic Rate ISDN 2nd
costs
defined
ISDN modems
Primary Rate ISDN
ISO (International Standards Organization)
ISPs
(Internet service providers)
equipment
redundant links
selecting 2nd 3rd
technical support
versus IAPs 2nd
ITU (International Telecommunications Union)
modem standards 2nd

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

K Desktop Environment (KDE)
KDE (K Desktop Environment)
KDiskFree
Kerberos 2nd
Konquerer (Lycoris)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

L2TP (Layer 2 Tunneling Protocol)
LAN Information Server (Lisa) 2nd 3rd
languages
DHTML (Dynamic HTML)
FORTRAN
HTML (Hypertext Markup Language) 2nd 3rd 4th
LANs (local area networks)
data transmission 2nd 3rd 4th
VLANs (virtual LANs)
LANtastic
laptops 2nd 3rd 4th
latency
Layer 2 Tunneling Protocol (L2TP)
layers
DOD model
layers (DOD model)
Application
Host-to-Host
Internet
Network Access
layers (OSI model)
advantages of 2nd
Application 2nd
Data Link 2nd
Network 2nd
overview 2nd 3rd 4th 5th 6th 7th
Physical 2nd
Presentation 2nd
Session 2nd
Transport 2nd 3rd
LCDs (liquid crystal displays)
licensing
NOS (network operating system) licensing 2nd 3rd 4th
SCL (server connection license)
UAL (user access license)
Licensing snap-in
links
redundant links
Linux
distributions
Lycoris 2nd
peer-to-peer networking 2nd
peer-to-peer networks
Red Hat Linux 2nd
adding users to 2nd
administrative tools 2nd
Apache Configuration tool
command line tools
config-services tool
Conquerer
Disk Management tool
DNS tool 2nd
Ethereal Network Analyzer 2nd
groups 2nd
Hardware Browser
installation 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th
KDiskFree
Linux Web site
Linuxconf tool 2nd 3rd
Lisa (LAN Information Server) 2nd 3rd
Network Configuration tool 2nd 3rd
network services 2nd 3rd 4th 5th
NFS (Network File System) 2nd 3rd 4th
Red hat Web site
shared resources 2nd 3rd 4th 5th 6th 7th 8th 9th
system logs
System Monitor
upgrades 2nd 3rd 4th 5th
User Manager 2nd 3rd
Samba 2nd
configuring 2nd 3rd
Web site
SWAT (Samba Web Administration Tool) 2nd 3rd 4th 5th 6th 7th
Linux Web site
Linuxconf tool 2nd 3rd
liquid crystal displays
Lisa (LAN Information Server) 2nd 3rd
List Folder Contents permissions
LLC (Logical Link Control)
Local Area Connection Properties dialog box 2nd
local area networks [See LANs]
local loops
local printers
local security
log files
Application Log
Security Log
Server Health Log
SYS$LOG.ERR file
System Log
system logs
Logical Link Control (LLC)
logon hours, restricting
lookup zones
forward lookup zones
primary zones
secondary zones
reverse lookup zones
Lotus Notes 2nd
Domino Administrator 2nd 3rd
Domino Server
Notes clients 2nd 3rd
Lycoris 2nd

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

MAC (Media Access Control)
MAC (Media Access Control) addresses 2nd
MAC hardware addresses 2nd
Macintosh Portable computers
macro viruses
Macromedia Dreamweaver
MAEs (metropolitan area ethernets)
mail [See email]
Mail Exchanger (MX) resource records
mainframes 2nd
malware
man-in-the-middle attacks
Manage Your Server tool
managing
partitions 2nd
server-based networks 2nd
Web servers
mapping
to OSI models
marketing 2nd 3rd
masks
subnet masks
IP addresses 2nd 3rd
masquerading (IP)
mastering buses
MAUs (Multistaton Access Units)
Mbps (million bits per second)
MCA (Micro Channel Architecture) bus
measurements
gigahertz
Media Access Control (MAC)
Media Access Control (MAC) addresses 2nd
memory 2nd 3rd
buffering
DMA (Direct Memory Access)
RAM (random access memory) 2nd
messages
broadcast messages 2nd
DHCPACK
DHCPDISCOVER
DHCPOFFER 2nd
Metcalfe, Robert
metropolitan area ethernets (MAEs)
MFS Communications Company
Micro Channel Architecture (MCA) bus
Microsoft .NET 2nd
Microsoft Exchange Server 2nd
administration 2nd
Outlook client 2nd 3rd
Microsoft FrontPage
Microsoft Networking model 2nd 3rd
Microsoft Windows Server 2003 Unleashed
million bits per second (Mbps)
miniframes
mirroring disks 2nd 3rd
mobile computing 2nd
history of 2nd 3rd
laptops 2nd 3rd 4th
monitoring remote connections 2nd 3rd
PDAs (Personal Digital Assistants) 2nd 3rd
BlackBerry 2nd 3rd
synchronizing with PCs 2nd
PPP (Point-to-Point Protocol)
RAS (Remote Access Services) 2nd 3rd
client configuration 2nd 3rd
server configuration 2nd 3rd
tunneling
SLIP (Serial Line Internet Protocol)
VPNs (Virtual Private Networks) 2nd
L2TP (Layer 2 Tunneling Protocol)
monitoring 2nd
PPTP (Point-to-Point Tunneling Protocol)
tunnel clients 2nd
tunnel servers 2nd
Model 100 computer
modem pools
modems
asynchronous modems 2nd 3rd 4th 5th
cable modems 2nd
external 2nd
ISDN modems
ITU (International Telecommunications Union) standards 2nd
model pools
speed
synchronous modems 2nd
Modify permissions 2nd
modulation 2nd [See also modems]
monitoring
Red Hat Linux networks
remote connections 2nd 3rd
VPNs (Virtual Private Networks) 2nd
monitoring networks 2nd 3rd 4th 5th
motherboard
data buses
motherboards 2nd
mount command
Multicasts Sent column (Network Monitor)
multipartite viruses
multiplayer gaming
multiplexers (MUXs)
Multistation Access Units (MAUs)
MUXs (multiplexers)
MX (Mail Exchanger) resource records

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

NADN (nearest active downstream neighbor)
Name Binding Protocol (NBP)
name resolution
DNS (Domain Name System) 2nd
forward lookup zones
how it works 2nd
namespaces 2nd 3rd
resource records 2nd
reverse lookup zones
root domains
server configuration 2nd 3rd 4th
top-level domains 2nd
Name Server (NS) resource records
name servers
DNS (Domain Name System)
configuring 2nd 3rd 4th
forward lookup zones
reverse lookup zones
names
DNS (Domain Name Service)
FQDNs (fully qualified domain names)
domain names
cost
registering 2nd 3rd
FQDNs (Fully Qualified Domain Name)
servers
friendly names
usernames 2nd
namespaces 2nd 3rd
naming
networks
servers
NAPs (network access points) 2nd
NAS (network attached storage)
NAT (Network Address Translation) 2nd 3rd 4th
NAUN (nearest active upstream neighbor)
navigating
server-based networks
Web sites
navigation
peer-to-peer networks
NBP (Name Binding Protocol)
NCP (NetWare Core Protocol)
NDS (Novell Directory Services)
nearest active downstream neighbor (NADN)
nearest active upstream neighbor (NAUN)
net domain name
Net Nanny
NetBEUI (NetBIOS Extended User Interface) 2nd
NetBIOS Extended User Interface (NetBEUI) 2nd
NetWare 2nd 3rd 4th
administration 2nd 3rd 4th 5th 6th
ConsoleOne 2nd
Health Monitor
iManager
NetWare Remote Manager 2nd 3rd 4th 5th
Advanced NetWare
bindery
client configuration 2nd
clients
configuring
DHCP (Dynamic Host Configuration Protocol) 2nd
directories
creating 2nd 3rd 4th
DNS (Domain Name System) 2nd
eDirectory 2nd
defined 2nd 3rd
groups
creating 2nd 3rd
iManager 2nd
installation 2nd 3rd 4th
DOS phase 2nd 3rd
GUI phase 2nd 3rd
iPrint clients 2nd 3rd
NDS (Novell Directory Services)
NSS (Novell Storage Services)
printer sharing 2nd 3rd 4th 5th
Remote Manager 2nd 3rd
reports, generating
storage pools
creating 2nd 3rd 4th
defined
Tree Walker 2nd
user accounts
creating 2nd 3rd
versions 2nd 3rd
volumes
creating 2nd 3rd
NetWare Core Protocol (NCP)
NetWare Enterprise Web server
network
servers
Network Access layer (DOD model)
network access points (NAPs) 2nd
Network Address column (Network Monitor)
Network Address Translation (NAT) 2nd 3rd 4th
network administrators [See administrators]
network architectures 2nd
ARCnet
bandwidth 2nd
contention-bases architectures
data transmission speed
defined
Ethernet 2nd 3rd 4th
1000BASE-T
100BASE-FX
100BASE-T4
100BASE-TX
10BASE-2
10BASE-5
10BASE-FL
10BASE-T
10Gigabit Ethernet
collisions 2nd
configurations
costs
CSMA/CD
Fast Ethernet 2nd
Gigabit Ethernet 2nd
IEEE specifications 2nd 3rd 4th 5th
FDDI 2nd 3rd
Token-Ring 2nd
Active Monitor
beaconing
cabling specifications 2nd
Gigabit Token-Ring
IEEE specifications 2nd
MAUs (Multistaton Access Units) 2nd
NADN (nearest active downstream neighbor)
NAUN (nearest active upstream neighbor)
speed
tokens
network attached storage (NAS)
Network Configuration tool 2nd 3rd
network connectivity devices 2nd
bridges 2nd
hubs 2nd 3rd
repeaters 2nd
routers 2nd
switches 2nd 3rd
Network File System (NFS) 2nd 3rd 4th
network interface cards [See NICs]
network interface cards (NICs) 2nd 3rd
Network layer (OSI model) 2nd 3rd
Network Monitor 2nd 3rd 4th 5th
Network News Transfer Protocol (NNTP)
network operating system (NOS) 2nd
network operating systems (NOSs)
network servers [See servers]
network services
Red Hat Linux 2nd 3rd 4th 5th
network shares 2nd
network-based applications 2nd
networks [See also protocols]2nd [See also Internet]3rd [See also Internet, Web sites]
administrators 2nd
tips and guidelines 2nd
advantages 2nd 3rd 4th
applications 2nd
choosing 2nd 3rd 4th 5th
client-based applications 2nd
client/server databases 2nd
groupware 2nd 3rd 4th
GroupWise 2nd 3rd 4th
Lotus Notes 2nd 3rd 4th 5th 6th 7th 8th 9th
Microsoft .NET 2nd
Microsoft Exchange Server 2nd 3rd 4th 5th 6th 7th
network-based applications 2nd
sharing with SharePoint Portal Server 2nd 3rd 4th
suite products
architectures 2nd
ARCnet
bandwidth 2nd
contention-bases architectures
data transmission speed
defined
Ethernet 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th 15th 16th 17th 18th 19th 20th 21st 22nd 23rd 24th 25th 26th 27th
FDDI 2nd 3rd
Token-Ring 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th 15th
ARPA (Advanced Research Projects Agency)
bridges 2nd
buses
cables [See cables]
clients 2nd 3rd 4th 5th 6th
configuration 2nd
defined
network client software 2nd
protocols 2nd 3rd
redirectors 2nd
workstations
ddata transmission 2nd 3rd 4th
defined 2nd
diagnostic tools
digital voltmeters
time domain reflectometers 2nd
Ethernet
filtering
gateways
hardware
NICs (network interface cards)
history of
dumb terminals
mainframes
miniframes
PCs 2nd 3rd 4th
hubs 2nd 3rd 4th
Internet
history and development 2nd
internetworks 2nd
compared to WANs (wide area networks)
intranets
creating 2nd
LANs (local area networks)
Microsoft Networking model 2nd 3rd
mobile computing 2nd
history of 2nd 3rd
laptops 2nd 3rd 4th
monitoring remote connections 2nd 3rd
PDAs (Personal Digital Assistants) 2nd 3rd
PDAs (Personal Digital Assistants); BlackBerry 2nd 3rd
PDAs (Personal Digital Assistants); synchronizing with PCs 2nd
PPP (Point-to-Point Protocol)
RAS (Remote Access Services) 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
SLIP (Serial Line Internet Protocol)
VPNs (Virtual Private Networks) 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
monitoring 2nd 3rd 4th 5th
naming
NetWare 2nd 3rd 4th
administration 2nd 3rd 4th 5th 6th
Advanced NetWare
bindery
client configuration 2nd
DHCP (Dynamic Host Configuration Protocol) 2nd
directories 2nd 3rd 4th
DNS (Domain Name System) 2nd
eDirectory 2nd 3rd 4th 5th
groups 2nd 3rd
installation 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
iPrint clients 2nd 3rd
NDS (Novell Directory Services)
NSS (Novell Storage Services)
printer sharing 2nd 3rd 4th 5th
storage pools 2nd 3rd 4th 5th
Tree Walker 2nd
user accounts 2nd 3rd
versions 2nd 3rd
volumes 2nd 3rd
NICs (network interface cards) 2nd 3rd 4th 5th
choosing 2nd 3rd 4th
EISA (Extended Industry Standard Architecture) bus
installing 2nd 3rd 4th
ISA (Industry Standard Architecture) bus
MAC (Media Access Control) addresses
MCA (Micro Channel Architecture) bus
PCI bus
VESA (Video Electronics Standards Association) bus
nodes
NOS (network operating system)
client configuration 2nd
defined 2nd
hardware compatibility list
installing 2nd 3rd 4th
licensing 2nd 3rd 4th
network client software 2nd
network printing 2nd 3rd
network shares 2nd
protocols 2nd 3rd
redirectors 2nd
server configuration 2nd 3rd 4th
troubleshooting 2nd 3rd
NOS (network operating systems
operating systems
NOS (network operating system)
peer-to-peer [See peer-to-peer networks]
peer-to-peer networks 2nd 3rd
advantages 2nd 3rd
Artisoft
disadvantages 2nd 3rd
history of 2nd
LANtastic
limitations 2nd 3rd
Linux
peer computers
requirements
workgroups
planning
network needs 2nd 3rd
overview 2nd
ports
serial ports
printers [See printers]2nd [See printers]3rd [See printers]
protocols [See protocols]
BOOTP
CHAP (Challenge Handshake Authentication Protocol)
CSMA/CD (Carrier Sense Multiple Access with Collision Detection)
DHCP (Dynamic Host Configuration Protocol) 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th
DHCP (Dynamic Host Configuration Protocol); running
HTTP (Hypertext Transfer Protocol) 2nd
HTTP (Hypertext Transport Protocol)
IMAP
IMAP (Internet Message Access Protocol) 2nd
IP (Internet Protocol) 2nd 3rd 4th 5th
IP (Internet Protocol) addresses 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th 15th 16th 17th 18th
IPv6 (IP Version 6) 2nd
Kerberos 2nd
L2TP (Layer 2 Tunneling Protocol)
NAT (Network Address Translation) 2nd 3rd 4th
NNTP (Network News Transfer Protocol)
OSPF (Open Shortest Path First)
PAP (Password Authentication Protocol)
POP3
POP3 (Post Office Protocol) 2nd
PPP (Point-to-Point Protocol)
PPTP (Point-to-Point Tunneling Protocol)
protocol sniffers 2nd
RIP (Routing Information Protocol)
SHTTP (Secure HTTP)
SLIP (Serial Line Internet Protocol)
SMTP (Simple Mail Transport Protocol) 2nd
TCP/IP (Transmission Control Protocol/Internet Protocol) 2nd
Red Hat Linux 2nd
adding users to 2nd
administrative tools 2nd
Apache Configuration tool
command line tools
config-services tool
Conquerer
Disk Management tool
DNS tool 2nd
Ethereal Network Analyzer 2nd
groups 2nd
Hardware Browser
installation 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th
KDiskFree
Linux Web site
Linuxconf tool 2nd 3rd
Lisa (LAN Information Server) 2nd 3rd
Network Configuration tool 2nd 3rd
network services 2nd 3rd 4th 5th
NFS (Network File System) 2nd 3rd 4th
Red Hat Web site
shared resources 2nd 3rd 4th 5th 6th 7th 8th 9th
system logs
System Monitor
upgrades 2nd 3rd 4th 5th
User Manager 2nd 3rd
remote access
monitoring remote connections 2nd 3rd
PPP (Point-to-Point Protocol)
RAS (Remote Access Services) 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
SLIP (Serial Line Internet Protocol)
VPNs (Virtual Private Networks) 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
repeaters 2nd
requests
filtering
routers 2nd 3rd 4th
configuring 2nd 3rd
scalable networks
security 2nd 3rd
access permissions
attacks 2nd 3rd 4th 5th 6th 7th 8th
crackers
cryptography
firewalls 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th 15th 16th 17th
groups 2nd
importance of 2nd
IP networks
passwords 2nd 3rd 4th
share permissions 2nd 3rd 4th
Trojan horses 2nd
user accounts 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th
user authentication
viruses 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th 15th 16th
worms 2nd
server-based networks 2nd
Active Directory
advantages 2nd 3rd
cost 2nd
disadvantages 2nd
managing 2nd
navigating
requirements
servers 2nd 3rd 4th 5th 6th 7th 8th [See servers]
application servers
communication servers
configuration 2nd 3rd 4th
defined
DNS servers 2nd
file servers
naming
print servers
Web servers 2nd
services
subnets 2nd
subnetting
borrowing bits 2nd
Class B networks 2nd 3rd 4th
host addresses 2nd
host ranges 2nd
switches 2nd 3rd
topologies
active topologies
bus topology 2nd 3rd 4th
passive topologies
ring topology 2nd
star topology 2nd 3rd
traffic, analyzing 2nd
troubleshooting 2nd
connectivity issues 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th
hardware problems 2nd 3rd 4th 5th 6th 7th 8th
NOS (network operating system) 2nd 3rd
tips and techniques 2nd
user errors 2nd 3rd
trusted networks
untrusted networks
users 2nd
VPNs (Virtual Private Networks) 2nd
L2TP (Layer 2 Tunneling Protocol)
monitoring 2nd
PPTP (Point-to-Point Tunneling Protocol)
tunnel clients 2nd
tunnel servers 2nd
WANs (wide area networks)
WANS (wide area networks) [See WANs]
wireless networks 2nd
infrared connectivity 2nd
radio connectivity 2nd 3rd 4th
zones
New Object - User dialog box
New Scope Wizard 2nd
newsgroups 2nd 3rd 4th 5th
NFS (Network File System) 2nd 3rd 4th
NICs (network interface cards) 2nd 3rd 4th 5th
choosing 2nd 3rd 4th
EISA (Extended Industry Standard Architecture)
installing 2nd 3rd 4th
ISA (Industry Standard Architecture)
MAC (Media Access Control) addresses 2nd
MCA (Micro Channel Architecture)
PCI
VESA (Video Electronics Standards Association)
NNTP (Network News Transfer Protocol)
node addresses
configuring
nodes (networks)
normal backups
NOS (network operating system) 2nd 3rd [See also NetWare]
client configuration 2nd
defined 2nd
hardware compatibility list
installing 2nd 3rd 4th
licensing 2nd 3rd 4th
network client software 2nd
network printing 2nd 3rd
network shares 2nd
protocols 2nd 3rd
redirectors 2nd
server configuration 2nd 3rd 4th
troubleshooting 2nd 3rd
NOS (network operating systems
NOSs
client/server
Novell NetWare
NOSs (network operating systems)
Notes [See Lotus Notes]2nd [See Lotus Notes]3rd [See Lotus Notes]
Novell Directory Services (NDS)
Novell GroupWise 2nd 3rd 4th
Novell Licensing Web site
Novell NetWare [See NetWare]
Novell Storage Services (NSS)
NS (Name Server) resource records
NSS (Novell Storage Services)
nssmu command
NT File System (NTFS)
NT Network dialog box
Protocols tab 2nd
NTFS
permissions
assigning
file permissions 2nd
folder permissions 2nd
guidelines 2nd
NTFS (NT File System)
NTFS file system
numbers
well-known port numbers
NWLink

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

objects
Olicom Inc
online marketing 2nd 3rd
online sales 2nd
Open Shortest Path First (OSPF)
Open Systems Interconnection Reference Model [See OSI model]
operating systems
Linux
peer-to-peer networks
NOS (network operating system)
org domain name
Osborne 1 computers
OSI model
(Open Systems Interconnection Reference Model)
advantages of 2nd
encapsulation 2nd
layers
Application 2nd
Data Link 2nd
Network 2nd
Physical 2nd
Presentation 2nd
Session 2nd
Transport 2nd 3rd
overview 2nd 3rd 4th 5th 6th 7th
peer communication
OSI models
mapping to
OSPF (Open Shortest Path First)
Outlook client 2nd 3rd
outside attacks
denial-of-service attacks
eavesdropping
IP address spoofing
man-in-the-middle attacks
password attacks
protecting against 2nd

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

packages
packet filter firewalls
packet switching 2nd
ATM (Asynchronous Transfer Mode) 2nd 3rd
Frame Relay 2nd
history and development
packets
capturing 2nd 3rd 4th
routing
segmenting
Palo Alto Research Center (PARC)
PAP (Password Authentication Protocol)
parameters
DHCP (Dynamic Host Configuration Protocol) servers 2nd
PARC (Palo Alto Research Center)
PARC (Xerox Palo Alto Reserch Center)
paritioning
hard drives
parity bits 2nd
partitioning
hard drives 2nd 3rd
Disk Management utility
FDISK utility
guidelines
partitions
creating 2nd
defined
duplicating
managing 2nd
passive matrix displays
passive topologies
password attacks
Password Authentication Protocol (PAP)
passwords 2nd 3rd 4th
Active Directory user accounts 2nd
administrator passwords
assigning 2nd
guidelines 2nd 3rd
Linux root passwords 2nd
PAP (Password Authentication Protocol)
password attacks
strong passwords
paths
virtual
PayPal
PCI bus
PCMCIA (Personal Computer Memory Card International Association) cards 2nd
PCs, history of 2nd 3rd
PDAs (Personal Digital Assistants) 2nd 3rd
BlackBerry 2nd 3rd
synchronizing with PCs 2nd
PE_LOVGATE.J virus
peer communication (OSI model)
peer computers
peer-to-peer networks 2nd 3rd 4th 5th
advantages 2nd 3rd
administration
cost
servers
setup
software
Artisoft
cabling 2nd
cost considerations
disadvantages 2nd 3rd 4th
file sharing 2nd 3rd 4th 5th 6th 7th
history of 2nd
LANtastic
limitations 2nd 3rd
backups
navigation
security 2nd
size
Linux
peer computers
printer sharing 2nd 3rd 4th 5th 6th 7th
protocols 2nd 3rd 4th
TCP/IP 2nd 3rd 4th
Windows configuration 2nd 3rd
requirements
Samba 2nd
configuring 2nd 3rd
Web site
size of 2nd
SWAT (Samba Web Administration Tool) 2nd 3rd 4th 5th 6th 7th
workgroups 2nd 3rd 4th 5th 6th 7th
Per Seat licensing
Per Server licensing
Performance Monitor 2nd 3rd 4th
peripherals
installing
permanent virtual circuits (PVCs)
permissions 2nd 3rd 4th 5th
defined
NTFS
assigning
file permissions 2nd
folder permissions 2nd
guidelines 2nd
share permissions 2nd 3rd
Personal Computer Memory Card International Association (PCMCIA) cards 2nd
Personal Digital Assistants [See PDAs]
phone wire 2nd
Physical layer (OSI model) 2nd 3rd
ping command 2nd
piracy of software
Plain Old Telephone System (POTS) 2nd
CPE (customer premise equipment)
demarcation
DSL (Digital Subscriber Line) 2nd 3rd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
history and development
local loops
planning networks
network needs 2nd 3rd
overview 2nd
Point-to-Point Protocol (PPP) 2nd
Point-to-Point Tunneling Protocol (PPTP)
Pointer (PTR) resource records
pools
storage pools
creating 2nd 3rd 4th
defined
POP3
POP3 (Post Office Protocol) 2nd
portable computers [See mobile computing]
ports
serial ports
well-known port numbers
Post Office Protocol (POP3) 2nd
POTS (Plain Old Telephone System) 2nd
CPE (customer premise equipment)
demarcation
DSL (Digital Subscriber Line) 2nd 3rd 4th 5th 6th
history and development
local loops
POTS pipes
power supplies
uninterruptible (UPS) 2nd 3rd
PPP (Point-to-Point Protocol) 2nd 3rd
PPTP (Point-to-Point Tunneling Protocol)
Practical Cisco Routers
Presentation layer (OSI model) 2nd 3rd
PRI (Primary Rate ISDN)
Primary Rate ISDN
primary zones
print brokers 2nd 3rd
print queues
print servers 2nd
print spoolers
printer pools
printers
direct connect printers
iPrint clients 2nd 3rd
local printers
print brokers 2nd 3rd
print queues
print spoolers
printer pools
remote printers
shared printers 2nd 3rd
sharing 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th
peer-to-peer networks 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th
Printers dialog box
printing 2nd 3rd
print servers
processing
email
processors 2nd
programs [See applications]
Webmin
projects
defined
Properties dialog box
Sharing tab 2nd
protecting against viruses 2nd 3rd
protocol sniffers 2nd
protocol stacks
IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange)
addressing 2nd
advantages
configuring 2nd
stack protocols 2nd
TCP/IP (Transmission Control Protocol/Internet Protocol) 2nd 3rd
DOD model 2nd
history of
protocols 2nd
protocols 2nd
AARP (AppleTalk Address Resolution Protocol)
adding to Windows clients 2nd 3rd
AFP (AppleTalk Filing Protocol)
AppleShare
AppleTalk 2nd
addressing 2nd
stack protocols 2nd
ARP (Address Resolution Protocol)
ATP (AppleTalk Transaction Protocol)
BOOTP
CHAP (Challenge Handshake Authentication Protocol)
configuring 2nd 3rd
CSMA/CD (Carrier Sense Multiple Access with Collision Detection)
DDP (Datagram Delivery Protocol)
DHCP (Dynamic Host Configuration Protocol) 2nd 3rd
client address requests 2nd 3rd
NetWare 2nd
running
server configuration 2nd 3rd 4th 5th 6th
DLC (Data Link Control) 2nd
DNS (Domain Name System) 2nd
forward lookup zones
how it works 2nd
namespaces 2nd 3rd
NetWare 2nd
resource records 2nd
reverse lookup zones
root domains
server configuration 2nd 3rd 4th
top-level domains 2nd
DOD model
Application layer
Host-to-Host layer
Internet layer
layers
Network Access layer
FTP (File Transfer Protocol) 2nd 3rd
anonymous FTP 2nd 3rd
browser support
clients 2nd 3rd 4th
servers 2nd 3rd
HTTP
HTTP (Hypertext Transfer Protocol) 2nd 3rd
HTTP (Hypertext Transport Protocol)
IMAP
IMAP (Internet Message Access Protocol) 2nd
installing
IP (Internet Protocol)
addresses
IP address spoofing
IP addresses 2nd 3rd 4th 5th 6th 7th 8th
IP masquerading
security
IP (Internet Protocol) addresses 2nd 3rd
address ranges 2nd
APIPA (Automatic Private IP Addressing)
configuring 2nd 3rd 4th 5th
IPv6 (IP Version 6) 2nd
subnetting 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th
IPSec (Internet Protocol Security)
IPX
IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange)
addressing 2nd
advantages
configuring 2nd
stack protocols 2nd
Kerberos 2nd
L2TP (Layer 2 Tunneling Protocol)
NAT (Network Address Translation) 2nd 3rd 4th
NBP (Name Binding Protocol)
NCP
NetBEUI (NetBIOS Extended User Interface) 2nd
NNTP (Network News Transfer Protocol)
OSI model
advantages of 2nd
Application layer 2nd
Data Link layer 2nd
Network layer 2nd
overview 2nd 3rd 4th 5th 6th 7th
peer communication
Physical layer 2nd
Presentation layer 2nd
Session layer 2nd
Transport layer 2nd 3rd
OSPF (Open Shortest Path First)
PAP (Password Authentication Protocol)
POP3
POP3 (Post Office Protocol) 2nd
PPP (Point-to-Point Protocol) 2nd
PPTP (Point-to-Point Tunneling Protocol)
protocol sniffers 2nd
protocol stacks
RIP
RIP (Routing Information Protocol) 2nd
routing protocols
SAP
SHTTP (Secure HTTP)
SLIP (Serial Line Internet Protocol)
SMB (Server Message Block)
SMTP (Simple Mail Transport Protocol) 2nd 3rd
SPX
TCP
TCP (Transfer Control Protocol)
TCP/IP
well-known port numbers
Windows configuration 2nd 3rd 4th
TCP/IP (Transmission Control Protocol/Internet Protocol) 2nd 3rd 4th
DOD model 2nd
history of
stack protocols 2nd
Telnet
UDP (User Datagram Protocol)
well-known port numbers
WINS (Windows Internet Naming Service) 2nd
X.25 2nd
ZIP (Zone Information Protocol)
Protocols tab (NT Network dialog box) 2nd
prots
well-known port numbers
proxy servers 2nd 3rd 4th
AnalogX Proxy Server 2nd
firewalls
PSTN (Public Switched Telephone Network) 2nd
CPE (customer premise equipment)
demarcation
DSL (Digital Subscriber Line) 2nd 3rd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
history and development
local loops
PTR (Pointer) resource records
public folders
Public Switched Telephone Network (PSTN) 2nd
CPE (customer premise equipment)
demarcation
DSL (Digital Subscriber Line) 2nd 3rd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
history and development
local loops
PVCs (permanent virtual circuits)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

Quantum SnapServer
queries
reverse lookup queries
queues
print queues

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

radio connectivity 2nd 3rd 4th
RAID 2nd 3rd
parity bits
RAID 0 2nd 3rd
RAID 1 2nd 3rd 4th
RAID 2
RAID 3
RAID 4
RAID 5 2nd 3rd
RAID 6
RAID 7
types 2nd 3rd
volumes
RAID (Redundant Array of Inexpensive Disks)
RAM (random access memory) 2nd
Rambus DRAM (RDRAM)
random access memory (RAM) 2nd
RAS (Remote Access Services) 2nd 3rd
client configuration 2nd 3rd
server configuration 2nd 3rd
tunneling
rat tails (hubs)
RDRAM (Rambus DRAM)
Read and Execute permissions 2nd
Read permissions 2nd 3rd
records
resource records 2nd
recovery
fault tolerance
Red Hat Linux 2nd 3rd
adding users to 2nd
administrative tools 2nd
Apache Configuration tool
command line tools
config-services tool
Conquerer
Disk Management tool
DNS tool 2nd
Ethereal Network Analyzer 2nd
groups 2nd
Hardware Browser
installation 2nd 3rd 4th
boot process 2nd
installation packages 2nd
network configuration 2nd
root configuration 2nd
KDiskFree
Linux Web site
Linuxconf tool 2nd 3rd
Lisa (LAN Information Server) 2nd 3rd
Network Configuration tool 2nd 3rd
network services 2nd 3rd 4th 5th
NFS (Network File System) 2nd 3rd 4th
Red Hat Web site
shared resources 2nd
browsing 2nd 3rd 4th
printers 2nd 3rd
system logs
System Monitor
upgrades 2nd 3rd 4th 5th
User Manager 2nd 3rd
Red Hat Linux 9 Unleashed
Red Hat Web site
redirectors 2nd
Redundant Array of Inexpensive Disks [See RAID]
redundant links
reflectometers 2nd
registering
domain names 2nd 3rd
remote access
WANs (wide area networks) 2nd
remote access servers 2nd
remote connections
monitoring 2nd 3rd
Remote Manager 2nd 3rd
Remote Manager (NetWare) 2nd 3rd 4th 5th
remote printers
repeaters 2nd
reports, generating
requests
DHCP (Dynamic Host Configuration Protocol) 2nd 3rd
filtering
resource records 2nd
resources
recovery
fault tolerance
reverse lookup queries
reverse lookup zones
rights [See permissions]
ring topology 2nd
RIP (Routing Information Protocol) 2nd 3rd
RIPE Network Coordination Centre
RJ-11 jacks
roles (server) 2nd
root domains
root passwords (Linux) 2nd
routers 2nd 3rd 4th
configuring 2nd 3rd
routing
packets
Routing Information Protocol (RIP) 2nd 3rd
routing protocols
routing tables
RS-32 cables
running
DHCP (Dynamic Host Configuration Protocol)

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

sales 2nd
Samba 2nd
configuring 2nd 3rd
SWAT (Samba Web Administration Tool) 2nd 3rd 4th 5th 6th 7th
Web site
Samba Web Administration Tool (SWAT) 2nd 3rd 4th 5th 6th 7th
Sams Teach Yourself .NET XML Web Services in 24 Hours
Sams Teach Yourself Microsoft Office 2003 in 24 Hours
Sams Teach Yourself Microsoft Windows Server 2003 in 24 Hours 2nd 3rd
Sams Teach Yourself Samba in 24 Hours
Sams Teach Yourself Windows Server 2003 in 24 Hours
SANS Web site
SAP (Service Advertising Protocol)
SAPs (service access points)
scalable networks
SCL (server connection license)
SCSI (Small Computer System Interface) drives 2nd
SDRAM (Synchronous Dynamic RAM)
secondary zones
sectors (hard drives)
Secure Electronic Transaction (SET)
Secure HTTP (SHTTP)
Secure Socket Layer (SSL)
security 2nd
access permissions
attacks
denial-of-service attacks
eavesdropping
IP address spoofing
man-in-the-middle attacks
password attacks
protecting against 2nd
backups [See backups]
CHAP (Challenge Handshake Authentication Protocol)
crackers
cryptography
firewalls 2nd 3rd 4th 5th 6th 7th
application-gateway firewalls
circuit-level firewalls
manufacturers
packet filter firewalls
proxy server capabilities
Shields Up Web site 2nd
software-only firewalls 2nd
ZoneAlarm
groups 2nd
importance of 2nd
Internet
IP networks
local
networks
NTFS permissions
assigning
file permissions 2nd
folder permissions 2nd
guidelines 2nd
online transaction security 2nd
PAP (Password Authentication Protocol)
passwords 2nd 3rd 4th
assigning 2nd
guidelines 2nd 3rd
strong passwords
peer-to-peer networks 2nd
SET (Secure Electronic Transaction)
share permissions 2nd 3rd 4th 5th 6th 7th
share-level security
SHTTP (Secure HTTP)
SSL (Secure Socket Layer)
Trojan horses 2nd
user accounts
access tokens
concurrent connections
creating 2nd
disabling
logon hours
passwords 2nd 3rd 4th
remote connections
usernames 2nd
user authentication
viruses 2nd 3rd
boot sector viruses
Brain virus
defined
F-Secure Web site
file viruses
macro viruses 2nd
multipartite viruses
PE_LOVGATE.J virus
protecting against 2nd 3rd
SANS Web site
Web servers
Windows Server 2003 2nd 3rd 4th
worms
WORM_KWBOT.C worm
Security Log
segmenting
packets
Select a Zone Type dialog box
Select Network Component Type dialog box 2nd 3rd 4th 5th
selecting [See choosing]
connection types 2nd 3rd
ISPs 2nd 3rd
Sequenced Packet Exchange (SPX)
Serial Line Internet Protocol (SLIP)
serial ports
serial transmission
server connection license (SCL)
Server Health Log
Server Message Block (SMB)
server-based networks 2nd 3rd [See also LANs]
Active Directory
advantages 2nd 3rd
cost 2nd
disadvantages 2nd
managing 2nd
navigating
requirements
servers
servers 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th
AnalogX Proxy Server 2nd 3rd
application servers
client/server databases 2nd
communication servers
configuration 2nd 3rd 4th
defined
DHCP (Dynamic Host Configuration Protocol)
configuring 2nd 3rd 4th 5th 6th
DNS servers 2nd 3rd
file servers
FTP (File Transfer Protocol) 2nd 3rd
hardware configuration 2nd
Lotus Domino Server
Microsoft Exchange Server 2nd
administration 2nd
Outlook client 2nd 3rd
names
friendly names
naming
peer-to-peer networks
print servers
proxy servers 2nd 3rd 4th
firewalls
RAS (Remote Access Services) servers 2nd 3rd
server configuration 2nd 3rd
tunneling
remote access servers
SharePoint Portal Server 2nd 3rd 4th
SQL Server
tape backup units
tunnel servers 2nd
Web servers 2nd 3rd 4th
hardware
managing
NetWare Enterprise
running
security
Windows Server 2003
Active Directory 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
communications servers
configuration 2nd
domain controllers
file servers 2nd
folder shares 2nd 3rd 4th 5th
Group Policy snap-in 2nd 3rd 4th
installation 2nd 3rd 4th 5th 6th 7th 8th 9th
Microsoft Networking model 2nd 3rd
NTFS permissions 2nd 3rd 4th 5th 6th 7th
print servers
printer sharing 2nd 3rd 4th
remote access servers
security 2nd 3rd 4th
shared Internet connections 2nd
Web servers
Web site
WINS (Windows Internet Naming Service) 2nd
Service (SRV) resource records
service access points (SAPs)
Service Advertising Protocol (SAP)
services
DNS (Domain Name System) 2nd
forward lookup zones
how it works 2nd
namespaces 2nd 3rd
resource records 2nd
reverse lookup zones
root domains
server configuration 2nd 3rd 4th
top-level domains 2nd
eDirectory 2nd
defined 2nd 3rd
NDS (Novell Directory Services)
RAS (Remote Access Services) 2nd 3rd
client configuration 2nd 3rd
server configuration 2nd 3rd
tunneling
Red Hat Linux network services 2nd 3rd 4th 5th
Web hosting services 2nd 3rd
WINS (Windows Internet Naming Service) 2nd
Session layer (OSI model) 2nd 3rd
SET (Secure Electronic Transaction)
Shadow Copy
share level security
share permissions 2nd 3rd 4th
shared resources 2nd
browsing 2nd 3rd 4th
printers 2nd 3rd
SharePoint Portal Server 2nd 3rd 4th
shares 2nd
creating 2nd
permissions 2nd 3rd 4th 5th 6th 7th
sharing
applications
applications with SharePoint Portal Server 2nd 3rd 4th
databases 2nd
directories 2nd
files
peer-to-peer networks 2nd 3rd 4th 5th 6th 7th
folders 2nd 3rd 4th 5th 6th 7th
hardware
Internet connections 2nd
IP addressing 2nd 3rd
NAT (Network Address Translation) 2nd 3rd 4th
proxy servers 2nd 3rd
required hardware
Windows Server 2003 2nd
printers 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th 15th
peer-to-peer networks 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 11th 12th 13th 14th
workspaces 2nd 3rd 4th
Sharing tab (Properties dialog box) 2nd
Shields Up Web site 2nd
SHTTP (Secure HTTP)
signals
baseband signals
broadband signals
SIMMs (Single Inline Memory Modules)
Simple Mail Transport Protocol (SMTP) 2nd 3rd
simplex communication
Single Inline Memory Modules (SIMMs)
sites [See Web sites]
Sites and Services snap-in (Active Directory)
size
peer-to-peer networks 2nd 3rd
slash (/)
SLIP (Serial Line Internet Protocol) 2nd
Small Computer System Interface (SCSI) drives 2nd
SMB (Server Message Block)
smb.conf file
SMTP (Simple Mail Transport Protocol) 2nd 3rd
snap-ins
Active Directory Domains and Trusts
Active Directory Sites and Services
Active Directory Users and Computers
Group Policy snap-in 2nd 3rd 4th
Licensing snap-in
SnapServer
sneakernet
Sniffer Technologies
sniffers 2nd
sniffing
snooping
SOA (Start of Authority) resource records
software [See applications]
network client software 2nd
NOS (network operating system)
client configuration 2nd
defined 2nd
installing 2nd 3rd 4th
licensing 2nd 3rd 4th
network client software 2nd
network printing 2nd 3rd
network shares 2nd
protocols 2nd 3rd
redirectors 2nd
server configuration 2nd 3rd 4th
peer-to-peer networks
redirectors 2nd
software piracy
software-only firewalls 2nd
Trojan horses 2nd
viruses 2nd 3rd
boot sector viruses
Brain virus
defined
F-Secure Web site
file viruses
macro viruses 2nd
multipartite viruses
PE_LOVGATE.J virus
protecting against 2nd 3rd
SANS Web site
worms
WORM_KWBOT.C worm
Software & Information Industry Association
software piracy
software-only firewalls 2nd
SONET (Synchronous Optical Network/Synchronous Digital Hierarchy)
SpartaCom, Inc
Artisoft
Special Edition Using HTML and XHTML
Special Edition Using TCP/IP
specifications
IEEE
Ethernet 2nd
speed
data transmission speed
disk speed
modems
Token-Ring
SPX (Sequenced Packet Exchange)
SQL (Structured Query Language)
SQL Server
SRV (Service) resource records
SSL (Secure Socket Layer)
star topology 2nd 3rd
Start of Authority (SOA) resource records
static addresses
static IP addresses
statistics (Network Monitor) 2nd 3rd
storage
hard drives [See hard drives]
NAS (network attached storage)
storage pools
creating 2nd 3rd 4th
defined
strategy
backups 2nd 3rd 4th 5th
striping disks 2nd 3rd 4th
strong passwords
Structured Query Language (SQL)
subnet masks
IP addresses 2nd 3rd
subnets 2nd
subnetting
borrowing bits 2nd
Class B networks 2nd 3rd 4th
host addresses 2nd
host ranges 2nd
suite applications
SuperStack 3 firewall
surge protection
SWAT (Samba Web Administration Tool) 2nd 3rd 4th 5th 6th 7th
switched networks 2nd 3rd
circuit switching 2nd
defined
DSL (Digital Subscriber Line) 2nd 3rd 4th 5th
ISDN 2nd 3rd
defined
packet switching 2nd
ATM (Asynchronous Transfer Mode) 2nd 3rd
Frame Relay 2nd
history and development
switches 2nd 3rd
IMPs (Interface Message Processors)
synchronizing
applications
PDAs (Personal Digital Assistants) with PCs 2nd
Synchronous Dynamic RAM (SDRAM)
synchronous modems 2nd
Synchronous Optical Network/Synchronous Digital Hierarchy (SONET)
SYS$LOG.ERR file
System Log
system logs
System Monitor

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

T-Carrier systems 2nd 3rd
T1 lines 2nd 3rd
T2 lines
T3 lines
T4 lines
tables
FAT (file allocation table)
routing tables
tags (HTML) 2nd
Tandy computers
tape backup units
tapping (cabling)
tarballs
TCP (Transfer Control Protocol)
TCP (Transmission Control Protocol)
TCP/IP 2nd
DOD model 2nd
history of
stack protocols 2nd
Transmission Control Protocol/Internet Protocol
well-known port numbers
Windows configuration 2nd 3rd 4th
TCP/IP (Transmission Control Protocol/Internet Protocol) 2nd
technical support (ISPs)
telephone system 2nd
CPE (customer premise equipment)
demarcation
DSL (Digital Subscriber Line) 2nd 3rd
ADSL (Asymmetric DSL)
costs
DSLAMs (Digital Subscriber Line Access Multiplexers)
history and development
local loops
Telnet
thicknet 2nd
thicknet (coaxial cables)
thinnet 2nd
time domain reflectometers 2nd
TITLE tag (HTML)
Token-Ring 2nd
beaconing
cabling specifications 2nd
Gigabit Token-Ring
IEEE specifications 2nd
MAUs (Multistaton Access Units) 2nd
NADN (nearest active downstream neighbor)
NAUN (nearest active upstream neighbor)
speed
tokens
token-ring networks
tokens
tools
Apache Configuration
config-services
Conquerer
digital voltmeters
Disk Management
Disk Management tool
DNS tool 2nd
Ethereal
Ethereal Network Analyzer 2nd
Event Viewer 2nd
FDISK 2nd
Hardware Browser
Health Monitor 2nd
ipconfig 2nd
KDiskFree
Linuxconf 2nd 3rd
Manage Your Server
Network Configuration
Network Configuration tool 2nd
Network Monitor 2nd 3rd 4th 5th
Performance Monitor 2nd 3rd 4th
ping 2nd
protocol sniffers 2nd
Remote Manager 2nd 3rd
Shadow Copy
System Monitor
time domain reflectometers 2nd
traceoute 2nd
User Manager 2nd 3rd
Web design tools 2nd 3rd
top-level domains 2nd 3rd 4th 5th
topologies
active topologies
bus topology 2nd 3rd
passive topologies
ring topology 2nd
star topology 2nd
topologies (network)
star topology
topologies (networks)
bus topology
traceroute command 2nd
traffic
broadcast traffic
traffic (network)
analyzing 2nd
training users 2nd
transaction security 2nd
transceivers
Transfer Control Protocol (TCP)
Transmission Control Protocol (TCP)
Transmission Control Protocol/Internet Protocol [See TCP/IP]2nd [See TCP/IP]
Transmission Control Protocol/Internet Protocol (TCP/IP)
transmisson of data 2nd 3rd 4th
transport
connection-oriented transport
connectionless transport
Transport layer (OSI model) 2nd 3rd 4th
Tree Walker (NetWare) 2nd
Trojan horses 2nd
troubleshooting 2nd
backups
connectivity issues 2nd
cables
digital voltmeters
ipconfig command 2nd
ping command 2nd
time domain reflectometers 2nd
traceroute command 2nd
diagnostic tools
Event Viewer
Health Monitor 2nd
ipconfig 2nd
Network Monitor 2nd 3rd 4th 5th
Performance Monitor 2nd 3rd 4th
ping 2nd
protocol sniffers 2nd
Remote Manager 2nd
traceoute 2nd
fiber-optic cables
hardware problems 2nd 3rd 4th 5th 6th 7th 8th
NOS (network operating system) 2nd 3rd
tips and techniques 2nd
user errors 2nd 3rd
trusted networks
TUCOWS (The Ultimate Collection of Winsock Software) Web site
Tucows.com Web site
tunneling
L2TP (Layer 2 Tunneling Protocol)
PPTP (Point-to-Point Tunneling Protocol)
tunnel clients 2nd
tunnel servers 2nd
twisted-pair cables 2nd
CAT 1
CAT 2
CAT 3
CAT 4
CAT 5
CAT 6
crosstalk
unshielded twisted-pair 2nd
twisted-pair wire
categories
Type 1 cables
Type 1 PCMCIA cards
Type 2 PCMCIA cards
Type 3 cables
Type 3 PCMCIA cards

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

UAL (user access license)
UDP (User Datagram Protocol)
Ultimate Collection of Winsock Software (TUCOWS) Web site
Uniform Resource Locators (URLs) 2nd
uninterruptible power supply (UPS) 2nd 3rd
unshielded twisted-pair cables 2nd 3rd
untrusted networks
upgrades
Red Hat Linux 2nd 3rd 4th 5th
upgrading
applications
Windows Server 2003 2nd
Upgrading and Repairing PCs
UPS (uninterruptible power supply) 2nd 3rd
URLs (Uniform Resource Locators) 2nd
Usenet newsgroups 2nd 3rd 4th 5th
user access license (UAL)
user accounts
creating 2nd 3rd
user authentication
User Datagram Protocol (UDP)
User Manager tool 2nd 3rd
user policies
usernames 2nd
users 2nd
access permissions
accounts
creating
Active Directory user accounts
creating 2nd 3rd
passwords 2nd
adding to Red Hat Linux networks 2nd
authentication
communication
groups
creating 2nd 3rd
training 2nd
user accounts
access tokens
concurrent connections
creating 2nd 3rd 4th 5th
disabling
logon hours
passwords 2nd 3rd 4th
remote connections
usernames 2nd
user errors 2nd 3rd
user policies
Users and Computers snap-in (Active Directory)
utilities
Disk Management
FDISK 2nd
Shadow Copy
UTP (unshielded twisted-pair) cables 2nd 3rd

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

VESA (Video Electronics Standards Association) bus
Video Electronics Standards Association (VESA) bus
virtual LANs (VLANs)
virtual paths
Virtual Private Networks [See VPNs]
Virtual Private Networks (VPNs)
viruses 2nd 3rd
boot sector viruses
Brain virus
defined
F-Secure Web site
file viruses
macro viruses 2nd
multipartite viruses
PE_LOVGATE.J virus
protecting against 2nd 3rd
SANS Web site
VLANs (virtual LANs)
voltmeters
volumes
creating 2nd 3rd
volumes (RAID)
VPNs (Virtual Private Networks) 2nd
L2TP (Layer 2 Tunneling Protocol)
monitoring 2nd
PPTP (Point-to-Point Tunneling Protocol)
tunnel clients 2nd
tunnel servers 2nd

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

WANs (wide area networks) 2nd 3rd
compared to internetworks
defined
dial-up connections
asynchronous modems 2nd 3rd 4th 5th
synchronous modems 2nd
POTS (Plain Old Telephone System) 2nd
CPE (customer premise equipment)
demarcation
DSL (Digital Subscriber Line) 2nd 3rd 4th 5th 6th
history and development
local loops
remote access 2nd
switched networks 2nd 3rd
circuit switching 2nd 3rd 4th 5th 6th 7th 8th 9th 10th
defined
packet switching 2nd 3rd 4th 5th 6th 7th 8th
T-Carrier systems 2nd 3rd
Web (World Wide Web)
HTML (Hypertext Markup Language)
HTTP (Hypertext Transfer Protocol)
Web browsers
FTP (File Transfer Protocol) support
Web servers 2nd
Web browsers
FTP (File Transfer Protocol) support
Web servers 2nd 3rd 4th 5th
hardware
managing
NetWare Enterprise
running
security
Web sites
Adaptec
Agilent Technologies
AnalogX
ARIN
bCentral
configuring
corporate Web sites
advantages 2nd 3rd
online marketing 2nd 3rd
online sales 2nd
transaction security 2nd
creating 2nd
design issues
HTML (Hypertext Markup Language) 2nd
design 2nd
design tools 2nd 3rd
Ebay
Ethereal
F-Secure
GCC
Home Phoneline Networking Alliance
hosting
bCentral
hosting services 2nd 3rd
private Web servers 2nd 3rd
Yahoo!
Hosting Locator
HTML tutorial
InternetSecure
InterNIC
intranets
Linux
navigating
Net Nanny
Nevell Licensing
PayPal
Red Hat
Samba
SANS
Shields Up 2nd
Software & Information Industry Association
TUCOWS (The Ultimate Collection of Winsock Software)
Tucows.com
Windows Server 2003
ZoneAlarm
Webmin program
well-known port numbers 2nd
wide area networks [See WANs]2nd [See WANs]
Windows 2000
APIPA (Automatic Private IP Addressing)
file sharing 2nd 3rd 4th 5th 6th 7th
local security
printer sharing 2nd 3rd 4th 5th 6th 7th
protocols
configuring 2nd 3rd
TCP/IP 2nd 3rd 4th
Windows 9x
file sharing 2nd 3rd 4th 5th 6th 7th
printer sharing 2nd 3rd 4th 5th 6th 7th
protocols
configuring 2nd 3rd
TCP/IP 2nd 3rd 4th
Windows Internet Naming Service (WINS) 2nd
Windows Me
APIPA (Automatic Private IP Addressing)
file sharing 2nd 3rd 4th 5th 6th 7th
printer sharing 2nd 3rd 4th 5th 6th 7th
protocols
configuring 2nd 3rd
TCP/IP 2nd 3rd 4th
Windows NT
file sharing 2nd 3rd 4th 5th 6th 7th
local security
printer sharing 2nd 3rd 4th 5th 6th 7th
protocols
configuring 2nd 3rd
TCP/IP 2nd 3rd 4th
Windows Server 2003
Active Directory 2nd
Active Directory Domains and Trusts snap-in
Active Directory Sites and Services snap-in
Active Directory Users and Computers snap-in
user accounts 2nd 3rd 4th 5th
communications servers
configuration 2nd
domain controllers
file servers 2nd
folder shares
creating 2nd
permissions 2nd 3rd
Group Policy snap-in 2nd 3rd 4th
installation 2nd
clean installs 2nd
hardware requirements 2nd
installation process 2nd 3rd
supported file systems 2nd
upgrades 2nd
Microsoft Networking model 2nd 3rd
NTFS permissions
assigning
file permissions 2nd
folder permissions 2nd
guidelines 2nd
print servers
printer sharing 2nd 3rd 4th
remote access servers
security 2nd 3rd 4th
shared Internet connections 2nd
Web servers
Web site
Windows Shares dialog box 2nd
WINS (Windows Internet Naming Service) 2nd
WINS resource records
Winsock
TUCOWS (The Ultimate Collection of Winsock Software)
wireless networks 2nd
infrared connectivity 2nd
radio connectivity 2nd 3rd 4th
wizards
Add Printer Driver Wizard
Add Printer Wizard
Configure Your Server Wizard
Corporate Presence Web Wizard
New Scope Wizard 2nd
workgroups 2nd [See also peer-to-peer networks]
configuring 2nd 3rd 4th 5th 6th
worksgroups
defined
workspaces
sharing 2nd 3rd 4th
workstations
defined
World Wide Web [See Web]
WORM_KWBOT.C worm
worms
WORM_KWBOT.C
Write permissions 2nd
WWW (World Wide Web) [See Web]

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

X.25 protocol 2nd
xDSL
Xerox Corporation's PARC (Palo Alto Research Center)
Xerox Palo Alto Research Center (PARC)
XML (Extensible Markup Language)
Xnews reader

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

Yahoo!

[ Team LiB ]


[ Team LiB ]

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Y] [Z]

ZIP (Zone Information Protocol)
Zone Information Protocol (ZIP)
ZoneAlarm
zones
forward lookup zones
primary zones
secondary zones
reverse lookup zones
zones (networks)

[ Team LiB ]


Team LiB

Brought to You by

Like the book? Buy it!